Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 4971 | udp | Reserved | |||||||||
| 4972-4979 | Unassigned | ||||||||||
| ctxs-vpp | 4980 | udp | Citrix Virtual Path | Citrix Systems | Rohith Ramkumar | 2015-04-17 | |||||
| 4980 | tcp | Reserved | |||||||||
| 4981-4982 | Unassigned | ||||||||||
| 4983 | Unassigned | 2005-12-22 | |||||||||
| webyast | 4984 | tcp | WebYast | Federico Lucifredi | Federico Lucifredi | 2009-09-25 | |||||
| 4984 | udp | Reserved | |||||||||
| gerhcs | 4985 | tcp | GER HC Standard | Roger Ward | Roger Ward | 2009-09-25 | |||||
| 4985 | udp | Reserved | |||||||||
| mrip | 4986 | tcp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| mrip | 4986 | udp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| smar-se-port1 | 4987 | tcp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port1 | 4987 | udp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port2 | 4988 | tcp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| smar-se-port2 | 4988 | udp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| parallel | 4989 | tcp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| parallel | 4989 | udp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| busycal | 4990 | tcp | BusySync Calendar Synch. Protocol | David Riggle | David Riggle | 2008-01-07 | Defined TXT keys: Proprietary | ||||
| busycal | 4990 | udp | BusySync Calendar Synch. Protocol | David Riggle | David Riggle | 2008-01-07 | Defined TXT keys: Proprietary | ||||
| vrt | 4991 | tcp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| vrt | 4991 | udp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| 4992-4998 | Unassigned | ||||||||||
| hfcs-manager | 4999 | tcp | HFSQL Client/Server Database Engine Manager | PC SOFT | Jerome AERTS | 2006-03-02 | 2014-02-02 | ||||
| hfcs-manager | 4999 | udp | HFSQL Client/Server Database Engine Manager | PC SOFT | Jerome AERTS | 2006-03-02 | 2014-02-02 | ||||
| winfs | 5009 | tcp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| winfs | 5009 | udp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| 5016-5019 | Unassigned | ||||||||||
| infobright | 5029 | tcp | Infobright Database Server | Mark Windrim | Mark Windrim | 2009-07-23 | |||||
| infobright | 5029 | udp | Infobright Database Server | Mark Windrim | Mark Windrim | 2009-07-23 | |||||
| ivocalize | 5049 | tcp | iVocalize Web Conference | Bryan Vergato | Bryan Vergato | 2006-05 | |||||
| ivocalize | 5049 | udp | iVocalize Web Conference | Bryan Vergato | Bryan Vergato | 2006-05 | |||||
| sds | 5059 | tcp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sds | 5059 | udp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| i-net-2000-npr | 5069 | tcp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| i-net-2000-npr | 5069 | udp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| 5079 | tcp | Reserved | |||||||||
| cp-spxrpts | 5079 | udp | Cambridge Pixel SPx Reports | Richard Warren | Richard Warren | 2008-09-17 | |||||
| 5088-5089 | Unassigned | ||||||||||
| car | 5090 | sctp | Candidate AR | ||||||||
| cxtp | 5091 | sctp | Context Transfer Protocol | 2005-07 | RFC 4065 | ||||||
| 5092 | tcp | Reserved | |||||||||
| magpie | 5092 | udp | Magpie Binary | Phil Maker | Phil Maker | 2008-06-18 | |||||
| sentinel-lm | 5093 | tcp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| sentinel-lm | 5093 | udp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| hart-ip | 5094 | tcp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| hart-ip | 5094 | udp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| 5095-5098 | Unassigned | ||||||||||
| sentlm-srv2srv | 5099 | tcp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| sentlm-srv2srv | 5099 | udp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| 5118-5119 | Unassigned | ||||||||||
| 5147-5149 | Unassigned | ||||||||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| snmpssh | 5161 | tcp | SNMP over SSH Transport Model | RFC 5592 | |||||||
| snmpssh-trap | 5162 | tcp | SNMP Notification over SSH Transport Model | RFC 5592 | Known Unauthorized Use on port 5162 | ||||||
| 5169-5171 | Unassigned | ||||||||||
| 5173-5189 | Unassigned | ||||||||||
| aol | 5190 | tcp | America-Online | Marty Lyons | Marty Lyons | ||||||
| aol | 5190 | udp | America-Online | Marty Lyons | Marty Lyons | ||||||
| aol-1 | 5191 | tcp | AmericaOnline1 | Bruce Mackey | Bruce Mackey | ||||||
| aol-1 | 5191 | udp | AmericaOnline1 | Bruce Mackey | Bruce Mackey | ||||||
| aol-2 | 5192 | tcp | AmericaOnline2 | Bruce Mackey | Bruce Mackey | ||||||
| aol-2 | 5192 | udp | AmericaOnline2 | Bruce Mackey | Bruce Mackey | ||||||
| aol-3 | 5193 | tcp | AmericaOnline3 | Bruce Mackey | Bruce Mackey | ||||||
| aol-3 | 5193 | udp | AmericaOnline3 | Bruce Mackey | Bruce Mackey | ||||||
| cpscomm | 5194 | tcp | CipherPoint Config Service | CipherPoint Software, inc. | CipherPoint Software, inc. | 2010-03-03 | |||||
| 5194 | udp | Reserved | |||||||||
| ampl-lic | 5195 | tcp | The protocol is used by a license server and client programs to control use of program licenses that float to networked machines | AMPL Optimization, Inc. | David M. Gay | 2012-05-25 | |||||
| 5195 | udp | Reserved | |||||||||
| ampl-tableproxy | 5196 | tcp | The protocol is used by two programs that exchange "table" data used in the AMPL modeling language | AMPL Optimization, Inc. | David M. Gay | 2012-05-25 | |||||
| 5196 | udp | Reserved | |||||||||
| tunstall-lwp | 5197 | tcp | Tunstall Lone worker device interface | Tunstall Healthcare (UK) Ltd. | Robert Moore | 2014-12-10 | |||||
| 5197 | udp | Reserved | |||||||||
| 5198-5199 | Unassigned | ||||||||||
| nomad | 5209 | tcp | Nomad Device Video Transfer | Morega Systems Inc. | Ashraf Tahir | 2012-08-20 | |||||
| 5209 | udp | Reserved | |||||||||
| jaxflow | 5229 | tcp | Netflow/IPFIX/sFlow Collector and Forwarder Management | JaxMP | Stephen Hull | 2014-08-15 | |||||
| 5229 | udp | Reserved | |||||||||
| caaclang2 | 5249 | tcp | CA AC Lang Service | Gabriel Kalmar | Gabriel Kalmar | 2008-02-19 | |||||
| caaclang2 | 5249 | udp | CA AC Lang Service | Gabriel Kalmar | Gabriel Kalmar | 2008-02-19 | |||||
| xmpp-server | 5269 | tcp | XMPP Server Connection | RFC 6120 | |||||||
| 5269 | udp | Reserved | |||||||||
| 5273-5279 | Unassigned | ||||||||||
| 5283-5297 | Unassigned | ||||||||||
| presence | 5298 | tcp | XMPP Link-Local Messaging | Eric St. Onge | Eric St. Onge | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| presence | 5298 | udp | XMPP Link-Local Messaging | Eric St. Onge | Eric St. Onge | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| nlg-data | 5299 | tcp | NLG Data Service | Andy Shellam | Andy Shellam | 2008-02-19 | |||||
| nlg-data | 5299 | udp | NLG Data Service | Andy Shellam | Andy Shellam | 2008-02-19 | |||||
| jprinter | 5309 | tcp | J Printer | Ken Blackwell | Ken Blackwell | ||||||
| jprinter | 5309 | udp | J Printer | Ken Blackwell | Ken Blackwell | ||||||
| roughtime | 5319 | tcp | Roughtime time synchronization | IESG | IETF Chair | 2026-03-27 | RFC 10049 | ||||
| roughtime | 5319 | udp | Roughtime time synchronization | IESG | IETF Chair | 2026-03-27 | RFC 10049 | ||||
| stuns | 5349 | tcp | Session Traversal Utilities for NAT (STUN) port | IESG | IETF Chair | 2019-03-28 | RFC 8489 | ||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | tcp | TURN over TLS | 2019-08-02 | RFC 8656 | ||||||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| stun-behaviors | 5349 | tcp | STUN Behavior Discovery over TLS | RFC 5780 | |||||||
| stun-behaviors | 5349 | udp | Reserved for a future enhancement of STUN-BEHAVIOR | RFC 5780 | |||||||
| ms-alerter | 5359 | tcp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| ms-alerter | 5359 | udp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| 5365-5396 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 | |
| Andy Shellam | andy&networkmail.eu | 2008-02-19 | |
| Arthur Wilton | art&awilton.com | 2006-03 | |
| Ashraf Tahir | Morega Systems Inc. | atahir&morega.com | 2012-08-20 |
| Bruce Mackey | BAMackey&aol.com | ||
| Bryan Vergato | iana&ivocalize.com | 2006-05 | |
| Chris Megede | chris.megede&tac.com | ||
| CipherPoint Software, inc. | wshea&cipherpointsoftware.com | 2010-03-03 | |
| Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 | |
| David M. Gay | AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 |
| David Riggle | dave&busymac.com | 2008-01-07 | |
| Delcio Prizon | dprizon&smar.com.br | ||
| Derick Snyder | dsnyder&rainbow.com | ||
| Eric St. Onge | stonge&apple.com | 2008-01-14 | |
| Federico Lucifredi | flucifredi&novell.com | 2009-09-25 | |
| Gabriel Kalmar | kalga01&ca.com | 2008-03-06 | |
| Howard Amos | amos&ccww.co.uk | 2006-04 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| JaxMP | shull&jaxmp.com | 2014-08-15 | |
| Jerome AERTS | PC SOFT | jae&pcsoft.fr | 2014-02-02 |
| Ken Blackwell | kenb&bristol.com | ||
| Marc McClure | marcmccµsoft.com | 2007-08-07 | |
| Mark Windrim | mark.windrim&infobright.com | 2009-07-23 | |
| Marty Lyons | marty&aol.com | ||
| Matthew Ford | Matthew.Ford&forward.com.au | 2003-03 | |
| Morega Systems Inc. | atahir&morega.com | 2012-08-20 | |
| PC SOFT | jae&pcsoft.fr | 2014-02-02 | |
| Phil Maker | pjm&gnu.org | 2008-06-18 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Robert Moore | Tunstall Healthcare (UK) Ltd. | robert.moore&tunstall.com | 2014-12-10 |
| Roger Ward | roger.ward&ger911.com | 2009-09-25 | |
| Rohith Ramkumar | Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 |
| Sam Bretheim | info&opensigint.org | 2009-01-08 | |
| Simon Skaria | simonskµsoft.com | 2006-01 | |
| Stephen Hull | JaxMP | shull&jaxmp.com | 2014-08-15 |
| Tunstall Healthcare (UK) Ltd. | robert.moore&tunstall.com | 2014-12-10 | |
| Wally Pratt Jr | wpratt&fieldcommgroup.org | 2012-12-14 |