Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
worldscores 4545 tcp WorldScores Steve Davis Steve Davis
worldscores 4545 udp WorldScores Steve Davis Steve Davis
sf-lm 4546 tcp SF License Manager (Sentinel) Thomas Koell Thomas Koell
sf-lm 4546 udp SF License Manager (Sentinel) Thomas Koell Thomas Koell
lanner-lm 4547 tcp Lanner License Manager Les Enstone Les Enstone
lanner-lm 4547 udp Lanner License Manager Les Enstone Les Enstone
synchromesh 4548 tcp Synchromesh Tom Hawkins Tom Hawkins 2006-02
synchromesh 4548 udp Synchromesh Tom Hawkins Tom Hawkins 2006-02
aegate 4549 tcp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
aegate 4549 udp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
gds-adppiw-db 4550 tcp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
gds-adppiw-db 4550 udp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
ieee-mih 4551 tcp MIH Services RFC 5677
ieee-mih 4551 udp MIH Services RFC 5677
menandmice-mon 4552 tcp Men and Mice Monitoring Carsten Strotmann Carsten Strotmann 2009-05-20
menandmice-mon 4552 udp Men and Mice Monitoring Carsten Strotmann Carsten Strotmann 2009-05-20
icshostsvc 4553 tcp ICS host services Gordan Vosicki Gordan Vosicki 2009-09-23
4553 udp Reserved
msfrs 4554 tcp MS FRS Replication Kev George Kev George 2006-09
msfrs 4554 udp MS FRS Replication Kev George Kev George 2006-09
rsip 4555 tcp RSIP Port RFC 3103
rsip 4555 udp RSIP Port RFC 3103
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
4557 tcp Reserved
mtcevrunqss 4557 udp Marathon everRun Quorum Service Server David Schwartz David Schwartz 2009-06-18
4558 tcp Reserved
mtcevrunqman 4558 udp Marathon everRun Quorum Service Manager David Schwartz David Schwartz 2009-06-18
hylafax 4559 tcp HylaFAX Lee Howard Lee Howard 2002-03
hylafax 4559 udp HylaFAX Lee Howard Lee Howard 2002-03
4560-4562 Unassigned
amahi-anywhere 4563 tcp Amahi Anywhere Amahi Carlos Puchol 2014-02-27
4563 udp Reserved
4564-4565 Unassigned
kwtc 4566 tcp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
kwtc 4566 udp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
tram 4567 tcp TRAM Joe Wesley Joe Wesley
tram 4567 udp TRAM Joe Wesley Joe Wesley
bmc-reporting 4568 tcp BMC Reporting Portnoy Boxman Portnoy Boxman
bmc-reporting 4568 udp BMC Reporting Portnoy Boxman Portnoy Boxman
iax 4569 tcp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
deploymentmap 4570 tcp Service to distribute and update within a site deployment information for Oracle Communications Suite Oracle Corp. Dan Newman 2013-09-20
4570 udp Reserved
4571-4572 Unassigned
cardifftec-back 4573 tcp A port for communication between a server and client for a custom backup system CardiffTec Benjamin Misell 2016-05-19
4573 udp Reserved
4574-4589 Unassigned
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
4590 udp Reserved
l3t-at-an 4591 tcp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
l3t-at-an 4591 udp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
4592 tcp Reserved
hrpd-ith-at-an 4592 udp HRPD-ITH (AT-AN) David Ott David Ott 2008-06-05
ipt-anri-anri 4593 tcp IPT (ANRI-ANRI)
ipt-anri-anri 4593 udp IPT (ANRI-ANRI)
ias-session 4594 tcp IAS-Session (ANRI-ANRI)
ias-session 4594 udp IAS-Session (ANRI-ANRI)
ias-paging 4595 tcp IAS-Paging (ANRI-ANRI)
ias-paging 4595 udp IAS-Paging (ANRI-ANRI)
ias-neighbor 4596 tcp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
ias-neighbor 4596 udp IAS-Neighbor (ANRI-ANRI) David Ott David Ott 2007-07-31
a21-an-1xbs 4597 tcp A21 (AN-1xBS) David Ott David Ott 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) David Ott David Ott 2006-02
a16-an-an 4598 tcp A16 (AN-AN) David Ott David Ott 2005-12
a16-an-an 4598 udp A16 (AN-AN) David Ott David Ott 2005-12
a17-an-an 4599 tcp A17 (AN-AN) David Ott David Ott 2006-02
a17-an-an 4599 udp A17 (AN-AN) David Ott David Ott 2006-02
sixchat 4605 tcp Direct End to End Secure Chat Protocol Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2014-09-11
4605 udp Reserved
4622-4645 Unassigned
4647-4657 Unassigned
playsta2-app 4658 tcp PlayStation2 App Port
playsta2-app 4658 udp PlayStation2 App Port
playsta2-lob 4659 tcp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
playsta2-lob 4659 udp PlayStation2 Lobby Port Noam Rimon Noam Rimon 2004-12
contclientms 4665 tcp Container Client Message Service Bruce Thompson Bruce Thompson 2006-02
contclientms 4665 udp Container Client Message Service Bruce Thompson Bruce Thompson 2006-02
dhct-status 4675 tcp BIAP Device Status
dhct-status 4675 udp BIAP Device Status
autopac 4685 tcp Autopac Protocol Peter Hallenbeck Peter Hallenbeck 2005-08
autopac 4685 udp Autopac Protocol Peter Hallenbeck Peter Hallenbeck 2005-08
4705-4710 Unassigned
truckstar 4725 tcp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
truckstar 4725 udp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
fmp 4745 tcp Funambol Mobile Push Andrea Gazzaniga Andrea Gazzaniga 2007-01
fmp 4745 udp Funambol Mobile Push Andrea Gazzaniga Andrea Gazzaniga 2007-01
ssad 4750 tcp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
ssad 4750 udp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
spocp 4751 tcp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
spocp 4751 udp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
snap 4752 tcp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
snap 4752 udp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
simon 4753 tcp Simple Invocation of Methods Over Network (SIMON) Alexander Christian Alexander Christian 2012-04-19
simon-disc 4753 udp Simple Invocation of Methods Over Network (SIMON) Discovery Alexander Christian Alexander Christian 2012-04-19
4754 tcp Reserved
gre-in-udp 4754 udp GRE-in-UDP Encapsulation IESG IETF Chair 2016-10-05 RFC 8086
4755 tcp Reserved
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
RDCenter 4756 tcp Reticle Decision Center KLA Tencor/RAPID George Hwa 2016-10-17

Contact Information

Name Organization Contact URI Last Updated
Alexander Christian alexander.christian&root1.de 2012-04-19
Amahi iana&amahi.org 2014-02-27
Andrea Gazzaniga gazzaniga&funambol.com 2007-01
Avi Lior avi&bridgewatersystems.com 2009-02-27
Benjamin Kowarsch benjamin&sunrise-tel.com 2004-11
Benjamin Misell beninjam174&gmail.com 2016-05-19
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
Bruce Thompson brucet&actioninformationsystems.com 2006-02
CardiffTec beninjam174&gmail.com 2016-05-19
Carlos Puchol Amahi iana&amahi.org 2014-02-27
Carsten Strotmann carsten.strotmann&menandmice.com 2009-05-20
Dameon Wagner d.wagner&freemail.absa.co.za 2002-02
Dan Newman Oracle Corp. dan.c.newman&oracle.com 2013-09-20
David Ott dott&qualcomm.com 2010-10-15
David Schwartz david.schwartz&marathontechnologies.com 2009-06-18
Dr Horst Herb horst&dorrigomedical.com 2005-12
George Hwa george.hwa&kla-tencor.com 2016-10-17
Gordan Vosicki admin&icsa.ch 2009-09-23
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Joe Wesley joe.wesley&east.sun.com
Kev George Kev.George&smiths-aerospace.com 2006-09
KLA Tencor/RAPID george.hwa&kla-tencor.com 2016-10-17
Larry Zarou zarla01&cbsits.com 2006-10
Lawrence E. Hughes Sixscape Communications, Ltd. lhughes&sixscape.com 2014-03-17
Lee Howard iana&hylafax.org 2002-03
Leo Lesage leo.lesage&adp.nl 2006-04
Les Enstone lenstone&lanner.co.uk
Nick Warrington nick.warrington&paconsulting.com 2006-03
Noam Rimon noam.rimon&playstation.sony.com 2004-12
Oracle Corp. dan.c.newman&oracle.com 2013-09-20
Peter Hallenbeck pete&consumertechnologiesgroup.com 2005-08
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Roland Hedberg roland&catalogix.se 2005-08
Sixscape Communications, Pte. Ltd. lhughes&sixscape.com 2014-08-26
Steve Davis sdavis&optum-inc.com
Thomas Koell info&sf.com
Tom Hawkins tomahawkins&gmail.com 2006-02