Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ems 4664 tcp Rimage Messaging Server David V. Raskin David V. Raskin 2006-02
ems 4664 udp Rimage Messaging Server David V. Raskin David V. Raskin 2006-02
contclientms 4665 tcp Container Client Message Service Bruce Thompson Bruce Thompson 2006-02
contclientms 4665 udp Container Client Message Service Bruce Thompson Bruce Thompson 2006-02
eportcomm 4666 tcp E-Port Message Service
eportcomm 4666 udp E-Port Message Service
mmacomm 4667 tcp MMA Comm Services
mmacomm 4667 udp MMA Comm Services
mmaeds 4668 tcp MMA EDS Service Robert Shaffer Robert Shaffer 2006-02
mmaeds 4668 udp MMA EDS Service Robert Shaffer Robert Shaffer 2006-02
eportcommdata 4669 tcp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
eportcommdata 4669 udp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
light 4670 tcp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
light 4670 udp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
acter 4671 tcp Bull RSF action server Christian Caudrelier Christian Caudrelier 2006-02
acter 4671 udp Bull RSF action server Christian Caudrelier Christian Caudrelier 2006-02
rfa 4672 tcp remote file access server
rfa 4672 udp remote file access server
cxws 4673 tcp CXWS Operations Phil Abercrombie Phil Abercrombie 2005-08
cxws 4673 udp CXWS Operations Phil Abercrombie Phil Abercrombie 2005-08
appiq-mgmt 4674 tcp AppIQ Agent Management Phil Abercrombie Phil Abercrombie 2005-08
appiq-mgmt 4674 udp AppIQ Agent Management Phil Abercrombie Phil Abercrombie 2005-08
dhct-status 4675 tcp BIAP Device Status
dhct-status 4675 udp BIAP Device Status
dhct-alerts 4676 tcp BIAP Generic Alert Louis Slothouber Louis Slothouber 2005-08
dhct-alerts 4676 udp BIAP Generic Alert Louis Slothouber Louis Slothouber 2005-08
bcs 4677 tcp Business Continuity Servi Siew Sim Siew Sim 2005-08
bcs 4677 udp Business Continuity Servi Siew Sim Siew Sim 2005-08
traversal 4678 tcp boundary traversal Kevin Lu Kevin Lu 2005-08
traversal 4678 udp boundary traversal Kevin Lu Kevin Lu 2005-08
mgesupervision 4679 tcp MGE UPS Supervision
mgesupervision 4679 udp MGE UPS Supervision
mgemanagement 4680 tcp MGE UPS Management Lecuivre J Lecuivre J 2005-08
mgemanagement 4680 udp MGE UPS Management Lecuivre J Lecuivre J 2005-08
parliant 4681 tcp Parliant Telephony System Colin Henein Colin Henein 2005-08
parliant 4681 udp Parliant Telephony System Colin Henein Colin Henein 2005-08
finisar 4682 tcp finisar Christina Mercier Christina Mercier 2005-08
finisar 4682 udp finisar Christina Mercier Christina Mercier 2005-08
spike 4683 tcp Spike Clipboard Service Scott Herscher Scott Herscher 2005-08
spike 4683 udp Spike Clipboard Service Scott Herscher Scott Herscher 2005-08
rfid-rp1 4684 tcp RFID Reader Protocol 1.0 Michael Mealling Michael Mealling 2005-08
rfid-rp1 4684 udp RFID Reader Protocol 1.0 Michael Mealling Michael Mealling 2005-08
autopac 4685 tcp Autopac Protocol Peter Hallenbeck Peter Hallenbeck 2005-08
autopac 4685 udp Autopac Protocol Peter Hallenbeck Peter Hallenbeck 2005-08
msp-os 4686 tcp Manina Service Protocol Markus Nix Markus Nix 2005-08
msp-os 4686 udp Manina Service Protocol Markus Nix Markus Nix 2005-08
nst 4687 tcp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
nst 4687 udp Network Scanner Tool FTP Mala Bhat Mala Bhat 2005-08
mobile-p2p 4688 tcp Mobile P2P Service Hanz Hager Hanz Hager 2008-12-04
mobile-p2p 4688 udp Mobile P2P Service Hanz Hager Hanz Hager 2008-12-04
altovacentral 4689 tcp Altova DatabaseCentral Altova Altova 2005-08
altovacentral 4689 udp Altova DatabaseCentral Altova Altova 2005-08
prelude 4690 tcp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
prelude 4690 udp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
mtn 4691 tcp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
mtn 4691 udp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
conspiracy 4692 tcp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
conspiracy 4692 udp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
4693-4699 Unassigned
4726 tcp Reserved
a26-fap-fgw 4726 udp A26 (FAP-FGW) David Ott David Ott 2010-10-15
4734-4736 Unassigned
4746 tcp Reserved
intelliadm-disc 4746 udp IntelliAdmin Discovery IntelliAdmin, LLC Steve Wiseman 2016-11-18
gre-in-udp 4754 udp GRE-in-UDP Encapsulation IESG IETF Chair 2016-10-05 RFC 8086
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
RDCenter 4756 tcp Reticle Decision Center KLA Tencor/RAPID George Hwa 2016-10-17
4756 udp Reserved
smart-install 4786 tcp Smart Install Service Amit Nigam Amit Nigam 2009-08-24
4786 udp Reserved
4805-4826 Unassigned
4828-4836 Unassigned
contamac-icm 4846 tcp Contamac ICM Service

IANA assigned this well-formed service name as a replacement for "contamac_icm".
Abdullah Obeid Abdullah Obeid 2008-03-20
contamac_icm 4846 tcp Contamac ICM Service Abdullah Obeid Abdullah Obeid 2008-03-20 This entry is an alias to "contamac-icm". This entry is now historic, not usable for use with many common service discovery mechanisms.
contamac-icm 4846 udp Contamac ICM Service

IANA assigned this well-formed service name as a replacement for "contamac_icm".
Abdullah Obeid Abdullah Obeid 2008-03-20
contamac_icm 4846 udp Contamac ICM Service Abdullah Obeid Abdullah Obeid 2008-03-20 This entry is an alias to "contamac-icm". This entry is now historic, not usable for use with many common service discovery mechanisms.
4852-4866 Unassigned
unify-debug 4867 tcp Unify Debugger Daegis, Inc. Chris Anderson 2006-05 2012-07-31
unify-debug 4867 udp Unify Debugger Daegis, Inc. Chris Anderson 2006-05 2012-07-31
phrelay 4868 tcp Photon Relay
phrelay 4868 udp Photon Relay
phrelaydbg 4869 tcp Photon Relay Debug Michael Hunter Michael Hunter
phrelaydbg 4869 udp Photon Relay Debug Michael Hunter Michael Hunter
tritium-can 4876 tcp Tritium CAN Bus Bridge Service James Kennedy James Kennedy 2011-02-15
tritium-can 4876 udp Tritium CAN Bus Bridge Service James Kennedy James Kennedy 2011-02-15
4886-4887 Unassigned
4916-4929 Unassigned
an-signaling 4936 udp Signal protocol port for autonomic networking Cisco Systems Toerless Eckert 2014-06-06
4936 tcp Reserved
4954-4968 Unassigned Known UNAUTHORIZED USE: port 4967
ccss-qmm 4969 tcp CCSS QMessageMonitor
ccss-qmm 4969 udp CCSS QMessageMonitor
mrip 4986 tcp Model Railway Interface Program Howard Amos Howard Amos 2006-04
mrip 4986 udp Model Railway Interface Program Howard Amos Howard Amos 2006-04
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
wsm-server 5006 tcp wsm server Adam Berk Adam Berk
wsm-server 5006 udp wsm server Adam Berk Adam Berk
fmpro-v6 5013 tcp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
fmpro-v6 5013 udp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
5016-5019 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Abdullah Obeid a.obeid&contamac.nl 2008-03-20
Adam Berk aberk&empirix.com
Adam Golovenko golovenko&gmail.com 2006-10
Alex Chen alex_chen&filemaker.com 2009-11-25
Altova has&altova.com 2005-08
Amit Nigam amnigam&cisco.com 2009-08-24
Bruce Thompson brucet&actioninformationsystems.com 2006-02
Chris Anderson Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Christian Caudrelier Christian.Caudrelier&bull.net 2006-02
Christina Mercier christina.mercier&finisar.com 2005-08
Cisco Systems eckert&cisco.com 2014-06-06
Colin Henein iana&cmh.parliant.com 2005-08
Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
David Ott dott&qualcomm.com 2010-10-15
David V. Raskin draskin&rimage.com 2006-02
George Hwa george.hwa&kla-tencor.com 2016-10-17
Hanz Hager Hanz.Hager&comhem.se 2008-12-04
Howard Amos amos&ccww.co.uk 2006-04
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
IntelliAdmin, LLC support&intelliadmin.com 2016-11-18
James Kennedy james&tritium.com.au 2011-02-15
Jens Edlund edlund&speech.kth.se 2005-08
Kevin Lu kevinlu&micromethod.com 2005-08
KLA Tencor/RAPID george.hwa&kla-tencor.com 2016-10-17
Lecuivre J software.team&mgeups.com 2005-08
Louis Slothouber lpslot&biap.com 2005-08
Mala Bhat bmala&ssdi.sharp.co.in 2005-08
Markus Nix mnix&docuverse.de 2005-08
Michael Hunter mphunter&qnx.com
Michael Mealling michael&refactored-networks.com 2005-08
Peter Hallenbeck pete&consumertechnologiesgroup.com 2005-08
Phil Abercrombie phil.abercrombie&appiq.com 2005-08
Robert Shaffer bob.shaffer&micmod.com 2006-02
Scott Herscher scott&porchdogsoft.com 2005-08
Siew Sim ssim&asempra.com 2005-08
Steve Wiseman steve.wiseman&intelliadmin.com 2016-11-18
Thomas Keller me&thomaskeller.biz 2010-12-22
Toerless Eckert Cisco Systems eckert&cisco.com 2014-06-06
Yoann Vandoorselaere yoann&prelude-ids.org 2005-08