Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
smar-se-port1 4987 tcp SMAR Ethernet Port 1
smar-se-port1 4987 udp SMAR Ethernet Port 1
avt-profile-1 5004 tcp RTP media data RFC 3551; RFC 4571
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 tcp RTP control protocol RFC 3551; RFC 4571
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
wsm-server-ssl 5007 tcp wsm server ssl Adam Berk Adam Berk
wsm-server-ssl 5007 udp wsm server ssl Adam Berk Adam Berk
strexec-s 5027 tcp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
strexec-s 5027 udp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
5047 tcp Reserved
iscape 5047 udp iSCAPE Data Broadcasting Roland van der Veen Roland van der Veen 2010-06-17
intecom-ps2 5057 tcp Intecom Pointspan 2 David Meermans David Meermans
intecom-ps2 5057 udp Intecom Pointspan 2 David Meermans David Meermans
authentx 5067 tcp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
authentx 5067 udp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
vtsas 5070 tcp VersaTrans Server Agent Service Christopher Miller Christopher Miller 2006-02
vtsas 5070 udp VersaTrans Server Agent Service Christopher Miller Christopher Miller 2006-02
powerschool 5071 tcp PowerSchool Greg Porter Greg Porter
powerschool 5071 udp PowerSchool Greg Porter Greg Porter
ayiya 5072 tcp Anything In Anything Jeroen Massar Jeroen Massar 2005-08
ayiya 5072 udp Anything In Anything Jeroen Massar Jeroen Massar 2005-08
tag-pm 5073 tcp Advantage Group Port Mgr James Goddard James Goddard 2005-08
tag-pm 5073 udp Advantage Group Port Mgr James Goddard James Goddard 2005-08
alesquery 5074 tcp ALES Query Tim Maloney Tim Maloney 2005-08
alesquery 5074 udp ALES Query Tim Maloney Tim Maloney 2005-08
pvaccess 5075 tcp Experimental Physics and Industrial Control System Matej Sekoranja Matej Sekoranja 2012-03-23
5075 udp Reserved
5076-5077 Unassigned
pixelpusher 5078 udp PixelPusher pixel data heroicrobotics.com Jasmine Strong 2014-06-24
5078 tcp Reserved
5079 tcp Reserved
cp-spxrpts 5079 udp Cambridge Pixel SPx Reports Richard Warren Richard Warren 2008-09-17
biotic 5087 tcp BIOTIC - Binary Internet of Things Interoperable Communication Waher Data AB Peter Waher 2014-06-16 2015-11-25
5087 udp Reserved
actifioreplic 5107 tcp Disk to Disk replication between Actifio Clusters Actifio Madhav Mutalik 2015-10-23
5107 udp Reserved
gradecam 5117 tcp GradeCam Image Processing Robert Porter Robert Porter 2009-09-24
5117 udp Reserved
ctsd 5137 tcp MyCTS server port Jilles Oldenbeuving Jilles Oldenbeuving 2002-06
ctsd 5137 udp MyCTS server port Jilles Oldenbeuving Jilles Oldenbeuving 2002-06
5147-5149 Unassigned
mediat 5157 tcp Mediat Remote Object Exchange Oliver Anan Oliver Anan 2010-09-02
5157 udp Reserved
scte104 5167 tcp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte104 5167 udp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
5169-5171 Unassigned
pcoip-mgmt 5172 tcp PC over IP Endpoint Management HP Inc. Jeff Jeansonne 2014-04-28 2026-03-10
5172 udp Reserved
5173-5189 Unassigned
tunstall-lwp 5197 tcp Tunstall Lone worker device interface Tunstall Healthcare (UK) Ltd. Robert Moore 2014-12-10
5197 udp Reserved
perfd 5227 tcp HP System Performance Metric Service Chris Bertin Chris Bertin 2009-05-19
perfd 5227 udp HP System Performance Metric Service Chris Bertin Chris Bertin 2009-05-19
mnet-discovery 5237 tcp m-net discovery Andy Crick Andy Crick 2007-11-13
mnet-discovery 5237 udp m-net discovery Andy Crick Andy Crick 2007-11-13
5247 tcp Reserved
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
cartographerxmp 5270 tcp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cartographerxmp 5270 udp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cuelink 5271 tcp StageSoft CueLink messaging Todd Pichler Todd Pichler 2010-03-26
cuelink-disc 5271 udp StageSoft CueLink discovery Todd Pichler Todd Pichler 2010-03-26
pk 5272 tcp PK Patrick Kara Patrick Kara
pk 5272 udp PK Patrick Kara Patrick Kara
5273-5279 Unassigned
5283-5297 Unassigned
sco-aip 5307 tcp SCO AIP Barrie Cooper Barrie Cooper
sco-aip 5307 udp SCO AIP Barrie Cooper Barrie Cooper
hpdevms 5317 tcp HP Device Monitor Service Alan Minchew Alan Minchew 2011-05-16
5317 udp Reserved
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
dns-llq 5352 tcp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
dns-llq 5352 udp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
mdns 5353 tcp Multicast DNS IESG IETF Chair RFC 6762
mdns 5353 udp Multicast DNS IESG IETF Chair RFC 6762
wsdapi 5357 tcp Web Services for Devices Henry Rawas Henry Rawas 2005-08
wsdapi 5357 udp Web Services for Devices Henry Rawas Henry Rawas 2005-08
stresstester 5397 tcp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
stresstester 5397 udp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
foresyte-clear 5407 tcp Foresyte-Clear Jorge Aldana Jorge Aldana
foresyte-clear 5407 udp Foresyte-Clear Jorge Aldana Jorge Aldana
sns-agent 5417 tcp SNS Agent Mary Holstage Mary Holstage
sns-agent 5417 udp SNS Agent Mary Holstage Mary Holstage
sco-peer-tta 5427 tcp SCO-PEER-TTA Andrew Shire Andrew Shire
sco-peer-tta 5427 udp SCO-PEER-TTA Andrew Shire Andrew Shire
5437 tcp Reserved
pmip6-data 5437 udp pmip6-data RFC 5844
5457-5460 Unassigned
apsolab-col 5470 tcp The Apsolab company's data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5470 udp Reserved
apsolab-cols 5471 tcp The Apsolab company's secure data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5471 udp Reserved
apsolab-tag 5472 tcp The Apsolab company's dynamic tag protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5472 udp Reserved
apsolab-tags 5473 tcp The Apsolab company's secure dynamic tag protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5473 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Actifio madhav.mutalik&actifio.com 2015-10-23
Adam Berk aberk&empirix.com
Alan Minchew alan.minchew&hp.com 2011-05-23
Alberto Fernandez af&xtec.com 2006-01
Andrew Shire sndrewsh&sco.com
Andy Crick acrick&haascnc.com 2007-11-13
Apsolab Inc. admin&apsolab.com 2014-11-10
Barrie Cooper barrie&sco.com
Bobby Krupczak rdk&krupczak.org 2008-04-03
Chris Bertin chris.bertin&hp.com 2009-05-19
Christopher Miller Chris.Miller&versatrans.com 2006-02
David Huffman sba&storix.com 2016-03-22
David Meermans david.meermans&aastra.com
Graham Parsons graham.parsons&reflective.com 2005-08
Greg Porter gporter&powerschool.com
Henry Rawas henryr&microsoft.com 2005-08
heroicrobotics.com jasmine&heroicrobotics.com 2014-06-24
HP Inc. jeff.jeansonne&hp.com 2026-03-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Goddard jamesg&taglim.com 2005-08
Jasmine Strong heroicrobotics.com jasmine&heroicrobotics.com 2014-06-24
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
Jeff Jeansonne jeff.jeansonne&hp.com 2026-03-10
Jeroen Massar jeroen&unfix.org 2005-08
Jilles Oldenbeuving ojilles&gmail.com 2020-11-18
Jorge Aldana operator&foresyte.com
Madhav Mutalik Actifio madhav.mutalik&actifio.com 2015-10-23
Mary Holstage holstege&firstfloor.com
Matej Sekoranja matej.sekoranja&cosylab.com 2012-03-23
Oliver Anan oliver&ananit.de 2010-09-02
Patrick Kara Patrick&eba.net
Peter Waher Waher Data AB peterwaher&hotmail.com 2015-11-25
Richard Warren richard&cambridgepixel.com 2008-09-17
Robert Moore Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Robert Porter rob&gradecam.com 2009-09-24
Roland van der Veen rvdveen&aqualectra.nl 2010-06-17
Storix Inc. sba&storix.com 2016-03-22
Stuart Cheshire cheshire&apple.com 2022-07-11
Thomas Russell trussell&scte.org 2005-05
Tim Maloney tim.maloney&allianceconsultingllc.com 2005-08
Todd Pichler todd.pichler&stagesoft.com 2010-03-26
Tunstall Healthcare (UK) Ltd. robert.moore&tunstall.com 2014-12-10
Waher Data AB peterwaher&hotmail.com 2015-11-25