Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5365-5396 Unassigned
stresstester 5397 tcp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
stresstester 5397 udp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
elektron-admin 5398 tcp Elektron Administration Chris Hawk Chris Hawk 2005-08
elektron-admin 5398 udp Elektron Administration Chris Hawk Chris Hawk 2005-08
securitychase 5399 tcp SecurityChase Daisuke Shinomiya Daisuke Shinomiya 2005-08
securitychase 5399 udp SecurityChase Daisuke Shinomiya Daisuke Shinomiya 2005-08
salient-dtasrv 5409 tcp Salient Data Server Richard Farnham Richard Farnham
salient-dtasrv 5409 udp Salient Data Server Richard Farnham Richard Farnham
dj-ice 5419 tcp DJ-ICE Don Tyson Don Tyson
dj-ice 5419 udp DJ-ICE Don Tyson Don Tyson
base 5429 tcp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
base 5429 udp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
5446-5449 Unassigned
5466-5469 Unassigned
5476-5499 Unassigned
5508-5539 Unassigned
5544-5549 Unassigned
rdmnet-ctrl 5569 tcp PLASA E1.33, Remote Device Management (RDM) controller status notifications PLASA Simon Newton 2012-06-01
rdmnet-device 5569 udp PLASA E1.33, Remote Device Management (RDM) messages PLASA Simon Newton 2012-06-01
fdtracks 5579 tcp FleetDisplay Tracking Service Henrik Woffinden Henrik Woffinden 2008-09-22
5579 udp Reserved
5587-5596 Unassigned
ininmessaging 5597 tcp inin secure messaging Mike Gagle Mike Gagle 2006-05
ininmessaging 5597 udp inin secure messaging Mike Gagle Mike Gagle 2006-05
mctfeed 5598 tcp MCT Market Data Feed Stephane Touizer Stephane Touizer 2006-05
mctfeed 5598 udp MCT Market Data Feed Stephane Touizer Stephane Touizer 2006-05
esinstall 5599 tcp Enterprise Security Remote Install Kimberly Gibbs Kimberly Gibbs
esinstall 5599 udp Enterprise Security Remote Install Kimberly Gibbs Kimberly Gibbs
5619-5626 Unassigned
symantec-sfdb 5629 tcp Symantec Storage Foundation for Database Quang Thoi Quang Thoi 2006-11
symantec-sfdb 5629 udp Symantec Storage Foundation for Database Quang Thoi Quang Thoi 2006-11
ics 5639 tcp Symantec Integrity Checking Service Symantec Danzhou Liu 2012-05-07
5639 udp Reserved
5667-5669 Unassigned
dccm 5679 tcp Direct Cable Connect Manager Mark Miller Mark Miller
dccm 5679 udp Direct Cable Connect Manager Mark Miller Mark Miller
qmvideo 5689 tcp QM video network management protocol Jamie Lokier Jamie Lokier 2006-05
qmvideo 5689 udp QM video network management protocol Jamie Lokier Jamie Lokier 2006-05
5690-5692 Unassigned
rbsystem 5693 tcp Robert Bosch Data Transfer Syntegon Technology GmbH Klaus Warth 2011-08-01 2020-02-04
5693 udp Reserved
5694-5695 Unassigned
kmip 5696 tcp Key Management Interoperability Protocol OASIS KMIP Technical Committee Robin Cover 2011-07-25
5696 udp Reserved
5697-5699 Unassigned
dpm-agent 5719 tcp DPM Agent Coordinator Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami 2006-05
dpm-agent 5719 udp DPM Agent Coordinator Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami 2006-05
openmail 5729 tcp Openmail User Agent Layer OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
openmail 5729 udp Openmail User Agent Layer OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
5749 Unassigned
spramsca 5769 tcp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
spramsca 5769 udp x509solutions Internal CA Brendan Fay Brendan Fay 2006-02
spramsd 5770 tcp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
spramsd 5770 udp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
5778-5779 Unassigned
5788-5792 Unassigned
xtreamx 5793 tcp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
xtreamx 5793 udp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
5794 tcp Reserved
spdp 5794 udp Simple Peered Discovery Protocol Dave Lindquist Dave Lindquist 2010-05-27
5795-5797 Unassigned
enlabel-dpl 5798 tcp Proprietary Website deployment service enLabel Global Services Clay S. Didier 2021-10-12
5798 udp Reserved
5799-5812 Unassigned
5815-5819 Unassigned
wherehoo 5859 tcp WHEREHOO Jim Youll Jim Youll
wherehoo 5859 udp WHEREHOO Jim Youll Jim Youll
5869-5882 Unassigned
5884-5899 Unassigned
rfb 5900 tcp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
rfb 5900 udp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
5901-5902 Unassigned
ff-ice 5903 tcp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 udp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ag-swim 5904 tcp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 udp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 sctp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
asmgcs 5905 tcp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
asmgcs 5905 udp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
asmgcs 5905 sctp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
rpas-c2 5906 tcp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 udp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 sctp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
dsd 5907 tcp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
dsd 5907 udp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
dsd 5907 sctp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
ipsma 5908 tcp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
ipsma 5908 udp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
ipsma 5908 sctp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
agma 5909 tcp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
agma 5909 udp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
agma 5909 sctp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
ats-atn 5910 tcp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-atn 5910 udp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cm 5910 sctp Context Management Justin Yu Justin Yu 2011-05-19
ats-acars 5911 tcp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-acars 5911 udp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cpdlc 5911 sctp Controller Pilot Data Link Communication Justin Yu Justin Yu 2011-05-18
ais-met 5912 tcp Aeronautical Information Service/Meteorological applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08

Contact Information

Name Organization Contact URI Last Updated
Ahmad Tajuddin Samsudin tajuddin&tmrnd.com.my 2007-02
Brendan Fay brendan.fay&x509solutions.com 2006-02
Chris Hawk chris&corriente.net 2005-08
Clay S. Didier enLabel Global Services cdidier&enlabel.com 2021-10-12
Daisuke Shinomiya shinomiya.daisu&jp.fujitsu.com 2005-08
Danzhou Liu Symantec Danzhou_Liu&symantec.com 2012-05-07
Dave Lindquist dlindquist&egistix.com 2010-05-27
Don Loughry DON_LOUGHRY&hp-cupertino-om4.om.hp.com
Don Tyson don.tyson&cor.dowjones.com
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
enLabel Global Services support&enlabel.com 2021-10-12
Graham Parsons graham.parsons&reflective.com 2005-08
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
Henrik Woffinden hw&nitramlexa.com 2008-09-22
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
Jamie Lokier jamie&jlokier.co.uk 2006-05
Jim Youll jim&media.mit.edu
Justin Yu yyu&mitre.org 2011-05-25
Kimberly Gibbs kimgib&ccgate-ut.axent.com
Klaus Warth Syntegon Technology GmbH Klaus.Warth&Syntegon.com 2020-02-04
Mark Miller mmiller&microsoft.com
Mike Gagle mikeg&inin.com 2006-05
OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Odo Maletzki Odo.Maletzki&ioag.de
OpenMail Encyclopedia opencyc&hpopd.pwd.hp.com
PLASA standards.na&plasa.org 2012-06-01
Quang Thoi quang_thoi&symantec.com 2006-11
Richard Farnham rfarnham&salient.com
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Simon Newton simon&nomis52.net 2012-06-01
Stephane Touizer touizer&microcaptrade.com 2006-05
Sundar Srinivasan sundars&microsoft.com 2006-05
Symantec info&symantec.com 2012-05-07
Syntegon Technology GmbH Klaus.Warth&syntegon.com 2020-02-04
Tristan Richardson iana&realvnc.com 2006-03
Vinay Badami VinayB&microsoft.com 2006-05