Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tcoaddressbook 1977 udp TCO Address Book Allan Panitch Allan Panitch
unisql 1978 tcp UniSQL
unisql 1978 udp UniSQL
unisql-java 1979 tcp UniSQL Java Keith Yarbrough Keith Yarbrough
unisql-java 1979 udp UniSQL Java Keith Yarbrough Keith Yarbrough
panquest-xact 1980 tcp PanQuest XACT Chris Vertonghen Chris Vertonghen 2025-11-20
panquest-xact 1980 udp PanQuest XACT Chris Vertonghen Chris Vertonghen 2025-11-20
p2pq 1981 tcp p2pQ Warren Alexander Warren Alexander
p2pq 1981 udp p2pQ Warren Alexander Warren Alexander
estamp 1982 tcp Evidentiary Timestamp Todd Glassey Todd Glassey
estamp 1982 udp Evidentiary Timestamp Todd Glassey Todd Glassey
lhtp 1983 tcp Loophole Test Protocol Kade Hansson Kade Hansson
lhtp 1983 udp Loophole Test Protocol Kade Hansson Kade Hansson
bb 1984 tcp BB Sean MacGuire Sean MacGuire
bb 1984 udp BB Sean MacGuire Sean MacGuire
hsrp 1985 tcp Hot Standby Router Protocol RFC 2281
hsrp 1985 udp Hot Standby Router Protocol RFC 2281
licensedaemon 1986 tcp cisco license management
licensedaemon 1986 udp cisco license management
tr-rsrb-p1 1987 tcp cisco RSRB Priority 1 port
tr-rsrb-p1 1987 udp cisco RSRB Priority 1 port
tr-rsrb-p2 1988 tcp cisco RSRB Priority 2 port
tr-rsrb-p2 1988 udp cisco RSRB Priority 2 port
tr-rsrb-p3 1989 tcp cisco RSRB Priority 3 port
tr-rsrb-p3 1989 udp cisco RSRB Priority 3 port
mshnet 1989 tcp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
mshnet 1989 udp MHSnet system Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
stun-p1 1990 tcp cisco STUN Priority 1 port
stun-p1 1990 udp cisco STUN Priority 1 port
stun-p2 1991 tcp cisco STUN Priority 2 port
stun-p2 1991 udp cisco STUN Priority 2 port
stun-p3 1992 tcp cisco STUN Priority 3 port
stun-p3 1992 udp cisco STUN Priority 3 port
ipsendmsg 1992 tcp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
ipsendmsg 1992 udp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
snmp-tcp-port 1993 tcp cisco SNMP TCP port
snmp-tcp-port 1993 udp cisco SNMP TCP port
stun-port 1994 tcp cisco serial tunnel port
stun-port 1994 udp cisco serial tunnel port
perf-port 1995 tcp cisco perf port
perf-port 1995 udp cisco perf port
tr-rsrb-port 1996 tcp cisco Remote SRB port
tr-rsrb-port 1996 udp cisco Remote SRB port
gdp-port 1997 tcp cisco Gateway Discovery Protocol
gdp-port 1997 udp cisco Gateway Discovery Protocol
x25-svc-port 1998 tcp cisco X.25 service (XOT)
x25-svc-port 1998 udp cisco X.25 service (XOT)
tcp-id-port 1999 tcp cisco identification port
tcp-id-port 1999 udp cisco identification port
dc 2001 tcp
wizard 2001 udp curry
search 2010 tcp
pipe-server 2010 udp IANA assigned this well-formed service name as a replacement for "pipe_server".
pipe_server 2010 udp This entry is an alias to "pipe-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
raid-cc 2011 tcp raid
servserv 2011 udp
ttyinfo 2012 tcp
raid-ac 2012 udp
raid-am 2013 tcp
raid-cd 2013 udp
troff 2014 tcp
raid-sf 2014 udp
cypress 2015 tcp
raid-cs 2015 udp
bootserver 2016 tcp
bootserver 2016 udp
cypress-stat 2017 tcp
bootclient 2017 udp
terminaldb 2018 tcp
rellpack 2018 udp
whosockami 2019 tcp
about 2019 udp
servexec 2021 tcp
xinuexpansion1 2021 udp
mobrien-chat 2031 tcp mobrien-chat Mike O'Brien Mike O'Brien 2004-11
mobrien-chat 2031 udp mobrien-chat Mike O'Brien Mike O'Brien 2004-11
interbase 2041 tcp
interbase 2041 udp
epnsdp 2051 tcp EPNSDP Hiroyasu Ogata Hiroyasu Ogata
epnsdp 2051 udp EPNSDP Hiroyasu Ogata Hiroyasu Ogata
lot105-ds-upd 2053 tcp Lot105 DSuper Updates Piers Scannell Piers Scannell
lot105-ds-upd 2053 udp Lot105 DSuper Updates Piers Scannell Piers Scannell
netmount 2061 tcp NetMount Alex Oberlander Alex Oberlander
netmount 2061 udp NetMount Alex Oberlander Alex Oberlander
acp-port 2071 tcp Axon Control Protocol Christiaan Simons Christiaan Simons
acp-port 2071 udp Axon Control Protocol Christiaan Simons Christiaan Simons
kme-trap-port 2081 tcp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
kme-trap-port 2081 udp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
prp 2091 tcp PRP Amir Peless Amir Peless
prp 2091 udp PRP Amir Peless Amir Peless
amiganetfs 2100 tcp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
amiganetfs 2100 udp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
rtcm-sc104 2101 tcp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
rtcm-sc104 2101 udp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
zephyr-srv 2102 tcp Zephyr server
zephyr-srv 2102 udp Zephyr server
zephyr-clt 2103 tcp Zephyr serv-hm connection
zephyr-clt 2103 udp Zephyr serv-hm connection
zephyr-hm 2104 tcp Zephyr hostmanager Greg Hudson Greg Hudson
zephyr-hm 2104 udp Zephyr hostmanager Greg Hudson Greg Hudson

Contact Information

Name Organization Contact URI Last Updated
Alex Oberlander alexo&netmount.com
Allan Panitch allanp&tcosoft.com
Amir Peless amirp&radware.co.il
Bob Kummerfeld bob&sarad.cs.su.oz.au
Chris Vertonghen chris&panquest.com 2025-11-20
Christiaan Simons christiaan.simons&axon.nl
Greg Hudson zephyr-bugs&mit.edu
Hiroyasu Ogata Ogata.Hiroyasu&exc.epson.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Kade Hansson kade_fh&postoffice.utas.edu.au
Keith Yarbrough kyarbro&windtraveller.com
Masakatsu Matsuo masa&sdsft.kme.mei.co.jp
Mike O'Brien mike&mobrien.com 2004-11
Piers Scannell iana-form&lot105.com
Rudi Chiarito nutello&sweetness.com
Sean MacGuire sean&maclawran.ca
Todd Glassey todd.glassey&att.net
Warren Alexander warren&chameleon-creative.co.uk
Wolfgang Rupprecht wolfgang&wsrcc.com