Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
RDCenter 4756 tcp Reticle Decision Center KLA Tencor/RAPID George Hwa 2016-10-17
4756 udp Reserved
4757-4773 Unassigned
4775-4783 Unassigned
4785 tcp Reserved
cncp 4785 udp Cisco Nexus Control Protocol Joseph Swaminathan Joseph Swaminathan 2009-04-01
4795-4799 Unassigned
4805-4826 Unassigned
wcr-remlib 4845 tcp WordCruncher Remote Library Service Jason Dzubak Jason Dzubak 2008-03-17
wcr-remlib 4845 udp WordCruncher Remote Library Service Jason Dzubak Jason Dzubak 2008-03-17
sun-as-nodeagt 4850 tcp Sun App Server - NA Kedar Mhaswade Kedar Mhaswade 2004-11
sun-as-nodeagt 4850 udp Sun App Server - NA Kedar Mhaswade Kedar Mhaswade 2004-11
derby-repli 4851 tcp Apache Derby Replication Jorgen Loland Jorgen Loland 2008-02-27
derby-repli 4851 udp Apache Derby Replication Jorgen Loland Jorgen Loland 2008-02-27
4852-4866 Unassigned
4872-4875 Unassigned
abbs 4885 tcp ABBS Ryan Rubley Ryan Rubley
abbs 4885 udp ABBS Ryan Rubley Ryan Rubley
4895-4898 Unassigned
frcs 4915 tcp Fibics Remote Control Service Ken Lagarec Ken Lagarec 2009-04-17
4915 udp Reserved
4931-4935 Unassigned
sybasesrvmon 4950 tcp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
sybasesrvmon 4950 udp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
pwgwims 4951 tcp PWG WIMS Ira McDonald Ira McDonald 2005-12
pwgwims 4951 udp PWG WIMS Ira McDonald Ira McDonald 2005-12
sagxtsds 4952 tcp SAG Directory Server Michael Chirila Michael Chirila 2006-01
sagxtsds 4952 udp SAG Directory Server Michael Chirila Michael Chirila 2006-01
dbsyncarbiter 4953 tcp Synchronization Arbiter Dave Neudoerffer Dave Neudoerffer 2009-11-18
4953 udp Reserved
4954-4968 Unassigned Known UNAUTHORIZED USE: port 4967
gerhcs 4985 tcp GER HC Standard Roger Ward Roger Ward 2009-09-25
4985 udp Reserved
commplex-main 5000 tcp
commplex-main 5000 udp
commplex-link 5001 tcp
commplex-link 5001 udp
rfe 5002 tcp radio free ethernet
rfe 5002 udp radio free ethernet
fmpro-internal 5003 tcp FileMaker, Inc. - Proprietary transport Clay Maeckel Clay Maeckel
fmpro-internal 5003 udp FileMaker, Inc. - Proprietary name binding Clay Maeckel Clay Maeckel
avt-profile-1 5004 tcp RTP media data RFC 3551; RFC 4571
avt-profile-1 5004 udp RTP media data RFC 3551
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 tcp RTP control protocol RFC 3551; RFC 4571
avt-profile-2 5005 udp RTP control protocol RFC 3551
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
wsm-server 5006 tcp wsm server Adam Berk Adam Berk
wsm-server 5006 udp wsm server Adam Berk Adam Berk
wsm-server-ssl 5007 tcp wsm server ssl Adam Berk Adam Berk
wsm-server-ssl 5007 udp wsm server ssl Adam Berk Adam Berk
synapsis-edge 5008 tcp Synapsis EDGE Paul Schilling Paul Schilling
synapsis-edge 5008 udp Synapsis EDGE Paul Schilling Paul Schilling
winfs 5009 tcp Microsoft Windows Filesystem Simon Skaria Simon Skaria 2006-01
winfs 5009 udp Microsoft Windows Filesystem Simon Skaria Simon Skaria 2006-01
telelpathstart 5010 tcp TelepathStart Helmuth Breitenfellner Helmuth Breitenfellner
telelpathstart 5010 udp TelepathStart Helmuth Breitenfellner Helmuth Breitenfellner
telelpathattack 5011 tcp TelepathAttack Helmuth Breitenfellner Helmuth Breitenfellner
telelpathattack 5011 udp TelepathAttack Helmuth Breitenfellner Helmuth Breitenfellner
nsp 5012 tcp NetOnTap Service Kim Hancock Kim Hancock 2007-10-24
nsp 5012 udp NetOnTap Service Kim Hancock Kim Hancock 2007-10-24
fmpro-v6 5013 tcp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
fmpro-v6 5013 udp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
5014 tcp Reserved
onpsocket 5014 udp Overlay Network Protocol Roger Matthias Roger Matthias 2009-08-24
fmwp 5015 tcp FileMaker, Inc. - Web publishing Alex Chen Alex Chen 2009-11-25
5015 udp Reserved
5016-5019 Unassigned
zenginkyo-1 5020 tcp zenginkyo-1 Masashi Suzaki Masashi Suzaki
zenginkyo-1 5020 udp zenginkyo-1 Masashi Suzaki Masashi Suzaki
zenginkyo-2 5021 tcp zenginkyo-2 Masashi Suzaki Masashi Suzaki
zenginkyo-2 5021 udp zenginkyo-2 Masashi Suzaki Masashi Suzaki
mice 5022 tcp mice server Alan Clifford Alan Clifford
mice 5022 udp mice server Alan Clifford Alan Clifford
htuilsrv 5023 tcp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
htuilsrv 5023 udp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
scpi-telnet 5024 tcp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-telnet 5024 udp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-raw 5025 tcp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-raw 5025 udp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
strexec-d 5026 tcp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
strexec-d 5026 udp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
strexec-s 5027 tcp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
strexec-s 5027 udp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
qvr 5028 tcp Quiqum Virtual Relais Philipp Marcel Albrecht Philipp Marcel Albrecht 2009-07-06
5028 udp Reserved
infobright 5029 tcp Infobright Database Server Mark Windrim Mark Windrim 2009-07-23
infobright 5029 udp Infobright Database Server Mark Windrim Mark Windrim 2009-07-23
5030 tcp Reserved 2006-12 2022-01-10 Historic usage was surfpass. De-Assigned on 2022-01-10
5030 udp Reserved 2006-12 2022-01-10 Historic usage was surfpass. De-Assigned on 2022-01-10
5031 tcp Reserved
dmp 5031 udp Direct Message Protocol Gjermund Wallenius Gjermund Wallenius 2009-09-30
signacert-agent 5032 tcp SignaCert Enterprise Trust Server Agent Harris, Corporation Daniel R Somerfield 2011-08-05
5032 udp Reserved
jtnetd-server 5033 tcp Janstor Secure Data Janstor Technology Anthony Johnson 2015-06-08
5033 udp Reserved
jtnetd-status 5034 tcp Janstor Status Janstor Technology Anthony Johnson 2015-06-08
5034 udp Reserved
5035-5041 Unassigned
asnaacceler8db 5042 tcp asnaacceler8db Walter Goodwin Walter Goodwin
asnaacceler8db 5042 udp asnaacceler8db Walter Goodwin Walter Goodwin

Contact Information

Name Organization Contact URI Last Updated
Adam Berk aberk&empirix.com
Alan Clifford alan&clifford.ac
Alex Chen alex_chen&filemaker.com 2009-11-25
Anthony Johnson Janstor Technology jtadmin&janstor.com 2015-06-08
Chris Irie irie&sybase.com 2008-03-26
Clay Maeckel clay&claris.com 2023-09-12
Daniel R Somerfield dsomerfi&harris.com 2011-08-05
David Huffman sba&storix.com 2016-03-22
Dave Neudoerffer dave.neudoerffer&sybase.com 2009-11-18
Dennis Reinhardt DennisR&dair.com
George Hwa george.hwa&kla-tencor.com 2016-10-17
Gjermund Wallenius gwallenius&ndlocis.mil.no 2009-09-30
Harris, Corporation dsomerfi&harris.com 2011-08-05
Helmuth Breitenfellner hbreitenf&vnet.imb.com
Ira McDonald imcdonald&sharplabs.com 2005-12
Interchangeable Virtual Instruments Foundation, Inc. ivi.contact&ivifoundation.org 2021-05-06
Janstor Technology jtadmin&janstor.com 2015-06-08
Jason Dzubak dzubak&byu.edu 2008-03-17
Jorgen Loland jorgen.loland&sun.com 2008-02-27
Joseph Swaminathan jswamina&cisco.com 2009-04-01
Kedar Mhaswade kedar.Mhaswade&sun.com 2004-11
Ken Lagarec klagarec&fibics.com 2009-04-17
Kim Hancock registry&dragondex.com 2007-10-24
KLA Tencor/RAPID george.hwa&kla-tencor.com 2016-10-17
Larry Ostheimer larry_ostheimer&keysight.com 2021-05-06
Mark Windrim mark.windrim&infobright.com 2009-07-23
Masashi Suzaki susakim&noa.nttdata.jp
Michael Chirila Michael.Chirila&softwareag.com 2006-01
Paul Schilling PaulS&synapsis.com
Philipp Marcel Albrecht info&uisa.ch 2023-10-23
Roger Matthias rogermatthias&yahoo.co.uk 2009-08-24
Roger Ward roger.ward&ger911.com 2009-09-25
Ryan Rubley root&ark.dyn.ml.org
Simon Skaria simonsk&microsoft.com 2006-01
Storix Inc. sba&storix.com 2016-03-22
Walter Goodwin wpgoodwin&asna.com