Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5016-5019 Unassigned
strexec-d 5026 tcp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
strexec-d 5026 udp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
5046 tcp Reserved
vpm-udp 5046 udp Vishay PM UDP Service Ashley Clarke Ashley Clarke 2010-06-17
intecom-ps1 5056 tcp Intecom Pointspan 1 David Meermans David Meermans
intecom-ps1 5056 udp Intecom Pointspan 1 David Meermans David Meermans
sip 5060 tcp SIP 2014-04-09 RFC 3263
sip 5060 udp SIP 2014-04-09 RFC 3263
sip 5060 sctp SIP RFC 4168
sips 5061 tcp SIP-TLS 2014-04-09 RFC 3263
sips 5061 udp SIP-TLS 2014-04-09 RFC 3263
sips 5061 sctp SIP-TLS RFC 4168
na-localise 5062 tcp Localisation access Jean-Pierre Garcia Jean-Pierre Garcia 2009-10-28
na-localise 5062 udp Localisation access Jean-Pierre Garcia Jean-Pierre Garcia 2009-10-28
csrpc 5063 tcp centrify secure RPC Paul Moore Paul Moore 2009-10-28
5063 udp Reserved
ca-1 5064 tcp Channel Access 1 Jeffrey Hill Jeffrey Hill 2002-08
ca-1 5064 udp Channel Access 1 Jeffrey Hill Jeffrey Hill 2002-08
ca-2 5065 tcp Channel Access 2 Jeffrey Hill Jeffrey Hill 2002-08
ca-2 5065 udp Channel Access 2 Jeffrey Hill Jeffrey Hill 2002-08
stanag-5066 5066 tcp STANAG-5066-SUBNET-INTF Rickard Berg Rickard Berg 2025-10-22
stanag-5066 5066 udp STANAG-5066-SUBNET-INTF Rickard Berg Rickard Berg 2025-10-22
authentx 5067 tcp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
authentx 5067 udp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
bitforestsrv 5068 tcp Bitforest Data Service Ville-Pekka Vahteala Ville-Pekka Vahteala 2008-06-05
5068 udp Reserved
i-net-2000-npr 5069 tcp I/Net 2000-NPR Chris Megede Chris Megede
i-net-2000-npr 5069 udp I/Net 2000-NPR Chris Megede Chris Megede
5076-5077 Unassigned
aprigo-cs 5086 tcp Aprigo Collection Service Ron Zalkind Ron Zalkind 2010-05-28
5086 udp Reserved
cxtp 5091 sctp Context Transfer Protocol 2005-07 RFC 4065
actifioudsagent 5106 tcp Actifio UDS Agent Actifio Madhav Mutalik 2014-06-05
5106 udp Reserved
5116 tcp Reserved
emb-proj-cmd 5116 udp EPSON Projecter Image Transfer SEIKO EPSON SEIKO EPSON 2008-11-17
5136 tcp Reserved
minotaur-sa 5136 udp Minotaur SA Kenneth Flynn Kenneth Flynn 2009-10-14
social-alarm 5146 tcp Social Alarm Service Shaun Byrne Shaun Byrne 2009-08-18
5146 udp Reserved
rugameonline 5156 tcp Russian Online Game Andrey Mohov Andrey Mohov 2010-08-17
5156 udp Reserved
5158-5160 Unassigned
snmpssh 5161 tcp SNMP over SSH Transport Model RFC 5592
5161 udp Reserved
snmpssh-trap 5162 tcp SNMP Notification over SSH Transport Model RFC 5592 Known Unauthorized Use on port 5162
5162 udp Reserved Known Unauthorized Use on port 5162
sbackup 5163 tcp Shadow Backup Glenn Allen Glenn Allen 2009-08-05
5163 udp Reserved
vpa 5164 tcp Virtual Protocol Adapter Douglas Goodall Douglas Goodall 2009-08-05
vpa-disc 5164 udp Virtual Protocol Adapter Discovery Douglas Goodall Douglas Goodall 2009-08-05
ife-icorp 5165 tcp ife_1corp

IANA assigned this well-formed service name as a replacement for "ife_icorp".
Paul Annala Paul Annala
ife_icorp 5165 tcp ife_1corp Paul Annala Paul Annala This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms.
ife-icorp 5165 udp ife_1corp

IANA assigned this well-formed service name as a replacement for "ife_icorp".
Paul Annala Paul Annala
ife_icorp 5165 udp ife_1corp Paul Annala Paul Annala This entry is an alias to "ife-icorp". This entry is now historic, not usable for use with many common service discovery mechanisms.
winpcs 5166 tcp WinPCS Service Connection Complan Network AS Complan Network AS 2006-02
winpcs 5166 udp WinPCS Service Connection Complan Network AS Complan Network AS 2006-02
scte104 5167 tcp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte104 5167 udp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte30 5168 tcp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
scte30 5168 udp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
5169-5171 Unassigned
ampl-tableproxy 5196 tcp The protocol is used by two programs that exchange "table" data used in the AMPL modeling language AMPL Optimization, Inc. David M. Gay 2012-05-25
5196 udp Reserved
5216-5220 Unassigned
xmpp-client 5222 tcp XMPP Client Connection RFC 6120
hp-status 5226 tcp HP Status Brett Green Brett Green
hp-status 5226 udp HP Status Brett Green Brett Green
padl2sim 5236 tcp
padl2sim 5236 udp
5246 tcp Reserved
capwap-control 5246 udp CAPWAP Control Protocol RFC 5415
5255-5263 Unassigned
3com-njack-1 5264 tcp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-1 5264 udp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-2 5265 tcp 3Com Network Jack Port 2 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-2 5265 udp 3Com Network Jack Port 2 Abhay Rajaram Abhay Rajaram 2003-03
5266-5268 Unassigned
xmpp-server 5269 tcp XMPP Server Connection RFC 6120
5269 udp Reserved
sun-mc-grp 5306 tcp Sun MC Group Michael DeMoney Michael DeMoney
sun-mc-grp 5306 udp Sun MC Group Michael DeMoney Michael DeMoney
hpbladems 5316 tcp HPBladeSystem Monitor Service Alan Minchew Alan Minchew 2011-05-23 2011-05-16
5316 udp Unassigned 2011-05-16
turns 5349 tcp TURN over TLS 2019-08-02 RFC 8656
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
dns-llq 5352 tcp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
dns-llq 5352 udp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
mdns 5353 tcp Multicast DNS IESG IETF Chair RFC 6762
mdns 5353 udp Multicast DNS IESG IETF Chair RFC 6762
ms-smlbiz 5356 tcp Microsoft Small Business Gopikrishna Sandra Gopikrishna Sandra 2005-02
ms-smlbiz 5356 udp Microsoft Small Business Gopikrishna Sandra Gopikrishna Sandra 2005-02
ms-sideshow 5360 tcp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-sideshow 5360 udp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-s-sideshow 5361 tcp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-s-sideshow 5361 udp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
serverwsd2 5362 tcp Microsoft Windows Server WSD2 Service Erhan Soyer-Osman Erhan Soyer-Osman 2008-03-26
serverwsd2 5362 udp Microsoft Windows Server WSD2 Service Erhan Soyer-Osman Erhan Soyer-Osman 2008-03-26

Contact Information

Name Organization Contact URI Last Updated
Actifio madhav.mutalik&actifio.com 2015-10-23
Abhay Rajaram Abhay_Rajaram&3com.com 2003-03
Alan Minchew alan.minchew&hp.com 2011-05-23
Alberto Fernandez af&xtec.com 2006-01
AMPL Optimization, Inc. dmg&ampl.com 2012-05-25
Andrey Mohov mohov_andrey&mail.ru 2010-08-17
Ashley Clarke Ashley.clarke&vishaypg.com 2010-06-17
Brett Green Brett_Green&hp.com
Chris Megede chris.megede&tac.com
Complan Network AS knut&winpcs.com 2006-02
Dan Polivy dpolivy&microsoft.com 2008-03-12
David Huffman sba&storix.com 2016-03-22
David M. Gay AMPL Optimization, Inc. dmg&ampl.com 2012-05-25
David Meermans david.meermans&aastra.com
Douglas Goodall douglas_goodall&mac.com 2009-08-05
Erhan Soyer-Osman erhanso&microsoft.com 2008-03-26
Glenn Allen gallen&goorooinc.com 2009-08-05
Gopikrishna Sandra v-gosand&microsoft.com 2005-02
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Pierre Garcia jp.garcia&netia.com 2009-10-28
Jeffrey Hill johill&lanl.gov 2002-08
Kenneth Flynn flynnk&darkcornersoftware.com 2009-10-14
Madhav Mutalik Actifio madhav.mutalik&actifio.com 2015-10-23
Michael DeMoney demoney&eng.sun.com
Paul Annala paa&bull.se
Paul Moore paul.moore&centrify.com 2009-10-28
Rickard Berg rickard.berg&fmv.se 2025-10-22
Ron Zalkind ron&aprigo.com 2010-05-28
SEIKO EPSON ProjectorSoft&exc.epson.co.jp 2008-11-17
Shaun Byrne s_byrne&tunstall.co.uk 2009-08-18
Storix Inc. sba&storix.com 2016-03-22
Stuart Cheshire cheshire&apple.com 2022-07-11
Thomas Russell trussell&scte.org 2005-05
Ville-Pekka Vahteala ville-pekka.vahteala&bitcomp.fi 2008-06-05