Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ais-met | 5912 | tcp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ais-met | 5912 | udp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| fis | 5912 | sctp | Flight Information Services | Justin Yu | Justin Yu | 2011-05-25 | |||||
| aoc-acars | 5913 | tcp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| aoc-acars | 5913 | udp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ads-c | 5913 | sctp | Automatic Dependent Surveillance | Justin Yu | Justin Yu | 2011-05-25 | |||||
| ipsdtls | 5914 | tcp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | udp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | sctp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| 5915-5962 | Unassigned | ||||||||||
| indy | 5963 | tcp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| indy | 5963 | udp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| 5964-5967 | Unassigned | ||||||||||
| mppolicy-v5 | 5968 | tcp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-v5 | 5968 | udp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | tcp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | udp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| 5970-5983 | Unassigned | ||||||||||
| couchdb | 5984 | tcp | CouchDB | Noah Slater | Noah Slater | 2007-11-27 | |||||
| couchdb | 5984 | udp | CouchDB | Noah Slater | Noah Slater | 2007-11-27 | |||||
| wsman | 5985 | tcp | WBEM WS-Management HTTP | Jim Davis | Jim Davis | 2006-11 | |||||
| wsman | 5985 | udp | WBEM WS-Management HTTP | Jim Davis | Jim Davis | 2006-11 | |||||
| wsmans | 5986 | tcp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| wsmans | 5986 | udp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| wbem-rmi | 5987 | tcp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| wbem-rmi | 5987 | udp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| wbem-http | 5988 | tcp | WBEM CIM-XML (HTTP) | Jim Davis | Jim Davis | ||||||
| wbem-http | 5988 | udp | WBEM CIM-XML (HTTP) | Jim Davis | Jim Davis | ||||||
| wbem-https | 5989 | tcp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-https | 5989 | udp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-exp-https | 5990 | tcp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| wbem-exp-https | 5990 | udp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| nuxsl | 5991 | tcp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| nuxsl | 5991 | udp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| consul-insight | 5992 | tcp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| consul-insight | 5992 | udp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| cim-rs | 5993 | tcp | DMTF WBEM CIM REST | WS, Inc | Jim Davis | 2015-04-24 | |||||
| 5993 | udp | Reserved | |||||||||
| rms-agent | 5994 | tcp | RMS Agent Listening Service | RiverMeadow Software Inc. | Greg Dennis | 2021-03-24 | |||||
| 5994 | udp | Reserved | |||||||||
| 5995-5998 | Unassigned | ||||||||||
| cvsup | 5999 | tcp | CVSup | Randall Atkinson | Randall Atkinson | ||||||
| cvsup | 5999 | udp | CVSup | Randall Atkinson | Randall Atkinson | ||||||
| trip | 6069 | tcp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| trip | 6069 | udp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| 6078-6079 | Unassigned | ||||||||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| reload-config | 6084 | tcp | Peer to Peer Infrastructure Configuration | IESG | IETF Chair | 2009-01-29 | 2013-03-26 | RFC 6940 | |||
| 6089-6098 | Unassigned | ||||||||||
| raxa-mgmt | 6099 | tcp | RAXA Management | Sukanta Ganguly | Sukanta Ganguly | ||||||
| 6099 | udp | Reserved | |||||||||
| globecast-id | 6109 | tcp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| globecast-id | 6109 | udp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| 6119-6120 | Unassigned | ||||||||||
| 6125-6129 | Unassigned | ||||||||||
| 6134-6139 | Unassigned | ||||||||||
| tal-pod | 6149 | tcp | tal-pod | Steven Loomis | Steven Loomis | ||||||
| tal-pod | 6149 | udp | tal-pod | Steven Loomis | Steven Loomis | ||||||
| efb-aci | 6159 | tcp | EFB Application Control Interface | Jonathan Schaaf | Jonathan Schaaf | 2010-02-10 | |||||
| 6159 | udp | Reserved | |||||||||
| 6164-6199 | Unassigned | ||||||||||
| qmtps | 6209 | tcp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| qmtps | 6209 | udp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| grid-alt | 6269 | tcp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid-alt | 6269 | udp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| 6270-6299 | Unassigned | ||||||||||
| 6319 | Unassigned | ||||||||||
| 6348-6349 | Unassigned | ||||||||||
| 6356-6359 | Unassigned | ||||||||||
| 6364-6369 | Unassigned | ||||||||||
| redis | 6379 | tcp | An advanced key-value cache and store | Salvatore Sanfilippo | Itamar Haber | 2015-04-23 | |||||
| 6379 | udp | Reserved | |||||||||
| clariion-evr01 | 6389 | tcp | clariion-evr01 | Dave DesRoches | Dave DesRoches | ||||||
| clariion-evr01 | 6389 | udp | clariion-evr01 | Dave DesRoches | Dave DesRoches | ||||||
| metaedit-ws | 6390 | tcp | MetaEdit+ WebService API | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| metaedit-ws | 6390 | udp | MetaEdit+ WebService API | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| 6391-6399 | Unassigned | ||||||||||
| boe-resssvr3 | 6409 | Business Objects Enterprise internal server | SAP | Giriraj Harapanahalli | 2008-05-05 | 2026-05-27 | |||||
| svdrp | 6419 | tcp | Simple VDR Protocol | Klaus Schmidinger | Klaus Schmidinger | 2010-03-31 | |||||
| svdrp-disc | 6419 | udp | Simple VDR Protocol Discovery | Klaus Schmidinger | Klaus Schmidinger | 2015-05-08 | |||||
| 6433-6439 | Unassigned | ||||||||||
| 6472-6479 | Unassigned | ||||||||||
| sun-sr-admin | 6489 | tcp | Service Registry Default Admin Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| sun-sr-admin | 6489 | udp | Service Registry Default Admin Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| 6490-6499 | Unassigned | ||||||||||
| mgcs-mfp-port | 6509 | tcp | MGCS-MFP Port | Minoru Ozaki | Minoru Ozaki | ||||||
| mgcs-mfp-port | 6509 | udp | MGCS-MFP Port | Minoru Ozaki | Minoru Ozaki | ||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | IESG | IETF Chair | 2024-01-24 | RFC 7589; RFC 9918 | ||||
| apc-6549 | 6549 | tcp | APC 6549 | American Power Conversion | American Power Conversion | ||||||
| apc-6549 | 6549 | udp | APC 6549 | American Power Conversion | American Power Conversion | ||||||
| 6559-6565 | Unassigned | ||||||||||
| 6569-6578 | Unassigned | ||||||||||
| affiliate | 6579 | tcp | Affiliate | David Catmull | David Catmull | 2006-01 | |||||
| affiliate | 6579 | udp | Affiliate | David Catmull | David Catmull | 2006-01 | |||||
| 6589-6599 | Unassigned | ||||||||||
| 6603-6609 | Unassigned | ||||||||||
| odette-ftps | 6619 | tcp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| odette-ftps | 6619 | udp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| nexgen-aux | 6629 | tcp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| nexgen-aux | 6629 | udp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| 6637-6639 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Allied Electronics | Rob&AlliedElectronics.com | 2016-11-29 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Arthur Hillenaar | arthur.hillenaar&consul.com | 2006-01 | |
| Bjorn Lantz | bjorn.lantz&encode.se | 2004-11 | |
| Dave DesRoches | ddesroches&clariion.com | ||
| David Catmull | uncommon&uncommonplace.com | 2006-01 | |
| Denise Eckstein | denise.eckstein&hp.com | 2004-11 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Erwin Hoffmann | FEHCom | feh&fehcom.de | 2015-01-09 |
| FEHCom | feh&fehcom.de | 2015-01-09 | |
| Giriraj Harapanahalli | giriraj.harapanahalli&sap.com | 2026-05-27 | |
| Greg Dennis | RiverMeadow Software Inc. | gdennis&rivermeadow.com | 2021-03-24 |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| Hussein F. Salama | hsalama&cisco.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Itamar Haber | Salvatore Sanfilippo | itamar&redislabs.com | 2015-04-23 |
| Ieuan Friend | ieuan.friend&dip.co.uk | 2006-03 | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jason Hamilton | JHamilton&griddatasecurity.com | 2006-06 | |
| Jim Davis | jim.davis&wbemsolutions.com | 2007-06 | |
| Jim Davis | WS, Inc | Jim.Davis&ws-inc.com | 2015-04-24 |
| Jonathan Schaaf | j.schaaf&astronautics.com | 2010-02-10 | |
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kai Kretschmann | K.Kretschmann&security-gui.de | 2002-03 | |
| Klaus Schmidinger | Klaus.Schmidinger&tvdr.de | 2010-03-31 | |
| Minoru Ozaki | Minoru.Ozaki&rdmg.mgcs.mei.co.jp | ||
| Nathan Lackey | nathan.lackey&boeing.com | 2024-11-19 | |
| Noah Slater | nslater&bytesexual.org | 2007-11-27 | |
| Paul Sterk | paul.sterk&sun.com | 2006-03 | |
| Piers Scannell | piers&globecastne.com | ||
| Randall Atkinson | rja&inet.org | ||
| RiverMeadow Software Inc. | gdennis&rivermeadow.com | 2021-03-24 | |
| Robert E. Tomenchok Jr. | Rob&AlliedElectronics.com | 2016-11-29 | |
| Salvatore Sanfilippo | antirez&gmail.com | 2015-04-23 | |
| SAP | Giriraj Harapanahalli | 2026-05-27 | |
| Steven Kelly | stevek&metacase.com | 2007-11-12 | |
| Steven Loomis | srl&taligent.com | ||
| Sukanta Ganguly | sganguly&kineticnetworks.com | ||
| WS, Inc | Jim.Davis&ws-inc.com | 2015-04-24 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |