Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| unieng | 5730 | tcp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| unieng | 5730 | udp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| 5731-5740 | Unassigned | ||||||||||
| ida-discover1 | 5741 | tcp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| ida-discover1 | 5741 | udp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| ida-discover2 | 5742 | tcp | IDA Discover Port 2 | MPITech Support | MPITech Support | ||||||
| ida-discover2 | 5742 | udp | IDA Discover Port 2 | MPITech Support | MPITech Support | ||||||
| watchdoc-pod | 5743 | tcp | Watchdoc NetPOD Protocol | Christophe Chevalier | Christophe Chevalier | 2005-08 | |||||
| watchdoc-pod | 5743 | udp | Watchdoc NetPOD Protocol | Christophe Chevalier | Christophe Chevalier | 2005-08 | |||||
| watchdoc | 5744 | tcp | Watchdoc Server | Christophe Chevalier | Christophe Chevalier | 2004-11 | |||||
| watchdoc | 5744 | udp | Watchdoc Server | Christophe Chevalier | Christophe Chevalier | 2004-11 | |||||
| fcopy-server | 5745 | tcp | fcopy-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopy-server | 5745 | udp | fcopy-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopys-server | 5746 | tcp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopys-server | 5746 | udp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| tunatic | 5747 | tcp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunatic | 5747 | udp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunalyzer | 5748 | tcp | Wildbits Tunalyzer | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunalyzer | 5748 | udp | Wildbits Tunalyzer | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| 5749 | Unassigned | ||||||||||
| rscd | 5750 | tcp | Bladelogic Agent Service | Brian Trevor | Brian Trevor | 2008-10-24 | |||||
| rscd | 5750 | udp | Bladelogic Agent Service | Brian Trevor | Brian Trevor | 2008-10-24 | |||||
| 5751-5754 | Unassigned | ||||||||||
| openmailg | 5755 | tcp | OpenMail Desk Gateway server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailg | 5755 | udp | OpenMail Desk Gateway server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| 5756 | Unassigned | ||||||||||
| x500ms | 5757 | tcp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| x500ms | 5757 | udp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| 5758-5765 | Unassigned | ||||||||||
| openmailns | 5766 | tcp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailns | 5766 | udp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| s-openmail | 5767 | tcp | OpenMail Suer Agent Layer (Secure) | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| s-openmail | 5767 | udp | OpenMail Suer Agent Layer (Secure) | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailpxy | 5768 | tcp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailpxy | 5768 | udp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| spramsca | 5769 | tcp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsca | 5769 | udp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsd | 5770 | tcp | x509solutions Secure Data | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsd | 5770 | udp | x509solutions Secure Data | Brendan Fay | Brendan Fay | 2006-02 | |||||
| netagent | 5771 | tcp | NetAgent | Bradley Birnbaum | Bradley Birnbaum | ||||||
| netagent | 5771 | udp | NetAgent | Bradley Birnbaum | Bradley Birnbaum | ||||||
| 5772-5776 | Unassigned | ||||||||||
| starfield-io | 5777 | tcp | Control commands and responses | Wayne Morrow | Wayne Morrow | 2003-10 | 2021-02-18 | ||||
| starfield-io | 5777 | udp | Control commands and responses | Wayne Morrow | Wayne Morrow | 2003-10 | 2021-02-18 | ||||
| 5778-5779 | Unassigned | ||||||||||
| vts-rpc | 5780 | tcp | Visual Tag System RPC | Graham Bloice | Graham Bloice | 2009-09-17 | |||||
| 5780 | udp | Reserved | |||||||||
| 3par-evts | 5781 | tcp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 3par-evts | 5781 | udp | 3PAR Event Reporting Service | Sushil Thomas | Sushil Thomas | 2008-03-10 | |||||
| 3par-mgmt | 5782 | tcp | 3PAR Management Service | Don Marselle | Don Marselle | 2008-04-09 | |||||
| 3par-mgmt | 5782 | udp | 3PAR Management Service | Don Marselle | Don Marselle | 2008-04-09 | |||||
| 3par-mgmt-ssl | 5783 | tcp | 3PAR Management Service with SSL | Don Marselle | Don Marselle | 2008-03-19 | |||||
| 3par-mgmt-ssl | 5783 | udp | 3PAR Management Service with SSL | Don Marselle | Don Marselle | 2008-03-19 | |||||
| 5784 | tcp | Reserved | |||||||||
| ibar | 5784 | udp | Cisco Interbox Application Redundancy | Cullen Jennings | Cullen Jennings | 2010-02-03 | |||||
| 3par-rcopy | 5785 | tcp | 3PAR Inform Remote Copy | Don Marselle | Don Marselle | 2010-02-03 | |||||
| 3par-rcopy | 5785 | udp | 3PAR Inform Remote Copy | Don Marselle | Don Marselle | 2008-04-09 | |||||
| 5786 | tcp | Reserved | |||||||||
| cisco-redu | 5786 | udp | redundancy notification | Ming Zhang | Ming Zhang | 2010-02-04 | |||||
| 5787 | tcp | Reserved | |||||||||
| waascluster | 5787 | udp | Cisco WAAS Cluster Protocol | Winston Chou | Winston Chou | 2011-02-08 | |||||
| 5788-5792 | Unassigned | ||||||||||
| xtreamx | 5793 | tcp | XtreamX Supervised Peer message | Ahmad Tajuddin Samsudin | Ahmad Tajuddin Samsudin | 2007-02 | |||||
| xtreamx | 5793 | udp | XtreamX Supervised Peer message | Ahmad Tajuddin Samsudin | Ahmad Tajuddin Samsudin | 2007-02 | |||||
| 5794 | tcp | Reserved | |||||||||
| spdp | 5794 | udp | Simple Peered Discovery Protocol | Dave Lindquist | Dave Lindquist | 2010-05-27 | |||||
| 5795-5797 | Unassigned | ||||||||||
| enlabel-dpl | 5798 | tcp | Proprietary Website deployment service | enLabel Global Services | Clay S. Didier | 2021-10-12 | |||||
| 5798 | udp | Reserved | |||||||||
| 5799-5812 | Unassigned | ||||||||||
| 5864-5867 | Unassigned | ||||||||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| dsd | 5907 | tcp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | udp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | sctp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| 5964-5967 | Unassigned | ||||||||||
| 5970-5983 | Unassigned | ||||||||||
| wbem-rmi | 5987 | tcp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| wbem-rmi | 5987 | udp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| 6067 | Unassigned | 2007-07-17 | |||||||||
| messageasap | 6070 | tcp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| messageasap | 6070 | udp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| ssdtp | 6071 | tcp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| ssdtp | 6071 | udp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| diagnose-proc | 6072 | tcp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| diagnose-proc | 6072 | udp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| directplay8 | 6073 | tcp | DirectPlay8 | John Kane | John Kane | ||||||
| directplay8 | 6073 | udp | DirectPlay8 | John Kane | John Kane | ||||||
| max | 6074 | tcp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| max | 6074 | udp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| dpm-acm | 6075 | tcp | Microsoft DPM Access Control Manager | Prabu Ambravaneswaran | Prabu Ambravaneswaran | 2009-10-29 | |||||
| 6075 | udp | Reserved | |||||||||
| msft-dpm-cert | 6076 | tcp | Microsoft DPM WCF Certificates | Microsoft Corporation | Prateek Sharma | 2011-08-04 | |||||
| 6076 | udp | Reserved | |||||||||
| iconstructsrv | 6077 | tcp | iConstruct Server | iConstruct (Aus) Pty Ltd | Afshin Jafari | 2012-12-21 | |||||
| 6077 | udp | Reserved | |||||||||
| 6078-6079 | Unassigned | ||||||||||
| ldss | 6087 | tcp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| ldss | 6087 | udp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| etc-control | 6107 | tcp | ETC Control | Electronic Theatre Controls, Inc. | ETC IANA Registration | 2021-09-24 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Afshin Jafari | iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 |
| Ahmad Tajuddin Samsudin | tajuddin&tmrnd.com.my | 2007-02 | |
| Allan Miller | amiller&handsfreenetworks.com | ||
| Bernard Desruisseaux | bernard&steltor.com | ||
| Bradley Birnbaum | bradley.birnbaum&eshare.com | ||
| Brendan Fay | brendan.fay&x509solutions.com | 2006-02 | |
| Brian Trevor | btrevor&bmc.com | 2008-10-24 | |
| Christophe Chevalier | chevalier&archimed.fr | 2005-08 | |
| Clay S. Didier | enLabel Global Services | cdidier&enlabel.com | 2021-10-12 |
| Clifford Heath | cjh&managesoft.com | 2006-05 | |
| Cullen Jennings | fluffy&cisco.com | 2010-02-03 | |
| Dave Lindquist | dlindquist&egistix.com | 2010-05-27 | |
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| Don Marselle | don.marselle&3par.com | 2008-04-09 | |
| Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 | |
| enLabel Global Services | support&enlabel.com | 2021-10-12 | |
| ETC IANA Registration | Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 |
| Graham Bloice | graham.bloice&trihedral.com | 2009-09-17 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jay Beavers | Jay.Beaversµsoft.com | 2006-02 | |
| Jim Davis | jim.davis&wbemsolutions.com | 2007-06 | |
| John Kane | johnkanµsoft.com | ||
| MPITech Support | morten.christensen&i-data.com | ||
| Michael Shearson | mikes&softsys-inc.com | ||
| Microsoft Corporation | pratsharµsoft.com | 2011-08-04 | |
| Ming Zhang | mzhang&cisco.com | 2010-02-04 | |
| Moshe Leibovitch | moshe&softlinkusa.com | ||
| Murray Freeman | murray&officedomain.com | ||
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| Prabu Ambravaneswaran | prambravµsoft.com | 2009-10-29 | |
| Prateek Sharma | pratsharµsoft.com | 2011-08-04 | |
| Sushil Thomas | iana-comm&3par.com | 2008-03-10 | |
| Sylvain Demongeot | sylvain.demongeot&wildbits.com | 2005-08 | |
| Wayne Morrow | wmorrow&slaauto.com | 2021-02-18 | |
| Winston Chou | wichou&cisco.com | 2011-02-08 |