Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| zre-disc | 5670 | udp | Local area discovery and messaging over ZeroMQ | Pieter Hintjens | Pieter Hintjens | 2012-12-17 | |||||
| amqps | 5671 | tcp | amqp protocol over TLS/SSL | Ted Ross | Ted Ross | 2008-03-26 | |||||
| amqps | 5671 | udp | amqp protocol over TLS/SSL | Ted Ross | Ted Ross | 2008-03-26 | |||||
| amqp | 5672 | tcp | AMQP | Pieter Hintjens | Pieter Hintjens | 2006-01 | |||||
| amqp | 5672 | udp | AMQP | Pieter Hintjens | Pieter Hintjens | 2006-01 | |||||
| amqp | 5672 | sctp | AMQP | Martin Sustrik | Martin Sustrik | 2007-03 | |||||
| jms | 5673 | tcp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| jms | 5673 | udp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| hyperscsi-port | 5674 | tcp | HyperSCSI Port | Data Storage Institute of Singapore | Data Storage Institute of Singapore | 2002-02 | |||||
| hyperscsi-port | 5674 | udp | HyperSCSI Port | Data Storage Institute of Singapore | Data Storage Institute of Singapore | 2002-02 | |||||
| v5ua | 5675 | tcp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | udp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | sctp | V5UA application port | RFC 3807 | |||||||
| raadmin | 5676 | tcp | RA Administration | Sergei Zjaikin | Sergei Zjaikin | 2002-02 | |||||
| raadmin | 5676 | udp | RA Administration | Sergei Zjaikin | Sergei Zjaikin | 2002-02 | |||||
| questdb2-lnchr | 5677 | tcp | Quest Central DB2 Launchr | Robert M. Mackowiak | Robert M. Mackowiak | 2002-02 | |||||
| questdb2-lnchr | 5677 | udp | Quest Central DB2 Launchr | Robert M. Mackowiak | Robert M. Mackowiak | 2002-02 | |||||
| rrac | 5678 | tcp | Remote Replication Agent Connection | ||||||||
| rrac | 5678 | udp | Remote Replication Agent Connection | ||||||||
| dccm | 5679 | tcp | Direct Cable Connect Manager | Mark Miller | Mark Miller | ||||||
| dccm | 5679 | udp | Direct Cable Connect Manager | Mark Miller | Mark Miller | ||||||
| auriga-router | 5680 | tcp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| auriga-router | 5680 | udp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| ncxcp | 5681 | tcp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| ncxcp | 5681 | udp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| 5682 | tcp | Reserved | |||||||||
| brightcore | 5682 | udp | BrightCore control & data transfer exchange | Marko Bjelac | Marko Bjelac | 2010-06-10 | |||||
| coap | 5683 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 8323 | ||||
| coap | 5683 | udp | Constrained Application Protocol | IESG | IETF Chair | 2011-06-13 | 2013-07-25 | RFC 7252 | |||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| coaps | 5684 | udp | DTLS-secured CoAP | IESG | IETF Chair | 2013-07-25 | RFC 7252 | ||||
| 5685-5686 | Unassigned | ||||||||||
| gog-multiplayer | 5687 | udp | GOG multiplayer game protocol | GOG.com | Michał Gruchała | 2014-07-31 | 2014-10-09 | ||||
| 5687 | tcp | Reserved | |||||||||
| ggz | 5688 | tcp | GGZ Gaming Zone | Josef Spillner | Josef Spillner | 2003-01 | |||||
| ggz | 5688 | udp | GGZ Gaming Zone | Josef Spillner | Josef Spillner | 2003-01 | |||||
| qmvideo | 5689 | tcp | QM video network management protocol | Jamie Lokier | Jamie Lokier | 2006-05 | |||||
| qmvideo | 5689 | udp | QM video network management protocol | Jamie Lokier | Jamie Lokier | 2006-05 | |||||
| 5690-5692 | Unassigned | ||||||||||
| rbsystem | 5693 | tcp | Robert Bosch Data Transfer | Syntegon Technology GmbH | Klaus Warth | 2011-08-01 | 2020-02-04 | ||||
| 5693 | udp | Reserved | |||||||||
| 5694-5695 | Unassigned | ||||||||||
| kmip | 5696 | tcp | Key Management Interoperability Protocol | OASIS KMIP Technical Committee | Robin Cover | 2011-07-25 | |||||
| 5696 | udp | Reserved | |||||||||
| 5697-5699 | Unassigned | ||||||||||
| 5706-5712 | Unassigned | ||||||||||
| prosharerequest | 5716 | tcp | proshare conf request | gunner | gunner | ||||||
| prosharerequest | 5716 | udp | proshare conf request | gunner | gunner | ||||||
| ms-ilm-sts | 5726 | tcp | Microsoft Lifecycle Manager Secure Token Service | Rob Ward | Rob Ward | ||||||
| 5726 | udp | Reserved | 2008-05-02 | ||||||||
| fcopys-server | 5746 | tcp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopys-server | 5746 | udp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| 5756 | Unassigned | ||||||||||
| 5758-5765 | Unassigned | ||||||||||
| openmailns | 5766 | tcp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailns | 5766 | udp | OpenMail NewMail Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| s-openmail | 5767 | tcp | OpenMail Suer Agent Layer (Secure) | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| s-openmail | 5767 | udp | OpenMail Suer Agent Layer (Secure) | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailpxy | 5768 | tcp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailpxy | 5768 | udp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| spramsca | 5769 | tcp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsca | 5769 | udp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| 5772-5776 | Unassigned | ||||||||||
| 5786 | tcp | Reserved | |||||||||
| cisco-redu | 5786 | udp | redundancy notification | Ming Zhang | Ming Zhang | 2010-02-04 | |||||
| 5860-5862 | Unassigned | ||||||||||
| ppsuitemsg | 5863 | tcp | PlanetPress Suite Messeng | Yannick Fortin | Yannick Fortin | 2006-02 | |||||
| ppsuitemsg | 5863 | udp | PlanetPress Suite Messeng | Yannick Fortin | Yannick Fortin | 2006-02 | |||||
| 5864-5867 | Unassigned | ||||||||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| 5868 | udp | Reserved | |||||||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| 5869-5882 | Unassigned | ||||||||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rpas-c2 | 5906 | tcp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | udp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | sctp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| 5915-5962 | Unassigned | ||||||||||
| indy | 5963 | tcp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| indy | 5963 | udp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| 5964-5967 | Unassigned | ||||||||||
| mppolicy-v5 | 5968 | tcp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-v5 | 5968 | udp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | tcp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | udp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| wsmans | 5986 | tcp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| wsmans | 5986 | udp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| x11 | 6000-6063 | udp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| ndl-ahp-svc | 6064 | tcp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| ndl-ahp-svc | 6064 | udp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| winpharaoh | 6065 | tcp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| winpharaoh | 6065 | udp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| ewctsp | 6066 | tcp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| ewctsp | 6066 | udp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| 6067 | Unassigned | 2007-07-17 | |||||||||
| gsmp-ancp | 6068 | tcp | GSMP/ANCP | Avri Doria | Avri Doria | RFC 6320 | |||||
| 6068 | udp | Reserved | |||||||||
| trip | 6069 | tcp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| trip | 6069 | udp | TRIP | Hussein F. Salama | Hussein F. Salama |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Avri Doria | avri.doria&nokia.com | ||
| Basil Lee | basil.lee&gnnettest.com | ||
| Bjorn Lantz | bjorn.lantz&encode.se | 2004-11 | |
| Brendan Fay | brendan.fay&x509solutions.com | 2006-02 | |
| Data Storage Institute of Singapore | Patrick&dsi.nus.edu.sg | 2002-02 | |
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| GOG.com | admin&gog.com | 2014-07-31 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| Hussein F. Salama | hsalama&cisco.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jamie Lokier | jamie&jlokier.co.uk | 2006-05 | |
| Jim Davis | jim.davis&wbemsolutions.com | 2007-06 | |
| John Richmond | john&ndl.co.uk | ||
| Josef Spillner | admin&ggzgamingzone.org | 2003-01 | |
| Klaus Warth | Syntegon Technology GmbH | Klaus.Warth&Syntegon.com | 2020-02-04 |
| Mark Bailon | mark.bailon&ericsson.com | ||
| Mark Miller | mmillerµsoft.com | ||
| Marko Bjelac | marko.bjelac&elma.hr | 2010-06-10 | |
| Martin Sustrik | sustrik&imatix.com | 2007-03 | |
| Michał Gruchała | GOG.com | admin&gog.com | 2014-07-31 |
| Ming Zhang | mzhang&cisco.com | 2010-02-04 | |
| Moshe Leibovitch | moshe&softlinkusa.com | ||
| OASIS KMIP Technical Committee | robin&oasis-open.org | 2011-07-25 | |
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| Pieter Hintjens | ph&imatix.com | 2006-01 | |
| Pieter Hintjens | ph&imatix.com | 2012-12-17 | |
| Rob Ward | RobWardµsoft.com | 2008-05-02 | |
| Robert M. Mackowiak | rmackowiak&quest.com | 2002-02 | |
| Robin Cover | OASIS KMIP Technical Committee | robin&oasis-open.org | 2011-07-25 |
| Ryan Werber | ryan&ncxti.com | 2006-06 | |
| Sergei Zjaikin | serge&previo.ee | 2002-02 | |
| Stephen Gildea | gildea&lcs.mit.edu | ||
| Stuart Allen | stuart&jacl.animats.net | 2002-02 | |
| Syntegon Technology GmbH | Klaus.Warth&syntegon.com | 2020-02-04 | |
| Ted Ross | tross&redhat.com | 2008-03-26 | |
| Tristan Richardson | iana&realvnc.com | 2006-03 | |
| Vincent Gaudeul | technique&auriga.fr | 2006-02 | |
| Yannick Fortin | fortiny&ca.objectiflune.com | 2006-02 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp | ||
| gunner&ibeam.intel.com |