Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
etc-control 6107 tcp ETC Control Electronic Theatre Controls, Inc. ETC IANA Registration 2021-09-24
etc-control 6107 udp ETC Control Electronic Theatre Controls, Inc. ETC IANA Registration 2021-09-24
daylitetouch 6117 tcp Daylite Touch Sync Brent Gulanowski Brent Gulanowski 2009-08-26
6117 udp Reserved
montage-lm 6147 tcp Montage License Manager Michael Ubell Michael Ubell
montage-lm 6147 udp Montage License Manager Michael Ubell Michael Ubell
gld 6267 tcp GridLAB-D User Interface David Chassin David Chassin 2010-12-10
6267 udp Reserved
6270-6299 Unassigned
6307-6314 Unassigned
nav-data-cmd 6317 tcp Navtech Radar Sensor Data Command Navtech Radar Guy Avery 2013-02-20
nav-data 6317 udp Navtech Radar Sensor Data Navtech Radar Guy Avery 2013-02-20
6327-6342 Unassigned
gnutella-rtr 6347 tcp gnutella-rtr Serguei Osokine Serguei Osokine
gnutella-rtr 6347 udp gnutella-rtr Serguei Osokine Serguei Osokine
metaedit-se 6370 tcp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
metaedit-se 6370 udp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
6371-6378 Unassigned
redis 6379 tcp An advanced key-value cache and store Salvatore Sanfilippo Itamar Haber 2015-04-23
6379 udp Reserved
boe-resssvr1 6407 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
faxcomservice 6417 tcp Faxcom Message Service Albert Leung Albert Leung 2006-04
faxcomservice 6417 udp Faxcom Message Service Albert Leung Albert Leung 2006-04
6447-6454 Unassigned
6457-6463 Unassigned
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
6465-6470 Unassigned
lvision-lm 6471 tcp LVision License Manager Brian McKinnon Brian McKinnon
lvision-lm 6471 udp LVision License Manager Brian McKinnon Brian McKinnon
6472-6479 Unassigned
sun-sr-iiop-aut 6487 tcp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop-aut 6487 udp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
bdir-priv 6507 tcp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 tcp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 udp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 udp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
apc-6547 6547 tcp APC 6547 American Power Conversion American Power Conversion
apc-6547 6547 udp APC 6547 American Power Conversion American Power Conversion
6557 Unassigned
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
6569-6578 Unassigned
affiliate 6579 tcp Affiliate David Catmull David Catmull 2006-01
affiliate 6579 udp Affiliate David Catmull David Catmull 2006-01
6584-6587 Unassigned
nexgen 6627 tcp Allied Electronics NeXGen Lou Seitchik Lou Seitchik 2005-08
nexgen 6627 udp Allied Electronics NeXGen Lou Seitchik Lou Seitchik 2005-08
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6637-6639 Unassigned
ovsdb 6640 tcp Open vSwitch Database protocol Bruce Davie Bruce Davie 2013-07-31 RFC 7047
6657 tcp Reserved
palcom-disc 6657 udp PalCom Discovery Boris Magnusson Boris Magnusson 2010-12-06
vocaltec-gold 6670 tcp Vocaltec Global Online Directory Scott Petrack Scott Petrack
vocaltec-gold 6670 udp Vocaltec Global Online Directory Scott Petrack Scott Petrack
p4p-portal 6671 tcp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
p4p-portal 6671 udp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
vision-server 6672 tcp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
Chris Kramer Chris Kramer
vision_server 6672 tcp vision_server Chris Kramer Chris Kramer This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-server 6672 udp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
Chris Kramer Chris Kramer
vision_server 6672 udp vision_server Chris Kramer Chris Kramer This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 tcp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 tcp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 udp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 udp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6674-6677 Unassigned
vfbp 6678 tcp Viscount Freedom Bridge Protocol Chris MacDonald Chris MacDonald 2011-03-16
vfbp-disc 6678 udp Viscount Freedom Bridge Discovery Chris MacDonald Chris MacDonald 2011-03-16
osaut 6679 tcp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
osaut 6679 udp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
clever-ctrace 6687 tcp CleverView for cTrace Message Service David Cheng David Cheng 2010-02-01
6687 udp Reserved
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6697 udp Reserved 2014-02-11
6700 Unassigned 2010-01-26
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6704 udp Reserved
6704 tcp Reserved
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
6705 udp Reserved
6705 tcp Reserved
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
6706 udp Reserved
6706 tcp Reserved
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
6707-6713 Unassigned
ibprotocol 6714 tcp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
ibprotocol 6714 udp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
fibotrader-com 6715 tcp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
fibotrader-com 6715 udp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
princity-agent 6716 tcp Princity Agent ENSTEAM Sp. z o.o. Tomasz Krakowiak 2014-07-07 2015-07-08
6716 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Albert Leung aleung&biscom.com 2006-04
Alessandro Bassi abassi&cs.utk.edu
American Power Conversion ports&apcc.com 2002-02
Boris Magnusson boris&cs.lth.se 2010-12-06
Brent Gulanowski bgulanowski&marketcircle.com 2009-08-26
Brian McKinnon bmk&lvision.com
Bruce Davie bdavie&vmware.com 2013-07-31
Chris Griffiths chris_griffiths&cable.comcast.com 2008-07-28
Chris Kramer CKramer&gis.shl.com
Chris MacDonald chris&viscount.com 2011-03-16
David Catmull uncommon&uncommonplace.com 2006-01
David Chassin david.chassin&pnl.gov 2010-12-10
David Cheng davec&aesclever.com 2010-02-01
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Electronic Theatre Controls, Inc. ianaregistration&etcconnect.com 2021-09-24
ENSTEAM Sp. z o.o. support&ensteam.com 2015-07-08
ETC IANA Registration Electronic Theatre Controls, Inc. ianaregistration&etcconnect.com 2021-09-24
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Guy Avery Navtech Radar guy.avery&navtechradar.com 2013-02-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Itamar Haber Salvatore Sanfilippo itamar&redislabs.com 2015-04-23
Janos Lerch lerch&softic.hu 2006-02
Lou Seitchik lou&alliedelectronics.com 2005-08
Magnus Nystrom magnus&dynas.se
Michael Ubell michael&montage.com
Paul Sterk paul.sterk&sun.com 2006-03
Peter Hombach p.hombach&osorno.ca 2011-03-16
Robert Wetzold robert.wetzold&fibotrader.com 2006-01
Salvatore Sanfilippo antirez&gmail.com 2015-04-23
SAP Giriraj Harapanahalli 2026-05-27
Scott Petrack Scott_Petrack&vocaltec.com
Serguei Osokine osokin&paragraph.com
Stanley Knutson Stanley.Knutson&ktiworld.com
Steven Kelly stevek&metacase.com 2007-11-12
Tomasz Krakowiak ENSTEAM Sp. z o.o. tomasz.krakowiak&ensteam.com 2015-07-08