Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 6716 | udp | Reserved | |||||||||
| 6717-6766 | Unassigned | ||||||||||
| bmc-perf-agent | 6767 | tcp | BMC PERFORM AGENT | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-agent | 6767 | udp | BMC PERFORM AGENT | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-mgrd | 6768 | tcp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-mgrd | 6768 | udp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| adi-gxp-srvprt | 6769 | tcp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| adi-gxp-srvprt | 6769 | udp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| plysrv-http | 6770 | tcp | PolyServe http | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-http | 6770 | udp | PolyServe http | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-https | 6771 | tcp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-https | 6771 | udp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| 6772-6776 | Unassigned | ||||||||||
| ntz-tracker | 6777 | tcp | netTsunami Tracker | Tomahawk Holdings Ltd | Sagara Wijetunga | 2013-05-01 | |||||
| 6777 | udp | Reserved | |||||||||
| ntz-p2p-storage | 6778 | tcp | netTsunami p2p storage system | Tomahawk Holdings Ltd | Sagara Wijetunga | 2013-05-01 | |||||
| 6778 | udp | Reserved | |||||||||
| 6779-6783 | Unassigned | ||||||||||
| 6784 | tcp | Reserved | |||||||||
| bfd-lag | 6784 | udp | Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces | IESG | IETF BFD Working Group Chairs | 2012-11-08 | 2014-01-09 | RFC 7130 | |||
| dgpf-exchg | 6785 | tcp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| dgpf-exchg | 6785 | udp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| smc-jmx | 6786 | tcp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-jmx | 6786 | udp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | tcp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | udp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-http | 6788 | tcp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| smc-http | 6788 | udp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| radg | 6789 | tcp | GSS-API for the Oracle Remote Administration Daemon | Oracle | Shawn Emery | 2002-08 | 2016-09-15 | ||||
| 6789 | udp | Reserved | 2002-08 | 2016-09-15 | |||||||
| hnmp | 6790 | tcp | HNMP | Jude George | Jude George | ||||||
| hnmp | 6790 | udp | HNMP | Jude George | Jude George | ||||||
| hnm | 6791 | tcp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| hnm | 6791 | udp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| 6792-6800 | Unassigned | ||||||||||
| pentbox-sim | 6817 | tcp | PenTBox Secure IM Protocol | Alberto Ortega Llamas | Alberto Ortega Llamas | 2009-11-04 | |||||
| 6817 | udp | Reserved | |||||||||
| 6851-6867 | Unassigned | ||||||||||
| 6869-6887 | Unassigned | ||||||||||
| 6937-6945 | Unassigned | ||||||||||
| 6947-6950 | Unassigned | ||||||||||
| 6967-6968 | Unassigned | ||||||||||
| conductor | 6970 | tcp | Conductor test coordination protocol | George Neville-Neil | George Neville-Neil | 2014-09-18 | |||||
| 6970 | udp | Reserved | |||||||||
| conductor-mpx | 6970 | sctp | conductor for multiplex | George Neville-Neil | George Neville-Neil | 2014-07-29 | |||||
| 6971-6979 | Unassigned | ||||||||||
| MobilitySrv | 6997 | tcp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| MobilitySrv | 6997 | udp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| afs3-fileserver | 7000 | tcp | file server itself | ||||||||
| afs3-fileserver | 7000 | udp | file server itself | ||||||||
| afs3-callback | 7001 | tcp | callbacks to cache managers | Known Unauthorized Use on port 7001 | |||||||
| afs3-callback | 7001 | udp | callbacks to cache managers | Known Unauthorized Use on port 7001 | |||||||
| afs3-prserver | 7002 | tcp | users & groups database | Known Unauthorized Use on port 7002 | |||||||
| afs3-prserver | 7002 | udp | users & groups database | Known Unauthorized Use on port 7002 | |||||||
| afs3-vlserver | 7003 | tcp | volume location database | ||||||||
| afs3-vlserver | 7003 | udp | volume location database | ||||||||
| afs3-kaserver | 7004 | tcp | AFS/Kerberos authentication service | ||||||||
| afs3-kaserver | 7004 | udp | AFS/Kerberos authentication service | ||||||||
| afs3-volser | 7005 | tcp | volume managment server | Known Unauthorized Use on port 7005 | |||||||
| afs3-volser | 7005 | udp | volume managment server | Known Unauthorized Use on port 7005 | |||||||
| afs3-errors | 7006 | tcp | error interpretation service | ||||||||
| afs3-errors | 7006 | udp | error interpretation service | ||||||||
| afs3-bos | 7007 | tcp | basic overseer process | ||||||||
| afs3-bos | 7007 | udp | basic overseer process | ||||||||
| afs3-update | 7008 | tcp | server-to-server updater | ||||||||
| afs3-update | 7008 | udp | server-to-server updater | ||||||||
| afs3-rmtsys | 7009 | tcp | remote cache manager service | ||||||||
| afs3-rmtsys | 7009 | udp | remote cache manager service | ||||||||
| ups-onlinet | 7010 | tcp | onlinet uninterruptable power supplies | Jim Thompson | Jim Thompson | ||||||
| ups-onlinet | 7010 | udp | onlinet uninterruptable power supplies | Jim Thompson | Jim Thompson | ||||||
| talon-disc | 7011 | tcp | Talon Discovery Port | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-disc | 7011 | udp | Talon Discovery Port | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-engine | 7012 | tcp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| talon-engine | 7012 | udp | Talon Engine | Jim Thompson | Jim Thompson | Known Unauthorized Use on 7011 | |||||
| microtalon-dis | 7013 | tcp | Microtalon Discovery | Jim Thompson | Jim Thompson | ||||||
| microtalon-dis | 7013 | udp | Microtalon Discovery | Jim Thompson | Jim Thompson | ||||||
| microtalon-com | 7014 | tcp | Microtalon Communications | Jim Thompson | Jim Thompson | ||||||
| microtalon-com | 7014 | udp | Microtalon Communications | Jim Thompson | Jim Thompson | ||||||
| talon-webserver | 7015 | tcp | Talon Webserver | Jim Thompson | Jim Thompson | ||||||
| talon-webserver | 7015 | udp | Talon Webserver | Jim Thompson | Jim Thompson | ||||||
| spg | 7016 | tcp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| spg | 7016 | udp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| grasp | 7017 | tcp | GeneRic Autonomic Signaling Protocol | IESG | IETF Chair | 2017-04-28 | 2017-07-20 | RFC 8990 | |||
| grasp | 7017 | udp | GeneRic Autonomic Signaling Protocol | IESG | IETF Chair | 2017-04-28 | 2017-07-20 | RFC 8990 | |||
| fisa-svc | 7018 | tcp | FISA Service | FAUCONNET Ingénierie SA | FAUCONNET Ingénierie SA | 2011-05-19 | |||||
| 7018 | udp | Reserved | |||||||||
| doceri-ctl | 7019 | tcp | doceri drawing service control | Paul Brown | Paul Brown | 2011-04-27 | |||||
| doceri-view | 7019 | udp | doceri drawing service screen view | Paul Brown | Paul Brown | 2011-04-27 | |||||
| dpserve | 7020 | tcp | DP Serve | Allan Stanley | Allan Stanley | ||||||
| dpserve | 7020 | udp | DP Serve | Allan Stanley | Allan Stanley | ||||||
| dpserveadmin | 7021 | tcp | DP Serve Admin | Allan Stanley | Allan Stanley | ||||||
| dpserveadmin | 7021 | udp | DP Serve Admin | Allan Stanley | Allan Stanley | ||||||
| ctdp | 7022 | tcp | CT Discovery Protocol | James Kirkwood | James Kirkwood | 2005-06 | |||||
| ctdp | 7022 | udp | CT Discovery Protocol | James Kirkwood | James Kirkwood | 2005-06 | |||||
| ct2nmcs | 7023 | tcp | Comtech T2 NMCS | Bryan Wilcutt | Bryan Wilcutt | 2005-06 | |||||
| ct2nmcs | 7023 | udp | Comtech T2 NMCS | Bryan Wilcutt | Bryan Wilcutt | 2005-06 | |||||
| vmsvc | 7024 | tcp | Vormetric service | Tom Boyle | Tom Boyle | 2005-06 | |||||
| vmsvc | 7024 | udp | Vormetric service | Tom Boyle | Tom Boyle | 2005-06 | |||||
| vmsvc-2 | 7025 | tcp | Vormetric Service II | Tom Boyle | Tom Boyle | 2005-06 | |||||
| vmsvc-2 | 7025 | udp | Vormetric Service II | Tom Boyle | Tom Boyle | 2005-06 | |||||
| loreji-panel | 7026 | tcp | Loreji Webhosting Panel | J.A. Smit | DALTCORE | 2018-02-21 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alberto Ortega Llamas | alberto.kun666&gmail.com | 2009-11-04 | |
| Allan Stanley | allan&hummingbird.com | ||
| IETF BFD Working Group Chairs | bfd-chairs&tools.ietf.org | 2014-01-09 | |
| Bill Edwards | bill.edwards&sun.com | 2005-08 | |
| Bryan Wilcutt | bwilcutt&comtechefdata.com | 2005-06 | |
| DALTCORE | Info&daltcore.com | 2018-02-21 | |
| FAUCONNET Ingénierie SA | dev&fisa.fr | 2011-05-19 | |
| Fortra | info&fortra.com | 2023-05-24 | |
| George Neville-Neil | gnn&neville-neil.com | 2014-07-29 | |
| Henriët Wilkinson | henriet.wilkinson&fortra.com | 2023-05-24 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J.A. Smit | rsmit&daltcore.com | 2018-02-21 | |
| James Kirkwood | james.kirkwood&controltechniques.com | 2005-06 | |
| Jim Thompson | jim.thompson&powerware.com | ||
| Joseph T Savarese | joesa&nmwco.com | 2007-06 | |
| Jude George | jude&nas.nasa.gov | ||
| Mathew Pitchforth | mathew&adinstruments.co.nz | 2005-08 | |
| Mike Spitzer | mjs&polyserve.com | 2005-08 | |
| Oracle | shawn.emery&oracle.com | 2016-09-15 | |
| Paul Brown | pbrown&spcontrols.com | 2011-04-27 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Ratnadeep Bhattacharjee | ratnadeep.bhattacharjee&sun.com | 2002-11 | |
| Sagara Wijetunga | Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 |
| Shawn Emery | shawn.emery&oracle.com | 2016-09-15 | |
| SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 | |
| Steve Barton | SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 |
| Thomas Weise | weise&vs.uni-kassel.de | 2006-04 | |
| Tom Boyle | tboyle&vormetric.com | 2005-06 | |
| Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 |