Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| sossd-agent | 7982 | tcp | Spotlight on SQL Server Desktop Agent | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| sossd-disc | 7982 | udp | Spotlight on SQL Server Desktop Agent Discovery | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| 7983-7997 | Unassigned | ||||||||||
| pushns | 7997 | tcp | PUSH Notification Service | Tristan Seifert | Tristan Seifert | 2011-01-31 | |||||
| 7997 | udp | Reserved | |||||||||
| 7998 | tcp | Reserved | |||||||||
| usicontentpush | 7998 | udp | USI Content Push Service | Prakash Iyer | Prakash Iyer | 2009-08-10 | |||||
| irdmi2 | 7999 | tcp | iRDMI2 | ||||||||
| irdmi2 | 7999 | udp | iRDMI2 | ||||||||
| nvme-disc | 8009 | tcp | NVMe over Fabrics Discovery Service | NVM Express, Inc. | Amber Huffman | 2018-03-27 | |||||
| 8009 | udp | Reserved | |||||||||
| qbdb | 8019 | tcp | QB DB Dynamic Port | Sridhar Krishnamurthy | Sridhar Krishnamurthy | 2008-02-15 | |||||
| qbdb | 8019 | udp | QB DB Dynamic Port | Sridhar Krishnamurthy | Sridhar Krishnamurthy | 2008-02-15 | |||||
| 8035-8039 | Unassigned | ||||||||||
| senomix08 | 8059 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix08 | 8059 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| 8068-8069 | Unassigned | ||||||||||
| 8078-8079 | Unassigned | ||||||||||
| 8089 | Unassigned | ||||||||||
| opsmessaging | 8090 | tcp | Vehicle to station messaging | LAN-ACES | Robert Ripberger | 2017-02-08 | |||||
| 8090 | udp | Reserved | |||||||||
| jamlink | 8091 | tcp | Jam Link Framework | Evgeniy Filatov | Evgeniy Filatov | 2009-11-25 | |||||
| 8091 | udp | Reserved | |||||||||
| 8092-8096 | Unassigned | ||||||||||
| sac | 8097 | tcp | SAC Port Id | Girish Bhat | Girish Bhat | 2006-04 | |||||
| sac | 8097 | udp | SAC Port Id | Girish Bhat | Girish Bhat | 2006-04 | |||||
| 8098-8099 | Unassigned | ||||||||||
| 8119-8120 | Unassigned | ||||||||||
| paycash-wbp | 8129 | tcp | PayCash Wallet-Browser | MegaZone | MegaZone | 2005-08 | |||||
| paycash-wbp | 8129 | udp | PayCash Wallet-Browser | MegaZone | MegaZone | 2005-08 | |||||
| 8133-8139 | Unassigned | ||||||||||
| 8149 | tcp | Reserved | |||||||||
| eor-game | 8149 | udp | Edge of Reality game data | Sky Schulz | Sky Schulz | 2011-05-09 | |||||
| 8154-8159 | Unassigned | ||||||||||
| 8185-8189 | Unassigned | ||||||||||
| gcp-rphy | 8190 | tcp | Generic control plane for RPHY | CableLabs | Karthik Sundaresan | 2015-11-24 | |||||
| 8190 | udp | Reserved | |||||||||
| limnerpressure | 8191 | tcp | Limner Pressure | Aaron Kleinsteiber | Aaron Kleinsteiber | 2014-01-16 | |||||
| 8191 | udp | Reserved | |||||||||
| spytechphone | 8192 | tcp | SpyTech Phone Service | Bill Kay | Bill Kay | 2006-04 | |||||
| spytechphone | 8192 | udp | SpyTech Phone Service | Bill Kay | Bill Kay | 2006-04 | |||||
| 8193 | Unassigned | ||||||||||
| blp1 | 8194 | tcp | Bloomberg data API | Albert Hou | Albert Hou | 2006-05 | |||||
| blp1 | 8194 | udp | Bloomberg data API | Albert Hou | Albert Hou | 2006-05 | |||||
| blp2 | 8195 | tcp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| blp2 | 8195 | udp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| 8196-8198 | Unassigned | ||||||||||
| vvr-data | 8199 | tcp | VVR DATA | Ming Xu | Ming Xu | ||||||
| vvr-data | 8199 | udp | VVR DATA | Ming Xu | Ming Xu | ||||||
| 8209-8210 | Unassigned | ||||||||||
| 8212-8229 | Unassigned | ||||||||||
| 8267-8269 | Unassigned | ||||||||||
| 8277-8279 | Unassigned | ||||||||||
| 8283-8291 | Unassigned | ||||||||||
| blp3 | 8292 | tcp | Bloomberg professional | Albert Hou | Albert Hou | 2006-05 | |||||
| blp3 | 8292 | udp | Bloomberg professional | Albert Hou | Albert Hou | 2006-05 | |||||
| hiperscan-id | 8293 | tcp | Hiperscan Identification Service | Thomas Klose | Thomas Klose | 2009-12-15 | |||||
| 8293 | udp | Reserved | |||||||||
| blp4 | 8294 | tcp | Bloomberg intelligent client | Albert Hou | Albert Hou | 2006-05 | |||||
| blp4 | 8294 | udp | Bloomberg intelligent client | Albert Hou | Albert Hou | 2006-05 | |||||
| 8295-8299 | Unassigned | ||||||||||
| 8314-8319 | Unassigned | ||||||||||
| cruise-diags | 8379 | tcp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| cruise-diags | 8379 | udp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| 8385-8399 | Unassigned | ||||||||||
| 8449 | Unassigned | ||||||||||
| 8458-8469 | Unassigned | ||||||||||
| pim-port | 8471 | tcp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8475-8499 | Unassigned | ||||||||||
| 8568-8599 | Unassigned | ||||||||||
| 8609 | tcp | Reserved | |||||||||
| canon-cpp-disc | 8609 | udp | Canon Compact Printer Protocol Discovery | Canon Inc. | Ryusuke Okuhara | 2012-06-08 | 2012-06-15 | ||||
| 8669-8674 | Unassigned | ||||||||||
| 8689-8698 | Unassigned | ||||||||||
| vnyx | 8699 | tcp | VNYX Primary Port | Gregg Green | Gregg Green | 2004-11 | |||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| 8700-8709 | Unassigned | ||||||||||
| 8734-8749 | Unassigned | ||||||||||
| oktaauthenticat | 8769 | tcp | Okta MultiPlatform Access Mgmt for Cloud Svcs | Okta Inc | Tom Belote | 2019-12-19 | |||||
| 8769 | udp | Reserved | |||||||||
| 8779-8785 | Unassigned | ||||||||||
| 8788-8792 | Unassigned | ||||||||||
| acd-pm | 8793 | tcp | Accedian Performance Measurement | Marco Mascitto | Marco Mascitto | ||||||
| acd-pm | 8793 | udp | Accedian Performance Measurement | Marco Mascitto | Marco Mascitto | ||||||
| 8794-8799 | Unassigned | ||||||||||
| 8809 | tcp | Reserved | |||||||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| 8874-8879 | Unassigned | ||||||||||
| ddi-tcp-2 | 8889 | tcp | Desktop Data TCP 1 | Fred Yao | Fred Yao | Known Unauthorized Use on port 8889 | |||||
| ddi-udp-2 | 8889 | udp | NewsEDGE server broadcast | Fred Yao | Fred Yao | Known Unauthorized Use on port 8889 | |||||
| ddi-tcp-3 | 8890 | tcp | Desktop Data TCP 2 | Fred Yao | Fred Yao | Known Unauthorized Use on port 8890 | |||||
| ddi-udp-3 | 8890 | udp | NewsEDGE client broadcast | Fred Yao | Fred Yao | Known Unauthorized Use on port 8890 | |||||
| ddi-tcp-4 | 8891 | tcp | Desktop Data TCP 3: NESS application | Fred Yao | Fred Yao | ||||||
| ddi-udp-4 | 8891 | udp | Desktop Data UDP 3: NESS application | Fred Yao | Fred Yao | ||||||
| ddi-tcp-5 | 8892 | tcp | Desktop Data TCP 4: FARM product | Fred Yao | Fred Yao | ||||||
| ddi-udp-5 | 8892 | udp | Desktop Data UDP 4: FARM product | Fred Yao | Fred Yao | ||||||
| ddi-tcp-6 | 8893 | tcp | Desktop Data TCP 5: NewsEDGE/Web application | Fred Yao | Fred Yao | ||||||
| ddi-udp-6 | 8893 | udp | Desktop Data UDP 5: NewsEDGE/Web application | Fred Yao | Fred Yao | ||||||
| ddi-tcp-7 | 8894 | tcp | Desktop Data TCP 6: COAL application | Fred Yao | Fred Yao | ||||||
| ddi-udp-7 | 8894 | udp | Desktop Data UDP 6: COAL application | Fred Yao | Fred Yao |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| Aaron Kleinsteiber | protocol&limnerapp.com | 2014-01-16 | |
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Amber Huffman | amber.huffman&intel.com | 2018-03-27 | |
| Bill Kay | bkay&spy-tec.com | 2006-04 | |
| CableLabs | info&cablelabs.com | 2015-11-24 | |
| Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 | |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Evgeniy Filatov | evgeniyfilatov&yandex.ru | 2009-11-25 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Girish Bhat | gbhat&cranite.com | 2006-04 | |
| Gregg Green | legal&vnyx.net | 2004-11 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Karthik Sundaresan | k.sundaresan&cablelabs.com | 2015-11-24 | |
| LAN-ACES | rip&lan-aces.com | 2017-02-08 | |
| Marco Mascitto | mmascitto&accedian.com | 2011-06-28 | |
| MegaZone | megazone&paycash.us | 2005-08 | |
| Ming Xu | ming&veritas.com | ||
| NVM Express, Inc. | admin&nvmexpress.org | 2018-03-27 | |
| Okta Inc | tbelote&okta.com | 2019-12-19 | |
| Prakash Iyer | prakash.iyer&intel.com | 2009-08-10 | |
| Rob Griffin | rob.gri55in&gmail.com | 2010-09-13 | |
| Robert Ripberger | rip&lan-aces.com | 2017-02-08 | |
| Ryusuke Okuhara | Canon Inc. | okuhara.ryuusuke&canon.co.jp | 2012-06-08 |
| Sky Schulz | sky&edgeofreality.com | 2011-05-09 | |
| Sridhar Krishnamurthy | Sridhar_Krishnamurthy&intuit.com | 2008-02-15 | |
| Steve Husak | portmaster&cruisetech.com | ||
| Thomas Klose | thomas.klose&hiperscan.com | 2009-12-15 | |
| Tom Belote | tbelote&okta.com | 2019-12-19 | |
| Tristan Seifert | admin&247server.net | 2011-01-31 |