Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| http-mgmt | 280 | tcp | http-mgmt | [Adrian_Pell] | [Adrian_Pell] | ||||||
| http-mgmt | 280 | udp | http-mgmt | [Adrian_Pell] | [Adrian_Pell] | ||||||
| personal-link | 281 | tcp | Personal Link | [Dan_Cummings] | [Dan_Cummings] | ||||||
| personal-link | 281 | udp | Personal Link | [Dan_Cummings] | [Dan_Cummings] | ||||||
| cableport-ax | 282 | tcp | Cable Port A/X | [Craig_Langfahl] | [Craig_Langfahl] | ||||||
| cableport-ax | 282 | udp | Cable Port A/X | [Craig_Langfahl] | [Craig_Langfahl] | ||||||
| k-block | 287 | tcp | K-BLOCK | [Simon_P_Jackson] | [Simon_P_Jackson] | ||||||
| k-block | 287 | udp | K-BLOCK | [Simon_P_Jackson] | [Simon_P_Jackson] | ||||||
| 288-299 | Unassigned | ||||||||||
| 301-307 | Unassigned | ||||||||||
| asip-webadmin | 311 | tcp | AppleShare IP WebAdmin | [Ann_Huang] | [Ann_Huang] | ||||||
| asip-webadmin | 311 | udp | AppleShare IP WebAdmin | [Ann_Huang] | [Ann_Huang] | ||||||
| magenta-logic | 313 | tcp | Magenta Logic | [Karl_Rousseau] | [Karl_Rousseau] | ||||||
| magenta-logic | 313 | udp | Magenta Logic | [Karl_Rousseau] | [Karl_Rousseau] | ||||||
| opalis-robot | 314 | tcp | Opalis Robot | [Laurent_Domenech] | [Laurent_Domenech] | ||||||
| opalis-robot | 314 | udp | Opalis Robot | [Laurent_Domenech] | [Laurent_Domenech] | ||||||
| pkix-timestamp | 318 | tcp | PKIX TimeStamp | [Robert_Zuccherato] | [Robert_Zuccherato] | ||||||
| pkix-timestamp | 318 | udp | PKIX TimeStamp | [Robert_Zuccherato] | [Robert_Zuccherato] | ||||||
| ptp-event | 319 | tcp | PTP Event | [Kang_Lee] | [Kang_Lee] | 2010-07-27 | |||||
| ptp-event | 319 | udp | PTP Event | [Kang_Lee] | [Kang_Lee] | 2010-07-27 | |||||
| ptp-general | 320 | tcp | PTP General | [Kang_Lee] | [Kang_Lee] | 2010-07-27 | |||||
| ptp-general | 320 | udp | PTP General | [Kang_Lee] | [Kang_Lee] | 2010-07-27 | |||||
| rpki-rtr | 323 | tcp | Resource PKI to Router Protocol | [IESG] | [IETF_Chair] | [RFC 6810] | |||||
| rpki-rtr-tls | 324 | tcp | Resource PKI to Router Protocol over TLS | [IESG] | [IETF_Chair] | [RFC 6810] | |||||
| 325-332 | Unassigned | ||||||||||
| 334-343 | Unassigned | ||||||||||
| csi-sgwp | 348 | tcp | Cabletron Management Protocol | ||||||||
| csi-sgwp | 348 | udp | Cabletron Management Protocol | ||||||||
| matip-type-a | 350 | tcp | MATIP Type A | [Alain_Robert] | [Alain_Robert] | [RFC 2351] | |||||
| matip-type-a | 350 | udp | MATIP Type A | [Alain_Robert] | [Alain_Robert] | [RFC 2351] | |||||
| matip-type-b | 351 | tcp | MATIP Type B | [Alain_Robert] | [Alain_Robert] | [RFC 2351] | |||||
| matip-type-b | 351 | udp | MATIP Type B | [Alain_Robert] | [Alain_Robert] | [RFC 2351] | |||||
| dtag-ste-sb | 352 | tcp | DTAG | [Ruediger_Wald] | [Ruediger_Wald] | (assigned long ago) | |||||
| dtag-ste-sb | 352 | udp | DTAG | [Ruediger_Wald] | [Ruediger_Wald] | (assigned long ago) | |||||
| datex-asn | 355 | tcp | DATEX-ASN | [Kenneth_Vaughn] | [Kenneth_Vaughn] | ||||||
| datex-asn | 355 | udp | DATEX-ASN | [Kenneth_Vaughn] | [Kenneth_Vaughn] | ||||||
| cloanto-net-1 | 356 | tcp | Cloanto Net 1 | [Michael_Battilana] | [Michael_Battilana] | 2010-04-30 | |||||
| cloanto-net-1 | 356 | udp | Cloanto Net 1 | [Michael_Battilana] | [Michael_Battilana] | 2010-04-30 | |||||
| 359 | tcp | Reserved | 2023-11-16 | De-Assigned on 2023-11-16. | |||||||
| 359 | udp | Reserved | 2023-11-16 | De-Assigned on 2023-11-16. | |||||||
| rsvp-tunnel | 363 | tcp | RSVP Tunnel IANA assigned this well-formed service name as a replacement for "rsvp_tunnel". |
[Andreas_Terzis] | [Andreas_Terzis] | ||||||
| rsvp_tunnel | 363 | tcp | RSVP Tunnel | [Andreas_Terzis] | [Andreas_Terzis] | This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| rsvp-tunnel | 363 | udp | RSVP Tunnel IANA assigned this well-formed service name as a replacement for "rsvp_tunnel". |
[Andreas_Terzis] | [Andreas_Terzis] | ||||||
| rsvp_tunnel | 363 | udp | RSVP Tunnel | [Andreas_Terzis] | [Andreas_Terzis] | This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| aurora-cmgr | 364 | tcp | Aurora CMGR | [Philip_Budne] | [Philip_Budne] | ||||||
| aurora-cmgr | 364 | udp | Aurora CMGR | [Philip_Budne] | [Philip_Budne] | ||||||
| legent-1 | 373 | tcp | Legent Corporation | ||||||||
| legent-1 | 373 | udp | Legent Corporation | ||||||||
| legent-2 | 374 | tcp | Legent Corporation | [Keith_Boyce] | [Keith_Boyce] | ||||||
| legent-2 | 374 | udp | Legent Corporation | [Keith_Boyce] | [Keith_Boyce] | ||||||
| is99c | 379 | tcp | TIA/EIA/IS-99 modem client | ||||||||
| is99c | 379 | udp | TIA/EIA/IS-99 modem client | ||||||||
| is99s | 380 | tcp | TIA/EIA/IS-99 modem server | [Frank_Quick] | [Frank_Quick] | ||||||
| is99s | 380 | udp | TIA/EIA/IS-99 modem server | [Frank_Quick] | [Frank_Quick] | ||||||
| hp-collector | 381 | tcp | hp performance data collector | ||||||||
| hp-collector | 381 | udp | hp performance data collector | ||||||||
| hp-managed-node | 382 | tcp | hp performance data managed node | ||||||||
| hp-managed-node | 382 | udp | hp performance data managed node | ||||||||
| hp-alarm-mgr | 383 | tcp | hp performance data alarm manager | [Frank_Blakely] | [Frank_Blakely] | ||||||
| hp-alarm-mgr | 383 | udp | hp performance data alarm manager | [Frank_Blakely] | [Frank_Blakely] | ||||||
| ibm-app | 385 | tcp | IBM Application | [Lisa_Tomita] | [Lisa_Tomita] | ||||||
| ibm-app | 385 | udp | IBM Application | [Lisa_Tomita] | [Lisa_Tomita] | ||||||
| aurp | 387 | tcp | Appletalk Update-Based Routing Pro. | [Chris_Ranch] | [Chris_Ranch] | ||||||
| aurp | 387 | udp | Appletalk Update-Based Routing Pro. | [Chris_Ranch] | [Chris_Ranch] | ||||||
| unidata-ldm | 388 | tcp | Unidata LDM | [University_Corporation_for_Atmospheric_Research2] | [Steven_Emmerson2] | 2012-05-18 | |||||
| unidata-ldm | 388 | udp | Unidata LDM | [University_Corporation_for_Atmospheric_Research2] | [Steven_Emmerson2] | 2012-05-18 | |||||
| synotics-relay | 391 | tcp | SynOptics SNMP Relay Port | ||||||||
| synotics-relay | 391 | udp | SynOptics SNMP Relay Port | ||||||||
| synotics-broker | 392 | tcp | SynOptics Port Broker Port | [Illan_Raab] | [Illan_Raab] | ||||||
| synotics-broker | 392 | udp | SynOptics Port Broker Port | [Illan_Raab] | [Illan_Raab] | ||||||
| embl-ndt | 394 | tcp | EMBL Nucleic Data Transfer | [Peter_Gad] | [Peter_Gad] | ||||||
| embl-ndt | 394 | udp | EMBL Nucleic Data Transfer | [Peter_Gad] | [Peter_Gad] | ||||||
| netware-ip | 396 | tcp | Novell Netware over IP | ||||||||
| netware-ip | 396 | udp | Novell Netware over IP | ||||||||
| iso-tsap-c2 | 399 | tcp | ISO Transport Class 2 Non-Control over TCP | [Yanick_Pouffary] | [Yanick_Pouffary] | ||||||
| iso-tsap-c2 | 399 | udp | ISO Transport Class 2 Non-Control over UDP | [Yanick_Pouffary] | [Yanick_Pouffary] | ||||||
| osb-sd | 400 | tcp | Oracle Secure Backup | [Steven_Wertheimer] | [Steven_Wertheimer] | 2008-06-06 | 2023-12-27 | Formerly was Workstation Solutions | |||
| osb-sd | 400 | udp | Oracle Secure Backup | [Steven_Wertheimer] | [Steven_Wertheimer] | 2008-06-06 | 2023-12-27 | Formerly was Workstation Solutions | |||
| prm-sm | 408 | tcp | Prospero Resource Manager Sys. Man. | ||||||||
| prm-sm | 408 | udp | Prospero Resource Manager Sys. Man. | ||||||||
| prm-nm | 409 | tcp | Prospero Resource Manager Node Man. | [B_Clifford_Neuman] | [B_Clifford_Neuman] | ||||||
| prm-nm | 409 | udp | Prospero Resource Manager Node Man. | [B_Clifford_Neuman] | [B_Clifford_Neuman] | ||||||
| synoptics-trap | 412 | tcp | Trap Convention Port | [Illan_Raab] | [Illan_Raab] | ||||||
| synoptics-trap | 412 | udp | Trap Convention Port | [Illan_Raab] | [Illan_Raab] | ||||||
| hyper-g | 418 | tcp | Hyper-G | [Frank_Kappe] | [Frank_Kappe] | ||||||
| hyper-g | 418 | udp | Hyper-G | [Frank_Kappe] | [Frank_Kappe] | ||||||
| opc-job-start | 423 | tcp | IBM Operations Planning and Control Start | ||||||||
| opc-job-start | 423 | udp | IBM Operations Planning and Control Start | ||||||||
| opc-job-track | 424 | tcp | IBM Operations Planning and Control Track | [Conny_Larsson] | [Conny_Larsson] | ||||||
| opc-job-track | 424 | udp | IBM Operations Planning and Control Track | [Conny_Larsson] | [Conny_Larsson] | ||||||
| icad-el | 425 | tcp | ICAD | [Larry_Stone] | [Larry_Stone] | ||||||
| icad-el | 425 | udp | ICAD | [Larry_Stone] | [Larry_Stone] | ||||||
| ocs-cmu | 428 | tcp | OCS_CMU IANA assigned this well-formed service name as a replacement for "ocs_cmu". |
||||||||
| ocs_cmu | 428 | tcp | OCS_CMU | This entry is an alias to "ocs-cmu". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| ocs-cmu | 428 | udp | OCS_CMU IANA assigned this well-formed service name as a replacement for "ocs_cmu". |
||||||||
| ocs_cmu | 428 | udp | OCS_CMU | This entry is an alias to "ocs-cmu". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| ocs-amu | 429 | tcp | OCS_AMU IANA assigned this well-formed service name as a replacement for "ocs_amu". |
[Florence_Wyman] | [Florence_Wyman] | ||||||
| ocs_amu | 429 | tcp | OCS_AMU | [Florence_Wyman] | [Florence_Wyman] | This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ocs-amu | 429 | udp | OCS_AMU IANA assigned this well-formed service name as a replacement for "ocs_amu". |
[Florence_Wyman] | [Florence_Wyman] | ||||||
| ocs_amu | 429 | udp | OCS_AMU | [Florence_Wyman] | [Florence_Wyman] | This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mobileip-agent | 434 | tcp | MobileIP-Agent |