Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| print-srv | 170 | udp | Network PostScript | Brian Reid | Brian Reid | ||||||
| multiplex | 171 | tcp | Network Innovations Multiplex | ||||||||
| multiplex | 171 | udp | Network Innovations Multiplex | ||||||||
| cl-1 | 172 | tcp | Network Innovations CL/1 IANA assigned this well-formed service name as a replacement for "cl/1". |
Kevin DeVault | Kevin DeVault | ||||||
| cl/1 | 172 | tcp | Network Innovations CL/1 | Kevin DeVault | Kevin DeVault | This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| cl-1 | 172 | udp | Network Innovations CL/1 IANA assigned this well-formed service name as a replacement for "cl/1". |
Kevin DeVault | Kevin DeVault | ||||||
| cl/1 | 172 | udp | Network Innovations CL/1 | Kevin DeVault | Kevin DeVault | This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| xyplex-mux | 173 | tcp | Xyplex | Bob Stewart | Bob Stewart | ||||||
| xyplex-mux | 173 | udp | Xyplex | Bob Stewart | Bob Stewart | ||||||
| mailq | 174 | tcp | MAILQ | Rayan Zachariassen | Rayan Zachariassen | ||||||
| mailq | 174 | udp | MAILQ | Rayan Zachariassen | Rayan Zachariassen | ||||||
| vmnet | 175 | tcp | VMNET | Christopher Tengi | Christopher Tengi | ||||||
| vmnet | 175 | udp | VMNET | Christopher Tengi | Christopher Tengi | ||||||
| genrad-mux | 176 | tcp | GENRAD-MUX | Ron Thornton | Ron Thornton | ||||||
| genrad-mux | 176 | udp | GENRAD-MUX | Ron Thornton | Ron Thornton | ||||||
| xdmcp | 177 | tcp | X Display Manager Control Protocol | Robert W. Scheifler | Robert W. Scheifler | ||||||
| xdmcp | 177 | udp | X Display Manager Control Protocol | Robert W. Scheifler | Robert W. Scheifler | ||||||
| nextstep | 178 | tcp | NextStep Window Server | Leo Hourvitz | Leo Hourvitz | ||||||
| nextstep | 178 | udp | NextStep Window Server | Leo Hourvitz | Leo Hourvitz | ||||||
| bgp | 179 | tcp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | udp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | sctp | BGP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| ris | 180 | tcp | Intergraph | Dave Buehmann | Dave Buehmann | ||||||
| ris | 180 | udp | Intergraph | Dave Buehmann | Dave Buehmann | ||||||
| unify | 181 | tcp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| unify | 181 | udp | Unify | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| audit | 182 | tcp | Unisys Audit SITP | Gil Greenbaum | Gil Greenbaum | ||||||
| audit | 182 | udp | Unisys Audit SITP | Gil Greenbaum | Gil Greenbaum | ||||||
| ocbinder | 183 | tcp | OCBinder | ||||||||
| ocbinder | 183 | udp | OCBinder | ||||||||
| ocserver | 184 | tcp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| ocserver | 184 | udp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| remote-kis | 185 | tcp | Remote-KIS | ||||||||
| remote-kis | 185 | udp | Remote-KIS | ||||||||
| kis | 186 | tcp | KIS Protocol | Ralph Droms | Ralph Droms | ||||||
| kis | 186 | udp | KIS Protocol | Ralph Droms | Ralph Droms | ||||||
| aci | 187 | tcp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| aci | 187 | udp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| mumps | 188 | tcp | Plus Five's MUMPS | Hokey Stenn | Hokey Stenn | ||||||
| mumps | 188 | udp | Plus Five's MUMPS | Hokey Stenn | Hokey Stenn | ||||||
| qft | 189 | tcp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| qft | 189 | udp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| gacp | 190 | tcp | Gateway Access Control Protocol | C. Philip Wood | C. Philip Wood | ||||||
| gacp | 190 | udp | Gateway Access Control Protocol | C. Philip Wood | C. Philip Wood | ||||||
| prospero | 191 | tcp | Prospero Directory Service | B. Clifford Neuman | B. Clifford Neuman | ||||||
| prospero | 191 | udp | Prospero Directory Service | B. Clifford Neuman | B. Clifford Neuman | ||||||
| osu-nms | 192 | tcp | OSU Network Monitoring System | Doug Karl | Doug Karl | ||||||
| osu-nms | 192 | udp | OSU Network Monitoring System | Doug Karl | Doug Karl | ||||||
| srmp | 193 | tcp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| srmp | 193 | udp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| irc | 194 | tcp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| irc | 194 | udp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| dn6-nlm-aud | 195 | tcp | DNSIX Network Level Module Audit | ||||||||
| dn6-nlm-aud | 195 | udp | DNSIX Network Level Module Audit | ||||||||
| dn6-smm-red | 196 | tcp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| dn6-smm-red | 196 | udp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| dls | 197 | tcp | Directory Location Service | ||||||||
| dls | 197 | udp | Directory Location Service | ||||||||
| dls-mon | 198 | tcp | Directory Location Service Monitor | Scott Bellew | Scott Bellew | ||||||
| dls-mon | 198 | udp | Directory Location Service Monitor | Scott Bellew | Scott Bellew | ||||||
| smux | 199 | tcp | SMUX | Marshall Rose | Marshall Rose | ||||||
| smux | 199 | udp | SMUX | Marshall Rose | Marshall Rose | ||||||
| at-rtmp | 201 | tcp | AppleTalk Routing Maintenance | ||||||||
| at-rtmp | 201 | udp | AppleTalk Routing Maintenance | ||||||||
| z39-50 | 210 | tcp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | tcp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| z39-50 | 210 | udp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | udp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | tcp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
Bill Harrell | Bill Harrell | ||||||
| 914c/g | 211 | tcp | Texas Instruments 914C/G Terminal | Bill Harrell | Bill Harrell | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | udp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
Bill Harrell | Bill Harrell | ||||||
| 914c/g | 211 | udp | Texas Instruments 914C/G Terminal | Bill Harrell | Bill Harrell | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| anet | 212 | tcp | ATEXSSTR | Jim Taylor | Jim Taylor | ||||||
| anet | 212 | udp | ATEXSSTR | Jim Taylor | Jim Taylor | ||||||
| ipx | 213 | tcp | IPX | Don Provan | Don Provan | ||||||
| ipx | 213 | udp | IPX | Don Provan | Don Provan | ||||||
| vmpwscs | 214 | tcp | VM PWSCS | Dan Shia | Dan Shia | ||||||
| vmpwscs | 214 | udp | VM PWSCS | Dan Shia | Dan Shia | ||||||
| softpc | 215 | tcp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| softpc | 215 | udp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| CAIlic | 216 | tcp | Computer Associates Int'l License Server | Chuck Spitz | Chuck Spitz | ||||||
| CAIlic | 216 | udp | Computer Associates Int'l License Server | Chuck Spitz | Chuck Spitz | ||||||
| dbase | 217 | tcp | dBASE Unix | Don Gibson | Don Gibson | ||||||
| dbase | 217 | udp | dBASE Unix | Don Gibson | Don Gibson | ||||||
| mpp | 218 | tcp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| mpp | 218 | udp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| uarps | 219 | tcp | Unisys ARPs | Ashok Marwaha | Ashok Marwaha | ||||||
| uarps | 219 | udp | Unisys ARPs | Ashok Marwaha | Ashok Marwaha | ||||||
| fln-spx | 221 | tcp | Berkeley rlogind with SPX auth | ||||||||
| fln-spx | 221 | udp | Berkeley rlogind with SPX auth | ||||||||
| 225-241 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| 249-255 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| nsiiops | 261 | tcp | IIOP Name Service over TLS/SSL | Jeff Stewart | Jeff Stewart | ||||||
| nsiiops | 261 | udp | IIOP Name Service over TLS/SSL | Jeff Stewart | Jeff Stewart | ||||||
| gist | 270 | udp | Q-mode encapsulation for GIST messages | RFC 5971 | |||||||
| pt-tls | 271 | tcp | IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) | IESG | IETF Chair | 2012-07-31 | RFC 6876 | ||||
| 271 | udp | Reserved | |||||||||
| personal-link | 281 | tcp | Personal Link | Dan Cummings | Dan Cummings | ||||||
| personal-link | 281 | udp | Personal Link | Dan Cummings | Dan Cummings | ||||||
| 301-307 | Unassigned | ||||||||||
| bhmds | 310 | tcp | bhmds | John Kelly | John Kelly |