Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cplscrambler-in | 1087 | tcp | CPL Scrambler Internal | ||||||||
| cplscrambler-in | 1087 | udp | CPL Scrambler Internal | ||||||||
| cplscrambler-al | 1088 | tcp | CPL Scrambler Alarm Log | Richard Corn | Richard Corn | ||||||
| cplscrambler-al | 1088 | udp | CPL Scrambler Alarm Log | Richard Corn | Richard Corn | ||||||
| ff-annunc | 1089 | tcp | FF Annunciation | ||||||||
| ff-annunc | 1089 | udp | FF Annunciation | ||||||||
| ff-fms | 1090 | tcp | FF Fieldbus Message Specification | ||||||||
| ff-fms | 1090 | udp | FF Fieldbus Message Specification | ||||||||
| ff-sm | 1091 | tcp | FF System Management | Fieldbus Foundation | Fieldbus Foundation | ||||||
| ff-sm | 1091 | udp | FF System Management | Fieldbus Foundation | Fieldbus Foundation | ||||||
| obrpd | 1092 | tcp | Open Business Reporting Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| obrpd | 1092 | udp | Open Business Reporting Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| proofd | 1093 | tcp | PROOFD | ||||||||
| proofd | 1093 | udp | PROOFD | ||||||||
| rootd | 1094 | tcp | ROOTD | Fons Rademakers | Fons Rademakers | ||||||
| rootd | 1094 | udp | ROOTD | Fons Rademakers | Fons Rademakers | ||||||
| nicelink | 1095 | tcp | NICELink | Jordi Lisbona | Jordi Lisbona | ||||||
| nicelink | 1095 | udp | NICELink | Jordi Lisbona | Jordi Lisbona | ||||||
| cnrprotocol | 1096 | tcp | Common Name Resolution Protocol | Michael Mealling | Michael Mealling | ||||||
| cnrprotocol | 1096 | udp | Common Name Resolution Protocol | Michael Mealling | Michael Mealling | ||||||
| sunclustermgr | 1097 | tcp | Sun Cluster Manager | Ashit Patel | Ashit Patel | ||||||
| sunclustermgr | 1097 | udp | Sun Cluster Manager | Ashit Patel | Ashit Patel | ||||||
| rmiactivation | 1098 | tcp | RMI Activation | ||||||||
| rmiactivation | 1098 | udp | RMI Activation | ||||||||
| rmiregistry | 1099 | tcp | RMI Registry | Mark Hodapp | Mark Hodapp | ||||||
| rmiregistry | 1099 | udp | RMI Registry | Mark Hodapp | Mark Hodapp | ||||||
| mctp | 1100 | tcp | MCTP | Vitaly Revsin | Vitaly Revsin | ||||||
| mctp | 1100 | udp | MCTP | Vitaly Revsin | Vitaly Revsin | ||||||
| pt2-discover | 1101 | tcp | PT2-DISCOVER | Ralph Kammerlander | Ralph Kammerlander | ||||||
| pt2-discover | 1101 | udp | PT2-DISCOVER | Ralph Kammerlander | Ralph Kammerlander | ||||||
| adobeserver-1 | 1102 | tcp | ADOBE SERVER 1 | ||||||||
| adobeserver-1 | 1102 | udp | ADOBE SERVER 1 | ||||||||
| adobeserver-2 | 1103 | tcp | ADOBE SERVER 2 | Frank Soetebeer | Frank Soetebeer | ||||||
| adobeserver-2 | 1103 | udp | ADOBE SERVER 2 | Frank Soetebeer | Frank Soetebeer | ||||||
| xrl | 1104 | tcp | XRL | Patrick Robinson | Patrick Robinson | ||||||
| xrl | 1104 | udp | XRL | Patrick Robinson | Patrick Robinson | ||||||
| ftranhc | 1105 | tcp | FTRANHC | Eriko Shimada | Eriko Shimada | ||||||
| ftranhc | 1105 | udp | FTRANHC | Eriko Shimada | Eriko Shimada | ||||||
| isoipsigport-1 | 1106 | tcp | ISOIPSIGPORT-1 | ||||||||
| isoipsigport-1 | 1106 | udp | ISOIPSIGPORT-1 | ||||||||
| isoipsigport-2 | 1107 | tcp | ISOIPSIGPORT-2 | Peter Egli | Peter Egli | ||||||
| isoipsigport-2 | 1107 | udp | ISOIPSIGPORT-2 | Peter Egli | Peter Egli | ||||||
| ratio-adp | 1108 | tcp | ratio-adp | Oliver Thulke | Oliver Thulke | ||||||
| ratio-adp | 1108 | udp | ratio-adp | Oliver Thulke | Oliver Thulke | ||||||
| 1109 | Reserved - IANA | ||||||||||
| webadmstart | 1110 | tcp | Start web admin server | ||||||||
| nfsd-keepalive | 1110 | udp | Client status info | Beth Crespo | Beth Crespo | ||||||
| ltp-deepspace | 1113 | dccp | Licklider Transmission Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 7107696 | ||||
| eoss | 1210 | tcp | EOSS | Robert Armes | Robert Armes | ||||||
| eoss | 1210 | udp | EOSS | Robert Armes | Robert Armes | ||||||
| 1301 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1301 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| husky | 1310 | tcp | Husky | Mark Zang | Mark Zang | ||||||
| husky | 1310 | udp | Husky | Mark Zang | Mark Zang | ||||||
| re101 | 1343 | tcp | re101 | Doriano Blengino | Doriano Blengino | ||||||
| re101 | 1343 | udp | re101 | Doriano Blengino | Doriano Blengino | ||||||
| hiq | 1410 | tcp | HiQ License Manager | Rick Pugh | Rick Pugh | ||||||
| hiq | 1410 | udp | HiQ License Manager | Rick Pugh | Rick Pugh | ||||||
| mvx-lm | 1510 | tcp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| mvx-lm | 1510 | udp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| taurus-wh | 1610 | tcp | taurus-wh | Jeff Moffatt | Jeff Moffatt | ||||||
| taurus-wh | 1610 | udp | taurus-wh | Jeff Moffatt | Jeff Moffatt | ||||||
| netview-aix-10 | 1670 | tcp | netview-aix-10 | ||||||||
| netview-aix-10 | 1670 | udp | netview-aix-10 | ||||||||
| impera | 1710 | tcp | impera | Stepehen Campbell | Stepehen Campbell | ||||||
| impera | 1710 | udp | impera | Stepehen Campbell | Stepehen Campbell | ||||||
| jerand-lm | 1810 | tcp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| jerand-lm | 1810 | udp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| ultrabac | 1910 | tcp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| ultrabac | 1910 | udp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| search | 2010 | tcp | |||||||||
| pipe-server | 2010 | udp | IANA assigned this well-formed service name as a replacement for "pipe_server". | ||||||||
| pipe_server | 2010 | udp | This entry is an alias to "pipe-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| lot105-ds-upd | 2053 | tcp | Lot105 DSuper Updates | Piers Scannell | Piers Scannell | ||||||
| lot105-ds-upd | 2053 | udp | Lot105 DSuper Updates | Piers Scannell | Piers Scannell | ||||||
| amiganetfs | 2100 | tcp | Amiga Network Filesystem | Rudi Chiarito | Rudi Chiarito | ||||||
| amiganetfs | 2100 | udp | Amiga Network Filesystem | Rudi Chiarito | Rudi Chiarito | ||||||
| rtcm-sc104 | 2101 | tcp | rtcm-sc104 | Wolfgang Rupprecht | Wolfgang Rupprecht | ||||||
| rtcm-sc104 | 2101 | udp | rtcm-sc104 | Wolfgang Rupprecht | Wolfgang Rupprecht | ||||||
| zephyr-srv | 2102 | tcp | Zephyr server | ||||||||
| zephyr-srv | 2102 | udp | Zephyr server | ||||||||
| zephyr-clt | 2103 | tcp | Zephyr serv-hm connection | ||||||||
| zephyr-clt | 2103 | udp | Zephyr serv-hm connection | ||||||||
| zephyr-hm | 2104 | tcp | Zephyr hostmanager | Greg Hudson | Greg Hudson | ||||||
| zephyr-hm | 2104 | udp | Zephyr hostmanager | Greg Hudson | Greg Hudson | ||||||
| minipay | 2105 | tcp | MiniPay | Amir Herzberg | Amir Herzberg | ||||||
| minipay | 2105 | udp | MiniPay | Amir Herzberg | Amir Herzberg | ||||||
| mzap | 2106 | tcp | MZAP | Dave Thaler | Dave Thaler | ||||||
| mzap | 2106 | udp | MZAP | Dave Thaler | Dave Thaler | ||||||
| bintec-admin | 2107 | tcp | BinTec Admin | Thomas Schmidt | Thomas Schmidt | ||||||
| bintec-admin | 2107 | udp | BinTec Admin | Thomas Schmidt | Thomas Schmidt | ||||||
| comcam | 2108 | tcp | Comcam | Don Gilbreath | Don Gilbreath | ||||||
| comcam | 2108 | udp | Comcam | Don Gilbreath | Don Gilbreath | ||||||
| ergolight | 2109 | tcp | Ergolight | Jindra Ryvola | Jindra Ryvola | ||||||
| ergolight | 2109 | udp | Ergolight | Jindra Ryvola | Jindra Ryvola | ||||||
| umsp | 2110 | tcp | UMSP | Alexander Bogdanov | Alexander Bogdanov | ||||||
| umsp | 2110 | udp | UMSP | Alexander Bogdanov | Alexander Bogdanov | ||||||
| noaaport | 2210 | tcp | NOAAPORT Broadcast Network | ||||||||
| noaaport | 2210 | udp | NOAAPORT Broadcast Network |