Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
prat 1264 udp PRAT Keith Wood Keith Wood
dssiapi 1265 tcp DSSIAPI Jim Turner Jim Turner
dssiapi 1265 udp DSSIAPI Jim Turner Jim Turner
dellpwrappks 1266 tcp DELLPWRAPPKS David Troeger David Troeger
dellpwrappks 1266 udp DELLPWRAPPKS David Troeger David Troeger
epc 1267 tcp eTrust Policy Compliance Aaron Stein Aaron Stein
epc 1267 udp eTrust Policy Compliance Aaron Stein Aaron Stein
propel-msgsys 1268 tcp PROPEL-MSGSYS Bert Van der Linden Bert Van der Linden
propel-msgsys 1268 udp PROPEL-MSGSYS Bert Van der Linden Bert Van der Linden
watilapp 1269 tcp WATiLaPP Frederic Weymann Frederic Weymann
watilapp 1269 udp WATiLaPP Frederic Weymann Frederic Weymann
opsmgr 1270 tcp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
opsmgr 1270 udp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
excw 1271 tcp eXcW Norm Freedman Norm Freedman
excw 1271 udp eXcW Norm Freedman Norm Freedman
cspmlockmgr 1272 tcp CSPMLockMgr Ibtsam Mahfouz Ibtsam Mahfouz
cspmlockmgr 1272 udp CSPMLockMgr Ibtsam Mahfouz Ibtsam Mahfouz
emc-gateway 1273 tcp EMC-Gateway Rene Fontaine Rene Fontaine
emc-gateway 1273 udp EMC-Gateway Rene Fontaine Rene Fontaine
t1distproc 1274 tcp t1distproc Julian Biddle Julian Biddle
t1distproc 1274 udp t1distproc Julian Biddle Julian Biddle
ivcollector 1275 tcp ivcollector
ivcollector 1275 udp ivcollector
1276 tcp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
1276 udp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
miva-mqs 1277 tcp mqs Miva Corporation Miva Corporation
miva-mqs 1277 udp mqs Miva Corporation Miva Corporation
dellwebadmin-1 1278 tcp Dell Web Admin 1 Bridget Navoda Bridget Navoda
dellwebadmin-1 1278 udp Dell Web Admin 1 Bridget Navoda Bridget Navoda
dellwebadmin-2 1279 tcp Dell Web Admin 2 Bridget Navoda Bridget Navoda
dellwebadmin-2 1279 udp Dell Web Admin 2 Bridget Navoda Bridget Navoda
pictrography 1280 tcp Pictrography Takashi Hoshino Takashi Hoshino
pictrography 1280 udp Pictrography Takashi Hoshino Takashi Hoshino
healthd 1281 tcp healthd James E. Housley James E. Housley
healthd 1281 udp healthd James E. Housley James E. Housley
emperion 1282 tcp Emperion Claus Thor Barth Claus Thor Barth
emperion 1282 udp Emperion Claus Thor Barth Claus Thor Barth
productinfo 1283 tcp Product Information
productinfo 1283 udp Product Information
iee-qfx 1284 tcp IEE-QFX Mehrdad Ashtiani Mehrdad Ashtiani 2009-10-19
iee-qfx 1284 udp IEE-QFX Mehrdad Ashtiani Mehrdad Ashtiani 2009-10-19
neoiface 1285 tcp neoiface Jason McManus Jason McManus
neoiface 1285 udp neoiface Jason McManus Jason McManus
netuitive 1286 tcp netuitive JF Huard JF Huard
netuitive 1286 udp netuitive JF Huard JF Huard
routematch 1287 tcp RouteMatch Com Jeff Jones Jeff Jones 2005-11
routematch 1287 udp RouteMatch Com Jeff Jones Jeff Jones 2005-11
navbuddy 1288 tcp NavBuddy Eric Hackman Eric Hackman
navbuddy 1288 udp NavBuddy Eric Hackman Eric Hackman
jwalkserver 1289 tcp JWalkServer
jwalkserver 1289 udp JWalkServer
winjaserver 1290 tcp WinJaServer
winjaserver 1290 udp WinJaServer
seagulllms 1291 tcp SEAGULLLMS Lee Breisacher Lee Breisacher
seagulllms 1291 udp SEAGULLLMS Lee Breisacher Lee Breisacher
dsdn 1292 tcp dsdn Stanislaw Skowronek Stanislaw Skowronek
dsdn 1292 udp dsdn Stanislaw Skowronek Stanislaw Skowronek
pkt-krb-ipsec 1293 tcp PKT-KRB-IPSec Nancy Davoust Nancy Davoust
pkt-krb-ipsec 1293 udp PKT-KRB-IPSec Nancy Davoust Nancy Davoust
cmmdriver 1294 tcp CMMdriver Lutz Karras Lutz Karras
cmmdriver 1294 udp CMMdriver Lutz Karras Lutz Karras
ehtp 1295 tcp End-by-Hop Transmission Protocol Alexander Bogdanov Alexander Bogdanov
ehtp 1295 udp End-by-Hop Transmission Protocol Alexander Bogdanov Alexander Bogdanov
dproxy 1296 tcp dproxy
dproxy 1296 udp dproxy
sdproxy 1297 tcp sdproxy Raimond Diederik Raimond Diederik
sdproxy 1297 udp sdproxy Raimond Diederik Raimond Diederik
lpcp 1298 tcp lpcp Christian Stredicke Christian Stredicke
lpcp 1298 udp lpcp Christian Stredicke Christian Stredicke
hp-sci 1299 tcp hp-sci Kim Scott Kim Scott
hp-sci 1299 udp hp-sci Kim Scott Kim Scott
sti-envision 1312 tcp STI Envision Don Stedman Don Stedman
sti-envision 1312 udp STI Envision Don Stedman Don Stedman
innosys 1412 tcp InnoSys
innosys 1412 udp InnoSys
wins 1512 tcp Microsoft's Windows Internet Name Service Pradeep Bahl Pradeep Bahl
wins 1512 udp Microsoft's Windows Internet Name Service Pradeep Bahl Pradeep Bahl
netbill-trans 1612 tcp NetBill Transaction Server
netbill-trans 1612 udp NetBill Transaction Server
t128-gateway 1627 tcp T.128 Gateway Phil May Phil May
t128-gateway 1627 udp T.128 Gateway Phil May Phil May
netview-aix-12 1672 tcp netview-aix-12 Martha Crisson Martha Crisson
netview-aix-12 1672 udp netview-aix-12 Martha Crisson Martha Crisson
registrar 1712 tcp resource monitoring service Ron Lawson Ron Lawson
registrar 1712 udp resource monitoring service Ron Lawson Ron Lawson
radius 1812 tcp RADIUS RFC 2865
radius 1812 udp RADIUS RFC 2865
rhp-iibp 1912 tcp rhp-iibp George Nachman; Tom Lake George Nachman; Tom Lake
rhp-iibp 1912 udp rhp-iibp George Nachman; Tom Lake George Nachman; Tom Lake
ttyinfo 2012 tcp
raid-ac 2012 udp
idonix-metanet 2112 tcp Idonix MetaNet Paul Harrison Paul Harrison
idonix-metanet 2112 udp Idonix MetaNet Paul Harrison Paul Harrison
qencp 2120 tcp Quick Eagle Networks CP Santa Dasu Santa Dasu
qencp 2120 udp Quick Eagle Networks CP Santa Dasu Santa Dasu
scientia-ssdb 2121 tcp SCIENTIA-SSDB SYSTEMS MANAGER SYSTEMS MANAGER
scientia-ssdb 2121 udp SCIENTIA-SSDB SYSTEMS MANAGER SYSTEMS MANAGER
caupc-remote 2122 tcp CauPC Remote Control Environics Oy Environics Oy
caupc-remote 2122 udp CauPC Remote Control Environics Oy Environics Oy
gtp-control 2123 tcp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati
gtp-control 2123 udp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati

Contact Information

Name Contact URI Last Updated
Aaron Stein aaron.stein&ca.com
Alessio Casati a.casati&computer.org
Alexander Bogdanov alexandr_bgd&softhome.net
Ashvin Sanghvi AshvinS&microsoft.com
Bert Van der Linden bert&propel.com
Bridget Navoda Bridget_Navoda&dell.com
Christian Stredicke stredicke&snom.de
Claus Thor Barth iana&barth.dk
David Troeger David_Troeger&dell.com
Don Stedman dones&stisystems.com
Environics Oy pasi.nuutinmaki&environics.fi
Eric Hackman ehackman&millapps.com
Frederic Weymann contact&fizzban.net
George Nachman
Ibtsam Mahfouz imahfouz&cisco.com
JF Huard jfhuard&netuitive.com
James E. Housley jim&thehousleys.net
Jason McManus jasonm&neoinformatics.com
Jeff Jones Jeff.Jones&routematch.com 2005-11
Jim Turner Jim.Turner&asg.com
Julian Biddle julian_biddle&technologyonecorp.com
Keith Wood keith.wood&epid.eurotherm.co.uk
Kim Scott kims&cup.hp.com
Lee Breisacher lbreisacher&seagullsw.com
Lutz Karras karras&zeiss.de
Martha Crisson CRISSON&ralvm12.vnet.ibm.com
Mehrdad Ashtiani mashtiani&ieeinc.com 2009-10-19
Miva Corporation jwoods&miva.com.au
Nancy Davoust n.davoust&cablelabs.com
Norm Freedman normfree&san.rr.com 2003-08
Paul Harrison paulh&idonix.co.uk
Phil May pm&datcon.co.uk
Pradeep Bahl pradeepb&microsoft.com
Raimond Diederik rdiederik&descartes.com
Rene Fontaine fontaine_rene&emc.com
Ron Lawson ronaldl&hpindacx.cup.hp.com
SYSTEMS MANAGER systems-manager&scientia.com
Santa Dasu Santa_Dasu&quickeagle.com
Stanislaw Skowronek thesis&elementary.pl
Takashi Hoshino hoshino&miya.fujifilm.co.jp
Tom Lake tlake&m-ware.com