Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
npqes-test 4703 tcp Network Performance Quality Evaluation System Test Service Zhengli Zhengli 2010-06-28
4703 udp Reserved
assuria-ins 4704 tcp Assuria Insider Nick Connor Nick Connor 2010-06-30
4704 udp Reserved
4705-4710 Unassigned
trinity-dist 4711 tcp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
trinity-dist 4711 udp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
trinity-dist 4711 sctp Trinity Trust Network Node Communication P3KI GmbH Gregor Jehle 2017-01-12
4712-4724 Unassigned
truckstar 4725 tcp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
truckstar 4725 udp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
4726 tcp Reserved
a26-fap-fgw 4726 udp A26 (FAP-FGW) David Ott David Ott 2010-10-15
fcis 4727 tcp F-Link Client Information Service
fcis-disc 4727 udp F-Link Client Information Service Discovery Makoto Zukawa Makoto Zukawa 2010-10-15
capmux 4728 tcp CA Port Multiplexer Nigel Groves Nigel Groves 2006-06
capmux 4728 udp CA Port Multiplexer Nigel Groves Nigel Groves 2006-06
4729 tcp Reserved
gsmtap 4729 udp GSM Interface Tap Harald Welte Harald Welte 2009-01-16
gearman 4730 tcp Gearman Job Queue System Eric Day Eric Day 2009-01-16
gearman 4730 udp Gearman Job Queue System Eric Day Eric Day 2009-01-16
remcap 4731 tcp Remote Capture Protocol Marc Donner Marc Donner 2009-01-16
4731 udp Reserved
4732 tcp Reserved
ohmtrigger 4732 udp OHM server trigger Franck Lefevre Franck Lefevre 2009-11-18
resorcs 4733 tcp RES Orchestration Catalog Services Bob Janssen Bob Janssen 2009-11-18
4733 udp Reserved
4734-4736 Unassigned
ipdr-sp 4737 tcp IPDR/SP Ken Sarno Ken Sarno 2005-08
ipdr-sp 4737 udp IPDR/SP Ken Sarno Ken Sarno 2005-08
solera-lpn 4738 tcp SoleraTec Locator Mark Armstrong Mark Armstrong 2005-12
solera-lpn 4738 udp SoleraTec Locator Mark Armstrong Mark Armstrong 2005-12
ipfix 4739 tcp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 udp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 sctp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2006-01
ipfixs 4740 tcp ipfix protocol over TLS Nevil Brownlee Nevil Brownlee 2006-10
ipfixs 4740 sctp ipfix protocol over DTLS Nevil Brownlee Nevil Brownlee 2006-10
ipfixs 4740 udp ipfix protocol over DTLS Nevil Brownlee Nevil Brownlee 2006-10
lumimgrd 4741 tcp Luminizer Manager George Hwa George Hwa 2007-03
lumimgrd 4741 udp Luminizer Manager George Hwa George Hwa 2007-03
sicct 4742 tcp SICCT
sicct-sdp 4742 udp SICCT Service Discovery Protocol TeleTrusT Deutschland e.V. TeleTrusT Deutschland e.V. 2006-04
openhpid 4743 tcp openhpi HPI service Thomas Kanngieser Thomas Kanngieser 2006-01
openhpid 4743 udp openhpi HPI service Thomas Kanngieser Thomas Kanngieser 2006-01
ifsp 4744 tcp Internet File Synchronization Protocol Alex White Alex White 2007-09-12
ifsp 4744 udp Internet File Synchronization Protocol Alex White Alex White 2007-09-12
fmp 4745 tcp Funambol Mobile Push Andrea Gazzaniga Andrea Gazzaniga 2007-01
fmp 4745 udp Funambol Mobile Push Andrea Gazzaniga Andrea Gazzaniga 2007-01
4746 tcp Reserved
intelliadm-disc 4746 udp IntelliAdmin Discovery IntelliAdmin, LLC Steve Wiseman 2016-11-18
buschtrommel 4747 udp peer-to-peer file exchange protocol Tobias Sturm Tobias Sturm 2013-01-14
4747 tcp Reserved
4748-4748 Unassigned
profilemac 4749 tcp Profile for Mac David Sinclair David Sinclair 2006-05
profilemac 4749 udp Profile for Mac David Sinclair David Sinclair 2006-05
ssad 4750 tcp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
ssad 4750 udp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
spocp 4751 tcp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
spocp 4751 udp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
snap 4752 tcp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
snap 4752 udp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
simon 4753 tcp Simple Invocation of Methods Over Network (SIMON) Alexander Christian Alexander Christian 2012-04-19
simon-disc 4753 udp Simple Invocation of Methods Over Network (SIMON) Discovery Alexander Christian Alexander Christian 2012-04-19
4754 tcp Reserved
gre-in-udp 4754 udp GRE-in-UDP Encapsulation IESG IETF Chair 2016-10-05 RFC 8086
4755 tcp Reserved
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
RDCenter 4756 tcp Reticle Decision Center KLA Tencor/RAPID George Hwa 2016-10-17
4756 udp Reserved
4757-4773 Unassigned
converge 4774 tcp Converge RPC Asteris, LLC Steven Borrelli 2016-09-16
4774 udp Reserved
4775-4783 Unassigned
bfd-multi-ctl 4784 tcp BFD Multihop Control Dave Katz; Dave Ward Dave Katz; Dave Ward 2006-02
bfd-multi-ctl 4784 udp BFD Multihop Control Dave Katz; Dave Ward Dave Katz; Dave Ward 2006-02
4785 tcp Reserved
cncp 4785 udp Cisco Nexus Control Protocol Joseph Swaminathan Joseph Swaminathan 2009-04-01
smart-install 4786 tcp Smart Install Service Amit Nigam Amit Nigam 2009-08-24
4786 udp Reserved
sia-ctrl-plane 4787 tcp Service Insertion Architecture (SIA) Control-Plane Shree Murthy Shree Murthy 2009-10-29
4787 udp Reserved
xmcp 4788 tcp eXtensible Messaging Client Protocol Cisco Glenn Matthews 2011-05-23 2011-10-25 Defined TXT keys: txtvers=1 (as described in the draft) protovers=<comma-separated list of major/minor versions supported> (examples: "protovers=1.0" "protovers=1.1,2.0"
4788 udp Reserved
vxlan 4789 udp Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2013-04-19 2014-06-17 RFC 7348
4789 tcp Reserved
vxlan-gpe 4790 udp Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2014-08-26
4790 tcp Reserved
roce 4791 udp IP Routable RocE InfiniBand Trade Association (IBTA) Diego Crupnicoff (IBTA TWG Chair) 2014-10-17
4791 tcp Reserved
unified-bus 4792 tcp IP Routable Unified Bus Huawei Wei Pan 2022-07-08 2023-04-10
unified-bus 4792 udp IP Routable Unified Bus Huawei Wei Pan 2022-07-08 2023-04-10
4793 tcp Reserved
uet 4793 udp Ultra Ethernet Transport Ultra Ethernet Consortium Vivek Kashyap 2025-06-16
4794 tcp Reserved
veroce 4794 udp veRoCE Transport Protocol ByteDance Dai Huichen 2026-03-06
4795-4799 Unassigned
wfc 4847 tcp Web Fresh Communication Jonathan Bastnagel Jonathan Bastnagel 2007-09-17
wfc 4847 udp Web Fresh Communication Jonathan Bastnagel Jonathan Bastnagel 2007-09-17
5047 tcp Reserved
iscape 5047 udp iSCAPE Data Broadcasting Roland van der Veen Roland van der Veen 2010-06-17

Contact Information

Name Organization Contact URI Last Updated
Alex White alex&intralan.co.uk 2007-09-12
Alexander Christian alexander.christian&root1.de 2012-04-19
Amit Nigam amnigam&cisco.com 2009-08-24
Andrea Gazzaniga gazzaniga&funambol.com 2007-01
Asteris, LLC info&aster.is 2016-09-16
Bob Janssen b.janssen&ressoftware.com 2009-11-18
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
ByteDance daihuichen&bytedance.com 2026-03-06
Cisco glenn.matthews&cisco.com 2011-10-25
Dai Huichen daihuichen&bytedance.com 2026-03-06
Dameon Wagner d.wagner&freemail.absa.co.za 2002-02
Dave Katz dkatz&juniper.net 2006-02
Dave Ward dward&cisco.com 2006-02
David Ott dott&qualcomm.com 2010-10-15
David Sinclair dev&profilemac.com 2006-05
Diego Crupnicoff (IBTA TWG Chair) diego&mellanox.com 2014-10-17
Dr Horst Herb horst&dorrigomedical.com 2005-12
Eric Day eday&oddments.org 2009-01-16
Franck Lefevre franck.lefevre&digitalairways.com 2009-11-18
George Hwa george.hwa&kla-tencor.com 2016-10-17
Glenn Matthews glenn.matthews&cisco.com 2011-05-23
Gregor Jehle hadez&p3ki.com 2017-01-12
Harald Welte laforge&gnumonks.org 2009-01-16
Huawei tarzan.pan&huawei.com 2023-04-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
InfiniBand Trade Association (IBTA) administration&infinibandta.org 2014-10-17
IntelliAdmin, LLC support&intelliadmin.com 2016-11-18
Jonathan Bastnagel jonthebagel&gmail.com 2007-09-17
Joseph Swaminathan jswamina&cisco.com 2009-04-01
Ken Sarno kensarno&insightbb.com 2005-08
KLA Tencor/RAPID george.hwa&kla-tencor.com 2016-10-17
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Makoto Zukawa zukawa&jp.fujitsu.com 2010-10-15
Marc Donner mail&poweraudio.de 2009-01-16
Mark Armstrong Mark.Armstrong&soleratec.com 2005-12
Nevil Brownlee n.brownlee&auckland.ac.nz 2006-10
Nick Connor nickc&assuria.com 2010-06-30
Nigel Groves nigel.groves&ca.com 2006-06
P3KI GmbH iana&p3ki.com 2017-01-12
Roland Hedberg roland&catalogix.se 2005-08
Roland van der Veen rvdveen&aqualectra.nl 2010-06-17
Shree Murthy shree&cisco.com 2009-10-29
Steve Wiseman steve.wiseman&intelliadmin.com 2016-11-18
Steven Borrelli steve&aster.is 2016-09-16
TeleTrusT Deutschland e.V. info&teletrust.de 2006-04
Thomas Kanngieser thomas.kanngieser&arcor.de 2006-01
Tobias Sturm tobias.sturm&student.kit.edu 2013-01-14
Ultra Ethernet Consortium vivek.kashyap&intel.com 2025-06-16
Victor Kirhenshtein victor&opticom.lv 2006-07
Vivek Kashyap vivek.kashyap&intel.com 2025-06-16
Wei Pan Huawei tarzan.pan&huawei.com 2023-04-10
Zhengli std&iwncomm.com 2010-06-28