Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5587-5596 Unassigned
5758-5765 Unassigned
5799-5812 Unassigned
icmpd 5813 tcp ICMPD Shane O'Donnell Shane O'Donnell
icmpd 5813 udp ICMPD Shane O'Donnell Shane O'Donnell
spt-automation 5814 tcp Support Automation Joshua Hawkins Joshua Hawkins 2003-11
spt-automation 5814 udp Support Automation Joshua Hawkins Joshua Hawkins 2003-11
5815-5819 Unassigned
autopassdaemon 5820 tcp AutoPass licensing opentext AutoPass 2022-06-10 2024-08-01
5820 udp Reserved
5821-5840 Unassigned
shiprush-d-ch 5841 tcp Z-firm ShipRush interface for web access and bidirectional data Z-Firm LLC Rafael Zimberoff 2014-08-22
5841 udp Reserved
reversion 5842 tcp Reversion Backup/Restore Pincoder Diagnostics Inc. Craig Nelson 2011-09-26 2022-10-12
5842 udp Reserved
5843-5858 Unassigned
wherehoo 5859 tcp WHEREHOO Jim Youll Jim Youll
wherehoo 5859 udp WHEREHOO Jim Youll Jim Youll
5860-5862 Unassigned
ppsuitemsg 5863 tcp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
ppsuitemsg 5863 udp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
5864-5867 Unassigned
diameters 5868 tcp Diameter over TLS/TCP IESG IETF Chair RFC 6733
5868 udp Reserved
diameters 5868 sctp Diameter over DTLS/SCTP IESG IETF Chair RFC 6733
5869-5882 Unassigned
jute 5883 tcp Javascript Unit Test Environment Mark Ethan Trostler Mark Ethan Trostler 2011-11-23
5884-5899 Unassigned
6150-6158 Unassigned
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
xdsxdm 6558 tcp Brian Tackett Brian Tackett possible contact
xdsxdm 6558 udp Brian Tackett Brian Tackett possible contact
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
parsec-peer 6581 tcp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-peer 6581 udp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-game 6582 tcp Parsec Gameserver Andreas Varga Andreas Varga
parsec-game 6582 udp Parsec Gameserver Andreas Varga Andreas Varga
joaJewelSuite 6583 tcp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
joaJewelSuite 6583 udp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
6584-6587 Unassigned
6588 Unassigned Unofficial use of port 6588 by AnalogX and Microsoft
6589-6599 Unassigned
6658-6664 Unassigned Unauthorized Use Known on Port 6659
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
7576-7587 Unassigned
sun-lm 7588 tcp Sun License Manager Sophie Deng Sophie Deng
sun-lm 7588 udp Sun License Manager Sophie Deng Sophie Deng
7589-7605 Unassigned
senomix07 8058 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix07 8058 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
8458-8469 Unassigned
9556-9558 Unassigned
x510 9877 tcp The X.510 wrapper protocol ITU/TSB (ITU-T Study Group 17) Erik Andersen 2019-09-30 ITU-T X.510 / ISO/IEC 9584-11
18244-18258 Unassigned
20058-20166 Unassigned
21555-21589 Unassigned
23458-23545 Unassigned
25794-25899 Unassigned
26258-26259 Unassigned
28241-28588 Unassigned
bosswave 28589 tcp Building operating system services wide area verified exchange University of California, Berkeley Michael Andersen 2016-06-13
28589 udp Reserved
31458-31619 Unassigned
35358-36000 Unassigned
45679-45823 Unassigned
dai-shell 45824 tcp Server for the DAI family of client-server products Data Access, Inc. Adam Robinson 2012-04-30
45824 udp Reserved
qdb2service 45825 tcp Qpuncture Data Access Service Michael Yun Michael Yun 2007-10-24
qdb2service 45825 udp Qpuncture Data Access Service Michael Yun Michael Yun 2007-10-24
45826-45965 Unassigned
47558-47623 Unassigned
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa
radiusdtls udp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiusdtls" for discovery of RADIUS/DTLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None
radiustls tcp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiustls" for discovery of RADIUS/TLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Adam Robinson Data Access, Inc. adam&dataaccessinc.com 2012-04-30
Andreas Varga sid&parsec.org
AutoPass MFI-swpdl.apls_core&opentext.com 2024-08-01
Bob Rundle rundle&rundle.com 2005-11
Brian Tackett cym&acrux.net
Charles O'Dale codale&hfx.andara.com 2006-07
Craig Nelson Pincoder Diagnostics Inc. craig&pincoder.ca 2022-10-12
Data Access, Inc. development&dataaccessinc.com 2012-04-30
Erik Andersen era&x500.eu 2019-08-13
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU/TSB (ITU-T Study Group 17) tsbsg17&itu.int 2019-09-30
Jim Youll jim&media.mit.edu
Joshua Hawkins joshua.hawkins&hp.com 2003-11
Mark Ethan Trostler mark&zzo.com 2011-11-23
Michael Andersen michael&steelcode.com 2016-06-13
Michael Yun cinnanda&gmail.com 2007-10-24
opentext MFI-swpdl.apls_core&opentext.com 2024-08-01
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Pincoder Diagnostics Inc. craig&pincoder.ca 2022-10-12
Rafael Zimberoff rafael&zfirmllc.com 2003-11
Shane O'Donnell shane&opennms.org
Sophie Deng Sophie.Deng&eng.sun.com
University of California, Berkeley m.andersen&cs.berkeley.edu 2016-06-13
Yannick Fortin fortiny&ca.objectiflune.com 2006-02
Z-Firm LLC rafael&zfirmllc.com 2014-08-22