Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mylex-mapd 467 udp mylex-mapd Gary Lewis Gary Lewis
photuris 468 tcp proturis Bill Simpson Bill Simpson
photuris 468 udp proturis Bill Simpson Bill Simpson
rcp 469 tcp Radio Control Protocol Jim Jennings Jim Jennings
rcp 469 udp Radio Control Protocol Jim Jennings Jim Jennings
tn-tl-fd1 476 tcp tn-tl-fd1 Ed Kress Ed Kress
tn-tl-fd1 476 udp tn-tl-fd1 Ed Kress Ed Kress
avian 486 tcp avian Robert Ullmann Robert Ullmann
avian 486 udp avian Robert Ullmann Robert Ullmann
pim-rp-disc 496 tcp PIM-RP-DISC Dino Farinacci Dino Farinacci
pim-rp-disc 496 udp PIM-RP-DISC Dino Farinacci Dino Farinacci
ohimsrv 506 tcp ohimsrv Scott Powell Scott Powell
ohimsrv 506 udp ohimsrv Scott Powell Scott Powell
syslog 514 udp 2020-06-01 RFC 5426
videotex 516 tcp videotex Daniel Mavrakis Daniel Mavrakis
videotex 516 udp videotex Daniel Mavrakis Daniel Mavrakis
tempo 526 tcp newdate
tempo 526 udp newdate
opalis-rdv 536 tcp opalis-rdv Laurent Domenech Laurent Domenech
opalis-rdv 536 udp opalis-rdv Laurent Domenech Laurent Domenech
dhcpv6-client 546 tcp DHCPv6 Client
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
remotefs 556 tcp rfs server
remotefs 556 udp rfs server
rmonitor 560 tcp rmonitord
rmonitor 560 udp rmonitord
monitor 561 tcp
monitor 561 udp
chshell 562 tcp chcmd
chshell 562 udp chcmd
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
9pfs 564 tcp plan 9 file service
9pfs 564 udp plan 9 file service
whoami 565 tcp whoami
whoami 565 udp whoami
streettalk 566 tcp streettalk
streettalk 566 udp streettalk
banyan-rpc 567 tcp banyan-rpc Tom Lemaire Tom Lemaire
banyan-rpc 567 udp banyan-rpc Tom Lemaire Tom Lemaire
ms-shuttle 568 tcp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-shuttle 568 udp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-rome 569 tcp microsoft rome Rudolph Balaz Rudolph Balaz
ms-rome 569 udp microsoft rome Rudolph Balaz Rudolph Balaz
ipcd 576 tcp ipcd
ipcd 576 udp ipcd
password-chg 586 tcp Password Change
password-chg 586 udp Password Change
submission 587 tcp Message Submission 2011-11-17 RFC 6409
submission 587 udp Message Submission 2011-11-17 RFC 6409
smsd 596 tcp SMSD Wayne Barlow Wayne Barlow
smsd 596 udp SMSD Wayne Barlow Wayne Barlow
ipcserver 600 tcp Sun IPC server Bill Schiefelbein Bill Schiefelbein
ipcserver 600 udp Sun IPC server Bill Schiefelbein Bill Schiefelbein
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
xmlrpc-beep 602 tcp XML-RPC over BEEP RFC 3529
xmlrpc-beep 602 udp XML-RPC over BEEP RFC 3529
idxp 603 tcp IDXP RFC 4767
idxp 603 udp IDXP RFC 4767
tunnel 604 tcp TUNNEL RFC 3620
tunnel 604 udp TUNNEL RFC 3620
soap-beep 605 tcp SOAP over BEEP RFC 4227
soap-beep 605 udp SOAP over BEEP RFC 4227
urm 606 tcp Cray Unified Resource Manager
urm 606 udp Cray Unified Resource Manager
nqs 607 tcp nqs Bill Schiefelbein Bill Schiefelbein
nqs 607 udp nqs Bill Schiefelbein Bill Schiefelbein
sift-uft 608 tcp Sender-Initiated/Unsolicited File Transfer Rick Troth Rick Troth
sift-uft 608 udp Sender-Initiated/Unsolicited File Transfer Rick Troth Rick Troth
npmp-trap 609 tcp npmp-trap
npmp-trap 609 udp npmp-trap
npmp-local 610 tcp npmp-local
npmp-local 610 udp npmp-local
npmp-gui 611 tcp npmp-gui John Barnes John Barnes
npmp-gui 611 udp npmp-gui John Barnes John Barnes
hmmp-ind 612 tcp HMMP Indication
hmmp-ind 612 udp HMMP Indication
hmmp-op 613 tcp HMMP Operation Andrew Sinclair Andrew Sinclair
hmmp-op 613 udp HMMP Operation Andrew Sinclair Andrew Sinclair
sshell 614 tcp SSLshell Simon J. Gerraty Simon J. Gerraty
sshell 614 udp SSLshell Simon J. Gerraty Simon J. Gerraty
sco-inetmgr 615 tcp Internet Configuration Manager
sco-inetmgr 615 udp Internet Configuration Manager
sco-sysmgr 616 tcp SCO System Administration Server
sco-sysmgr 616 udp SCO System Administration Server
sco-dtmgr 617 tcp SCO Desktop Administration Server Christopher Durham Christopher Durham
sco-dtmgr 617 udp SCO Desktop Administration Server Christopher Durham Christopher Durham
dei-icda 618 tcp DEI-ICDA David Turner David Turner
dei-icda 618 udp DEI-ICDA David Turner David Turner
compaq-evm 619 tcp Compaq EVM Jem Treadwell Jem Treadwell
compaq-evm 619 udp Compaq EVM Jem Treadwell Jem Treadwell
sco-websrvrmgr 620 tcp SCO WebServer Manager Christopher Durham Christopher Durham
sco-websrvrmgr 620 udp SCO WebServer Manager Christopher Durham Christopher Durham
escp-ip 621 tcp ESCP Lai Zit Seng Lai Zit Seng
escp-ip 621 udp ESCP Lai Zit Seng Lai Zit Seng
collaborator 622 tcp Collaborator Johnson Davis Johnson Davis
collaborator 622 udp Collaborator Johnson Davis Johnson Davis
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06

Contact Information

Name Organization Contact URI Last Updated
Andrew Sinclair andrsin&microsoft.com
Bill Schiefelbein schief&aspen.cray.com
Bill Simpson Bill.Simpson&um.cc.umich.edu
Christopher Durham chrisdu&sco.com
Daniel Mavrakis system&venus.mctel.fr
David Turner digital&quetico.tbaytel.net
Dino Farinacci dino&cisco.com 2008-08-21
Ed Kress eskress&thinknet.com
Gary Lewis GaryL&hq.mylex.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jem Treadwell Jem.Treadwell&compaq.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jim Jennings tel:+1-708-538-7241
John Barnes jbarnes&crl.com
Johnson Davis johnsond&opteamasoft.com
Lai Zit Seng lzs&pobox.com
Laurent Domenech Opalis ldomenech&opalis.com
Rick Troth troth&rice.edu
Robert Ullmann Robert_Ullmann/CAM/Lotus.LOTUS@crd.lotus.com
Rudolph Balaz rudolphb&microsoft.com
Scott Powell spowell&openhorizon.com
Simon J. Gerraty sjg&quick.com.au
Tom Lemaire toml&banyan.com
Wayne Barlow web&unx.dec.com