Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| patrol-coll | 6162 | udp | PATROL Collector | Portnoy Boxman | Portnoy Boxman | 2005-01 | |||||
| lm-x | 6200 | tcp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| lm-x | 6200 | udp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| 6201 | tcp | Reserved | |||||||||
| thermo-calc | 6201 | udp | Management of service nodes in a processing grid for thermodynamic calculations | Thermo-Calc Software AB | Thomas Revesz | 2012-06-28 | |||||
| 6202-6208 | Unassigned | ||||||||||
| qmtps | 6209 | tcp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| qmtps | 6209 | udp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| 6210-6221 | Unassigned | ||||||||||
| radmind | 6222 | tcp | Radmind Access Protocol | Patrick M McNeal | Patrick M McNeal | 2006-03 | |||||
| radmind | 6222 | udp | Radmind Access Protocol | Patrick M McNeal | Patrick M McNeal | 2006-03 | |||||
| 6223-6240 | Unassigned | ||||||||||
| jeol-nsdtp-1 | 6241 | tcp | JEOL Network Services Data Transport Protocol 1 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-1 | 6241 | udp | JEOL Network Services Dynamic Discovery Protocol 1 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-2 | 6242 | tcp | JEOL Network Services Data Transport Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-2 | 6242 | udp | JEOL Network Services Dynamic Discovery Protocol 2 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-3 | 6243 | tcp | JEOL Network Services Data Transport Protocol 3 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-3 | 6243 | udp | JEOL Network Services Dynamic Discovery Protocol 3 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsdtp-4 | 6244 | tcp | JEOL Network Services Data Transport Protocol 4 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| jeol-nsddp-4 | 6244 | udp | JEOL Network Services Dynamic Discovery Protocol 4 | Kevin Wellwood | Kevin Wellwood | 2008-04-17 | |||||
| 6245-6250 | Unassigned | ||||||||||
| tl1-raw-ssl | 6251 | tcp | TL1 Raw Over SSL/TLS | Jim Humphreys | Jim Humphreys | 2008-01-29 | |||||
| tl1-raw-ssl | 6251 | udp | TL1 Raw Over SSL/TLS | Jim Humphreys | Jim Humphreys | 2008-01-29 | |||||
| tl1-ssh | 6252 | tcp | TL1 over SSH | Jim Humphreys | Jim Humphreys | 2008-01-25 | |||||
| tl1-ssh | 6252 | udp | TL1 over SSH | Jim Humphreys | Jim Humphreys | 2008-01-25 | |||||
| crip | 6253 | tcp | CRIP | Mike Rodbell | Mike Rodbell | ||||||
| crip | 6253 | udp | CRIP | Mike Rodbell | Mike Rodbell | ||||||
| 6254-6266 | Unassigned | ||||||||||
| gld | 6267 | tcp | GridLAB-D User Interface | David Chassin | David Chassin | 2010-12-10 | |||||
| 6267 | udp | Reserved | |||||||||
| grid | 6268 | tcp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid | 6268 | udp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid-alt | 6269 | tcp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid-alt | 6269 | udp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| 6270-6299 | Unassigned | ||||||||||
| 6361-6362 | Unassigned | ||||||||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | tcp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | udp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| mcftp | 6622 | tcp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| mcftp | 6622 | udp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| ktelnet | 6623 | tcp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| ktelnet | 6623 | udp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| datascaler-db | 6624 | tcp | DataScaler database | Vasu Murthy | Vasu Murthy | 2010-02-08 | |||||
| 6624 | udp | Reserved | |||||||||
| datascaler-ctl | 6625 | tcp | DataScaler control | Vasu Murthy | Vasu Murthy | 2010-02-08 | |||||
| 6625 | udp | Reserved | |||||||||
| wago-service | 6626 | tcp | WAGO Service and Update | Wolfgang Adler | Wolfgang Adler | 2006-04 | |||||
| wago-service | 6626 | udp | WAGO Service and Update | Wolfgang Adler | Wolfgang Adler | 2006-04 | |||||
| nexgen | 6627 | tcp | Allied Electronics NeXGen | Lou Seitchik | Lou Seitchik | 2005-08 | |||||
| nexgen | 6627 | udp | Allied Electronics NeXGen | Lou Seitchik | Lou Seitchik | 2005-08 | |||||
| afesc-mc | 6628 | tcp | AFE Stock Channel M/C | K. K Ho | K. K Ho | 2004-04 | |||||
| afesc-mc | 6628 | udp | AFE Stock Channel M/C | K. K Ho | K. K Ho | 2004-04 | |||||
| nexgen-aux | 6629 | tcp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| nexgen-aux | 6629 | udp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| jmevt2 | 6962 | tcp | jmevt2 | Yutaka Ono | Yutaka Ono | ||||||
| jmevt2 | 6962 | udp | jmevt2 | Yutaka Ono | Yutaka Ono | ||||||
| caistoragemgr | 7162 | tcp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| caistoragemgr | 7162 | udp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| cnap | 7262 | tcp | Calypso Network Access Protocol | Frontrow Calypso, LLC | Scott Halberg | 2009-06-02 | |||||
| cnap | 7262 | udp | Calypso Network Access Protocol | Frontrow Calypso, LLC | Scott Halberg | 2009-06-02 | |||||
| 7561-7562 | Unassigned | ||||||||||
| cfw | 7563 | tcp | Control Framework | RFC 6230 | |||||||
| 7607-7623 | Unassigned | ||||||||||
| indi | 7624 | tcp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| indi | 7624 | udp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| 7625 | Unassigned | ||||||||||
| simco | 7626 | tcp | SImple Middlebox COnfiguration (SIMCO) Server | RFC 4540 | |||||||
| 7626 | udp | De-registered | 2006-01-30 | ||||||||
| simco | 7626 | sctp | SImple Middlebox COnfiguration (SIMCO) | Sebastian Kiesel | Sebastian Kiesel | 2006-01 | |||||
| soap-http | 7627 | tcp | SOAP Service Port | Donald Dylla | Donald Dylla | 2004-12 | |||||
| soap-http | 7627 | udp | SOAP Service Port | Donald Dylla | Donald Dylla | 2004-12 | |||||
| zen-pawn | 7628 | tcp | Primary Agent Work Notification | Ty Ellis | Ty Ellis | 2006-05 | |||||
| zen-pawn | 7628 | udp | Primary Agent Work Notification | Ty Ellis | Ty Ellis | 2006-05 | |||||
| xdas | 7629 | tcp | OpenXDAS Wire Protocol | John Calcote | John Calcote | 2006-10 | |||||
| xdas | 7629 | udp | OpenXDAS Wire Protocol | John Calcote | John Calcote | 2006-10 | |||||
| 7649-7662 | Unassigned | ||||||||||
| generalsync | 7962 | tcp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| generalsync | 7962 | udp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| 8062-8065 | Unassigned | ||||||||||
| lpar2rrd | 8162 | tcp | LPAR2RRD client server communication | LPAR2RRD project | Pavel Hampl | 2013-08-14 | |||||
| 8162 | udp | Reserved | |||||||||
| 8751-8762 | Unassigned | ||||||||||
| apani3 | 9162 | tcp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | udp | apani3 | Neal Taylor | Neal Taylor | ||||||
| 9619-9627 | Unassigned | ||||||||||
| odbcpathway | 9628 | tcp | ODBC Pathway Service | Adrian Hungate | Adrian Hungate | 2007-05 | |||||
| odbcpathway | 9628 | udp | ODBC Pathway Service | Adrian Hungate | Adrian Hungate | 2007-05 | |||||
| uniport | 9629 | tcp | UniPort SSO Controller | Adrian Hungate | Adrian Hungate | 2007-09-05 | |||||
| uniport | 9629 | udp | UniPort SSO Controller | Adrian Hungate | Adrian Hungate | 2007-09-05 | |||||
| tungsten-http | 9762 | tcp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| tungsten-http | 9762 | udp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| snmptls-trap | 10162 | tcp | SNMP-Trap-TLS | RFC 6353 | |||||||
| snmpdtls-trap | 10162 | udp | SNMP-Trap-DTLS | RFC 6353 | |||||||
| 10262-10287 | Unassigned | ||||||||||
| suncacao-jmxmp | 11162 | tcp | sun cacao JMX-remoting access point | Nick Stephen | Nick Stephen | 2005-08 | |||||
| suncacao-jmxmp | 11162 | udp | sun cacao JMX-remoting access point | Nick Stephen | Nick Stephen | 2005-08 | |||||
| 11601-11622 | Unassigned | ||||||||||
| emc-xsw-dconfig | 11623 | tcp | EMC XtremSW distributed config | EMC | David Erel | 2013-09-18 | |||||
| 11623 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adrian Hungate | adrian&tlspu.com | 2014-07-11 | |
| Afkham Azeez | azeez&wso2.com | 2006-06 | |
| Allied Electronics | Rob&AlliedElectronics.com | 2016-11-29 | |
| Bruce Lueckenhoff | bruce&scalabledesign.com | 2006-02 | |
| David Chassin | david.chassin&pnl.gov | 2010-12-10 | |
| David Erel | EMC | david.erel&emc.com | 2013-09-18 |
| Dirk Steinmetz | ds&generalsync.com | 2014-04-17 | |
| Donald Dylla | donald.dylla&hp.com | 2004-12 | |
| Elwood Downey | ecdowney&clearskyinstitute.com | 2002-04 | |
| EMC | david.erel&emc.com | 2013-09-18 | |
| Emre Tunar | emre.tunar&ca.com | 2004-11 | |
| Erwin Hoffmann | FEHCom | feh&fehcom.de | 2015-01-09 |
| FEHCom | feh&fehcom.de | 2015-01-09 | |
| Frontrow Calypso, LLC | eng&gofrontrow.com | 2016-04-13 | |
| Henrik Goldman | hg&x-formation.com | 2006-10 | |
| Jason Hamilton | JHamilton&griddatasecurity.com | 2006-06 | |
| Jim Humphreys | jhumphre&ciena.com | 2008-01-29 | |
| John Calcote | jcalcote&novell.com | 2006-10 | |
| K. K Ho | kk.ho&afe-solutions.com | 2004-04 | |
| Kevin Wellwood | wellwood&jeol.com | 2008-04-17 | |
| Lou Seitchik | lou&alliedelectronics.com | 2005-08 | |
| LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 | |
| Mike Rodbell | mrodbell&ciena.com | ||
| Neal Taylor | ianareg&apani.com | ||
| Nick Stephen | nick.stephen&sun.com | 2005-08 | |
| Patrick M McNeal | mcneal&umich.edu | 2006-03 | |
| Pavel Hampl | LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Robert E. Tomenchok Jr. | Rob&AlliedElectronics.com | 2016-11-29 | |
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| Scott Halberg | slh&gofrontrow.com | 2016-04-13 | |
| Sebastian Kiesel | kiesel&ikr.uni-stuttgart.de | 2006-01 | |
| Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 | |
| Thomas Revesz | Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 |
| Ty Ellis | tellis&novell.com | 2006-05 | |
| Vasu Murthy | vmurthy&datascaler.com | 2010-02-08 | |
| Wolfgang Adler | electronicc_rd&wago.com | 2006-04 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |