Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
net-projection 5363 tcp Windows Network Projection Rob Williams Rob Williams 2009-02-17
net-projection 5363 udp Windows Network Projection Rob Williams Rob Williams 2009-02-17
ttlpriceproxy 5463 tcp TTL Price Proxy Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 udp TTL Price Proxy Peter Jacobs Peter Jacobs
precise-comm 5630 tcp PreciseCommunication Alon Tamir Alon Tamir 2006-04
precise-comm 5630 udp PreciseCommunication Alon Tamir Alon Tamir 2006-04
pcanywheredata 5631 tcp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywheredata 5631 udp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywherestat 5632 tcp pcANYWHEREstat Jon Rosarky Jon Rosarky
pcanywherestat 5632 udp pcANYWHEREstat Jon Rosarky Jon Rosarky
beorl 5633 tcp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
beorl 5633 udp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
xprtld 5634 tcp SF Message Service VR Satish VR Satish 2007-08-16
xprtld 5634 udp SF Message Service VR Satish VR Satish 2007-08-16
sfmsso 5635 tcp SFM Authentication Subsystem De-Chih Chien De-Chih Chien 2008-09-15
5635 udp Reserved
sfm-db-server 5636 tcp SFMdb - SFM DB server De-Chih Chien De-Chih Chien 2008-10-06
5636 udp Reserved
cssc 5637 tcp Symantec CSSC Amol P Tambe Amol P Tambe 2011-02-02
5637 udp Reserved
flcrs 5638 tcp Symantec Fingerprint Lookup and Container Reference Service Symantec Corp Neel A. Bhatt 2012-01-03
5638 udp Reserved
ics 5639 tcp Symantec Integrity Checking Service Symantec Danzhou Liu 2012-05-07
5639 udp Reserved
ppsuitemsg 5863 tcp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
ppsuitemsg 5863 udp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
indy 5963 tcp Indy Application Server Bjorn Lantz Bjorn Lantz 2004-11
indy 5963 udp Indy Application Server Bjorn Lantz Bjorn Lantz 2004-11
x11 6000-6063 tcp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
x11 6000-6063 udp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
gsmp-ancp 6068 tcp GSMP/ANCP Avri Doria Avri Doria RFC 6320
pscribe 6163 tcp Precision Scribe Cnx Port Robert W Hodges Robert W Hodges 2005-01
pscribe 6163 udp Precision Scribe Cnx Port Robert W Hodges Robert W Hodges 2005-01
bmc-grx 6300 tcp BMC GRX Portnoy Boxman Portnoy Boxman
bmc-grx 6300 udp BMC GRX Portnoy Boxman Portnoy Boxman
bmc-ctd-ldap 6301 tcp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 tcp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
bmc-ctd-ldap 6301 udp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 udp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
6302-6305 Unassigned
ufmp 6306 tcp Unified Fabric Management Protocol Mellanox Technologies, Inc. Shachar Dor 2009-12-17 2019-07-02
ufmp 6306 udp Unified Fabric Management Protocol Mellanox Technologies, Inc. Shachar Dor 2009-12-17 2019-07-02
6307-6314 Unassigned
scup 6315 tcp Sensor Control Unit Protocol Sven Kopacz Sven Kopacz 2010-09-01
scup-disc 6315 udp Sensor Control Unit Protocol Discovery Protocol Sven Kopacz Sven Kopacz 2010-09-01
abb-escp 6316 tcp Ethernet Sensor Communications Protocol Jaime Antolin Jaime Antolin 2008-09-25
abb-escp 6316 udp Ethernet Sensor Communications Protocol Jaime Antolin Jaime Antolin 2008-09-25
nav-data-cmd 6317 tcp Navtech Radar Sensor Data Command Navtech Radar Guy Avery 2013-02-20
nav-data 6317 udp Navtech Radar Sensor Data Navtech Radar Guy Avery 2013-02-20
iona-data 6318 tcp IONA Measurement and control data Insphere Ltd Guy Avery 2024-07-01
6318 udp Reserved
6319 Unassigned
repsvc 6320 tcp Double-Take Replication Service Carbonite, Inc. James Wilkinson 2006-04 2019-08-23
repsvc 6320 udp Double-Take Replication Service Carbonite, Inc. James Wilkinson 2006-04 2019-08-23
emp-server1 6321 tcp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
emp-server1 6321 udp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
emp-server2 6322 tcp Empress Software Connectivity Server 2 Srdjan Holovac Srdjan Holovac
emp-server2 6322 udp Empress Software Connectivity Server 2 Srdjan Holovac Srdjan Holovac
6323 Unassigned
hrd-ncs 6324 tcp HR Device Network Configuration Service Hall Research Vishal Dharmadhikari 2011-11-29
hrd-ns-disc 6324 udp HR Device Network service Hall Research Vishal Dharmadhikari 2011-11-29
dt-mgmtsvc 6325 tcp Double-Take Management Service Carbonite, Inc. James Wilkinson 2012-06-06 2019-08-23
6325 udp Reserved
dt-vra 6326 tcp Double-Take Virtual Recovery Assistant Carbonite, Inc. James Wilkinson 2012-10-08 2019-08-23
6326 udp Reserved
6327-6342 Unassigned
sflow 6343 tcp sFlow traffic monitoring Peter Phaal Peter Phaal 2003-06
sflow 6343 udp sFlow traffic monitoring Peter Phaal Peter Phaal 2003-06
streletz 6344 tcp Argus-Spectr security and fire-prevention systems service Argus-Spectr Kirill Marinushkin 2013-10-25
6344 udp Reserved
6345-6345 Unassigned
gnutella-svc 6346 tcp gnutella-svc Serguei Osokine Serguei Osokine
gnutella-svc 6346 udp gnutella-svc Serguei Osokine Serguei Osokine
gnutella-rtr 6347 tcp gnutella-rtr Serguei Osokine Serguei Osokine
gnutella-rtr 6347 udp gnutella-rtr Serguei Osokine Serguei Osokine
6348-6349 Unassigned
adap 6350 tcp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
adap 6350 udp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
6351-6354 Unassigned
pmcs 6355 tcp PMCS applications Pavel Mendl Pavel Mendl 2007-03
pmcs 6355 udp PMCS applications Pavel Mendl Pavel Mendl 2007-03
6356-6359 Unassigned
metaedit-mu 6360 tcp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
metaedit-mu 6360 udp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
6361-6362 Unassigned
ndn 6363 udp Named Data Networking Regents of the University of California Jeff Burke 2013-10-30
6363 tcp Reserved
6364-6369 Unassigned
metaedit-se 6370 tcp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
metaedit-se 6370 udp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
6371-6378 Unassigned
redis 6379 tcp An advanced key-value cache and store Salvatore Sanfilippo Itamar Haber 2015-04-23
6379 udp Reserved
6380-6381 Unassigned
metatude-mds 6382 tcp Metatude Dialogue Server Menno Zweistra Menno Zweistra
metatude-mds 6382 udp Metatude Dialogue Server Menno Zweistra Menno Zweistra
6383-6388 Unassigned
clariion-evr01 6389 tcp clariion-evr01 Dave DesRoches Dave DesRoches
clariion-evr01 6389 udp clariion-evr01 Dave DesRoches Dave DesRoches
metaedit-ws 6390 tcp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12

Contact Information

Name Organization Contact URI Last Updated
Alon Tamir alon_tamir&symantec.com 2006-04
Amol P Tambe amol_tambe&symantec.com 2011-02-02
Argus-Spectr mail&argus-spectr.ru 2013-10-25
Avri Doria avri.doria&nokia.com
Bjorn Lantz bjorn.lantz&encode.se 2004-11
Carbonite, Inc. jwilkinson&carbonite.com 2019-08-23
Chirag Desai Chirag_Desai&symantec.com 2006-02
Danzhou Liu Symantec Danzhou_Liu&symantec.com 2012-05-07
Dave DesRoches ddesroches&clariion.com
De-Chih Chien de-chih_chien&symantec.com 2008-10-06
Guy Avery Navtech Radar guy.avery&navtechradar.com 2013-02-20
Guy Avery Insphere Ltd guy&insphereltd.com 2013-02-20
Hall Research vishal&hallresearch.com 2011-11-29
Itamar Haber Salvatore Sanfilippo itamar&redislabs.com 2015-04-23
Insphere Ltd guy&insphereltd.com 2024-07-01
Jaime Antolin jaime.antolin&ie.abb.com 2008-09-25
James Wilkinson jwilkinson&carbonite.com 2019-08-23
Jeff Burke Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Jon Rosarky JRosarky&symantec.com
Kirill Marinushkin Argus-Spectr k.marinushkin&argus-spectr.ru 2013-10-25
Mellanox Technologies, Inc. info&mellanox.com 2019-07-02
Menno Zweistra m.zweistra&metatude.com
Neel A. Bhatt Symantec Corp neel_bhatt&symantec.com 2012-01-03
Pavel Mendl pavel_mendl&centrum.cz 2007-03
Peter Jacobs pjacobs&tullib.com
Peter Phaal peter.phaal&inmon.com 2003-06
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Portnoy Boxman Portnoy_Boxman&bmc.com 2006-09
Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Rob Williams rob.williams&microsoft.com 2009-02-17
Robert W Hodges iana&precdata.com 2005-01
Salvatore Sanfilippo antirez&gmail.com 2015-04-23
Serguei Osokine osokin&paragraph.com
Shachar Dor Mellanox Technologies, Inc. shachard&mellanox.com 2019-07-02
Srdjan Holovac srdjan&empress.com
Stephen Gildea gildea&lcs.mit.edu
Steven Kelly stevek&metacase.com 2007-11-12
Sven Kopacz s.kopacz&controllerware.com 2010-09-01
Symantec Corp neel_bhatt&symantec.com 2012-01-03
Symantec info&symantec.com 2012-05-07
Thomas Kjoernes thomas&ipv.no 2010-06-22
VR Satish vr_satish&symantec.com 2007-08-16
Vishal Dharmadhikari Hall Research vishal&hallresearch.com 2011-11-29
Yannick Fortin fortiny&ca.objectiflune.com 2006-02