Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| meter | 570 | udp | demon | ||||||||
| meter | 571 | tcp | udemon | ||||||||
| meter | 571 | udp | udemon | ||||||||
| sonar | 572 | tcp | sonar | Keith Moore | Keith Moore | ||||||
| sonar | 572 | udp | sonar | Keith Moore | Keith Moore | ||||||
| banyan-vip | 573 | tcp | banyan-vip | Denis Leclerc | Denis Leclerc | ||||||
| banyan-vip | 573 | udp | banyan-vip | Denis Leclerc | Denis Leclerc | ||||||
| ftp-agent | 574 | tcp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| ftp-agent | 574 | udp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| vemmi | 575 | tcp | VEMMI | Daniel Mavrakis | Daniel Mavrakis | ||||||
| vemmi | 575 | udp | VEMMI | Daniel Mavrakis | Daniel Mavrakis | ||||||
| ipcd | 576 | tcp | ipcd | ||||||||
| ipcd | 576 | udp | ipcd | ||||||||
| vnas | 577 | tcp | vnas | ||||||||
| vnas | 577 | udp | vnas | ||||||||
| ipdd | 578 | tcp | ipdd | Jay Farhat | Jay Farhat | ||||||
| ipdd | 578 | udp | ipdd | Jay Farhat | Jay Farhat | ||||||
| decbsrv | 579 | tcp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| decbsrv | 579 | udp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| submission | 587 | tcp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| submission | 587 | udp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| ptcnameservice | 597 | tcp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| ptcnameservice | 597 | udp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| idxp | 603 | tcp | IDXP | RFC 4767 | |||||||
| idxp | 603 | udp | IDXP | RFC 4767 | |||||||
| soap-beep | 605 | tcp | SOAP over BEEP | RFC 4227 | |||||||
| soap-beep | 605 | udp | SOAP over BEEP | RFC 4227 | |||||||
| nqs | 607 | tcp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| nqs | 607 | udp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| sco-dtmgr | 617 | tcp | SCO Desktop Administration Server | Christopher Durham | Christopher Durham | ||||||
| sco-dtmgr | 617 | udp | SCO Desktop Administration Server | Christopher Durham | Christopher Durham | ||||||
| passgo-tivoli | 627 | tcp | PassGo Tivoli | John Rainford | John Rainford | ||||||
| passgo-tivoli | 627 | udp | PassGo Tivoli | John Rainford | John Rainford | ||||||
| lanserver | 637 | tcp | lanserver | Chris Larsson | Chris Larsson | ||||||
| lanserver | 637 | udp | lanserver | Chris Larsson | Chris Larsson | ||||||
| dhcp-failover | 647 | tcp | DHCP Failover | IESG | IETF Chair | 2018-05-21 | RFC 8156 | ||||
| dhcp-failover | 647 | udp | DHCP Failover | Bernard Volz | Bernard Volz | ||||||
| rmc | 657 | tcp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| rmc | 657 | udp | RMC | Michael Schmidt | Michael Schmidt | ||||||
| disclose | 667 | tcp | campaign contribution disclosures - SDR Technologies | Jim Dixon | Jim Dixon | ||||||
| disclose | 667 | udp | campaign contribution disclosures - SDR Technologies | Jim Dixon | Jim Dixon | ||||||
| vacdsm-sws | 670 | tcp | VACDSM-SWS | ||||||||
| vacdsm-sws | 670 | udp | VACDSM-SWS | ||||||||
| vacdsm-app | 671 | tcp | VACDSM-APP | ||||||||
| vacdsm-app | 671 | udp | VACDSM-APP | ||||||||
| vpps-qua | 672 | tcp | VPPS-QUA | ||||||||
| vpps-qua | 672 | udp | VPPS-QUA | ||||||||
| cimplex | 673 | tcp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| cimplex | 673 | udp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| acap | 674 | tcp | ACAP | Chris Newman | Chris Newman | 2010-10-15 | |||||
| acap | 674 | udp | ACAP | Chris Newman | Chris Newman | 2010-10-15 | |||||
| dctp | 675 | tcp | DCTP | Andre Kramer | Andre Kramer | ||||||
| dctp | 675 | udp | DCTP | Andre Kramer | Andre Kramer | ||||||
| vpps-via | 676 | tcp | VPPS Via | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| vpps-via | 676 | udp | VPPS Via | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| vpp | 677 | tcp | Virtual Presence Protocol | Klaus Wolf | Klaus Wolf | ||||||
| vpp | 677 | udp | Virtual Presence Protocol | Klaus Wolf | Klaus Wolf | ||||||
| ggf-ncp | 678 | tcp | GNU Generation Foundation NCP | Noah Paul | Noah Paul | ||||||
| ggf-ncp | 678 | udp | GNU Generation Foundation NCP | Noah Paul | Noah Paul | ||||||
| mrm | 679 | tcp | MRM | Liming Wei | Liming Wei | ||||||
| mrm | 679 | udp | MRM | Liming Wei | Liming Wei | ||||||
| asipregistry | 687 | tcp | asipregistry | Erik Sea | Erik Sea | ||||||
| asipregistry | 687 | udp | asipregistry | Erik Sea | Erik Sea | ||||||
| uuidgen | 697 | tcp | UUIDGEN | James Falkner | James Falkner | ||||||
| uuidgen | 697 | udp | UUIDGEN | James Falkner | James Falkner | ||||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| lmp | 701 | tcp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| lmp | 701 | udp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| 703 | Unassigned | ||||||||||
| elcsd | 704 | tcp | errlog copy/server daemon | ||||||||
| elcsd | 704 | udp | errlog copy/server daemon | ||||||||
| agentx | 705 | tcp | AgentX | Bob Natale | Bob Natale | ||||||
| agentx | 705 | udp | AgentX | Bob Natale | Bob Natale | ||||||
| silc | 706 | tcp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| silc | 706 | udp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| borland-dsj | 707 | tcp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| borland-dsj | 707 | udp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| 708 | Unassigned | ||||||||||
| entrust-kmsh | 709 | tcp | Entrust Key Management Service Handler | ||||||||
| entrust-kmsh | 709 | udp | Entrust Key Management Service Handler | ||||||||
| entrust-ash | 710 | tcp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| entrust-ash | 710 | udp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| cisco-tdp | 711 | tcp | Cisco TDP | Bruce Davie | Bruce Davie | ||||||
| cisco-tdp | 711 | udp | Cisco TDP | Bruce Davie | Bruce Davie | ||||||
| tbrpf | 712 | tcp | TBRPF | RFC 3684 | |||||||
| tbrpf | 712 | udp | TBRPF | RFC 3684 | |||||||
| iris-xpc | 713 | tcp | IRIS over XPC | ||||||||
| iris-xpc | 713 | udp | IRIS over XPC | ||||||||
| iris-xpcs | 714 | tcp | IRIS over XPCS | RFC 4992 | |||||||
| iris-xpcs | 714 | udp | IRIS over XPCS | RFC 4992 | |||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| pana | 716 | udp | PANA Messages | RFC 5191 | |||||||
| 717-728 | Unassigned | ||||||||||
| netviewdm1 | 729 | tcp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm1 | 729 | udp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm2 | 730 | tcp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm2 | 730 | udp | IBM NetView DM/6000 send/tcp |