Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5700 udp Reserved
5701-5704 Unassigned
storageos 5705 tcp StorageOS REST API StorageOS Simon Croome 2017-03-03
5705 udp Reserved
5706-5712 Unassigned
spramsd 5770 tcp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
spramsd 5770 udp x509solutions Secure Data Brendan Fay Brendan Fay 2006-02
5970-5983 Unassigned
messageasap 6070 tcp Messageasap Murray Freeman Murray Freeman
messageasap 6070 udp Messageasap Murray Freeman Murray Freeman
6270-6299 Unassigned
metaedit-se 6370 tcp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
metaedit-se 6370 udp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
6465-6470 Unassigned
ovsdb 6640 tcp Open vSwitch Database protocol Bruce Davie Bruce Davie 2013-07-31 RFC 7047
vocaltec-gold 6670 tcp Vocaltec Global Online Directory Scott Petrack Scott Petrack
vocaltec-gold 6670 udp Vocaltec Global Online Directory Scott Petrack Scott Petrack
6700 Unassigned 2010-01-26
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6704 udp Reserved
6704 tcp Reserved
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
6705 udp Reserved
6705 tcp Reserved
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
6706 udp Reserved
6706 tcp Reserved
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
6707-6713 Unassigned
plysrv-http 6770 tcp PolyServe http Mike Spitzer Mike Spitzer 2005-08
plysrv-http 6770 udp PolyServe http Mike Spitzer Mike Spitzer 2005-08
conductor 6970 tcp Conductor test coordination protocol George Neville-Neil George Neville-Neil 2014-09-18
6970 udp Reserved
conductor-mpx 6970 sctp conductor for multiplex George Neville-Neil George Neville-Neil 2014-07-29
afs3-fileserver 7000 tcp file server itself
afs3-fileserver 7000 udp file server itself
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-prserver 7002 tcp users & groups database Known Unauthorized Use on port 7002
afs3-prserver 7002 udp users & groups database Known Unauthorized Use on port 7002
afs3-vlserver 7003 tcp volume location database
afs3-vlserver 7003 udp volume location database
afs3-kaserver 7004 tcp AFS/Kerberos authentication service
afs3-kaserver 7004 udp AFS/Kerberos authentication service
afs3-volser 7005 tcp volume managment server Known Unauthorized Use on port 7005
afs3-volser 7005 udp volume managment server Known Unauthorized Use on port 7005
afs3-errors 7006 tcp error interpretation service
afs3-errors 7006 udp error interpretation service
afs3-bos 7007 tcp basic overseer process
afs3-bos 7007 udp basic overseer process
afs3-update 7008 tcp server-to-server updater
afs3-update 7008 udp server-to-server updater
afs3-rmtsys 7009 tcp remote cache manager service
afs3-rmtsys 7009 udp remote cache manager service
ups-onlinet 7010 tcp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
ups-onlinet 7010 udp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
talon-disc 7011 tcp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-disc 7011 udp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 tcp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 udp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
microtalon-dis 7013 tcp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-dis 7013 udp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-com 7014 tcp Microtalon Communications Jim Thompson Jim Thompson
microtalon-com 7014 udp Microtalon Communications Jim Thompson Jim Thompson
talon-webserver 7015 tcp Talon Webserver Jim Thompson Jim Thompson
talon-webserver 7015 udp Talon Webserver Jim Thompson Jim Thompson
spg 7016 tcp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
spg 7016 udp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
fisa-svc 7018 tcp FISA Service FAUCONNET Ingénierie SA FAUCONNET Ingénierie SA 2011-05-19
7018 udp Reserved
doceri-ctl 7019 tcp doceri drawing service control Paul Brown Paul Brown 2011-04-27
doceri-view 7019 udp doceri drawing service screen view Paul Brown Paul Brown 2011-04-27
dpserve 7020 tcp DP Serve Allan Stanley Allan Stanley
dpserve 7020 udp DP Serve Allan Stanley Allan Stanley
dpserveadmin 7021 tcp DP Serve Admin Allan Stanley Allan Stanley
dpserveadmin 7021 udp DP Serve Admin Allan Stanley Allan Stanley
ctdp 7022 tcp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ctdp 7022 udp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ct2nmcs 7023 tcp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
ct2nmcs 7023 udp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
vmsvc 7024 tcp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc 7024 udp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 tcp Vormetric Service II Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 udp Vormetric Service II Tom Boyle Tom Boyle 2005-06
loreji-panel 7026 tcp Loreji Webhosting Panel J.A. Smit DALTCORE 2018-02-21
7026 udp Reserved
7027-7029 Unassigned
op-probe 7030 tcp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
op-probe 7030 udp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
iposplanet 7031 tcp IPOSPLANET retailing multi devices protocol Fabrice Paget Fabrice Paget 2012-10-23

Contact Information

Name Organization Contact URI Last Updated
Allan Stanley allan&hummingbird.com
Bjorn Jarle Kvande bjorn&objectplanet.com 2002-04
Brendan Fay brendan.fay&x509solutions.com 2006-02
Bruce Davie bdavie&vmware.com 2013-07-31
Bryan Wilcutt bwilcutt&comtechefdata.com 2005-06
DALTCORE Info&daltcore.com 2018-02-21
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Fabrice Paget onefrench&me.com 2012-10-23
FAUCONNET Ingénierie SA dev&fisa.fr 2011-05-19
George Neville-Neil gnn&neville-neil.com 2014-07-29
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.A. Smit rsmit&daltcore.com 2018-02-21
James Kirkwood james.kirkwood&controltechniques.com 2005-06
Janos Lerch lerch&softic.hu 2006-02
Jim Thompson jim.thompson&powerware.com
Mike Spitzer mjs&polyserve.com 2005-08
Murray Freeman murray&officedomain.com
Paul Brown pbrown&spcontrols.com 2011-04-27
Scott Petrack Scott_Petrack&vocaltec.com
Simon Croome simon.croome&storageos.com 2017-03-03
SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Stanley Knutson Stanley.Knutson&ktiworld.com
Steve Barton SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Steven Kelly stevek&metacase.com 2007-11-12
StorageOS simon.croome&storageos.com 2017-03-03
Tom Boyle tboyle&vormetric.com 2005-06