Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
prosharedata 5715 udp proshare conf data gunner gunner
prosharerequest 5716 tcp proshare conf request gunner gunner
prosharerequest 5716 udp proshare conf request gunner gunner
prosharenotify 5717 tcp proshare conf notify gunner gunner
prosharenotify 5717 udp proshare conf notify
dpm 5718 tcp DPM Communication Server Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami
dpm 5718 udp DPM Communication Server Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami
dpm-agent 5719 tcp DPM Agent Coordinator Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami 2006-05
dpm-agent 5719 udp DPM Agent Coordinator Sundar Srinivasan; Vinay Badami Sundar Srinivasan; Vinay Badami 2006-05
netagent 5771 tcp NetAgent Bradley Birnbaum Bradley Birnbaum
netagent 5771 udp NetAgent Bradley Birnbaum Bradley Birnbaum
ssdtp 6071 tcp SSDTP Michael Shearson Michael Shearson
ssdtp 6071 udp SSDTP Michael Shearson Michael Shearson
6371-6378 Unassigned
lvision-lm 6471 tcp LVision License Manager Brian McKinnon Brian McKinnon
lvision-lm 6471 udp LVision License Manager Brian McKinnon Brian McKinnon
p4p-portal 6671 tcp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
p4p-portal 6671 udp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6707-6713 Unassigned
ibprotocol 6714 tcp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
ibprotocol 6714 udp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
fibotrader-com 6715 tcp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
fibotrader-com 6715 udp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
princity-agent 6716 tcp Princity Agent ENSTEAM Sp. z o.o. Tomasz Krakowiak 2014-07-07 2015-07-08
6716 udp Reserved
6717-6766 Unassigned
plysrv-https 6771 tcp PolyServe https Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 udp PolyServe https Mike Spitzer Mike Spitzer 2005-08
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces IESG IETF BFD Working Group Chairs 2012-11-08 2014-01-09 RFC 7130
6971-6979 Unassigned
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
font-service 7100 tcp X Font Service Stephen Gildea Stephen Gildea
font-service 7100 udp X Font Service Stephen Gildea Stephen Gildea
elcn 7101 tcp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
elcn 7101 udp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
7102-7106 Unassigned
7107 tcp Reserved
aes-x170 7107 udp AES-X170 Richard Foss Richard Foss 2011-02-10
7108-7116 Unassigned
rothaga 7117 tcp Encrypted chat and file transfer service Arcadian Computers Jonathan Pollock 2016-05-10
7117 udp Reserved
7118-7120 Unassigned
virprot-lm 7121 tcp Virtual Prototypes License Manager Victor Galis Victor Galis
virprot-lm 7121 udp Virtual Prototypes License Manager Victor Galis Victor Galis
7122 Unassigned
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection VESvault Corp Jim Zubov 2021-12-24 2026-07-22 draft-zubov-snif-05, Section 4.3
snif 7123 udp SNIF End-to-End TLS Relay over QUIC VESvault Corp Jim Zubov 2026-07-22 2026-07-22 draft-zubov-snif-05, Section 4.4
7124-7127 Unassigned
scenidm 7128 tcp intelligent data manager Paul Ignatius Paul Ignatius 2006-03
scenidm 7128 udp intelligent data manager Paul Ignatius Paul Ignatius 2006-03
scenccs 7129 tcp Catalog Content Search Anil Sharma Anil Sharma 2006-04
scenccs 7129 udp Catalog Content Search Anil Sharma Anil Sharma 2006-04
7130-7160 Unassigned
cabsm-comm 7161 tcp CA BSM Comm Chun-Ho Chang Chun-Ho Chang 2004-11
cabsm-comm 7161 udp CA BSM Comm Chun-Ho Chang Chun-Ho Chang 2004-11
caistoragemgr 7162 tcp CA Storage Manager Emre Tunar Emre Tunar 2004-11
caistoragemgr 7162 udp CA Storage Manager Emre Tunar Emre Tunar 2004-11
cacsambroker 7163 tcp CA Connection Broker David Roberts David Roberts 2005-05
cacsambroker 7163 udp CA Connection Broker David Roberts David Roberts 2005-05
fsr 7164 tcp File System Repository Agent Micha Ben-Efraim Micha Ben-Efraim 2007-07-19
fsr 7164 udp File System Repository Agent Micha Ben-Efraim Micha Ben-Efraim 2007-07-19
doc-server 7165 tcp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
doc-server 7165 udp Document WCF Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
aruba-server 7166 tcp Aruba eDiscovery Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
aruba-server 7166 udp Aruba eDiscovery Server Micha Ben-Efraim Micha Ben-Efraim 2008-01-07
casrmagent 7167 tcp CA SRM Agent Venkata Krishna Venkata Krishna 2010-02-24
7167 udp Reserved
cnckadserver 7168 tcp cncKadServer DB & Inventory Services Micha Ben-Efraim Micha Ben-Efraim 2011-01-31
7168 udp Reserved
ccag-pib 7169 tcp Consequor Consulting Process Integration Bridge Frank Goenninger Frank Goenninger 2010-02-22
ccag-pib 7169 udp Consequor Consulting Process Integration Bridge Frank Goenninger Frank Goenninger 2010-02-22
nsrp 7170 tcp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
nsrp 7170 udp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
drm-production 7171 tcp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
drm-production 7171 udp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
metalbend 7172 tcp Port used for MetalBend programmable interface Micha Ben-Efraim Micha Ben-Efraim 2012-11-27
7172 udp Reserved
zsecure 7173 tcp zSecure Server Hans Schoone Hans Schoone 2010-10-01
7173 udp Reserved
clutild 7174 tcp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
clutild 7174 udp Clutild Cheryl Stoutenburg Cheryl Stoutenburg
7175-7180 Unassigned
janus-disc 7181 udp Janus Guidewire Enterprise Discovery Service Bus Guidewire Software, Inc Luca Debiasi 2014-02-06
7181 tcp Reserved
7182-7199 Unassigned
7263-7271 Unassigned
sttunnel 7471 tcp Stateless Transport Tunneling Protocol Bruce Davie Bruce Davie 2014-04-28
7471 udp Reserved
7571-7573 Unassigned
7669-7671 Unassigned
7709-7719 Unassigned
raqmon-pdu 7744 tcp RAQMON PDU RFC 4712
raqmon-pdu 7744 udp RAQMON PDU RFC 4712
mdm 7871 tcp Mobile Device Management Dan Harkins Dan Harkins 2011-08-15
7871 udp Reserved
8071-8073 Unassigned
8271-8275 Unassigned
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559

Contact Information

Name Organization Contact URI Last Updated
Alessandro Bassi abassi&cs.utk.edu
Anil Sharma anil.sharma&scentric.com 2006-04
Arcadian Computers support&arcadiancomputers.com 2016-05-10
IETF BFD Working Group Chairs bfd-chairs&tools.ietf.org 2014-01-09
Bradley Birnbaum bradley.birnbaum&eshare.com
Brian McKinnon bmk&lvision.com
Bruce Davie bdavie&vmware.com 2014-04-28
Cheryl Stoutenburg cstoutenburg&vnet.ibm.com
Chris Griffiths chris_griffiths&cable.comcast.com 2008-07-28
Chun-Ho Chang chun-ho.chang&ca.com 2004-11
Dan Harkins dharkins&lounge.org 2011-08-15
David Roberts David.Roberts&ca.com 2005-05
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Emre Tunar emre.tunar&ca.com 2004-11
ENSTEAM Sp. z o.o. support&ensteam.com 2015-07-08
Frank Goenninger frank.goenninger&consequor.de 2010-02-22
Geoff Back geoff&demonlair.co.uk 2010-02-01
Guidewire Software, Inc info&guidewire.com 2014-02-06
Hans Schoone Hans.Schoone&nl.ibm.com 2010-10-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Zubov VESvault Corp jz&vesvault.com 2021-12-29
Jonathan Pollock jon&arcadiancomputers.com 2016-05-10
Luca Debiasi Guidewire Software, Inc ldebiasi&guidewire.com 2014-02-06
Micha Ben-Efraim benmi07&ca.com 2008-01-07
Micha Ben-Efraim micha&metalix.net 2011-01-31
Micha Ben-Efraim micha.ben-efraim&ca.com 2010-02-18
Micha Ben-Efraim micha&metalix.net 2012-11-27
Michael Scarito ms&mit.edu 2007-02
Michael Shearson mikes&softsys-inc.com
Mike Spitzer mjs&polyserve.com 2005-08
Paul Ignatius paul.ignatius&scentric.com 2006-03
Richard Foss r.foss&ru.ac.za 2011-02-10
Robert Wetzold robert.wetzold&fibotrader.com 2006-01
Stephen Gildea gildea&lcs.mit.edu
Sundar Srinivasan sundars&microsoft.com 2006-05
Tomasz Krakowiak ENSTEAM Sp. z o.o. tomasz.krakowiak&ensteam.com 2015-07-08
Venkata Krishna VenkataKrishna.Bezawada&ca.com 2010-02-24
VESvault Corp info&vesvault.com 2021-12-29
Victor Galis galis&satchmo.virtualprototypes.ca
Vinay Badami VinayB&microsoft.com 2006-05
gunner&ibeam.intel.com