Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xmpp-bosh 5280 tcp Bidirectional-streams Over Synchronous HTTP (BOSH) Peter Saint-Andre Peter Saint-Andre 2009-11-25
5280 udp Reserved
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
tmosms0 5580 tcp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
tmosms0 5580 udp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
v5ua 5675 tcp V5UA application port RFC 3807
v5ua 5675 udp V5UA application port RFC 3807
v5ua 5675 sctp V5UA application port RFC 3807
auriga-router 5680 tcp Auriga Router Service Vincent Gaudeul Vincent Gaudeul 2006-02
auriga-router 5680 udp Auriga Router Service Vincent Gaudeul Vincent Gaudeul 2006-02
vts-rpc 5780 tcp Visual Tag System RPC Graham Bloice Graham Bloice 2009-09-17
5780 udp Reserved
gue 6080 udp Generic UDP Encapsulation Tom Herbert Tom Herbert 2015-03-05 draft-herbert-gue-02
6080 tcp Reserved
6380-6381 Unassigned
sun-sr-http 6480 tcp Service Registry Default HTTP Domain Paul Sterk Paul Sterk 2006-03
sun-sr-http 6480 udp Service Registry Default HTTP Domain Paul Sterk Paul Sterk 2006-03
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
6680-6686 Unassigned
6792-6800 Unassigned
acnet 6801 tcp ACNET Control System Protocol Fermilab Rich Neswold 2007-02 2017-07-13
acnet 6801 udp ACNET Control System Protocol Fermilab Rich Neswold 2007-02 2017-07-13
6802-6816 Unassigned
6980 tcp Reserved
qolyester 6980 udp QoS-extended OLSR protocol Green Communications SAS Ignacy Gawedzki 2022-05-24
empowerid 7080 tcp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
empowerid 7080 udp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
7175-7180 Unassigned
itactionserver1 7280 tcp ITACTIONSERVER 1 Brian Taylor Brian Taylor
itactionserver1 7280 udp ITACTIONSERVER 1 Brian Taylor Brian Taylor
ms-do 7680 tcp Microsoft Delivery Optimization Peer-to-Peer Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
ms-do 7680 udp Microsoft Delivery Optimization Peer-to-Peer Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
7780 Unassigned
asr 7800 tcp Apple Software Restore Jim Kateley; Shantonu Sen Jim Kateley; Shantonu Sen 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
asr 7800 udp Apple Software Restore Jim Kateley; Shantonu Sen Jim Kateley; Shantonu Sen 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
ssp-client 7801 tcp Secure Server Protocol - client Rick Macchio Rick Macchio 2006-11
ssp-client 7801 udp Secure Server Protocol - client Rick Macchio Rick Macchio 2006-11
vns-tp 7802 udp Virtualized Network Services Tunnel Protocol Juniper Networks Bruno Rijsman 2013-02-01
7802 tcp Reserved
7803-7809 Unassigned
pss 7880 tcp Pearson Pearson Pearson 2008-01-17
pss 7880 udp Pearson Pearson Pearson 2008-01-17
quest-vista 7980 tcp Quest Vista Preston Bannister Preston Bannister
quest-vista 7980 udp Quest Vista Preston Bannister Preston Bannister
irdmi 8000 tcp iRDMI Gil Shafriri Gil Shafriri
irdmi 8000 udp iRDMI Gil Shafriri Gil Shafriri
vcom-tunnel 8001 tcp VCOM Tunnel Mark Lewandowski Mark Lewandowski Known Unauthorized Use on port 8001
vcom-tunnel 8001 udp VCOM Tunnel Mark Lewandowski Mark Lewandowski Known Unauthorized Use on port 8001
teradataordbms 8002 tcp Teradata ORDBMS Curt Ellmann Curt Ellmann
teradataordbms 8002 udp Teradata ORDBMS Curt Ellmann Curt Ellmann
mcreport 8003 tcp Mulberry Connect Reporting Service Dave Stoneham Dave Stoneham 2008-03-10
mcreport 8003 udp Mulberry Connect Reporting Service Dave Stoneham Dave Stoneham 2008-03-10
p2pevolvenet 8004 tcp Opensource Evolv Enterprise Platform P2P Network Node Connection Protocol Tris Puki Adrians Borsteins 2018-01-16
8004 udp Reserved
mxi 8005 tcp MXI Generation II for z/OS Rob Scott Rob Scott 2007-05
mxi 8005 udp MXI Generation II for z/OS Rob Scott Rob Scott 2007-05
wpl-analytics 8006 tcp World Programming analytics World Programming Limited Thomas Quarendon 2017-04-04
wpl-disc 8006 udp World Programming analytics discovery World Programming Limited Thomas Quarendon 2017-04-04
warppipe 8007 tcp I/O oriented cluster computing software MirrorWeb LTD Jonathan Kingsley 2017-07-19
warppipe 8007 udp I/O oriented cluster computing software MirrorWeb LTD Jonathan Kingsley 2017-07-19
http-alt 8008 tcp HTTP Alternate James Gettys James Gettys
http-alt 8008 udp HTTP Alternate James Gettys James Gettys
nvme-disc 8009 tcp NVMe over Fabrics Discovery Service NVM Express, Inc. Amber Huffman 2018-03-27
8009 udp Reserved
8010 Reserved 2018-01-09 yes
bier-echo 8011 udp The UDP destination port number for the IP/UDP encapsulated BIER Echo Reply message. IESG IETF Chair 2026-10-22 RFC-ietf-bier-ping-29
8011 tcp Reserved
8012-8014 Unassigned
cfg-cloud 8015 tcp Configuration Cloud Service admin_at_cfg_cloud Goksel Darcan 2019-01-09
8015 udp Reserved
ads-s 8016 tcp Beckhoff Automation Device Specification Beckhoff Automation GmbH & Co. KG Henning Mersch 2019-02-28
8016 udp Reserved
8017 tcp Reserved
cisco-cloudsec 8017 udp Cisco Cloudsec Dataplane Port Number Cisco Systems, Inc. Govind Sharma 2021-03-18
8018 Unassigned
qbdb 8019 tcp QB DB Dynamic Port Sridhar Krishnamurthy Sridhar Krishnamurthy 2008-02-15
qbdb 8019 udp QB DB Dynamic Port Sridhar Krishnamurthy Sridhar Krishnamurthy 2008-02-15
intu-ec-svcdisc 8020 tcp Intuit Entitlement Service and Discovery Daniel C. McGloin Daniel C. McGloin 2005-05
intu-ec-svcdisc 8020 udp Intuit Entitlement Service and Discovery Daniel C. McGloin Daniel C. McGloin 2005-05
intu-ec-client 8021 tcp Intuit Entitlement Client Daniel C. McGloin Daniel C. McGloin 2005-05
intu-ec-client 8021 udp Intuit Entitlement Client Daniel C. McGloin Daniel C. McGloin 2005-05
oa-system 8022 tcp oa-system Marie-France Dubreuil Marie-France Dubreuil
oa-system 8022 udp oa-system Marie-France Dubreuil Marie-France Dubreuil
arca-api 8023 tcp ARCATrust vault API ARCATrust SA Yacince Felk 2018-07-05
arca-api 8023 udp ARCATrust vault API ARCATrust SA Yacince Felk 2018-07-05
gaap 8024 udp GAAP Control Packets IESG IETF Chair 2026-11-06 RFC-ietf-pim-gaap-25
8024 tcp Reserved
ca-audit-da 8025 tcp CA Audit Distribution Agent Henning Smith Henning Smith 2006-07
ca-audit-da 8025 udp CA Audit Distribution Agent Henning Smith Henning Smith 2006-07
ca-audit-ds 8026 tcp CA Audit Distribution Server Henning Smith Henning Smith 2006-07
ca-audit-ds 8026 udp CA Audit Distribution Server Henning Smith Henning Smith 2006-07
papachi-p2p-srv 8027 tcp peer tracker and data relay service Pavel Csefalvay Pavel Csefalvay 2020-09-18
papachi-p2p-srv 8027 udp peer tracker and data relay service Pavel Csefalvay Pavel Csefalvay 2020-09-18
8028-8031 Unassigned
pro-ed 8032 tcp ProEd
pro-ed 8032 udp ProEd
mindprint 8033 tcp MindPrint Larry Tusoni Larry Tusoni
mindprint 8033 udp MindPrint Larry Tusoni Larry Tusoni
vantronix-mgmt 8034 tcp .vantronix Management Reyk Floeter Reyk Floeter 2008-02-27

Contact Information

Name Organization Contact URI Last Updated
admin_at_cfg_cloud gdarcan&gmail.com 2019-01-09
Adrians Borsteins evolv&protonmail.com 2018-01-16
Amber Huffman amber.huffman&intel.com 2018-03-27
Andreas Varga sid&parsec.org
ARCATrust SA info&arcatrust.io 2018-07-05
Beckhoff Automation GmbH & Co. KG legal&beckhoff.com 2019-02-28
Brian Taylor btaylor&imagetag.com
Bruno Rijsman Juniper Networks brijsman&juniper.net 2013-02-01
Cisco Systems, Inc. gosharma&cisco.com 2021-03-18
Curt Ellmann curt.ellmann&ncr.com
Daniel C. McGloin daniel_mcgloin&intuit.com 2005-05
Dave Stoneham dave&mulberry-consultants.co.uk 2008-03-10
Ezinne Oji ezinne.oji&t-mobile.com 2006-06
Fermilab neswold&fnal.gov 2017-07-13
Gil Shafriri shafriri&ilccm1.iil.intel.com
Goksel Darcan gdarcan&gmail.com 2019-01-09
Govind Sharma Cisco Systems, Inc. gosharma&cisco.com 2021-03-18
Graham Bloice graham.bloice&trihedral.com 2009-09-17
Green Communications SAS contact&green-communications.fr 2022-05-24
Henning Mersch support&beckhoff.com 2019-02-28
Henning Smith henning.smith&ca.com 2006-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ignacy Gawedzki Green Communications SAS ignacy.gawedzki&green-communications.fr 2022-05-24
James Gettys jg&w3.org
Jim Kateley asr-dev&group.apple.com 2006-01
Jonathan Kingsley jon&mirrorweb.com 2017-07-19
Juniper Networks brijsman&juniper.net 2013-02-01
Larry Tusoni larry&goldrush.com
Marie-France Dubreuil Marie-France.Dubreuil&evidian.com 2002-11
Mark Lewandowski mlewan0&us.ibm.com
Matthew Whited matt&thedotnetfactory.com 2008-01-16
Microsoft Corporation naengler&microsoft.com 2022-05-03
MirrorWeb LTD jon&mirrorweb.com 2017-07-19
Narkis Engler Microsoft Corporation naengler&microsoft.com 2022-05-03
NVM Express, Inc. admin&nvmexpress.org 2018-03-27
Paul Sterk paul.sterk&sun.com 2006-03
Pavel Csefalvay csefalvay&gmail.com 2020-09-18
Pearson chad.smith&pearson.com 2008-01-17
Peter Saint-Andre stpeter&stpeter.im 2009-11-25
Preston Bannister pbannister&quests.com
Reyk Floeter reyk&vantronix.net 2008-02-27
Rich Neswold neswold&fnal.gov 2007-02
Rick Macchio rmacchio&juniper.net 2006-11
Rob Scott rscott&rs.com 2007-05
Shantonu Sen ssen&apple.com
Sridhar Krishnamurthy Sridhar_Krishnamurthy&intuit.com 2008-02-15
Thomas Quarendon World Programming Limited tom.quarendon&worldprogramming.com 2017-04-04
Tom Herbert tom&herbertland.com 2017-05-19
Tris Puki evolv&protonmail.com 2018-01-16
Vincent Gaudeul technique&auriga.fr 2006-02
World Programming Limited support&worldprogramming.com 2017-04-04
Yacince Felk yacine&arcatrust.io 2018-07-05