Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 8283-8291 | Unassigned | ||||||||||
| tmi | 8300 | tcp | Transport Management Interface | Steve Kneizys | Steve Kneizys | 2006-11 | |||||
| tmi | 8300 | udp | Transport Management Interface | Steve Kneizys | Steve Kneizys | 2006-11 | |||||
| amberon | 8301 | tcp | Amberon PPC/PPS | Ronald Snyder | Ronald Snyder | 2006-03 | |||||
| amberon | 8301 | udp | Amberon PPC/PPS | Ronald Snyder | Ronald Snyder | 2006-03 | |||||
| 8302-8312 | Unassigned | ||||||||||
| hub-open-net | 8313 | tcp | Hub Open Network | Grexie | Tim Behrsin | 2012-06-13 | Defined TXT keys: _hub._tcp.host.example.com | ||||
| 8313 | udp | Reserved | |||||||||
| 8314-8319 | Unassigned | ||||||||||
| tnp-discover | 8320 | tcp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| tnp-discover | 8320 | udp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| tnp | 8321 | tcp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| tnp | 8321 | udp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| garmin-marine | 8322 | tcp | Garmin Marine | Garmin International, Inc." | Nathan Karstens | 2015-07-23 | |||||
| garmin-marine | 8322 | udp | Garmin Marine | Garmin International, Inc." | Nathan Karstens | 2015-07-23 | |||||
| 8323-8350 | Unassigned | ||||||||||
| server-find | 8351 | tcp | Server Find | Chris Brown | Chris Brown | ||||||
| server-find | 8351 | udp | Server Find | Chris Brown | Chris Brown | ||||||
| 8352-8375 | Unassigned | ||||||||||
| cruise-enum | 8376 | tcp | Cruise ENUM | Steve Husak | Steve Husak | ||||||
| cruise-enum | 8376 | udp | Cruise ENUM | Steve Husak | Steve Husak | ||||||
| cruise-swroute | 8377 | tcp | Cruise SWROUTE | Steve Husak | Steve Husak | ||||||
| cruise-swroute | 8377 | udp | Cruise SWROUTE | Steve Husak | Steve Husak | ||||||
| cruise-config | 8378 | tcp | Cruise CONFIG | Steve Husak | Steve Husak | ||||||
| cruise-config | 8378 | udp | Cruise CONFIG | Steve Husak | Steve Husak | ||||||
| cruise-diags | 8379 | tcp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| cruise-diags | 8379 | udp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| cruise-update | 8380 | tcp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| cruise-update | 8380 | udp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| 8381-8382 | Unassigned | ||||||||||
| m2mservices | 8383 | tcp | M2m Services | Carlos Arteaga | Carlos Arteaga | 2004-11 | |||||
| m2mservices | 8383 | udp | M2m Services | Carlos Arteaga | Carlos Arteaga | 2004-11 | |||||
| marathontp | 8384 | udp | Marathon Transport Protocol | Inertia Systemes | Jasmin Blouin | 2015-06-11 | |||||
| 8384 | tcp | Reserved | |||||||||
| 8385-8399 | Unassigned | ||||||||||
| secure-mqtt | 8883 | tcp | Secure MQTT | OASIS | Robin Cover | 2008-02-27 | 2015-03-06 | ||||
| secure-mqtt | 8883 | udp | Secure MQTT | OASIS | Robin Cover | 2008-02-27 | 2015-03-06 | ||||
| emc-pp-mgmtsvc | 9083 | tcp | EMC PowerPath Mgmt Service | Jim Perreault | Jim Perreault | 2010-06-04 | |||||
| 9083 | udp | Reserved | |||||||||
| sirius-agent | 9183 | tcp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| sirius-agent | 9183 | udp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| callwaveiam | 9283 | tcp | CallWaveIAM | Colin Kelley | Colin Kelley | ||||||
| callwaveiam | 9283 | udp | CallWaveIAM | Colin Kelley | Colin Kelley | ||||||
| nmea-0183 | 10110 | tcp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| nmea-0183 | 10110 | udp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| vopied | 13783 | tcp | VOPIED Protocol | Jeff Holmbeck | Jeff Holmbeck | ||||||
| vopied | 13783 | udp | VOPIED Protocol | Jeff Holmbeck | Jeff Holmbeck | ||||||
| 13824-13831 | Unassigned | ||||||||||
| a-trust-rpc | 13832 | tcp | Certificate Management and Issuing | A-Trust GmbH | Patrick Hagelkruys | 2023-06-05 | |||||
| 13832 | udp | Reserved | |||||||||
| 13833-13893 | Unassigned | ||||||||||
| 16369-16383 | Unassigned | ||||||||||
| 17011-17183 | Unassigned | ||||||||||
| opsec-sam | 18183 | tcp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| opsec-sam | 18183 | udp | OPSEC SAM | Alon Kantor | Alon Kantor | ||||||
| keysrvr | 19283 | tcp | Key Server for SASSAFRAS | Mark Valence | Mark Valence | ||||||
| keysrvr | 19283 | udp | Key Server for SASSAFRAS | Mark Valence | Mark Valence | ||||||
| 27783-27875 | Unassigned | ||||||||||
| 30401-30831 | Unassigned | ||||||||||
| samsung-disc | 30832 | udp | Samsung Convergence Discovery Protocol | Samsung | Young Ki Kim | 2013-05-29 | |||||
| 30832 | tcp | Reserved | |||||||||
| 30833-30938 | Unassigned | ||||||||||
| apm-link | 32483 | tcp | Access Point Manager Link | Tony Diodato | Tony Diodato | 2005-08 | |||||
| apm-link | 32483 | udp | Access Point Manager Link | Tony Diodato | Tony Diodato | 2005-08 | |||||
| gdrive-sync | 37483 | tcp | Google Drive Sync | Google Inc. | Jason Schiller | 2013-02-01 | 2015-07-31 | ||||
| 37483 | udp | Reserved | |||||||||
| brski-reg-cmp | tcp | Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 | IESG | IETF Chair | 2024-09-23 | RFC 9733 | Defined TXT keys: None | ||||
| slpda | tcp | Remote Service Discovery in the Service Location | RFC 3832 | ||||||||
| slpda | udp | Remote Service Discovery in the Service Location | RFC 3832 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| A-Trust GmbH | technik&a-trust.at | 2023-08-03 | |
| Alon Kantor | alonk&checkpoint.com | ||
| Aly Orady | Atto Devices Inc. | aly.orady&attodevices.com | 2007-08-07 |
| Carlos Arteaga | carteaga&adelphia.net | 2004-11 | |
| Chris Brown | chrisb&chancery.com | ||
| Colin Kelley | cdk&callwave.com | ||
| Garmin International, Inc." | nettel&garmin.com | 2015-07-23 | |
| Google Inc. | numbers&google.com | 2015-07-31 | |
| Grexie | webmaster&grexie.com | 2012-06-15 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Inertia Systemes | jasmin.blouin&inertiasystemes.com | 2015-06-11 | |
| Jasmin Blouin | Inertia Systemes | jasmin.blouin&inertiasystemes.com | 2015-06-11 |
| Jason Schiller | Google Inc. | jschiller&google.com | 2015-07-31 |
| Jason Van der Schyff | jason&sirius.computer | 2026-03-09 | |
| Jeff Holmbeck | Jeff.Holmbeck&veritas.com | ||
| Jim Perreault | jim.perreault&emc.com | 2010-06-04 | |
| Mark Valence | kurash&sassafras.com | ||
| Meindert Sprang | ms&customware.nl | 2009-02-18 | |
| Nathan Karstens | Garmin International, Inc. | nettel&garmin.com | 2015-07-23 |
| OASIS | robin&oasis-open.org | 2015-02-10 | |
| Patrick Hagelkruys | hagelkruys&a-trust.at | 2023-06-05 | |
| Robin Cover | OASIS KMIP Technical Committee | robin&oasis-open.org | 2011-07-25 |
| Ronald Snyder | pugaroni&sssnet.com | 2006-03 | |
| Samsung | young.ki.kim&samsung.com | 2013-05-29 | |
| Sirius Computer, Inc | jason&sirius.computer | 2026-03-09 | |
| Steve Husak | portmaster&cruisetech.com | ||
| Steve Kneizys | skneizys&erpdata.com | 2006-11 | |
| Tim Behrsin | tim&behrsin.com | 2012-06-15 | |
| Tony Diodato | tdiodato&cyprx.com | 2005-08 | |
| Young Ki Kim | Samsung | young.ki.kim&samsung.com | 2013-05-29 |