Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-05

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
6584-6587 Unassigned
clever-ctrace 6687 tcp CleverView for cTrace Message Service David Cheng David Cheng 2010-02-01
6687 udp Reserved
smc-admin 6787 tcp Sun Web Console Admin Bill Edwards Bill Edwards 2005-08
smc-admin 6787 udp Sun Web Console Admin Bill Edwards Bill Edwards 2005-08
6869-6887 Unassigned
7081-7087 Unassigned
7576-7587 Unassigned
bolt 7687 tcp Bolt database connection Neo Technology, Inc Julian Simpson 2016-09-29
7687 udp Reserved
popup-reminders 7787 tcp Popup Reminders Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7787
popup-reminders 7787 udp Popup Reminders Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7787
rbt-smc 7870 tcp Riverbed Steelhead Mobile Service Gabriel Levy Gabriel Levy 2008-08-29
7870 udp Reserved
mdm 7871 tcp Mobile Device Management Dan Harkins Dan Harkins 2011-08-15
7871 udp Reserved
7872 tcp Reserved
mipv6tls 7872 udp TLS-based Mobile IPv6 Security IESG IETF Chair 2012-04-12 RFC 6618
7873-7877 Unassigned
owms 7878 tcp Opswise Message Service Stonebranch, Inc. Nathan Hammond 2013-06-25
7878 udp Reserved
7879 Unassigned
ubroker 7887 tcp Universal Broker Nathan Hammond Nathan Hammond 2005-10
ubroker 7887 udp Universal Broker Nathan Hammond Nathan Hammond 2005-10
simplifymedia 8087 tcp Simplify Media SPP Protocol Emmanuel Saint-Loubert Emmanuel Saint-Loubert 2008-08-08
simplifymedia 8087 udp Simplify Media SPP Protocol Emmanuel Saint-Loubert Emmanuel Saint-Loubert 2008-08-08
8687 Unassigned
8700-8709 Unassigned
semi-grpc 8710 tcp gRPC for SEMI Standards implementations SEMI Albert Fuchigami 2020-01-10
8710 udp Reserved
nvc 8711 tcp Nuance Voice Control Nuance Communications Diego Negre 2012-10-05
8711 udp Reserved
8712-8731 Unassigned
8732 tcp Reserved
dtp-net 8732 udp DASGIP Net Services Dr. Matthias Arnold Dr. Matthias Arnold 2009-03-23
ibus 8733 tcp iBus Silvano Maffeis Silvano Maffeis
ibus 8733 udp iBus Silvano Maffeis Silvano Maffeis
8734-8749 Unassigned
dey-keyneg 8750 tcp DEY Storage Key Negotiation DEY Storage Systems, Inc. Garrett D'Amore 2013-03-01
8750 udp Reserved
8751-8762 Unassigned
mc-appserver 8763 tcp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
mc-appserver 8763 udp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
openqueue 8764 tcp OPENQUEUE Matt Jensen Matt Jensen
openqueue 8764 udp OPENQUEUE Matt Jensen Matt Jensen
ultraseek-http 8765 tcp Ultraseek HTTP Walter Underwood Walter Underwood
ultraseek-http 8765 udp Ultraseek HTTP Walter Underwood Walter Underwood
amcs 8766 tcp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
amcs 8766 udp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
core-of-source 8767 tcp Online mobile multiplayer game Alt Solve Sdn Bhd Almaz Hong 2019-07-24
8767 udp Reserved
sandpolis 8768 tcp Sandpolis Server Tyler Cook Tyler Cook 2019-11-22
8768 udp Reserved
oktaauthenticat 8769 tcp Okta MultiPlatform Access Mgmt for Cloud Svcs Okta Inc Tom Belote 2019-12-19
8769 udp Reserved
dpap 8770 tcp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
dpap 8770 udp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
8771-8777 Unassigned
uec 8778 tcp Stonebranch Universal Enterprise Controller Stonebranch, Inc. Nathan Hammond 2013-06-25
8778 udp Reserved
8779-8785 Unassigned
msgclnt 8786 tcp Message Client Michael O'Brien Michael O'Brien 2003-03
msgclnt 8786 udp Message Client Michael O'Brien Michael O'Brien 2003-03
msgsrvr 8787 tcp Message Server Michael O'Brien Michael O'Brien 2003-03
msgsrvr 8787 udp Message Server Michael O'Brien Michael O'Brien 2003-03
8788-8792 Unassigned
acd-pm 8793 tcp Accedian Performance Measurement Marco Mascitto Marco Mascitto
acd-pm 8793 udp Accedian Performance Measurement Marco Mascitto Marco Mascitto
8794-8799 Unassigned
8810-8872 Unassigned
dxspider 8873 tcp dxspider linking protocol Dirk Koopman Dirk Koopman 2005-08
dxspider 8873 udp dxspider linking protocol Dirk Koopman Dirk Koopman 2005-08
8874-8879 Unassigned
8884-8887 Unassigned
classic 9087 tcp Classic Data Server Paul Cadarette Paul Cadarette 2007-01
classic 9087 udp Classic Data Server Paul Cadarette Paul Cadarette 2007-01
cumulus 9287 tcp Cumulus Thomas Schleu Thomas Schleu
cumulus 9287 udp Cumulus Thomas Schleu Thomas Schleu
d2dconfig 9387 tcp D2D Configuration Service Pete Camble Pete Camble 2008-12-24
9387 udp Reserved
9803-9874 Unassigned
sapv1 9875 tcp Session Announcement v1 RFC 2974
sapv1 9875 udp Session Announcement v1 RFC 2974
sd 9876 tcp Session Director Van Jacobson Van Jacobson
x510 9877 tcp The X.510 wrapper protocol ITU/TSB (ITU-T Study Group 17) Erik Andersen 2019-09-30 ITU-T X.510 / ISO/IEC 9584-11
9877 udp Reserved
kca-service 9878 udp The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 IESG IETF Chair 2012-07-12 RFC 6717 Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements.
9878 tcp Reserved
9879-9887 Unassigned
dsm-scm-target 9987 tcp DSM/SCM Target Interface Mike Dyslin Mike Dyslin 2006-08
dsm-scm-target 9987 udp DSM/SCM Target Interface Mike Dyslin Mike Dyslin 2006-08
10262-10287 Unassigned
10861-10879 Unassigned
11797-11875 Unassigned
xoraya 11876 tcp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
xoraya 11876 udp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
11877 tcp Reserved
x2e-disc 11877 udp X2E service discovery protocol Hannes K√§lber Hannes K√§lber 2010-09-13
11878-11966 Unassigned
13787-13817 Unassigned
opsec-ela 18187 tcp OPSEC ELA Alon Kantor Alon Kantor

Contact Information

Name Organization Contact URI Last Updated
Albert Fuchigami albert.fuchigami&peergroup.com 2020-01-10
Almaz Hong almaz.hong&altsolve.com 2019-07-24
Alon Kantor alonk&checkpoint.com
Alt Solve Sdn Bhd support&altsolve.com 2019-07-24
Amandeep Jawa dpap&apple.com 2004-11
Bill Edwards bill.edwards&sun.com 2005-08
Dan Harkins dharkins&lounge.org 2011-08-15
David Cheng davec&aesclever.com 2010-02-01
DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Diego Negre Nuance Communications Diego.Negre&nuance.com 2012-10-05
Dirk Koopman djk&tobit.co.uk 2005-08
Dr. Matthias Arnold m.arnold&dasgip.de 2009-03-23
Emmanuel Saint-Loubert emmanuel&simplifymedia.com 2008-08-08
Erik Andersen era&x500.eu 2019-08-13
Gabriel Levy glevy&riverbed.com 2008-08-29
Garrett D'Amore DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Hannes K√§lber hannes.kaelber&x2e.de 2010-09-13
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU/TSB (ITU-T Study Group 17) tsbsg17&itu.int 2019-09-30
Julian Simpson Neo Technology, Inc julian.simpson&neotechnology.com 2016-09-29
Keysight Technologies, Inc. iana.contact&keysight.com 2016-09-12
Marco Mascitto mmascitto&accedian.com 2011-06-28
Matt Jensen mattj&newsblip.com
Michael O'Brien mobrien03&gmail.com 2020-05-11
Mike Dyslin mike.dyslin&hp.com 2006-08
Nathan Hammond nathan.hammond&stonebranch.com 2005-10
Nathan Hammond Stonebranch, Inc. nathan.hammond&stonebranch.com 2013-06-25
Neo Technology, Inc admins&neotechnology.com 2016-09-29
Nuance Communications NOD_SolutionsArchitecture&nuance.com 2012-10-05
Okta Inc tbelote&okta.com 2019-12-19
Paul Cadarette pcadaret&us.ibm.com 2007-01
Pete Camble pete.camble&hpe.com 2023-04-05
Robert Harvey robert&officetoolspro.com 2006-01
Romeo Kasanwidjojo romeo&microcomgroup.com
SEMI jamano&semi.org 2020-01-10
Silvano Maffeis maffeis&softwired.ch
Stonebranch, Inc. nathan.hammond&stonebranch.com 2013-06-25
Thomas Schleu tschleu&canto.de
Tom Belote tbelote&okta.com 2019-12-19
Tom Fay iana.contact&keysight.com 2016-09-12
Tyler Cook tcc&sandpolis.com 2019-11-22
Van Jacobson van&ee.lbl.gov
Walter Underwood wunder&infoseek.com