Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
8089 Unassigned
8185-8189 Unassigned
8689-8698 Unassigned
ddi-tcp-2 8889 tcp Desktop Data TCP 1 [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8889
ddi-udp-2 8889 udp NewsEDGE server broadcast [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8889
ddi-tcp-3 8890 tcp Desktop Data TCP 2 [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8890
ddi-udp-3 8890 udp NewsEDGE client broadcast [Fred_Yao] [Fred_Yao] Known Unauthorized Use on port 8890
ddi-tcp-4 8891 tcp Desktop Data TCP 3: NESS application [Fred_Yao] [Fred_Yao]
ddi-udp-4 8891 udp Desktop Data UDP 3: NESS application [Fred_Yao] [Fred_Yao]
ddi-tcp-5 8892 tcp Desktop Data TCP 4: FARM product [Fred_Yao] [Fred_Yao]
ddi-udp-5 8892 udp Desktop Data UDP 4: FARM product [Fred_Yao] [Fred_Yao]
ddi-tcp-6 8893 tcp Desktop Data TCP 5: NewsEDGE/Web application [Fred_Yao] [Fred_Yao]
ddi-udp-6 8893 udp Desktop Data UDP 5: NewsEDGE/Web application [Fred_Yao] [Fred_Yao]
ddi-tcp-7 8894 tcp Desktop Data TCP 6: COAL application [Fred_Yao] [Fred_Yao]
ddi-udp-7 8894 udp Desktop Data UDP 6: COAL application [Fred_Yao] [Fred_Yao]
8895-8898 Unassigned
ospf-lite 8899 tcp ospf-lite [Matthew_Thomas] [Matthew_Thomas] 2008-01-07
ospf-lite 8899 udp ospf-lite [Matthew_Thomas] [Matthew_Thomas] 2008-01-07
jmb-cds1 8900 tcp JMB-CDS 1 [Curtis_Bray] [Curtis_Bray]
jmb-cds1 8900 udp JMB-CDS 1 [Curtis_Bray] [Curtis_Bray]
jmb-cds2 8901 tcp JMB-CDS 2 [Curtis_Bray] [Curtis_Bray]
jmb-cds2 8901 udp JMB-CDS 2 [Curtis_Bray] [Curtis_Bray]
8902-8907 Unassigned
dpp 8908 tcp WFA Device Provisioning Protocol [Wi-Fi_Alliance_4] [Dr_Jun_Tian] 2020-10-19
8908 udp Reserved
8909 Unassigned
manyone-http 8910 tcp manyone-http [Matt_King] [Matt_King] 2002-04
manyone-http 8910 udp manyone-http [Matt_King] [Matt_King] 2002-04
manyone-xml 8911 tcp manyone-xml [Matt_King] [Matt_King] 2002-04
manyone-xml 8911 udp manyone-xml [Matt_King] [Matt_King] 2002-04
wcbackup 8912 tcp Windows Client Backup [Jim_Lyon] [Jim_Lyon] 2005-11
wcbackup 8912 udp Windows Client Backup [Jim_Lyon] [Jim_Lyon] 2005-11
dragonfly 8913 tcp Dragonfly System Service [Paul_Hodara] [Paul_Hodara] 2005-11
dragonfly 8913 udp Dragonfly System Service [Paul_Hodara] [Paul_Hodara] 2005-11
8914-8936 Unassigned
twds 8937 tcp Transaction Warehouse Data Service [Lance_M_Steenson] [Lance_M_Steenson] 2009-09-18
8937 udp Reserved
8938-8952 Unassigned
ub-dns-control 8953 tcp unbound dns nameserver control [NLnet_Labs_Support] [NLnet_Labs_Support] 2011-05-10 2011-07-11
8953 udp Reserved
cumulus-admin 8954 tcp Cumulus Admin Port [Thomas_Schleu] [Thomas_Schleu]
cumulus-admin 8954 udp Cumulus Admin Port [Thomas_Schleu] [Thomas_Schleu]
8955-8979 Unassigned
nod-provider 8980 tcp Network of Devices Provider [David_Muller] [David_Muller] 2015-02-22
nod-provider 8980 udp Network of Devices Provider [David_Muller] [David_Muller] 2015-02-22
nod-client 8981 udp Network of Devices Client [David_Muller] [David_Muller] 2015-02-22
8981 tcp Reserved
8982-8988 Unassigned
sunwebadmins 8989 tcp Sun Web Server SSL Admin Service [Jyri_J_Virkki] [Jyri_J_Virkki] 2005-12
sunwebadmins 8989 udp Sun Web Server SSL Admin Service [Jyri_J_Virkki] [Jyri_J_Virkki] 2005-12
http-wmap 8990 tcp webmail HTTP service [Chris_Newman] [Chris_Newman] 2007-12-03
http-wmap 8990 udp webmail HTTP service [Chris_Newman] [Chris_Newman] 2007-12-03
https-wmap 8991 tcp webmail HTTPS service [Chris_Newman] [Chris_Newman] 2007-12-03
https-wmap 8991 udp webmail HTTPS service [Chris_Newman] [Chris_Newman] 2007-12-03
8992-8996 Unassigned
oracle-ms-ens 8997 tcp Oracle Messaging Server Event Notification Service [Oracle_6] [Hubert_Vijay_Arokiasamy] 2014-10-28
8997 udp Reserved
canto-roboflow 8998 tcp Canto RoboFlow Control [Canto] [Thomas_Schleu_2] 2014-02-26
8998 udp Reserved
bctp 8999 tcp Brodos Crypto Trade Protocol [Alexander_Sahler] [Alexander_Sahler] 2002-02
bctp 8999 udp Brodos Crypto Trade Protocol [Alexander_Sahler] [Alexander_Sahler] 2002-02
sqlexec-ssl 9089 tcp IBM Informix SQL Interface - Encrypted [Jonathan_Leffler] [Jonathan_Leffler] 2005-12
sqlexec-ssl 9089 udp IBM Informix SQL Interface - Encrypted [Jonathan_Leffler] [Jonathan_Leffler] 2005-12
adws 9389 tcp Active Directory Web Services [Nitin_Gupta] [Nitin_Gupta] 2008-12-24
9389 udp Reserved
gt-proxy 9889 tcp Port for Cable network related data proxy or repeater [Dawei_Qi] [Dawei_Qi] 2010-07-07
gt-proxy 9889 udp Port for Cable network related data proxy or repeater [Dawei_Qi] [Dawei_Qi] 2010-07-07
9890-9897 Unassigned
monkeycom 9898 tcp MonkeyCom [Yuji_Kuwabara] [Yuji_Kuwabara]
monkeycom 9898 udp MonkeyCom [Yuji_Kuwabara] [Yuji_Kuwabara]
9899 tcp Reserved 2013-04-10
sctp-tunneling 9899 udp SCTP TUNNELING [IESG] [IETF_Chair] 2013-04-10 [RFC 6951]
9989-9989 Unassigned
10289-10320 Unassigned
10934-10989 Unassigned
asgcypresstcps 11489 tcp ASG Cypress Secure Only [David_Luxford] [David_Luxford] 2010-07-01
11489 udp Reserved
13833-13893 Unassigned
ucontrol 13894 tcp Ultimate Control communication protocol [NEGU_Soft] [borja_lopez_urkidi] 2012-09-10
ucontrol 13894 udp Ultimate Control communication protocol [NEGU_Soft] [borja_lopez_urkidi] 2012-09-10
13895-13928 Unassigned
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform [Broadcom] [Thomas_Sakowski] 2015-06-02 2023-03-29
16789 udp Reserved
16790-16899 Unassigned
18889-18999 Unassigned
19789 Unassigned
21555-21589 Unassigned
25794-25899 Unassigned
exonet 26489 tcp EXOnet [Urban_Fosseus] [Urban_Fosseus] 2008-12-24
exonet 26489 udp EXOnet [Urban_Fosseus] [Urban_Fosseus] 2008-12-24
bosswave 28589 tcp Building operating system services wide area verified exchange [University_of_California_Berkeley] [Michael_Andersen] 2016-06-13
28589 udp Reserved
28590-28999 Unassigned
32812-32895 Unassigned
idmgratm 32896 tcp Attachmate ID Manager [George_Gianelos_2] [George_Gianelos_2] 2003-03
idmgratm 32896 udp Attachmate ID Manager [George_Gianelos_2] [George_Gianelos_2] 2003-03
32897-32999 Unassigned
33657-33889 Unassigned
digilent-adept 33890 tcp Adept IP protocol [Digilent_Inc] [Michael_T_Alexander] 2020-06-25
33890 udp Reserved
33891-34248 Unassigned

Contact Information

ID Name Organization Contact URI Last Updated
[Alexander_Sahler] Alexander Sahler mailto:alexander.sahler&brodos.de 2002-02
[borja_lopez_urkidi] borja lopez urkidi NEGU Soft mailto:lopezurkidi&gmail.com 2012-09-10
[Broadcom] Broadcom mailto:thomas.sakowski&broadcom.com 2023-03-29
[Canto] Canto mailto:tschleu&canto.com 2014-02-26
[Chris_Newman] Chris Newman mailto:chris.newman&oracle.com 2017-01-26
[Curtis_Bray] Curtis Bray mailto:CurtisB&creativedesign.com
[David_Luxford] David Luxford mailto:david.luxford&asg.com 2010-07-01
[David_Muller] David Müller mailto:david.muller.cz&gmail.com 2015-02-22
[Dawei_Qi] Dawei Qi mailto:dqi&galaxytelecomms.com 2010-07-07
[Digilent_Inc] Digilent Inc. mailto:software&digilent.com 2020-06-25
[Dr_Jun_Tian] Dr. Jun Tian mailto:jtian&wi-fi.org 2020-10-19
[Fred_Yao] Fred Yao mailto:Fred_Yao&ddigate2.desktopdata.com
[George_Gianelos_2] George Gianelos mailto:GeorgeGi&attachmate.com 2003-03
[Hubert_Vijay_Arokiasamy] Hubert Vijay Arokiasamy Oracle Corp. mailto:hubert.vijay.arokiasamy&oracle.com 2014-10-28
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jim_Lyon] Jim Lyon mailto:JimLyon&microsoft.com 2005-11
[Jonathan_Leffler] Jonathan Leffler mailto:jleffler&us.ibm.com 2005-12
[Jyri_J_Virkki] Jyri J. Virkki mailto:jyri.virkki&sun.com 2005-12
[Lance_M_Steenson] Lance M. Steenson mailto:lance&transactionwarehouse.net 2009-09-18
[Matt_King] Matt King mailto:m&manyone.net 2002-04
[Matthew_Thomas] Matthew Thomas mailto:mrthom&essex.ac.uk 2008-01-07
[Michael_Andersen] Michael Andersen mailto:michael&steelcode.com 2016-06-13
[Michael_T_Alexander] Michael T. Alexander mailto:malexander&digilentinc.com 2020-06-25
[NLnet_Labs_Support] NLnet Labs Support NLnet Labs mailto:support&nlnetlabs.nl 2011-07-11
[NEGU_Soft] NEGU Soft mailto:info&negusoft.com 2012-09-10
[Nitin_Gupta] Nitin Gupta mailto:ngupt&microsoft.com 2008-12-24
[Oracle_6] Oracle Corp. mailto:hubert.vijay.arokiasamy&oracle.com 2014-10-28
[Paul_Hodara] Paul Hodara mailto:phodara&netwave.com 2005-11
[Thomas_Sakowski] Thomas Sakowski Broadcom mailto:thomas.sakowski&broadcom.com 2023-03-29
[Thomas_Schleu] Thomas Schleu mailto:tschleu&canto.de
[Thomas_Schleu_2] Thomas Schleu Canto mailto:tschleu&canto.com 2014-02-26
[University_of_California_Berkeley] University of California, Berkeley mailto:m.andersen&cs.berkeley.edu 2016-06-13
[Urban_Fosseus] Urban Fosseus mailto:urban.fosseus&regin.se 2008-12-24
[Wi-Fi_Alliance_4] Wi-Fi Alliance mailto:technical&wi-fi.org 2020-10-19
[Yuji_Kuwabara] Yuji Kuwabara mailto:HHG01200&niftyserve.or.jp