Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| iso-ill | 499 | udp | ISO ILL Protocol | Mark H. Needleman | Mark H. Needleman | ||||||
| snare | 509 | tcp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| snare | 509 | udp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| utime | 519 | tcp | unixtime | ||||||||
| utime | 519 | udp | unixtime | ||||||||
| irc-serv | 529 | tcp | IRC-SERV | Brian Tackett | Brian Tackett | ||||||
| irc-serv | 529 | udp | IRC-SERV | Brian Tackett | Brian Tackett | ||||||
| apertus-ldp | 539 | tcp | Apertus Technologies Load Determination | ||||||||
| apertus-ldp | 539 | udp | Apertus Technologies Load Determination | ||||||||
| dhcpv6-client | 546 | udp | DHCPv6 Client | IESG | IETF Chair | 2018-05-21 | RFC 9915 | ||||
| dhcpv6-server | 547 | udp | DHCPv6 Server | IESG | IETF Chair | 2018-05-21 | RFC 9915 | ||||
| idfp | 549 | tcp | IDFP | Ramana Kovi | Ramana Kovi | ||||||
| idfp | 549 | udp | IDFP | Ramana Kovi | Ramana Kovi | ||||||
| cybercash | 551 | tcp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| cybercash | 551 | udp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| teedtap | 559 | tcp | TEEDTAP | Charlie Limoges | Charlie Limoges | ||||||
| teedtap | 559 | udp | TEEDTAP | Charlie Limoges | Charlie Limoges | ||||||
| 9pfs | 564 | tcp | plan 9 file service | ||||||||
| 9pfs | 564 | udp | plan 9 file service | ||||||||
| ms-rome | 569 | tcp | microsoft rome | Rudolph Balaz | Rudolph Balaz | ||||||
| ms-rome | 569 | udp | microsoft rome | Rudolph Balaz | Rudolph Balaz | ||||||
| decbsrv | 579 | tcp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| decbsrv | 579 | udp | decbsrv | Rudi Martin | Rudi Martin | ||||||
| 585 | De-registered | 2006-04-25 | Use of 585 is not recommended, use 993 instead | ||||||||
| submission | 587 | tcp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| submission | 587 | udp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| eyelink | 589 | tcp | EyeLink | Dave Stampe | Dave Stampe | ||||||
| eyelink | 589 | udp | EyeLink | Dave Stampe | Dave Stampe | ||||||
| tns-cml | 590 | tcp | TNS CML | Jerome Albin | Jerome Albin | ||||||
| tns-cml | 590 | udp | TNS CML | Jerome Albin | Jerome Albin | ||||||
| http-alt | 591 | tcp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| http-alt | 591 | udp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| eudora-set | 592 | tcp | Eudora Set | Randall Gellens | Randall Gellens | ||||||
| eudora-set | 592 | udp | Eudora Set | Randall Gellens | Randall Gellens | ||||||
| http-rpc-epmap | 593 | tcp | HTTP RPC Ep Map | Edward Reus | Edward Reus | ||||||
| http-rpc-epmap | 593 | udp | HTTP RPC Ep Map | Edward Reus | Edward Reus | ||||||
| tpip | 594 | tcp | TPIP | Brad Spear | Brad Spear | ||||||
| tpip | 594 | udp | TPIP | Brad Spear | Brad Spear | ||||||
| cab-protocol | 595 | tcp | CAB Protocol | Winston Hetherington | Winston Hetherington | ||||||
| cab-protocol | 595 | udp | CAB Protocol | Winston Hetherington | Winston Hetherington | ||||||
| smsd | 596 | tcp | SMSD | Wayne Barlow | Wayne Barlow | ||||||
| smsd | 596 | udp | SMSD | Wayne Barlow | Wayne Barlow | ||||||
| ptcnameservice | 597 | tcp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| ptcnameservice | 597 | udp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| sco-websrvrmg3 | 598 | tcp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| sco-websrvrmg3 | 598 | udp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| acp | 599 | tcp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| acp | 599 | udp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | RFC 3195 | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | RFC 3195 | |||||||
| xmlrpc-beep | 602 | tcp | XML-RPC over BEEP | RFC 3529 | |||||||
| xmlrpc-beep | 602 | udp | XML-RPC over BEEP | RFC 3529 | |||||||
| npmp-trap | 609 | tcp | npmp-trap | ||||||||
| npmp-trap | 609 | udp | npmp-trap | ||||||||
| compaq-evm | 619 | tcp | Compaq EVM | Jem Treadwell | Jem Treadwell | ||||||
| compaq-evm | 619 | udp | Compaq EVM | Jem Treadwell | Jem Treadwell | ||||||
| 3com-amp3 | 629 | tcp | 3Com AMP3 | Prakash Banthia | Prakash Banthia | ||||||
| 3com-amp3 | 629 | udp | 3Com AMP3 | Prakash Banthia | Prakash Banthia | ||||||
| msdp | 639 | tcp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| msdp | 639 | udp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| cadview-3d | 649 | tcp | Cadview-3d - streaming 3d models over the internet | David Cooper | David Cooper | ||||||
| cadview-3d | 649 | udp | Cadview-3d - streaming 3d models over the internet | David Cooper | David Cooper | ||||||
| 659 | Removed | 2001-06-06 | |||||||||
| meregister | 669 | tcp | MeRegister | Armin Sawusch | Armin Sawusch | ||||||
| meregister | 669 | udp | MeRegister | Armin Sawusch | Armin Sawusch | ||||||
| mrm | 679 | tcp | MRM | Liming Wei | Liming Wei | ||||||
| mrm | 679 | udp | MRM | Liming Wei | Liming Wei | ||||||
| nmap | 689 | tcp | NMAP | Peter Dennis Bartok | Peter Dennis Bartok | ||||||
| nmap | 689 | udp | NMAP | Peter Dennis Bartok | Peter Dennis Bartok | ||||||
| vatp | 690 | tcp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| vatp | 690 | udp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| msexch-routing | 691 | tcp | MS Exchange Routing | David Lemson | David Lemson | ||||||
| msexch-routing | 691 | udp | MS Exchange Routing | David Lemson | David Lemson | ||||||
| hyperwave-isp | 692 | tcp | Hyperwave-ISP | Gerald Mesaric | Gerald Mesaric | ||||||
| hyperwave-isp | 692 | udp | Hyperwave-ISP | Gerald Mesaric | Gerald Mesaric | ||||||
| connendp | 693 | tcp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| connendp | 693 | udp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| ha-cluster | 694 | tcp | ha-cluster | Alan Robertson | Alan Robertson | ||||||
| ha-cluster | 694 | udp | ha-cluster | Alan Robertson | Alan Robertson | ||||||
| ieee-mms-ssl | 695 | tcp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| ieee-mms-ssl | 695 | udp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| rushd | 696 | tcp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| rushd | 696 | udp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| uuidgen | 697 | tcp | UUIDGEN | James Falkner | James Falkner | ||||||
| uuidgen | 697 | udp | UUIDGEN | James Falkner | James Falkner | ||||||
| olsr | 698 | tcp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| olsr | 698 | udp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| accessnetwork | 699 | tcp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| accessnetwork | 699 | udp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| entrust-kmsh | 709 | tcp | Entrust Key Management Service Handler | ||||||||
| entrust-kmsh | 709 | udp | Entrust Key Management Service Handler | ||||||||
| iris-xpcs | 714 | tcp | IRIS over XPCS | RFC 4992 | |||||||
| iris-xpcs | 714 | udp | IRIS over XPCS | RFC 4992 | |||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| pana | 716 | udp | PANA Messages | RFC 5191 | |||||||
| netviewdm1 | 729 | tcp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm1 | 729 | udp | IBM NetView DM/6000 Server/Client | ||||||||
| kerberos-adm | 749 | tcp | kerberos administration |