Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ag-swim 5904 tcp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 udp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
ag-swim 5904 sctp Air-Ground SWIM International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AG-SWIM
asmgcs 5905 tcp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
asmgcs 5905 udp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
asmgcs 5905 sctp Adv Surface Mvmnt and Guidance Cont Sys International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: ASMGCS
rpas-c2 5906 tcp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 udp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
rpas-c2 5906 sctp Remotely Piloted Vehicle C&C International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: RPAS-C2
dsd 5907 tcp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
dsd 5907 udp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
dsd 5907 sctp Distress and Safety Data App International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: DSD
ipsma 5908 tcp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
ipsma 5908 udp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
ipsma 5908 sctp IPS Management Application International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: IPSMA
agma 5909 tcp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
agma 5909 udp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
agma 5909 sctp Air-ground media advisory International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: AGMA
wbem-exp-https 5990 tcp WBEM Export HTTPS Denise Eckstein Denise Eckstein 2004-11
wbem-exp-https 5990 udp WBEM Export HTTPS Denise Eckstein Denise Eckstein 2004-11
metaedit-ws 6390 tcp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
6490-6499 Unassigned
cleverdetect 6690 tcp CLEVERDetect Message Service Applied Expert Systems, Inc. David Cheng 2014-12-03
6690 udp Reserved
hnmp 6790 tcp HNMP Jude George Jude George
hnmp 6790 udp HNMP Jude George Jude George
rtimeviewer 6900 tcp R*TIME Viewer Data Interface Curtiss-Wright Corporation Robert Ammon 2016-12-14
6900 udp Reserved
jetstream 6901 tcp Novell Jetstream messaging protocol Anil Tyagi Anil Tyagi 2010-06-11
6901 udp Reserved
6902-6923 Unassigned
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
7366-7390 Unassigned 2006-02-06
7479-7490 Unassigned
sovd 7690 tcp Service-Oriented Vehicle Diagnostics ASAM e.V. Bernd Wenzel 2022-07-01
7690 udp Reserved
7790-7793 Unassigned
mevent 7900 tcp Multicast Event YoonSoo Kim YoonSoo Kim 2006-05
mevent 7900 udp Multicast Event YoonSoo Kim YoonSoo Kim 2006-05
tnos-sp 7901 tcp TNOS Service Protocol Rene Kurt Rene Kurt 2005-08
tnos-sp 7901 udp TNOS Service Protocol Rene Kurt Rene Kurt 2005-08
tnos-dp 7902 tcp TNOS shell Protocol Rene Kurt Rene Kurt 2005-08
tnos-dp 7902 udp TNOS shell Protocol Rene Kurt Rene Kurt 2005-08
tnos-dps 7903 tcp TNOS Secure DiaguardProtocol Rene Kurt Rene Kurt 2005-08
tnos-dps 7903 udp TNOS Secure DiaguardProtocol Rene Kurt Rene Kurt 2005-08
7904-7912 Unassigned
opsmessaging 8090 tcp Vehicle to station messaging LAN-ACES Robert Ripberger 2017-02-08
8090 udp Reserved
gcp-rphy 8190 tcp Generic control plane for RPHY CableLabs Karthik Sundaresan 2015-11-24
8190 udp Reserved
ddi-tcp-3 8890 tcp Desktop Data TCP 2 Fred Yao Fred Yao Known Unauthorized Use on port 8890
ddi-udp-3 8890 udp NewsEDGE client broadcast Fred Yao Fred Yao Known Unauthorized Use on port 8890
jmb-cds1 8900 tcp JMB-CDS 1 Curtis Bray Curtis Bray
jmb-cds1 8900 udp JMB-CDS 1 Curtis Bray Curtis Bray
jmb-cds2 8901 tcp JMB-CDS 2 Curtis Bray Curtis Bray
jmb-cds2 8901 udp JMB-CDS 2 Curtis Bray Curtis Bray
8902-8907 Unassigned
dpp 8908 tcp WFA Device Provisioning Protocol Wi-Fi Alliance Dr. Jun Tian 2020-10-19
8908 udp Reserved
8909 Unassigned
http-wmap 8990 tcp webmail HTTP service Chris Newman Chris Newman 2007-12-03
http-wmap 8990 udp webmail HTTP service Chris Newman Chris Newman 2007-12-03
cslistener 9000 tcp CSlistener David Jones David Jones
cslistener 9000 udp CSlistener David Jones David Jones
etlservicemgr 9001 tcp ETL Service Manager Stephen McCrea Stephen McCrea 2002-03 Known Unauthorized Use on port 9001
etlservicemgr 9001 udp ETL Service Manager Stephen McCrea Stephen McCrea 2002-03 Known Unauthorized Use on port 9001
dynamid 9002 tcp DynamID authentication Jerome Dusautois Jerome Dusautois 2002-03
dynamid 9002 udp DynamID authentication Jerome Dusautois Jerome Dusautois 2002-03
9003-9004 Unassigned
golem 9005 tcp Golem Inter-System RPC Jose Luis Tallon Jose Luis Tallon 2015-03-09
9005 udp Reserved
9006 De-Commissioned Port 2000-02-24
9007 tcp Reserved
ogs-client 9007 udp Open Grid Services Client Gareth Nelson Gareth Nelson 2008-08-22
ogs-server 9008 tcp Open Grid Services Server Gareth Nelson Gareth Nelson 2008-08-22
9008 udp Reserved
pichat 9009 tcp Pichat Server Mark Seuffert Mark Seuffert 2004-11
pichat 9009 udp Pichat Server Mark Seuffert Mark Seuffert 2004-11
sdr 9010 tcp Secure Data Replicator Protocol Sufyan Almajali Sufyan Almajali 2008-06-27
9010 udp Reserved
9011 tcp Reserved
d-star 9011 udp D-Star Routing digital voice+data for amateur radio QuadNet2 USA IRC Network Thomas A Early 2018-03-16
9012-9019 Unassigned
tambora 9020 tcp TAMBORA Jason van Zyl Jason van Zyl 2002-03
tambora 9020 udp TAMBORA Jason van Zyl Jason van Zyl 2002-03
panagolin-ident 9021 tcp Pangolin Identification William Benner William Benner 2002-03
panagolin-ident 9021 udp Pangolin Identification William Benner William Benner 2002-03
paragent 9022 tcp PrivateArk Remote Agent Gal Cucuy Gal Cucuy 2002-03
paragent 9022 udp PrivateArk Remote Agent Gal Cucuy Gal Cucuy 2002-03
swa-1 9023 tcp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-1 9023 udp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-2 9024 tcp Secure Web Access - 2 Tim McGranaghan Tim McGranaghan
swa-2 9024 udp Secure Web Access - 2 Tim McGranaghan Tim McGranaghan
swa-3 9025 tcp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-3 9025 udp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-4 9026 tcp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
swa-4 9026 udp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
9027-9049 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Anil Tyagi tanil&novell.com 2010-06-11
Applied Expert Systems, Inc. davec&aesclever.com 2014-12-03
ASAM e.V. marius.dupuis&asam.net 2022-07-01
Bernd Wenzel ASAM e.V. bernd.wenzel&asam.net 2022-07-01
CableLabs info&cablelabs.com 2015-11-24
Chris Newman chris.newman&oracle.com 2017-01-26
Curtis Bray CurtisB&creativedesign.com
Curtiss-Wright Corporation rammon&curtisswright.com 2016-12-14
David Cheng davec&aesclever.com 2010-02-01
David Jones djones&cincom.com
Denise Eckstein denise.eckstein&hp.com 2004-11
Dr. Jun Tian jtian&wi-fi.org 2020-10-19
Fred Yao Fred_Yao&ddigate2.desktopdata.com
Gal Cucuy galc&cyber-ark.com 2002-03
Gareth Nelson gareth&litesim.com 2008-08-22
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
Jason van Zyl jvanzyl&zenplex.com 2002-03
Jerome Dusautois jdusautois&scrypto.fr 2002-03
Jose Luis Tallon joseluis&talloncorp.com 2015-03-09
Jude George jude&nas.nasa.gov
Karthik Sundaresan k.sundaresan&cablelabs.com 2015-11-24
LAN-ACES rip&lan-aces.com 2017-02-08
Mark Seuffert captain2004&pirate.de 2004-11
QuadNet2 USA IRC Network admins&openquad.net 2018-03-16
Rene Kurt rene.kurt&adasoft.ch 2005-08
Robert Ammon rammon&curtisswright.com 2016-12-14
Robert Ripberger rip&lan-aces.com 2017-02-08
Stephen McCrea smccrea&etlelectronique.com 2002-03
Steven Kelly stevek&metacase.com 2007-11-12
Sufyan Almajali sufyan.almajali&sdrlive.com 2008-06-27
Thomas A Early tom.n7tae&tearly.net 2018-03-16
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
Wi-Fi Alliance technical&wi-fi.org 2020-10-19
William Benner wrb2&pangolin.com 2025-03-27
YoonSoo Kim ys71.kim&samsung.com 2006-05