Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mngsuite | 9535 | tcp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| mngsuite | 9535 | udp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| laes-bf | 9536 | tcp | Surveillance buffering function | Glen Myers | Glen Myers | 2007-05 | |||||
| laes-bf | 9536 | udp | Surveillance buffering function | Glen Myers | Glen Myers | 2007-05 | |||||
| 9537-9554 | Unassigned | ||||||||||
| trispen-sra | 9555 | tcp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| trispen-sra | 9555 | udp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| 9556-9558 | Unassigned | ||||||||||
| p4runtime | 9559 | tcp | P4Runtime gRPC Service | Open Networking Foundation | Antonin Bas | 2020-09-22 | |||||
| 9559 | udp | Reserved | |||||||||
| 9560-9591 | Unassigned | ||||||||||
| ldgateway | 9592 | tcp | LANDesk Gateway | Alan Butt | Alan Butt | 2006-03 | |||||
| ldgateway | 9592 | udp | LANDesk Gateway | Alan Butt | Alan Butt | 2006-03 | |||||
| cba8 | 9593 | tcp | LANDesk Management Agent (cba8) | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| cba8 | 9593 | udp | LANDesk Management Agent (cba8) | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| msgsys | 9594 | tcp | Message System | Alan Butt | Alan Butt | ||||||
| msgsys | 9594 | udp | Message System | Alan Butt | Alan Butt | ||||||
| pds | 9595 | tcp | Ping Discovery Service | Alan Butt | Alan Butt | ||||||
| pds | 9595 | udp | Ping Discovery Service | Alan Butt | Alan Butt | ||||||
| mercury-disc | 9596 | tcp | Mercury Discovery | Paul Mclachlan | Paul Mclachlan | 2005-11 | |||||
| mercury-disc | 9596 | udp | Mercury Discovery | Paul Mclachlan | Paul Mclachlan | 2005-11 | |||||
| pd-admin | 9597 | tcp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| pd-admin | 9597 | udp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| vscp | 9598 | tcp | Very Simple Ctrl Protocol | Ake Hedman | Ake Hedman | 2005-11 | |||||
| vscp | 9598 | udp | Very Simple Ctrl Protocol | Ake Hedman | Ake Hedman | 2005-11 | |||||
| robix | 9599 | tcp | Robix | Evan Rosen | Evan Rosen | 2005-11 | |||||
| robix | 9599 | udp | Robix | Evan Rosen | Evan Rosen | 2005-11 | |||||
| ccnx | 9695 | tcp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| ccnx | 9695 | udp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| sctp-tunneling | 9899 | udp | SCTP TUNNELING | IESG | IETF Chair | 2013-04-10 | RFC 6951 | ||||
| apc-9950 | 9950 | tcp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9950 | 9950 | udp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | tcp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | udp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| apc-9952 | 9952 | tcp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| apc-9952 | 9952 | udp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| acis | 9953 | tcp | 9953 | Thomas Guth | Thomas Guth | 2006-01 | |||||
| acis | 9953 | udp | 9953 | Thomas Guth | Thomas Guth | 2006-01 | |||||
| hinp | 9954 | tcp | HaloteC Instrument Network Protocol | HaloteC Instruments B.V. | Michel Stam | 2012-02-07 | |||||
| 9954 | udp | Reserved | |||||||||
| alljoyn-stm | 9955 | tcp | Contact Port for AllJoyn standard messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| alljoyn-mcm | 9955 | udp | Contact Port for AllJoyn multiplexed constrained messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| 9956 | tcp | Reserved | |||||||||
| alljoyn | 9956 | udp | Alljoyn Name Service | Qualcomm Innovation Center, Inc. | Craig Dowell | 2011-12-21 | |||||
| 9957-9965 | Unassigned | ||||||||||
| palace-4 | 9995 | tcp | Palace-4 | Douglas Crockford | Douglas Crockford | ||||||
| palace-4 | 9995 | udp | Palace-4 | Douglas Crockford | Douglas Crockford | ||||||
| weave | 11095 | tcp | Nest device-to-device and device-to-service application protocol | Nest Labs, Inc. | Grant Erickson | 2014-01-16 | |||||
| weave | 11095 | udp | Nest device-to-device and device-to-service application protocol | Nest Labs, Inc. | Grant Erickson | 2014-01-16 | |||||
| 11752-11795 | Unassigned | ||||||||||
| 13895-13928 | Unassigned | ||||||||||
| sgcip | 16950 | tcp | Simple Generic Client Interface Protocol | John Aquilino | John Aquilino | ||||||
| sgcip | 16950 | udp | Simple Generic Client Interface Protocol | John Aquilino | John Aquilino | ||||||
| 16951-16990 | Unassigned | ||||||||||
| amt-redir-tls | 16995 | tcp | Intel(R) AMT Redirection/TLS | Nimrod Diamant | Nimrod Diamant | 2005-02 | |||||
| amt-redir-tls | 16995 | udp | Intel(R) AMT Redirection/TLS | Nimrod Diamant | Nimrod Diamant | 2005-02 | |||||
| 19195-19219 | Unassigned | ||||||||||
| 19413-19538 | Unassigned | ||||||||||
| fxuptp | 19539 | tcp | FXUPTP | Keiji Okuma | Keiji Okuma | 2005-08 | |||||
| fxuptp | 19539 | udp | FXUPTP | Keiji Okuma | Keiji Okuma | 2005-08 | |||||
| sxuptp | 19540 | tcp | SXUPTP | Keiji Okuma | Keiji Okuma | 2002-08 | |||||
| sxuptp | 19540 | udp | SXUPTP | Keiji Okuma | Keiji Okuma | 2002-08 | |||||
| jcp | 19541 | tcp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| jcp | 19541 | udp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| 19542-19787 | Unassigned | ||||||||||
| 22801-22950 | Unassigned | ||||||||||
| brf-gw | 22951 | tcp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| brf-gw | 22951 | udp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| 22952-22999 | Unassigned | ||||||||||
| 23295-23332 | Unassigned | ||||||||||
| 25904-25953 | Unassigned | ||||||||||
| bf-game | 25954 | udp | Bitfighter game server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25954 | tcp | Reserved | |||||||||
| bf-master | 25955 | udp | Bitfighter master server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25955 | tcp | Reserved | |||||||||
| 25956-25999 | Unassigned | ||||||||||
| 31950-32033 | Unassigned | ||||||||||
| 32812-32895 | Unassigned | ||||||||||
| crestron-ctp | 41795 | tcp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | udp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| brski-proxy | tcp | The Bootstrapping Remote Secure Key Infrastructure Proxy | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| brski-registrar | tcp | The Bootstrapping Remote Secure Key Infrastructure Registrar | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None | ||||
| wot | tcp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http. |
||||
| wot | udp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Ake Hedman | akhe&eurosource.se | 2005-11 | |
| Alan Butt | alan.butt&landesk.com | 2006-03 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Antonin Bas | Open Networking Foundation | antonin.bas&gmail.com | 2020-09-22 |
| Christopher Eykamp | chris&eykamp.com | 2012-08-16 | |
| Craig Dowell | Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 |
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| Douglas Crockford | douglas&crockford.com | ||
| Duk Loi | dloi&peerdirect.com | 2005-11 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Evan Rosen | evan&robix.com | 2005-11 | |
| Glen Myers | glen.myers&ipfabrics.com | 2007-05 | |
| Grant Erickson | Nest Labs, Inc. | grant&nestlabs.com | 2014-01-16 |
| HaloteC Instruments B.V. | michel.stam&halotec.com | 2012-02-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jaco Botha | jaco.botha&trispen.com | 2004-11 | |
| John Aquilino | john.aquilino&maryville.com | ||
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Kazuyuki Ashimura | ashimura&w3.org | 2022-11-22 | |
| Keiji Okuma | okuma&silex.jp | 2005-08 | |
| Michel Stam | HaloteC Instruments B.V. | michel.stam&halotec.com | 2012-02-07 |
| Nest Labs, Inc. | grant&nestlabs.com | 2014-01-16 | |
| Nimrod Diamant | nimrod.diamant&intel.com | 2005-02 | |
| Open Networking Foundation | iana&opennetworking.org | 2013-07-18 | |
| Paul Mclachlan | pmclachlan&mercury.com | 2005-11 | |
| Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 | |
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Simon Barber | simon.barber&parc.com | 2009-09-29 | |
| Thomas Guth | t.guth&zeiss.de | 2006-01 | |
| Timo Sivonen | timo.sivonen&ccmail.dowjones.com | ||
| Trevor Perkes | trevor.perkes&landesk.com | 2010-02-01 | |
| Van Jacobson | van&parc.com | 2009-09-29 | |
| W3C Web of Things Working Group | team-wot&w3.org | 2022-11-22 | |
| Yuji Sasaki | sasaki&silex.jp |