Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| board-roar | 9700 | udp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9701-9746 | Unassigned | ||||||||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| 9748-9749 | Unassigned | ||||||||||
| board-voip | 9750 | tcp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-voip | 9750 | udp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9751-9752 | Unassigned | ||||||||||
| rasadv | 9753 | tcp | rasadv | Dave Thaler | Dave Thaler | ||||||
| rasadv | 9753 | udp | rasadv | Dave Thaler | Dave Thaler | ||||||
| 9754-9761 | Unassigned | ||||||||||
| tungsten-http | 9762 | tcp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| tungsten-http | 9762 | udp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| 9763-9799 | Unassigned | ||||||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| 9890-9897 | Unassigned | ||||||||||
| 9967-9977 | Unassigned | ||||||||||
| xybrid-rt | 9978 | tcp | XYBRID RT Server | Rx Networks Inc. | Drew Davies | 2013-01-24 | |||||
| 9978 | udp | Reserved | |||||||||
| visweather | 9979 | tcp | Valley Information Systems Weather station data | Valley Information Systems, Inc. | Michael Walsh | 2017-05-12 | |||||
| 9979 | udp | Reserved | |||||||||
| palace-6 | 9997 | tcp | Palace-6 | Douglas Crockford | Douglas Crockford | ||||||
| palace-6 | 9997 | udp | Palace-6 | Douglas Crockford | Douglas Crockford | ||||||
| 11797-11875 | Unassigned | ||||||||||
| 11968-11970 | Unassigned | ||||||||||
| tibsd | 11971 | tcp | TiBS Service | Teradactyl LLC | Kristen Webb | 2019-05-17 | |||||
| 11971 | udp | Reserved | |||||||||
| 11972-11996 | Unassigned | ||||||||||
| wmereceiving | 11997 | sctp | WorldMailExpress | Greg Foutz | Greg Foutz | 2006-03 | |||||
| 15741-15997 | Unassigned | ||||||||||
| 19316-19397 | Unassigned | ||||||||||
| 19542-19787 | Unassigned | ||||||||||
| mle | 19788 | udp | Mesh Link Establishment | IESG | IETF Chair | 2012-12-18 | |||||
| 19788 | tcp | Reserved | |||||||||
| 19789 | Unassigned | ||||||||||
| faircom-db | 19790 | tcp | FairCom Database | FairCom Corporation | Michael Bowers | 2020-12-04 | |||||
| 19790 | udp | Reserved | |||||||||
| 19791-19997 | Unassigned | ||||||||||
| 32897-32999 | Unassigned | ||||||||||
| 34967-34979 | Unassigned | ||||||||||
| crestron-ctps | 41797 | tcp | Crestron Secure Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41797 | udp | Reserved | |||||||||
| 46337-46997 | Unassigned | ||||||||||
| brski-reg-cmp | tcp | Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 | IESG | IETF Chair | 2024-09-23 | RFC 9733 | Defined TXT keys: None | ||||
| dots-call-home | tcp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-call-home | udp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-data | tcp | DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| msrps | tcp | MSRP protocol over TLS | 2014-04-25 | RFC 4976 | Defined TXT keys: |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Afkham Azeez | azeez&wso2.com | 2006-06 | |
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| Dave Thaler | dthalerµsoft.com | ||
| Douglas Crockford | douglas&crockford.com | ||
| Drew Davies | Rx Networks Inc. | ddavies&rxnetworks.com | 2013-01-24 |
| FairCom Corporation | alysha.brown&faircom.com | 2020-12-04 | |
| Francesco Rosi | frosi&orenburg.com | 2006-01 | |
| Greg Foutz | gregf&adminovation.com | 2006-03 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Kristen Webb | kwebb&teradactyl.com | 2019-05-17 | |
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Michael Bowers | FairCom Corporation | mike.bowers&faircom.com | 2020-12-04 |
| Michael Walsh | michael.walsh&valleyinfosys.com | 2017-05-12 | |
| Rx Networks Inc. | ddavies&rxnetworks.com | 2013-01-24 | |
| Teradactyl LLC | vendors&teradactyl.com | 2019-05-17 | |
| Valley Information Systems, Inc. | info@valleyinfosys.com> | 2017-05-12 |