Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| fg-fps | 3293 | tcp | fg-fps | ||||||||
| fg-fps | 3293 | udp | fg-fps | ||||||||
| fg-gip | 3294 | tcp | fg-gip | [Jean_Marc_Frailong] | [Jean_Marc_Frailong] | ||||||
| fg-gip | 3294 | udp | fg-gip | [Jean_Marc_Frailong] | [Jean_Marc_Frailong] | ||||||
| rib-slm | 3296 | tcp | Rib License Manager | [Kristean_Heisler] | [Kristean_Heisler] | ||||||
| rib-slm | 3296 | udp | Rib License Manager | [Kristean_Heisler] | [Kristean_Heisler] | ||||||
| cytel-lm | 3297 | tcp | Cytel License Manager | [Yogesh_P_Gajjar] | [Yogesh_P_Gajjar] | ||||||
| cytel-lm | 3297 | udp | Cytel License Manager | [Yogesh_P_Gajjar] | [Yogesh_P_Gajjar] | ||||||
| tarantool | 3301 | tcp | Tarantool in-memory computing platform | [Tarantool] | [Alexander_Turenko] | 2022-06-10 | Known Unauthorized Use on port 3301 | ||||
| tarantool | 3301 | udp | Tarantool in-memory computing platform | [Tarantool] | [Alexander_Turenko] | 2022-06-10 | Known Unauthorized Use on port 3301 | ||||
| mcs-fastmail | 3302 | tcp | MCS Fastmail | [Patti_Jo_Newsom] | [Patti_Jo_Newsom] | ||||||
| mcs-fastmail | 3302 | udp | MCS Fastmail | [Patti_Jo_Newsom] | [Patti_Jo_Newsom] | ||||||
| opsession-clnt | 3303 | tcp | OP Session Client | ||||||||
| opsession-clnt | 3303 | udp | OP Session Client | ||||||||
| opsession-srvr | 3304 | tcp | OP Session Server | [Amir_Blich] | [Amir_Blich] | ||||||
| opsession-srvr | 3304 | udp | OP Session Server | [Amir_Blich] | [Amir_Blich] | ||||||
| odette-ftp | 3305 | tcp | ODETTE-FTP | [David_Nash] | [David_Nash] | [RFC 5024] | |||||
| odette-ftp | 3305 | udp | ODETTE-FTP | [David_Nash] | [David_Nash] | [RFC 5024] | |||||
| opsession-prxy | 3307 | tcp | OP Session Proxy | [Amir_Blich] | [Amir_Blich] | ||||||
| opsession-prxy | 3307 | udp | OP Session Proxy | [Amir_Blich] | [Amir_Blich] | ||||||
| tns-server | 3308 | tcp | TNS Server | ||||||||
| tns-server | 3308 | udp | TNS Server | ||||||||
| tns-adv | 3309 | tcp | TNS ADV | [Jerome_Albin] | [Jerome_Albin] | ||||||
| tns-adv | 3309 | udp | TNS ADV | [Jerome_Albin] | [Jerome_Albin] | ||||||
| dyna-access | 3310 | tcp | Dyna Access | [Dave_Belliveau] | [Dave_Belliveau] | ||||||
| dyna-access | 3310 | udp | Dyna Access | [Dave_Belliveau] | [Dave_Belliveau] | ||||||
| mcns-tel-ret | 3311 | tcp | MCNS Tel Ret | [Randall_Atkinson] | [Randall_Atkinson] | ||||||
| mcns-tel-ret | 3311 | udp | MCNS Tel Ret | [Randall_Atkinson] | [Randall_Atkinson] | ||||||
| appman-server | 3312 | tcp | Application Management Server | ||||||||
| appman-server | 3312 | udp | Application Management Server | ||||||||
| aicc-cmi | 3316 | tcp | AICC/CMI | [William_McDonald] | [William_McDonald] | ||||||
| aicc-cmi | 3316 | udp | AICC/CMI | [William_McDonald] | [William_McDonald] | ||||||
| sdt-lmd | 3319 | tcp | SDT License Manager | [Salvo_Nassisi] | [Salvo_Nassisi] | ||||||
| sdt-lmd | 3319 | udp | SDT License Manager | [Salvo_Nassisi] | [Salvo_Nassisi] | ||||||
| active-net | 3322-3325 | Active Networks | [Bob_Braden_2] | [Bob_Braden_2] | |||||||
| hp-device-disc | 3329 | tcp | HP Device Disc | [Shivaun_Albright] | [Shivaun_Albright] | ||||||
| hp-device-disc | 3329 | udp | HP Device Disc | [Shivaun_Albright] | [Shivaun_Albright] | ||||||
| mcs-calypsoicf | 3330 | tcp | MCS Calypso ICF | ||||||||
| mcs-calypsoicf | 3330 | udp | MCS Calypso ICF | ||||||||
| mcs-messaging | 3331 | tcp | MCS Messaging | ||||||||
| mcs-messaging | 3331 | udp | MCS Messaging | ||||||||
| mcs-mailsvr | 3332 | tcp | MCS Mail Server | [Patti_Jo_Newsom] | [Patti_Jo_Newsom] | ||||||
| mcs-mailsvr | 3332 | udp | MCS Mail Server | [Patti_Jo_Newsom] | [Patti_Jo_Newsom] | ||||||
| dec-notes | 3333 | tcp | DEC Notes | [Kim_Moraros] | [Kim_Moraros] | ||||||
| dec-notes | 3333 | udp | DEC Notes | [Kim_Moraros] | [Kim_Moraros] | ||||||
| directv-web | 3334 | tcp | Direct TV Webcasting | ||||||||
| directv-web | 3334 | udp | Direct TV Webcasting | ||||||||
| directv-soft | 3335 | tcp | Direct TV Software Updates | ||||||||
| directv-soft | 3335 | udp | Direct TV Software Updates | ||||||||
| directv-tick | 3336 | tcp | Direct TV Tickers | ||||||||
| directv-tick | 3336 | udp | Direct TV Tickers | ||||||||
| directv-catlg | 3337 | tcp | Direct TV Data Catalog | [Michael_Friedman] | [Michael_Friedman] | ||||||
| directv-catlg | 3337 | udp | Direct TV Data Catalog | [Michael_Friedman] | [Michael_Friedman] | ||||||
| anet-b | 3338 | tcp | OMF data b | ||||||||
| anet-b | 3338 | udp | OMF data b | ||||||||
| anet-l | 3339 | tcp | OMF data l | ||||||||
| anet-l | 3339 | udp | OMF data l | ||||||||
| anet-m | 3340 | tcp | OMF data m | ||||||||
| anet-m | 3340 | udp | OMF data m | ||||||||
| anet-h | 3341 | tcp | OMF data h | [Per_Sahlqvist] | [Per_Sahlqvist] | ||||||
| anet-h | 3341 | udp | OMF data h | [Per_Sahlqvist] | [Per_Sahlqvist] | ||||||
| ms-cluster-net | 3343 | tcp | MS Cluster Net | [David_Dion] | [David_Dion] | 2009-02-12 | |||||
| ms-cluster-net | 3343 | udp | MS Cluster Net | [David_Dion] | [David_Dion] | 2009-02-12 | |||||
| bnt-manager | 3344 | tcp | BNT Manager | [Engineering_Dept] | [Engineering_Dept] | ||||||
| bnt-manager | 3344 | udp | BNT Manager | [Engineering_Dept] | [Engineering_Dept] | ||||||
| phoenix-rpc | 3347 | tcp | Phoenix RPC | [Ian_Anderson] | [Ian_Anderson] | ||||||
| phoenix-rpc | 3347 | udp | Phoenix RPC | [Ian_Anderson] | [Ian_Anderson] | ||||||
| pangolin-laser | 3348 | tcp | Pangolin Laser | [William_Benner] | [William_Benner] | ||||||
| pangolin-laser | 3348 | udp | Pangolin Laser | [William_Benner] | [William_Benner] | ||||||
| ordinox-dbase | 3355 | tcp | Ordinox Dbase | [Denis_Ducharme] | [Denis_Ducharme] | ||||||
| ordinox-dbase | 3355 | udp | Ordinox Dbase | [Denis_Ducharme] | [Denis_Ducharme] | ||||||
| adtech-test | 3357 | tcp | Adtech Test IP | [Robin_Uyeshiro] | [Robin_Uyeshiro] | ||||||
| adtech-test | 3357 | udp | Adtech Test IP | [Robin_Uyeshiro] | [Robin_Uyeshiro] | ||||||
| wg-netforce | 3359 | tcp | WG NetForce | [Lee_Wheat] | [Lee_Wheat] | ||||||
| wg-netforce | 3359 | udp | WG NetForce | [Lee_Wheat] | [Lee_Wheat] | ||||||
| kv-server | 3360 | tcp | KV Server | ||||||||
| kv-server | 3360 | udp | KV Server | ||||||||
| kv-agent | 3361 | tcp | KV Agent | [Thomas_Soranno] | [Thomas_Soranno] | ||||||
| kv-agent | 3361 | udp | KV Agent | [Thomas_Soranno] | [Thomas_Soranno] | ||||||
| dj-ilm | 3362 | tcp | DJ ILM | [Don_Tyson] | [Don_Tyson] | ||||||
| dj-ilm | 3362 | udp | DJ ILM | [Don_Tyson] | [Don_Tyson] | ||||||
| nati-vi-server | 3363 | tcp | NATI Vi Server | [National_Instruments_2] | [Jeff_Peters] | ||||||
| nati-vi-server | 3363 | udp | NATI Vi Server | [National_Instruments_2] | [Jeff_Peters] | ||||||
| satvid-datalnk | 3367-3371 | Satellite Video Data Link | [Scott_Engel] | [Scott_Engel] | |||||||
| lavenir-lm | 3373 | tcp | Lavenir License Manager | [Marius_Matioc] | [Marius_Matioc] | ||||||
| lavenir-lm | 3373 | udp | Lavenir License Manager | [Marius_Matioc] | [Marius_Matioc] | ||||||
| cluster-disc | 3374 | tcp | Cluster Disc | [Jeff_Hughes] | [Jeff_Hughes] | ||||||
| cluster-disc | 3374 | udp | Cluster Disc | [Jeff_Hughes] | [Jeff_Hughes] | ||||||
| vsnm-agent | 3375 | tcp | VSNM Agent | [Venkat_Rangan] | [Venkat_Rangan] | ||||||
| vsnm-agent | 3375 | udp | VSNM Agent | [Venkat_Rangan] | [Venkat_Rangan] | ||||||
| cogsys-lm | 3377 | tcp | Cogsys Network License Manager | [Simon_Chinnick] | [Simon_Chinnick] | ||||||
| cogsys-lm | 3377 | udp | Cogsys Network License Manager | [Simon_Chinnick] | [Simon_Chinnick] | ||||||
| sns-channels | 3380 | tcp | SNS Channels | [Shekar_Pasumarthi] | [Shekar_Pasumarthi] | ||||||
| sns-channels | 3380 | udp | SNS Channels | [Shekar_Pasumarthi] | [Shekar_Pasumarthi] | ||||||
| fujitsu-neat | 3382 | tcp | Fujitsu Network Enhanced Antitheft function | [Markku_Viima] | [Markku_Viima] | ||||||
| fujitsu-neat | 3382 | udp | Fujitsu Network Enhanced Antitheft function | [Markku_Viima] | [Markku_Viima] | ||||||
| esp-lm | 3383 | tcp | Enterprise Software Products License Manager | [George_Rudy] | [George_Rudy] | ||||||
| esp-lm | 3383 | udp | Enterprise Software Products License Manager | [George_Rudy] | [George_Rudy] | ||||||
| hp-clic | 3384 | tcp | Cluster Management Services | [Rajesh_Srinivasaragh] | [Rajesh_Srinivasaragh] | ||||||
| hp-clic | 3384 | udp | Hardware Management | [Rajesh_Srinivasaragh] | [Rajesh_Srinivasaragh] | ||||||
| gprs-data | 3386 | tcp | GPRS Data |