Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
aurora 9084 sctp IBM AURORA Performance Visualizer Jeroen Massar Jeroen Massar 2008-08-21
ibm-rsyscon 9085 tcp IBM Remote System Console William LePera William LePera 2008-06-18
ibm-rsyscon 9085 udp IBM Remote System Console William LePera William LePera 2008-06-18
net2display 9086 tcp Vesa Net2Display Kenneth B. Ocheltree Kenneth B. Ocheltree 2008-01-07
net2display 9086 udp Vesa Net2Display Kenneth B. Ocheltree Kenneth B. Ocheltree 2008-01-07
classic 9087 tcp Classic Data Server Paul Cadarette Paul Cadarette 2007-01
classic 9087 udp Classic Data Server Paul Cadarette Paul Cadarette 2007-01
sqlexec 9088 tcp IBM Informix SQL Interface Jonathan Leffler Jonathan Leffler 2005-12
sqlexec 9088 udp IBM Informix SQL Interface Jonathan Leffler Jonathan Leffler 2005-12
sqlexec-ssl 9089 tcp IBM Informix SQL Interface - Encrypted Jonathan Leffler Jonathan Leffler 2005-12
sqlexec-ssl 9089 udp IBM Informix SQL Interface - Encrypted Jonathan Leffler Jonathan Leffler 2005-12
websm 9090 tcp WebSM I-Hsing Tsao I-Hsing Tsao
websm 9090 udp WebSM I-Hsing Tsao I-Hsing Tsao
xmltec-xmlmail 9091 tcp xmltec-xmlmail Mitch Kaufman Mitch Kaufman
xmltec-xmlmail 9091 udp xmltec-xmlmail Mitch Kaufman Mitch Kaufman
XmlIpcRegSvc 9092 tcp Xml-Ipc Server Reg Casey Harrington Casey Harrington 2006-01
XmlIpcRegSvc 9092 udp Xml-Ipc Server Reg Casey Harrington Casey Harrington 2006-01
copycat 9093 tcp Copycat database replication service Microtec Informatique Raphael Neve 2012-03-15
9093 udp Reserved
9094-9099 Unassigned
hp-pdl-datastr 9100 tcp PDL Data Streaming Port Shivaun Albright Shivaun Albright 2002-04
hp-pdl-datastr 9100 udp PDL Data Streaming Port Shivaun Albright Shivaun Albright 2002-04
pdl-datastream 9100 tcp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
bacula-dir 9101 tcp Bacula Director Kern Sibbald Kern Sibbald 2002-01
bacula-dir 9101 udp Bacula Director Kern Sibbald Kern Sibbald 2002-01
bacula-fd 9102 tcp Bacula File Daemon Kern Sibbald Kern Sibbald 2002-01
bacula-fd 9102 udp Bacula File Daemon Kern Sibbald Kern Sibbald 2002-01
bacula-sd 9103 tcp Bacula Storage Daemon Kern Sibbald Kern Sibbald 2002-01
bacula-sd 9103 udp Bacula Storage Daemon Kern Sibbald Kern Sibbald 2002-01
peerwire 9104 tcp PeerWire Steven Gerhardt Steven Gerhardt 2004-02
peerwire 9104 udp PeerWire Steven Gerhardt Steven Gerhardt 2004-02
xadmin 9105 tcp Xadmin Control Service Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009
xadmin 9105 udp Xadmin Control Service Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009
astergate 9106 tcp Astergate Control Service Ariën Huisken Ariën Huisken 2010-01-04
astergate-disc 9106 udp Astergate Discovery Service Ariën Huisken Ariën Huisken 2010-01-04
astergatefax 9107 tcp AstergateFax Control Service Gijs Middelkamp Gijs Middelkamp 2010-02-03
9107 udp Reserved
9108-9110 Unassigned
hexxorecore 9111 tcp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
hexxorecore 9111 udp Multiple Purpose, Distributed Message Bus Hexxore Patrick Roozeboom 2018-07-31
9112-9118 Unassigned
mxit 9119 tcp MXit Instant Messaging Marnus Freeman Marnus Freeman 2006-02
mxit 9119 udp MXit Instant Messaging Marnus Freeman Marnus Freeman 2006-02
9120-9121 Unassigned
grcmp 9122 tcp Global Relay compliant mobile instant messaging protocol Global Relay Communications Inc Lu Vo 2012-11-28 2025-06-12
9122 udp Reserved
grcp 9123 tcp Global Relay compliant instant messaging protocol Global Relay Communications Inc Lu Vo 2012-11-28 2025-06-12
9123 udp Reserved
9124-9130 Unassigned
dddp 9131 tcp Dynamic Device Discovery Shane Dick Shane Dick 2005-08
dddp 9131 udp Dynamic Device Discovery Shane Dick Shane Dick 2005-08
9132-9159 Unassigned
apani1 9160 tcp apani1 Neal Taylor Neal Taylor
apani1 9160 udp apani1 Neal Taylor Neal Taylor
apani2 9161 tcp apani2 Neal Taylor Neal Taylor
apani2 9161 udp apani2 Neal Taylor Neal Taylor
apani3 9162 tcp apani3 Neal Taylor Neal Taylor
apani3 9162 udp apani3 Neal Taylor Neal Taylor
apani4 9163 tcp apani4 Neal Taylor Neal Taylor
apani4 9163 udp apani4 Neal Taylor Neal Taylor
apani5 9164 tcp apani5 Neal Taylor Neal Taylor
apani5 9164 udp apani5 Neal Taylor Neal Taylor
9165-9182 Unassigned
sirius-agent 9183 tcp Sirius Configuration Agent Sirius Computer, Inc Jason Van der Schyff 2026-03-09
sirius-agent 9183 udp Sirius Configuration Agent Sirius Computer, Inc Jason Van der Schyff 2026-03-09
9184-9190 Unassigned
sun-as-jpda 9191 tcp Sun AppSvr JPDA Abhijit Kumar Abhijit Kumar 2005-11
sun-as-jpda 9191 udp Sun AppSvr JPDA Abhijit Kumar Abhijit Kumar 2005-11
9192-9199 Unassigned
wap-wsp 9200 tcp WAP connectionless session service WAP Forum WAP Forum
wap-wsp 9200 udp WAP connectionless session service WAP Forum WAP Forum
wap-wsp-wtp 9201 tcp WAP session service WAP Forum WAP Forum
wap-wsp-wtp 9201 udp WAP session service WAP Forum WAP Forum
wap-wsp-s 9202 tcp WAP secure connectionless session service WAP Forum WAP Forum
wap-wsp-s 9202 udp WAP secure connectionless session service WAP Forum WAP Forum
wap-wsp-wtp-s 9203 tcp WAP secure session service WAP Forum WAP Forum
wap-wsp-wtp-s 9203 udp WAP secure session service WAP Forum WAP Forum
wap-vcard 9204 tcp WAP vCard WAP Forum WAP Forum
wap-vcard 9204 udp WAP vCard WAP Forum WAP Forum
wap-vcal 9205 tcp WAP vCal WAP Forum WAP Forum
wap-vcal 9205 udp WAP vCal WAP Forum WAP Forum
wap-vcard-s 9206 tcp WAP vCard Secure WAP Forum WAP Forum
wap-vcard-s 9206 udp WAP vCard Secure WAP Forum WAP Forum
wap-vcal-s 9207 tcp WAP vCal Secure WAP Forum WAP Forum
wap-vcal-s 9207 udp WAP vCal Secure WAP Forum WAP Forum
rjcdb-vcards 9208 tcp rjcdb vCard Robert John Churchill Robert John Churchill 2006-01
rjcdb-vcards 9208 udp rjcdb vCard Robert John Churchill Robert John Churchill 2006-01
almobile-system 9209 tcp ALMobile System Service Rob Graber Rob Graber 2006-01
almobile-system 9209 udp ALMobile System Service Rob Graber Rob Graber 2006-01
oma-mlp 9210 tcp OMA Mobile Location Protocol Hans Rohnert Hans Rohnert 2002-04
oma-mlp 9210 udp OMA Mobile Location Protocol Hans Rohnert Hans Rohnert 2002-04
oma-mlp-s 9211 tcp OMA Mobile Location Protocol Secure Hans Rohnert Hans Rohnert 2002-04
oma-mlp-s 9211 udp OMA Mobile Location Protocol Secure Hans Rohnert Hans Rohnert 2002-04
serverviewdbms 9212 tcp Server View dbms access Detlef Rothe Detlef Rothe 2009-05-15
serverviewdbms 9212 udp Server View dbms access Detlef Rothe Detlef Rothe 2009-05-15
serverstart 9213 tcp ServerStart RemoteControl Detlef Rothe Detlef Rothe 2009-05-15
serverstart 9213 udp ServerStart RemoteControl Detlef Rothe Detlef Rothe 2009-05-15
ipdcesgbs 9214 tcp IPDC ESG BootstrapService Joerg Heuer Joerg Heuer 2006-02
ipdcesgbs 9214 udp IPDC ESG BootstrapService Joerg Heuer Joerg Heuer 2006-02
insis 9215 tcp Integrated Setup and Install Service Markus Treinen Markus Treinen 2006-02

Contact Information

Name Organization Contact URI Last Updated
Abhijit Kumar as-iana-ports&sun.com 2005-11
Ariën Huisken astergate&huisken-systems.nl 2010-01-04
Casey Harrington charrington&isxinc.com 2006-01
Detlef Rothe detlef.rothe&ts.fujitsu.com 2009-05-15
Gijs Middelkamp astergate-fax&huisken-systems.nl 2010-02-03
Global Relay Communications Inc info&globalrelay.net 2025-06-12
Hans Rohnert hans.rohnert&siemens.com 2002-04
Hexxore info&hexxore.nl 2018-07-31
I-Hsing Tsao itsao&austin.ibm.com
Jason Van der Schyff jason&sirius.computer 2026-03-09
Jeroen Massar jma&zurich.ibm.com 2008-08-21
Joerg Heuer Joerg.Heuer&siemens.com 2006-02
Jonathan Leffler jleffler&us.ibm.com 2005-12
Kenneth B. Ocheltree kennetho&us.ibm.com 2008-01-07
Kern Sibbald kern&sibbald.com 2002-01
Lu Vo Global Relay Communications Inc lu.vo&globalrelay.net 2025-06-12
Markus Treinen markus.treinen&siemens.com 2006-02
Marnus Freeman marnus&swistgroup.com 2006-02
Microtec Informatique raph&microtec.fr 2012-03-15
Mitch Kaufman mk&weconnectyou.com
Neal Taylor ianareg&apani.com
Patrick Roozeboom info&hexxore.nl 2018-07-31
Paul Cadarette pcadaret&us.ibm.com 2007-01
Raphael Neve Microtec Informatique raph&microtec.fr 2012-03-15
Rob Graber r.graber&austinlane.com 2006-01
Robert John Churchill rjc&rjcdb.com 2006-01
Shane Dick shane.dick&amx.com 2005-08
Shivaun Albright shivaun_albright&hp.com 2002-04
Sirius Computer, Inc jason&sirius.computer 2026-03-09
Steven Gerhardt sgerhardt&ixiononline.com 2004-02
Stuart Cheshire pdl-datastream&apple.com 2002-09
WAP Forum wap-feedback&mail.wapforum.org
pg&uplanet.com
William LePera lepera&us.ibm.com 2008-06-18