Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| q3ade | 7794 | tcp | Q3ADE Cluster Service | Uffe Harksen | Uffe Harksen | 2005-08 | |||||
| q3ade | 7794 | udp | Q3ADE Cluster Service | Uffe Harksen | Uffe Harksen | 2005-08 | |||||
| 7795-7796 | Unassigned | ||||||||||
| pnet-conn | 7797 | tcp | Propel Connector port | ||||||||
| pnet-conn | 7797 | udp | Propel Connector port | ||||||||
| pnet-enc | 7798 | tcp | Propel Encoder port | Leif Hedstrom | Leif Hedstrom | 2002-04 | |||||
| pnet-enc | 7798 | udp | Propel Encoder port | Leif Hedstrom | Leif Hedstrom | 2002-04 | |||||
| altbsdp | 7799 | tcp | Alternate BSDP Service | Dieter Siegmund | Dieter Siegmund | 2007-10-22 | |||||
| altbsdp | 7799 | udp | Alternate BSDP Service | Dieter Siegmund | Dieter Siegmund | 2007-10-22 | |||||
| asr | 7800 | tcp | Apple Software Restore | Jim Kateley; Shantonu Sen | Jim Kateley; Shantonu Sen | 2006-01 | Defined TXT keys: image=<HTTP URL of disk image> | ||||
| asr | 7800 | udp | Apple Software Restore | Jim Kateley; Shantonu Sen | Jim Kateley; Shantonu Sen | 2006-01 | Defined TXT keys: image=<HTTP URL of disk image> | ||||
| ssp-client | 7801 | tcp | Secure Server Protocol - client | Rick Macchio | Rick Macchio | 2006-11 | |||||
| ssp-client | 7801 | udp | Secure Server Protocol - client | Rick Macchio | Rick Macchio | 2006-11 | |||||
| vns-tp | 7802 | udp | Virtualized Network Services Tunnel Protocol | Juniper Networks | Bruno Rijsman | 2013-02-01 | |||||
| 7802 | tcp | Reserved | |||||||||
| 7803-7809 | Unassigned | ||||||||||
| rbt-wanopt | 7810 | tcp | Riverbed WAN Optimization Protocol | Vladimir Legalov | Vladimir Legalov | 2007-09-04 | |||||
| rbt-wanopt | 7810 | udp | Riverbed WAN Optimization Protocol | Vladimir Legalov | Vladimir Legalov | 2007-09-04 | |||||
| 7811-7844 | Unassigned | ||||||||||
| apc-7845 | 7845 | tcp | APC 7845 | American Power Conversion | American Power Conversion | ||||||
| apc-7845 | 7845 | udp | APC 7845 | American Power Conversion | American Power Conversion | ||||||
| apc-7846 | 7846 | tcp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| apc-7846 | 7846 | udp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| csoauth | 7847 | tcp | A product key authentication protocol made by CSO | Jeff Wamsley | Jacob Kiesel | 2013-09-04 | |||||
| 7847 | udp | Reserved | |||||||||
| 7848-7868 | Unassigned | ||||||||||
| mobileanalyzer | 7869 | tcp | MobileAnalyzer& MobileMonitor | Jonas Gyllensvaan | Jonas Gyllensvaan | 2009-04-27 | |||||
| 7869 | udp | Reserved | |||||||||
| rbt-smc | 7870 | tcp | Riverbed Steelhead Mobile Service | Gabriel Levy | Gabriel Levy | 2008-08-29 | |||||
| 7870 | udp | Reserved | |||||||||
| mdm | 7871 | tcp | Mobile Device Management | Dan Harkins | Dan Harkins | 2011-08-15 | |||||
| 7871 | udp | Reserved | |||||||||
| 7872 | tcp | Reserved | |||||||||
| mipv6tls | 7872 | udp | TLS-based Mobile IPv6 Security | IESG | IETF Chair | 2012-04-12 | RFC 6618 | ||||
| 7873-7877 | Unassigned | ||||||||||
| owms | 7878 | tcp | Opswise Message Service | Stonebranch, Inc. | Nathan Hammond | 2013-06-25 | |||||
| 7878 | udp | Reserved | |||||||||
| 7879 | Unassigned | ||||||||||
| pss | 7880 | tcp | Pearson | Pearson | Pearson | 2008-01-17 | |||||
| pss | 7880 | udp | Pearson | Pearson | Pearson | 2008-01-17 | |||||
| 7881-7886 | Unassigned | ||||||||||
| ubroker | 7887 | tcp | Universal Broker | Nathan Hammond | Nathan Hammond | 2005-10 | |||||
| ubroker | 7887 | udp | Universal Broker | Nathan Hammond | Nathan Hammond | 2005-10 | |||||
| 7888-7899 | Unassigned | ||||||||||
| mevent | 7900 | tcp | Multicast Event | YoonSoo Kim | YoonSoo Kim | 2006-05 | |||||
| mevent | 7900 | udp | Multicast Event | YoonSoo Kim | YoonSoo Kim | 2006-05 | |||||
| tnos-sp | 7901 | tcp | TNOS Service Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-sp | 7901 | udp | TNOS Service Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dp | 7902 | tcp | TNOS shell Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dp | 7902 | udp | TNOS shell Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dps | 7903 | tcp | TNOS Secure DiaguardProtocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dps | 7903 | udp | TNOS Secure DiaguardProtocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| 7904-7912 | Unassigned | ||||||||||
| qo-secure | 7913 | tcp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| qo-secure | 7913 | udp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| 7914-7931 | Unassigned | ||||||||||
| t2-drm | 7932 | tcp | Tier 2 Data Resource Manager | Peter Carlson | Peter Carlson | ||||||
| t2-drm | 7932 | udp | Tier 2 Data Resource Manager | Peter Carlson | Peter Carlson | ||||||
| t2-brm | 7933 | tcp | Tier 2 Business Rules Manager | Peter Carlson | Peter Carlson | ||||||
| t2-brm | 7933 | udp | Tier 2 Business Rules Manager | Peter Carlson | Peter Carlson | ||||||
| 7934-7961 | Unassigned | ||||||||||
| generalsync | 7962 | tcp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| generalsync | 7962 | udp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| 7963-7966 | Unassigned | ||||||||||
| supercell | 7967 | tcp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| supercell | 7967 | udp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| 7968-7978 | Unassigned | ||||||||||
| micromuse-ncps | 7979 | tcp | Micromuse-ncps | Hing Wing To | Hing Wing To | ||||||
| micromuse-ncps | 7979 | udp | Micromuse-ncps | Hing Wing To | Hing Wing To | ||||||
| quest-vista | 7980 | tcp | Quest Vista | Preston Bannister | Preston Bannister | ||||||
| quest-vista | 7980 | udp | Quest Vista | Preston Bannister | Preston Bannister | ||||||
| sossd-collect | 7981 | tcp | Spotlight on SQL Server Desktop Collect | Rob Griffin | Rob Griffin | 2010-08-30 | |||||
| 7981 | udp | Reserved | |||||||||
| sossd-agent | 7982 | tcp | Spotlight on SQL Server Desktop Agent | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| sossd-disc | 7982 | udp | Spotlight on SQL Server Desktop Agent Discovery | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| 7983-7997 | Unassigned | ||||||||||
| pushns | 7997 | tcp | PUSH Notification Service | Tristan Seifert | Tristan Seifert | 2011-01-31 | |||||
| 7997 | udp | Reserved | |||||||||
| 7998 | tcp | Reserved | |||||||||
| usicontentpush | 7998 | udp | USI Content Push Service | Prakash Iyer | Prakash Iyer | 2009-08-10 | |||||
| irdmi2 | 7999 | tcp | iRDMI2 | ||||||||
| irdmi2 | 7999 | udp | iRDMI2 | ||||||||
| warppipe | 8007 | tcp | I/O oriented cluster computing software | MirrorWeb LTD | Jonathan Kingsley | 2017-07-19 | |||||
| warppipe | 8007 | udp | I/O oriented cluster computing software | MirrorWeb LTD | Jonathan Kingsley | 2017-07-19 | |||||
| 8017 | tcp | Reserved | |||||||||
| cisco-cloudsec | 8017 | udp | Cisco Cloudsec Dataplane Port Number | Cisco Systems, Inc. | Govind Sharma | 2021-03-18 | |||||
| papachi-p2p-srv | 8027 | tcp | peer tracker and data relay service | Pavel Csefalvay | Pavel Csefalvay | 2020-09-18 | |||||
| papachi-p2p-srv | 8027 | udp | peer tracker and data relay service | Pavel Csefalvay | Pavel Csefalvay | 2020-09-18 | |||||
| senomix06 | 8057 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix06 | 8057 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix07 | 8058 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix07 | 8058 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| aero | 8060 | udp | Asymmetric Extended Route Optimization (AERO) | IESG | IETF Chair | RFC 6706 | |||||
| infi-async | 8067 | tcp | Infinidat async replication | INFINIDAT | Eldar Kleiner | 2015-05-01 | |||||
| 8067 | udp | Reserved | |||||||||
| ucs-isc | 8070 | tcp | Oracle Unified Communication Suite's Indexed Search Converter | Oracle Corp | Bharathi Sivaramakrishnan | 2017-02-10 | |||||
| 8070 | udp | Reserved | |||||||||
| 8071-8073 | Unassigned | ||||||||||
| gadugadu | 8074 | tcp | Gadu-Gadu | Marcin Gozdalik | Marcin Gozdalik | 2006-05 | |||||
| gadugadu | 8074 | udp | Gadu-Gadu | Marcin Gozdalik | Marcin Gozdalik | 2006-05 | |||||
| 8075-8076 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Bharathi Sivaramakrishnan | bharathi.sivaramakrishnan&oracle.com | 2017-02-10 | |
| Bruno Rijsman | Juniper Networks | brijsman&juniper.net | 2013-02-01 |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 | |
| Dan Harkins | dharkins&lounge.org | 2011-08-15 | |
| Dieter Siegmund | dieter&apple.com | 2007-10-22 | |
| Dirk Steinmetz | ds&generalsync.com | 2014-04-17 | |
| Eldar Kleiner | INFINIDAT | eldark&infinidat.com | 2015-05-01 |
| Gabriel Levy | glevy&riverbed.com | 2008-08-29 | |
| Govind Sharma | Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 |
| Hing Wing To | wing.to&mircromuse.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| INFINIDAT | info&infinidat.com | 2015-05-01 | |
| Jacob Kiesel | gocso.net | jake.k&gocso.net | 2013-09-04 |
| Jeff Wamsley | gocso.net | jeffw&gocso.net | 2013-09-04 |
| Jim Kateley | asr-dev&group.apple.com | 2006-01 | |
| Jonas Bovin | jonas.bovin&quickobjects.com | ||
| Jonas Gyllensvaan | jonas&conceivium.com | 2009-04-27 | |
| Jonathan Kingsley | jon&mirrorweb.com | 2017-07-19 | |
| Juniper Networks | brijsman&juniper.net | 2013-02-01 | |
| Kevin Nakagawa | nakagawa&sigsci.com | ||
| Leif Hedstrom | leif&propel.com | 2002-04 | |
| Marcin Gozdalik | gozdal&gadu-gadu.pl | 2006-05 | |
| MirrorWeb LTD | jon&mirrorweb.com | 2017-07-19 | |
| Nathan Hammond | nathan.hammond&stonebranch.com | 2005-10 | |
| Nathan Hammond | Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 |
| Oracle Corp | bharathi.sivaramakrishnan&oracle.com
chris.newman&oracle.com |
2017-02-10 | |
| Pavel Csefalvay | csefalvay&gmail.com | 2020-09-18 | |
| Pearson | chad.smith&pearson.com | 2008-01-17 | |
| Peter Carlson | pcarlson&tier2.com | ||
| Prakash Iyer | prakash.iyer&intel.com | 2009-08-10 | |
| Preston Bannister | pbannister&quests.com | ||
| Rene Kurt | rene.kurt&adasoft.ch | 2005-08 | |
| Rick Macchio | rmacchio&juniper.net | 2006-11 | |
| Rob Griffin | rob.gri55in&gmail.com | 2010-09-13 | |
| Shantonu Sen | ssen&apple.com | ||
| Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 | |
| Tristan Seifert | admin&247server.net | 2011-01-31 | |
| Uffe Harksen | uh&uhcommunications.com | 2005-08 | |
| Vladimir Legalov | vlegalov&riverbed.com | 2007-09-04 | |
| YoonSoo Kim | ys71.kim&samsung.com | 2006-05 |