Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
board-voip 9750 tcp Board M.I.T. Synchronous Collaboration Francesco Rosi Francesco Rosi 2006-01
board-voip 9750 udp Board M.I.T. Synchronous Collaboration Francesco Rosi Francesco Rosi 2006-01
9751-9752 Unassigned
rasadv 9753 tcp rasadv Dave Thaler Dave Thaler
rasadv 9753 udp rasadv Dave Thaler Dave Thaler
9754-9761 Unassigned
tungsten-http 9762 tcp WSO2 Tungsten HTTP Afkham Azeez Afkham Azeez 2006-06
tungsten-http 9762 udp WSO2 Tungsten HTTP Afkham Azeez Afkham Azeez 2006-06
9763-9799 Unassigned
davsrc 9800 tcp WebDav Source Port Ethan Fremen Ethan Fremen
davsrc 9800 udp WebDav Source Port Ethan Fremen Ethan Fremen
sstp-2 9801 tcp Sakura Script Transfer Protocol-2 Kouichi Takeda Kouichi Takeda
sstp-2 9801 udp Sakura Script Transfer Protocol-2 Kouichi Takeda Kouichi Takeda
davsrcs 9802 tcp WebDAV Source TLS/SSL Rob Isaac Rob Isaac 2003-07
davsrcs 9802 udp WebDAV Source TLS/SSL Rob Isaac Rob Isaac 2003-07
9803-9874 Unassigned
sapv1 9875 tcp Session Announcement v1 RFC 2974
sapv1 9875 udp Session Announcement v1 RFC 2974
sd 9876 tcp Session Director Van Jacobson Van Jacobson
x510 9877 tcp The X.510 wrapper protocol ITU/TSB (ITU-T Study Group 17) Erik Andersen 2019-09-30 ITU-T X.510 / ISO/IEC 9584-11
9877 udp Reserved
kca-service 9878 udp The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 IESG IETF Chair 2012-07-12 RFC 6717 Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements.
9878 tcp Reserved
9879-9887 Unassigned
cyborg-systems 9888 tcp CYBORG Systems Malcolm Graham Malcolm Graham
cyborg-systems 9888 udp CYBORG Systems Malcolm Graham Malcolm Graham
gt-proxy 9889 tcp Port for Cable network related data proxy or repeater Dawei Qi Dawei Qi 2010-07-07
gt-proxy 9889 udp Port for Cable network related data proxy or repeater Dawei Qi Dawei Qi 2010-07-07
9890-9897 Unassigned
monkeycom 9898 tcp MonkeyCom Yuji Kuwabara Yuji Kuwabara
monkeycom 9898 udp MonkeyCom Yuji Kuwabara Yuji Kuwabara
9899 tcp Reserved 2013-04-10
sctp-tunneling 9899 udp SCTP TUNNELING IESG IETF Chair 2013-04-10 RFC 6951
iua 9900 tcp IUA Lyndon Ong Lyndon Ong
iua 9900 udp IUA Lyndon Ong Lyndon Ong
iua 9900 sctp IUA Lyndon Ong Lyndon Ong
enrp 9901 udp enrp server channel
enrp-sctp 9901 sctp enrp server channel RFC 5353
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
9903 tcp Reserved
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
9904-9908 Unassigned
domaintime 9909 tcp domaintime Jeffry Dwight Jeffry Dwight
domaintime 9909 udp domaintime Jeffry Dwight Jeffry Dwight
9910 Unassigned
sype-transport 9911 tcp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
sype-transport 9911 udp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
9912-9924 Unassigned
xybrid-cloud 9925 tcp XYBRID Cloud Rx Networks Inc. Drew Davies 2013-04-25
9925 udp Reserved
9926-9949 Unassigned
apc-9950 9950 tcp APC 9950 American Power Conversion American Power Conversion
apc-9950 9950 udp APC 9950 American Power Conversion American Power Conversion
apc-9951 9951 tcp APC 9951 American Power Conversion American Power Conversion
apc-9951 9951 udp APC 9951 American Power Conversion American Power Conversion
apc-9952 9952 tcp APC 9952 American Power Conversion American Power Conversion
apc-9952 9952 udp APC 9952 American Power Conversion American Power Conversion
acis 9953 tcp 9953 Thomas Guth Thomas Guth 2006-01
acis 9953 udp 9953 Thomas Guth Thomas Guth 2006-01
hinp 9954 tcp HaloteC Instrument Network Protocol HaloteC Instruments B.V. Michel Stam 2012-02-07
9954 udp Reserved
alljoyn-stm 9955 tcp Contact Port for AllJoyn standard messaging Qualcomm Innovation Center, Inc. Craig Dowell 2012-03-14
alljoyn-mcm 9955 udp Contact Port for AllJoyn multiplexed constrained messaging Qualcomm Innovation Center, Inc. Craig Dowell 2012-03-14
9956 tcp Reserved
alljoyn 9956 udp Alljoyn Name Service Qualcomm Innovation Center, Inc. Craig Dowell 2011-12-21
9957-9965 Unassigned
odnsp 9966 tcp OKI Data Network Setting Protocol Masato Sato Masato Sato 2006-05
odnsp 9966 udp OKI Data Network Setting Protocol Masato Sato Masato Sato 2006-05
9967-9977 Unassigned
xybrid-rt 9978 tcp XYBRID RT Server Rx Networks Inc. Drew Davies 2013-01-24
9978 udp Reserved
visweather 9979 tcp Valley Information Systems Weather station data Valley Information Systems, Inc. Michael Walsh 2017-05-12
9979 udp Reserved
9980 Unassigned
pumpkindb 9981 tcp Event sourcing database engine with a built-in programming language Eventsourcing, Inc. Yurii Rashkovskii 2017-04-18
9981 udp Reserved
9982-9985 Unassigned
kaostransport 9986 tcp KAOS secure message transport protocol for safety-critical environments KAOS Management Group, LLC Philip Duvalsaint 2025-10-30
9986 udp Reserved
dsm-scm-target 9987 tcp DSM/SCM Target Interface Mike Dyslin Mike Dyslin 2006-08
dsm-scm-target 9987 udp DSM/SCM Target Interface Mike Dyslin Mike Dyslin 2006-08
nsesrvr 9988 tcp Software Essentials Secure HTTP server Narayanan Raju Narayanan Raju 2009-02-05
9988 udp Reserved
9989-9989 Unassigned
osm-appsrvr 9990 tcp OSM Applet Server Vinay Gupta Vinay Gupta 2003-08
osm-appsrvr 9990 udp OSM Applet Server Vinay Gupta Vinay Gupta 2003-08
osm-oev 9991 tcp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
osm-oev 9991 udp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
palace-1 9992 tcp OnLive-1 Douglas Crockford Douglas Crockford
palace-1 9992 udp OnLive-1 Douglas Crockford Douglas Crockford
palace-2 9993 tcp OnLive-2 Douglas Crockford Douglas Crockford
palace-2 9993 udp OnLive-2 Douglas Crockford Douglas Crockford
palace-3 9994 tcp OnLive-3 Douglas Crockford Douglas Crockford
palace-3 9994 udp OnLive-3 Douglas Crockford Douglas Crockford
palace-4 9995 tcp Palace-4 Douglas Crockford Douglas Crockford
palace-4 9995 udp Palace-4 Douglas Crockford Douglas Crockford
palace-5 9996 tcp Palace-5 Douglas Crockford Douglas Crockford
palace-5 9996 udp Palace-5 Douglas Crockford Douglas Crockford
palace-6 9997 tcp Palace-6 Douglas Crockford Douglas Crockford
palace-6 9997 udp Palace-6 Douglas Crockford Douglas Crockford
distinct32 9998 tcp Distinct32 Anoop Tewari Anoop Tewari

Contact Information

Name Organization Contact URI Last Updated
Afkham Azeez azeez&wso2.com 2006-06
American Power Conversion ports&apcc.com 2002-02
Anoop Tewari anoop&next.distinct.com
Craig Dowell Qualcomm Innovation Center, Inc. cdowell&quicinc.com 2011-12-21
Dave Thaler dthaler&microsoft.com
Dawei Qi dqi&galaxytelecomms.com 2010-07-07
Douglas Crockford douglas&crockford.com
Drew Davies Rx Networks Inc. ddavies&rxnetworks.com 2013-01-24
Drew Davies Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25
Erik Andersen era&x500.eu 2019-08-13
Ethan Fremen mindlace&digicool.com
Eventsourcing, Inc. accounts&eventsourcing.com 2017-04-18
Francesco Rosi frosi&orenburg.com 2006-01
HaloteC Instruments B.V. michel.stam&halotec.com 2012-02-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU/TSB (ITU-T Study Group 17) tsbsg17&itu.int 2019-09-30
Jeffry Dwight jeffryd&greyware.com
KAOS Management Group, LLC phil&GotKAOS.com 2025-10-30
Kouichi Takeda KHB05271&nifty.com
Lyndon Ong Lyong&ciena.com
Malcolm Graham Malcolm_Graham&cyborg.com
Masato Sato satou203&oki.com 2006-05
Michael Walsh michael.walsh&valleyinfosys.com 2017-05-12
Michel Stam HaloteC Instruments B.V. michel.stam&halotec.com 2012-02-07
Mike Dyslin mike.dyslin&hp.com 2006-08
Narayanan Raju narayanan.raju&hp.com 2009-02-05
Philip Duvalsaint phil&GotKAOS.com 2025-10-30
Qualcomm Innovation Center, Inc. cdowell&quicinc.com 2011-12-21
Rob Isaac rob&automagic.org 2003-07
Rx Networks Inc. ddavies&rxnetworks.com 2013-01-24
Rx Networks Inc. ddavies&rxnetworks.com 2013-04-25
Sylvain Pedneault sylvain&sypecom.qc.ca 2003-03
Thomas Guth t.guth&zeiss.de 2006-01
Valley Information Systems, Inc. info@valleyinfosys.com> 2017-05-12
Van Jacobson van&ee.lbl.gov
Vinay Gupta vinay.gupta&hp.com 2003-08
Yuji Kuwabara HHG01200&niftyserve.or.jp
Yurii Rashkovskii yrashk&eventsourcing.com 2017-04-18