Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
fksp-audit 3729 tcp Fireking Audit Port [Richard_Thurman] [Richard_Thurman] 2003-04
fksp-audit 3729 udp Fireking Audit Port [Richard_Thurman] [Richard_Thurman] 2003-04
client-ctrl 3730 tcp Client Control [Lawrence_W_Dunn] [Lawrence_W_Dunn] 2003-04
client-ctrl 3730 udp Client Control [Lawrence_W_Dunn] [Lawrence_W_Dunn] 2003-04
m-wnn 3732 tcp Mobile Wnn [Yasunari_Yamashita] [Yasunari_Yamashita] 2003-04
m-wnn 3732 udp Mobile Wnn [Yasunari_Yamashita] [Yasunari_Yamashita] 2003-04
multip-msg 3733 tcp Multipuesto Msg Port [Felisa_Ares] [Felisa_Ares] 2003-04
multip-msg 3733 udp Multipuesto Msg Port [Felisa_Ares] [Felisa_Ares] 2003-04
synel-data 3734 tcp Synel Data Collection Port [David_Ashkenazi] [David_Ashkenazi] 2003-04
synel-data 3734 udp Synel Data Collection Port [David_Ashkenazi] [David_Ashkenazi] 2003-04
rs-rmi 3736 tcp RealSpace RMI [Barry_McDarby] [Barry_McDarby] 2003-04
rs-rmi 3736 udp RealSpace RMI [Barry_McDarby] [Barry_McDarby] 2003-04
launchbird-lm 3739 tcp Launchbird LicenseManager [Tom_Hawkins] [Tom_Hawkins] 2003-04
launchbird-lm 3739 udp Launchbird LicenseManager [Tom_Hawkins] [Tom_Hawkins] 2003-04
cst-port 3742 tcp CST - Configuration & Service Tracker [Hai_Ou_Yang] [Hai_Ou_Yang] 2003-04
cst-port 3742 udp CST - Configuration & Service Tracker [Hai_Ou_Yang] [Hai_Ou_Yang] 2003-04
ipcs-command 3743 tcp IP Control Systems Ltd. [Paul_Anderson] [Paul_Anderson] 2003-04
ipcs-command 3743 udp IP Control Systems Ltd. [Paul_Anderson] [Paul_Anderson] 2003-04
gw-call-port 3745 tcp GWRTC Call Port [Felisa_Ares] [Felisa_Ares] 2003-04
gw-call-port 3745 udp GWRTC Call Port [Felisa_Ares] [Felisa_Ares] 2003-04
linktest-s 3747 tcp LXPRO.COM LinkTest SSL [Greg_Bailey] [Greg_Bailey] 2003-04
linktest-s 3747 udp LXPRO.COM LinkTest SSL [Greg_Bailey] [Greg_Bailey] 2003-04
cbos-ip-port 3750 tcp CBOS/IP ncapsalation port [Thomas_Dannemiller] [Thomas_Dannemiller] 2003-04
cbos-ip-port 3750 udp CBOS/IP ncapsalation port [Thomas_Dannemiller] [Thomas_Dannemiller] 2003-04
gprs-cube 3751 tcp CommLinx GPRS Cube [Peter_Johnson] [Peter_Johnson] 2003-04
gprs-cube 3751 udp CommLinx GPRS Cube [Peter_Johnson] [Peter_Johnson] 2003-04
vipremoteagent 3752 tcp Vigil-IP RemoteAgent [Bryan_Alvord] [Bryan_Alvord] 2003-04
vipremoteagent 3752 udp Vigil-IP RemoteAgent [Bryan_Alvord] [Bryan_Alvord] 2003-04
sas-remote-hlp 3755 tcp SAS Remote Help Server [Gary_T_Ciampa] [Gary_T_Ciampa] 2003-04
sas-remote-hlp 3755 udp SAS Remote Help Server [Gary_T_Ciampa] [Gary_T_Ciampa] 2003-04
canon-capt 3756 tcp Canon CAPT Port [Takashi_Okazawa] [Takashi_Okazawa] 2003-04
canon-capt 3756 udp Canon CAPT Port [Takashi_Okazawa] [Takashi_Okazawa] 2003-04
grf-port 3757 tcp GRF Server Port [Robert_Banfill] [Robert_Banfill] 2003-04
grf-port 3757 udp GRF Server Port [Robert_Banfill] [Robert_Banfill] 2003-04
apw-registry 3758 tcp apw RMI registry [Dan_Davis] [Dan_Davis] 2003-04
apw-registry 3758 udp apw RMI registry [Dan_Davis] [Dan_Davis] 2003-04
exapt-lmgr 3759 tcp Exapt License Manager [Christoph_Kukulies] [Christoph_Kukulies] 2003-04
exapt-lmgr 3759 udp Exapt License Manager [Christoph_Kukulies] [Christoph_Kukulies] 2003-04
gbs-smp 3762 tcp GBS SnapMail Protocol [Eric_Harris_Braun] [Eric_Harris_Braun] 2003-06
gbs-smp 3762 udp GBS SnapMail Protocol [Eric_Harris_Braun] [Eric_Harris_Braun] 2003-06
xo-wave 3763 tcp XO Wave Control Port [Bjorn_Dittmer_Roche] [Bjorn_Dittmer_Roche] 2003-06
xo-wave 3763 udp XO Wave Control Port [Bjorn_Dittmer_Roche] [Bjorn_Dittmer_Roche] 2003-06
mni-prot-rout 3764 tcp MNI Protected Routing [Tim_Behne] [Tim_Behne] 2003-06
mni-prot-rout 3764 udp MNI Protected Routing [Tim_Behne] [Tim_Behne] 2003-06
sitewatch-s 3766 tcp SSL e-watch sitewatch server [e-Watch_Corporation] [John_M_Baird_2] 2014-05-13 this port was previously updated on 2009-06-19
3766 udp Reserved this port was previously updated on 2009-06-19
listmgr-port 3767 tcp ListMGR Port [Takashi_Kubota] [Takashi_Kubota] 2003-06
listmgr-port 3767 udp ListMGR Port [Takashi_Kubota] [Takashi_Kubota] 2003-06
haipe-otnk 3769 tcp HAIPE Network Keying [Mike_Irani_2] [Mike_Irani_2] 2003-06
haipe-otnk 3769 udp HAIPE Network Keying [Mike_Irani_2] [Mike_Irani_2] 2003-06
paging-port 3771 tcp RTP Paging Port [Patrick_Ferriter] [Patrick_Ferriter] 2003-06
paging-port 3771 udp RTP Paging Port [Patrick_Ferriter] [Patrick_Ferriter] 2003-06
dvcprov-port 3776 tcp Device Provisioning Port [Rob_Lehew] [Rob_Lehew] 2003-06
dvcprov-port 3776 udp Device Provisioning Port [Rob_Lehew] [Rob_Lehew] 2003-06
jibe-eb 3777 tcp Jibe EdgeBurst [Chap_Tippin] [Chap_Tippin] 2003-06
jibe-eb 3777 udp Jibe EdgeBurst [Chap_Tippin] [Chap_Tippin] 2003-06
c-h-it-port 3778 tcp Cutler-Hammer IT Port [Thomas_Ruchti] [Thomas_Ruchti] 2003-06
c-h-it-port 3778 udp Cutler-Hammer IT Port [Thomas_Ruchti] [Thomas_Ruchti] 2003-06
abcvoice-port 3781 tcp ABCvoice server port [Carlos_Gonzalez_Roma] [Carlos_Gonzalez_Roma] 2003-06
abcvoice-port 3781 udp ABCvoice server port [Carlos_Gonzalez_Roma] [Carlos_Gonzalez_Roma] 2003-06
iso-tp0s 3782 tcp Secure ISO TP0 port [Herbert_Falk] [Herbert_Falk] 2003-06
iso-tp0s 3782 udp Secure ISO TP0 port [Herbert_Falk] [Herbert_Falk] 2003-06
bim-pem 3783 tcp Impact Mgr./PEM Gateway [Walter_G_Giroir] [Walter_G_Giroir] 2003-07
bim-pem 3783 udp Impact Mgr./PEM Gateway [Walter_G_Giroir] [Walter_G_Giroir] 2003-07
bfd-control 3784 tcp BFD Control Protocol [RFC 5881]
bfd-control 3784 udp BFD Control Protocol [RFC 5881]
bfd-echo 3785 tcp BFD Echo Protocol [RFC 5881]
bfd-echo 3785 udp BFD Echo Protocol [RFC 5881]
isrp-port 3788 tcp SPACEWAY Routing port [Vaibhav_Kumar] [Vaibhav_Kumar] 2003-07
isrp-port 3788 udp SPACEWAY Routing port [Vaibhav_Kumar] [Vaibhav_Kumar] 2003-07
sitewatch 3792 tcp e-Watch Corporation SiteWatch [John_M_Baird] [John_M_Baird] 2003-07
sitewatch 3792 udp e-Watch Corporation SiteWatch [John_M_Baird] [John_M_Baird] 2003-07
spw-dialer 3796 tcp Spaceway Dialer [Patrick_Fisher] [Patrick_Fisher] 2003-07
spw-dialer 3796 udp Spaceway Dialer [Patrick_Fisher] [Patrick_Fisher] 2003-07
radius-dynauth 3799 tcp RADIUS Dynamic Authorization [RFC 3576]
radius-dynauth 3799 udp RADIUS Dynamic Authorization [RFC 3576]
ibm-mgr 3801 tcp ibm manager service [Tim_Hahn] [Tim_Hahn] 2006-03
ibm-mgr 3801 udp ibm manager service [Tim_Hahn] [Tim_Hahn] 2006-03
iqnet-port 3804 tcp Harman IQNet Port [Bruce_Vander_Werf] [Bruce_Vander_Werf] 2004-02
iqnet-port 3804 udp Harman IQNet Port [Bruce_Vander_Werf] [Bruce_Vander_Werf] 2004-02
sun-as-iiops-ca 3808 tcp Sun App Svr-IIOPClntAuth [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
sun-as-iiops-ca 3808 udp Sun App Svr-IIOPClntAuth [Abhijit_Kumar] [Abhijit_Kumar] 2005-11
neto-wol-server 3812 tcp netO WOL Server [Martin_Bestmann_2] [Martin_Bestmann_2] 2004-03
neto-wol-server 3812 udp netO WOL Server [Martin_Bestmann_2] [Martin_Bestmann_2] 2004-03
rap-ip 3813 tcp Rhapsody Interface Protocol [Paul_Zander] [Paul_Zander] 2004-03
rap-ip 3813 udp Rhapsody Interface Protocol [Paul_Zander] [Paul_Zander] 2004-03
neto-dcs 3814 tcp netO DCS [Martin_Bestmann_2] [Martin_Bestmann_2] 2004-03
neto-dcs 3814 udp netO DCS [Martin_Bestmann_2] [Martin_Bestmann_2] 2004-03
sunlps-http 3816 tcp Sun Local Patch Server [Barry_Greenberg] [Barry_Greenberg] 2004-04
sunlps-http 3816 udp Sun Local Patch Server [Barry_Greenberg] [Barry_Greenberg] 2004-04
crinis-hb 3818 tcp Crinis Heartbeat [Eric_McMurry] [Eric_McMurry] 2004-04
crinis-hb 3818 udp Crinis Heartbeat [Eric_McMurry] [Eric_McMurry] 2004-04
epl-slp 3819 tcp EPL Sequ Layer Protocol [Hans_Weibel] [Hans_Weibel] 2004-10
epl-slp 3819 udp EPL Sequ Layer Protocol [Hans_Weibel] [Hans_Weibel] 2004-10
acp-discovery 3822 tcp Compute Pool Discovery
acp-discovery 3822 udp Compute Pool Discovery
acp-conduit 3823 tcp Compute Pool Conduit
acp-conduit 3823 udp Compute Pool Conduit
acp-policy 3824 tcp Compute Pool Policy [Andy_Belk_2] [Andy_Belk_2] 2005-02
acp-policy 3824 udp Compute Pool Policy [Andy_Belk_2] [Andy_Belk_2] 2005-02
neteh-ext 3829 tcp Netadmin Systems Event Handler External [Jonas_Krogell] [Jonas_Krogell] 2007-07-10

Contact Information

ID Name Organization Contact URI Last Updated
[Abhijit_Kumar] Abhijit Kumar mailto:as-iana-ports&sun.com 2005-11
[Andy_Belk_2] Andy Belk mailto:register1&azulsystems.com 2005-02
[Barry_Greenberg] Barry Greenberg mailto:barry.greenberg&sun.com 2004-04
[Barry_McDarby] Barry McDarby mailto:realspace&starwolf.biz 2003-04
[Bjorn_Dittmer_Roche] Bjorn Dittmer-Roche mailto:bjorn&xowave.com 2003-06
[Bruce_Vander_Werf] Bruce Vander Werf mailto:bvanderwerf&crownintl.com 2004-02
[Bryan_Alvord] Bryan Alvord mailto:bryan&vaticor.com 2003-04
[Carlos_Gonzalez_Roma] Carlos Gonzalez-Roman Ferrer mailto:iana&abcdatos.com 2003-06
[Chap_Tippin] Chap Tippin mailto:chad.tippin&jibeinc.com 2003-06
[Christoph_Kukulies] Christoph Kukulies mailto:info&exapt.de 2003-04
[Dan_Davis] Dan Davis mailto:Dan.A.Davis&hp.com 2003-04
[David_Ashkenazi] David Ashkenazi mailto:david&synel.co.il 2010-03-23
[e-Watch_Corporation] e-Watch Corporation mailto:jbaird&e-watch.com 2014-05-13
[Eric_Harris_Braun] Eric Harris-Braun mailto:eric&glassbead.com 2003-06
[Eric_McMurry] Eric McMurry mailto:emcmurry&crinisnetworks.com 2004-04
[Felisa_Ares] Felisa Ares mailto:faa06&tid.es 2003-04
[Gary_T_Ciampa] Gary T. Ciampa mailto:Gary.Ciampa&sas.com 2003-04
[Greg_Bailey] Greg Bailey mailto:gbailey&lxpro.com 2003-04
[Hai_Ou_Yang] Hai Ou-Yang mailto:hai.ou-yang&sun.com 2003-04
[Hans_Weibel] Hans Weibel mailto:hans.weibel&zhwin.ch 2004-10
[Herbert_Falk] Herbert Falk mailto:herb&sisconet.com 2003-06
[John_M_Baird] John M. Baird mailto:jbaird&e-watch.com 2003-07
[John_M_Baird_2] John M Baird e-Watch Corporation mailto:jbaird&e-watch.com 2014-05-13
[Jonas_Krogell] Jonas Krogell mailto:jonas.krogell&netadmin.se 2007-07-10
[Lawrence_W_Dunn] Lawrence W. Dunn mailto:larrydunn&aptcomp.com 2003-04
[Martin_Bestmann_2] Martin Bestmann mailto:martin&no.netopia.com 2004-03
[Mike_Irani_2] Mike Irani mailto:irani&spawar.navy.mil 2003-06
[Patrick_Ferriter] Patrick Ferriter mailto:Patrick.Ferriter&zultys.com 2003-06
[Patrick_Fisher] Patrick Fisher mailto:pfisher&hns.com 2004-12
[Paul_Anderson] Paul Anderson mailto:paul.anderson&ip-cs.com 2003-04
[Paul_Zander] Paul Zander Philips CFT mailto:p.j.zander&philips.com 2004-03
[Peter_Johnson] Peter Johnson mailto:peter&commlinx.com.au 2004-11
[Richard_Thurman] Richard Thurman mailto:richt&fireking.com 2003-04
[Rob_Lehew] Rob Lehew mailto:rlehew&microsoft.com 2003-06
[Robert_Banfill] Robert Banfill mailto:robert&banfill.net 2003-04
[Takashi_Kubota] Takashi Kubota mailto:kubota.takashi&pfu.fugitsu.com 2003-06
[Takashi_Okazawa] Takashi Okazawa mailto:okazawa.takashi&canon.co.jp 2003-04
[Thomas_Dannemiller] Thomas Dannemiller mailto:tom.dannemiller&rolls-royce.com 2003-04
[Thomas_Ruchti] Thomas Ruchti mailto:thomasmruchti&eaton.com 2003-06
[Tim_Behne] Tim Behne mailto:timothyb&microwavenetworks.com 2003-06
[Tim_Hahn] Tim Hahn mailto:hahnt&us.ibm.com 2006-03
[Tom_Hawkins] Tom Hawkins mailto:tom1&launchbird.com 2003-04
[Vaibhav_Kumar] Vaibhav Kumar mailto:vakumar&hns.com 2003-07
[Walter_G_Giroir] Walter G. Giroir mailto:walt_giroir&bmc.com 2003-07
[Yasunari_Yamashita] Yasunari Yamashita mailto:yamasita&omronsoft.co.jp 2003-04