Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| embrace-dp-c | 3198 | tcp | Embrace Device Protocol Client | Elliot Schwartz | Elliot Schwartz | ||||||
| embrace-dp-c | 3198 | udp | Embrace Device Protocol Client | Elliot Schwartz | Elliot Schwartz | ||||||
| dmod-workspace | 3199 | tcp | DMOD WorkSpace | Nick Plante | Nick Plante | ||||||
| dmod-workspace | 3199 | udp | DMOD WorkSpace | Nick Plante | Nick Plante | ||||||
| cpq-tasksmart | 3201 | tcp | CPQ-TaskSmart | Jackie Lau | Jackie Lau | ||||||
| cpq-tasksmart | 3201 | udp | CPQ-TaskSmart | Jackie Lau | Jackie Lau | ||||||
| isns | 3205 | tcp | iSNS Server Port | RFC 4171 | |||||||
| isns | 3205 | udp | iSNS Server Port | RFC 4171 | |||||||
| flamenco-proxy | 3210 | tcp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| flamenco-proxy | 3210 | udp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| avsecuremgmt | 3211 | tcp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| avsecuremgmt | 3211 | udp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| surveyinst | 3212 | tcp | Survey Instrument | Al Amet | Al Amet | ||||||
| surveyinst | 3212 | udp | Survey Instrument | Al Amet | Al Amet | ||||||
| neon24x7 | 3213 | tcp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| neon24x7 | 3213 | udp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| jmq-daemon-1 | 3214 | tcp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-1 | 3214 | udp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-2 | 3215 | tcp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| jmq-daemon-2 | 3215 | udp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| ferrari-foam | 3216 | tcp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| ferrari-foam | 3216 | udp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| unite | 3217 | tcp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| unite | 3217 | udp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| smartpackets | 3218 | tcp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| smartpackets | 3218 | udp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| wms-messenger | 3219 | tcp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| wms-messenger | 3219 | udp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| xnm-clear-text | 3221 | tcp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| xnm-clear-text | 3221 | udp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| fcip-port | 3225 | tcp | FCIP | RFC 3821 | |||||||
| fcip-port | 3225 | udp | FCIP | RFC 3821 | |||||||
| vidigo | 3231 | tcp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| vidigo | 3231 | udp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| sysorb | 3241 | tcp | SysOrb Monitoring Server | Jakob Oestergaard | Jakob Oestergaard | 2002-02 | |||||
| sysorb | 3241 | udp | SysOrb Monitoring Server | Jakob Oestergaard | Jakob Oestergaard | 2002-02 | |||||
| sysscanner | 3251 | tcp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| sysscanner | 3251 | udp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| iscsi-target | 3260 | tcp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi-target | 3260 | udp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| winshadow | 3261 | tcp | winShadow | Colin Barry | Colin Barry | ||||||
| winshadow | 3261 | udp | winShadow | Colin Barry | Colin Barry | ||||||
| csoft-prev | 3271 | tcp | CSoft Prev Port | Nedelcho Stanev | Nedelcho Stanev | ||||||
| csoft-prev | 3271 | udp | CSoft Prev Port | Nedelcho Stanev | Nedelcho Stanev | ||||||
| sysopt | 3281 | tcp | SYSOPT | Tony Hoffman | Tony Hoffman | ||||||
| sysopt | 3281 | udp | SYSOPT | Tony Hoffman | Tony Hoffman | ||||||
| sah-lm | 3291 | tcp | S A Holditch & Associates - LM | Randy Hudgens | Randy Hudgens | ||||||
| sah-lm | 3291 | udp | S A Holditch & Associates - LM | Randy Hudgens | Randy Hudgens | ||||||
| tarantool | 3301 | tcp | Tarantool in-memory computing platform | Tarantool | Alexander Turenko | 2022-06-10 | Known Unauthorized Use on port 3301 | ||||
| tarantool | 3301 | udp | Tarantool in-memory computing platform | Tarantool | Alexander Turenko | 2022-06-10 | Known Unauthorized Use on port 3301 | ||||
| dyna-access | 3310 | tcp | Dyna Access | Dave Belliveau | Dave Belliveau | ||||||
| dyna-access | 3310 | udp | Dyna Access | Dave Belliveau | Dave Belliveau | ||||||
| mcns-tel-ret | 3311 | tcp | MCNS Tel Ret | Randall Atkinson | Randall Atkinson | ||||||
| mcns-tel-ret | 3311 | udp | MCNS Tel Ret | Randall Atkinson | Randall Atkinson | ||||||
| appman-server | 3312 | tcp | Application Management Server | ||||||||
| appman-server | 3312 | udp | Application Management Server | ||||||||
| uorb | 3313 | tcp | Unify Object Broker | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| uorb | 3313 | udp | Unify Object Broker | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| uohost | 3314 | tcp | Unify Object Host | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| uohost | 3314 | udp | Unify Object Host | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| cdid | 3315 | tcp | CDID | Andrew Borisov | Andrew Borisov | ||||||
| cdid | 3315 | udp | CDID | Andrew Borisov | Andrew Borisov | ||||||
| aicc-cmi | 3316 | tcp | AICC/CMI | William McDonald | William McDonald | ||||||
| aicc-cmi | 3316 | udp | AICC/CMI | William McDonald | William McDonald | ||||||
| vsaiport | 3317 | tcp | VSAI PORT | Rieko Asai | Rieko Asai | ||||||
| vsaiport | 3317 | udp | VSAI PORT | Rieko Asai | Rieko Asai | ||||||
| ssrip | 3318 | tcp | Swith to Swith Routing Information Protocol | Baba Hidekazu | Baba Hidekazu | ||||||
| ssrip | 3318 | udp | Swith to Swith Routing Information Protocol | Baba Hidekazu | Baba Hidekazu | ||||||
| sdt-lmd | 3319 | tcp | SDT License Manager | Salvo Nassisi | Salvo Nassisi | ||||||
| sdt-lmd | 3319 | udp | SDT License Manager | Salvo Nassisi | Salvo Nassisi | ||||||
| vnsstr | 3321 | tcp | VNSSTR | Takeshi Ohmura | Takeshi Ohmura | ||||||
| vnsstr | 3321 | udp | VNSSTR | Takeshi Ohmura | Takeshi Ohmura | ||||||
| mcs-messaging | 3331 | tcp | MCS Messaging | ||||||||
| mcs-messaging | 3331 | udp | MCS Messaging | ||||||||
| anet-h | 3341 | tcp | OMF data h | Per Sahlqvist | Per Sahlqvist | ||||||
| anet-h | 3341 | udp | OMF data h | Per Sahlqvist | Per Sahlqvist | ||||||
| btrieve | 3351 | tcp | Btrieve port | ||||||||
| btrieve | 3351 | udp | Btrieve port | ||||||||
| kv-agent | 3361 | tcp | KV Agent | Thomas Soranno | Thomas Soranno | ||||||
| kv-agent | 3361 | udp | KV Agent | Thomas Soranno | Thomas Soranno | ||||||
| satvid-datalnk | 3367-3371 | Satellite Video Data Link | Scott Engel | Scott Engel | |||||||
| geneous | 3381 | tcp | Geneous | Nick de Smith | Nick de Smith | ||||||
| geneous | 3381 | udp | Geneous | Nick de Smith | Nick de Smith | ||||||
| savant | 3391 | tcp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| savant | 3391 | udp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| d2k-tapestry1 | 3393 | tcp | D2K Tapestry Client to Server | ||||||||
| d2k-tapestry1 | 3393 | udp | D2K Tapestry Client to Server | ||||||||
| filecast | 3401 | tcp | filecast | Eden Sherry | Eden Sherry | ||||||
| filecast | 3401 | udp | filecast | Eden Sherry | Eden Sherry | ||||||
| nokia-ann-ch1 | 3405 | tcp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch1 | 3405 | udp | Nokia Announcement ch 1 | ||||||||
| networklenss | 3410 | tcp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| networklenss | 3410 | udp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| biolink-auth | 3411 | tcp | BioLink Authenteon server | BioLink Support | BioLink Support | 2002-02 | |||||
| biolink-auth | 3411 | udp | BioLink Authenteon server | BioLink Support | BioLink Support | 2002-02 | |||||
| xmlblaster | 3412 | tcp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| xmlblaster | 3412 | udp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| svnet | 3413 | tcp | SpecView Networking | Richard Dickins | Richard Dickins | 2002-02 | |||||
| svnet | 3413 | udp | SpecView Networking | Richard Dickins | Richard Dickins | 2002-02 |