Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| acmsoda | 6969 | tcp | acmsoda | Daniel Simms | Daniel Simms | ||||||
| acmsoda | 6969 | udp | acmsoda | Daniel Simms | Daniel Simms | ||||||
| conductor | 6970 | tcp | Conductor test coordination protocol | George Neville-Neil | George Neville-Neil | 2014-09-18 | |||||
| 6970 | udp | Reserved | |||||||||
| conductor-mpx | 6970 | sctp | conductor for multiplex | George Neville-Neil | George Neville-Neil | 2014-07-29 | |||||
| 6971-6979 | Unassigned | ||||||||||
| 6980 | tcp | Reserved | |||||||||
| qolyester | 6980 | udp | QoS-extended OLSR protocol | Green Communications SAS | Ignacy Gawedzki | 2022-05-24 | |||||
| 6981-6996 | Unassigned | ||||||||||
| MobilitySrv | 6997 | tcp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| MobilitySrv | 6997 | udp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| iatp-highpri | 6998 | tcp | IATP-highPri | John Murphy | John Murphy | ||||||
| iatp-highpri | 6998 | udp | IATP-highPri | John Murphy | John Murphy | ||||||
| iatp-normalpri | 6999 | tcp | IATP-normalPri | John Murphy | John Murphy | ||||||
| iatp-normalpri | 6999 | udp | IATP-normalPri | John Murphy | John Murphy | ||||||
| afs3-errors | 7006 | tcp | error interpretation service | ||||||||
| afs3-errors | 7006 | udp | error interpretation service | ||||||||
| spg | 7016 | tcp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| spg | 7016 | udp | SPG Controls Carrier | SPG Controls Ltd | Steve Barton | 2017-03-27 | |||||
| loreji-panel | 7026 | tcp | Loreji Webhosting Panel | J.A. Smit | DALTCORE | 2018-02-21 | |||||
| 7026 | udp | Reserved | |||||||||
| 7041-7069 | Unassigned | ||||||||||
| 7096-7098 | Unassigned | ||||||||||
| 7102-7106 | Unassigned | ||||||||||
| 7108-7116 | Unassigned | ||||||||||
| 7130-7160 | Unassigned | ||||||||||
| cabsm-comm | 7161 | tcp | CA BSM Comm | Chun-Ho Chang | Chun-Ho Chang | 2004-11 | |||||
| cabsm-comm | 7161 | udp | CA BSM Comm | Chun-Ho Chang | Chun-Ho Chang | 2004-11 | |||||
| caistoragemgr | 7162 | tcp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| caistoragemgr | 7162 | udp | CA Storage Manager | Emre Tunar | Emre Tunar | 2004-11 | |||||
| cacsambroker | 7163 | tcp | CA Connection Broker | David Roberts | David Roberts | 2005-05 | |||||
| cacsambroker | 7163 | udp | CA Connection Broker | David Roberts | David Roberts | 2005-05 | |||||
| fsr | 7164 | tcp | File System Repository Agent | Micha Ben-Efraim | Micha Ben-Efraim | 2007-07-19 | |||||
| fsr | 7164 | udp | File System Repository Agent | Micha Ben-Efraim | Micha Ben-Efraim | 2007-07-19 | |||||
| doc-server | 7165 | tcp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| doc-server | 7165 | udp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| aruba-server | 7166 | tcp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| aruba-server | 7166 | udp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| casrmagent | 7167 | tcp | CA SRM Agent | Venkata Krishna | Venkata Krishna | 2010-02-24 | |||||
| 7167 | udp | Reserved | |||||||||
| cnckadserver | 7168 | tcp | cncKadServer DB & Inventory Services | Micha Ben-Efraim | Micha Ben-Efraim | 2011-01-31 | |||||
| 7168 | udp | Reserved | |||||||||
| ccag-pib | 7169 | tcp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| ccag-pib | 7169 | udp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| PS-Capture-Pro | 7216 | tcp | PaperStream Capture Professional | PFU Systems Inc. | Hari Asuri | 2016-02-26 | |||||
| 7216 | udp | Reserved | |||||||||
| 7217-7226 | Unassigned | ||||||||||
| display | 7236 | tcp | Wi-Fi Alliance Wi-Fi Display Protocol | Wi-Fi Alliance | Thomas Sciorilli | 2012-04-09 | Defined TXT keys: _display.tcp. Display Protocol | ||||
| 7236 | udp | Reserved | |||||||||
| 7245-7261 | Unassigned | ||||||||||
| cnap | 7262 | tcp | Calypso Network Access Protocol | Frontrow Calypso, LLC | Scott Halberg | 2009-06-02 | |||||
| cnap | 7262 | udp | Calypso Network Access Protocol | Frontrow Calypso, LLC | Scott Halberg | 2009-06-02 | |||||
| 7263-7271 | Unassigned | ||||||||||
| oma-ilp | 7276 | tcp | OMA Internal Location Protocol | Khiem Tran | Khiem Tran | 2007-11-06 | |||||
| oma-ilp | 7276 | udp | OMA Internal Location Protocol | Khiem Tran | Khiem Tran | 2007-11-06 | |||||
| 7360-7364 | Unassigned | 2006-02-06 | |||||||||
| lcm-server | 7365 | tcp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| lcm-server | 7365 | udp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| 7366-7390 | Unassigned | 2006-02-06 | |||||||||
| 7396 | Unassigned | ||||||||||
| pmdmgr | 7426 | tcp | OpenView DM Postmaster Manager | Dave Lamb | Dave Lamb | ||||||
| pmdmgr | 7426 | udp | OpenView DM Postmaster Manager | Dave Lamb | Dave Lamb | ||||||
| 7432-7436 | Unassigned | ||||||||||
| cfs | 7546 | tcp | Cisco Fabric service | Rituparna Agrawal | Rituparna Agrawal | 2005-09 | |||||
| cfs | 7546 | udp | Cisco Fabric service | Rituparna Agrawal | Rituparna Agrawal | 2005-09 | |||||
| sncp | 7560 | tcp | Sniffer Command Protocol | Dominick Cafarelli | Dominick Cafarelli | 2005-08 | |||||
| sncp | 7560 | udp | Sniffer Command Protocol | Dominick Cafarelli | Dominick Cafarelli | 2005-08 | |||||
| 7561-7562 | Unassigned | ||||||||||
| cfw | 7563 | tcp | Control Framework | RFC 6230 | |||||||
| 7563 | udp | Reserved | |||||||||
| 7564-7565 | Unassigned | ||||||||||
| vsi-omega | 7566 | tcp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| vsi-omega | 7566 | udp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| 7567-7568 | Unassigned | ||||||||||
| dell-eql-asm | 7569 | tcp | Dell EqualLogic Host Group Management | James E. King, III | James E. King, III | ||||||
| 7569 | udp | Reserved | |||||||||
| 7576-7587 | Unassigned | ||||||||||
| 7589-7605 | Unassigned | ||||||||||
| mipi-debug | 7606 | tcp | MIPI Alliance Debug | Mipi Alliance | Peter Lefkin | 2016-02-26 | |||||
| mipi-debug | 7606 | udp | MIPI Alliance Debug | Mipi Alliance | Peter Lefkin | 2016-02-26 | |||||
| 7607-7623 | Unassigned | ||||||||||
| indi | 7624 | tcp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| indi | 7624 | udp | Instrument Neutral Distributed Interface | Elwood Downey | Elwood Downey | 2002-04 | |||||
| 7625 | Unassigned | ||||||||||
| simco | 7626 | tcp | SImple Middlebox COnfiguration (SIMCO) Server | RFC 4540 | |||||||
| 7626 | udp | De-registered | 2006-01-30 | ||||||||
| simco | 7626 | sctp | SImple Middlebox COnfiguration (SIMCO) | Sebastian Kiesel | Sebastian Kiesel | 2006-01 | |||||
| soap-http | 7627 | tcp | SOAP Service Port | Donald Dylla | Donald Dylla | 2004-12 | |||||
| soap-http | 7627 | udp | SOAP Service Port | Donald Dylla | Donald Dylla | 2004-12 | |||||
| zen-pawn | 7628 | tcp | Primary Agent Work Notification | Ty Ellis | Ty Ellis | 2006-05 | |||||
| zen-pawn | 7628 | udp | Primary Agent Work Notification | Ty Ellis | Ty Ellis | 2006-05 | |||||
| xdas | 7629 | tcp | OpenXDAS Wire Protocol | John Calcote | John Calcote | 2006-10 | |||||
| xdas | 7629 | udp | OpenXDAS Wire Protocol | John Calcote | John Calcote | 2006-10 | |||||
| hawk | 7630 | tcp | HA Web Konsole | Tim Serong | Tim Serong | 2010-03-31 | |||||
| 7630 | udp | Reserved | |||||||||
| tesla-sys-msg | 7631 | tcp | TESLA System Messaging | Andy Perreault | Andy Perreault | 2010-03-31 | |||||
| 7631 | udp | Reserved | |||||||||
| 7632 | Unassigned | ||||||||||
| pmdfmgt | 7633 | tcp | PMDF Management | Hunter Goatley | Hunter Goatley | ||||||
| pmdfmgt | 7633 | udp | PMDF Management | Hunter Goatley | Hunter Goatley | ||||||
| 7634-7647 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andy Perreault | aperreault&erlphase.com | 2010-03-31 | |
| Chun-Ho Chang | chun-ho.chang&ca.com | 2004-11 | |
| Curtis Smith | curtis.smith&vsin.com | ||
| DALTCORE | Info&daltcore.com | 2018-02-21 | |
| Daniel Simms | dsimms&acm.uiuc.edu | ||
| Dave Lamb | rdl&rdl.cnd.hp.com | ||
| David Roberts | David.Roberts&ca.com | 2005-05 | |
| Dominick Cafarelli | dominick.cafarelli&networkgeneral.com | 2005-08 | |
| Donald Dylla | donald.dylla&hp.com | 2004-12 | |
| Elwood Downey | ecdowney&clearskyinstitute.com | 2002-04 | |
| Emre Tunar | emre.tunar&ca.com | 2004-11 | |
| Frank Goenninger | frank.goenninger&consequor.de | 2010-02-22 | |
| Frontrow Calypso, LLC | eng&gofrontrow.com | 2016-04-13 | |
| George Neville-Neil | gnn&neville-neil.com | 2014-07-29 | |
| Green Communications SAS | contact&green-communications.fr | 2022-05-24 | |
| Hari Asuri | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Hunter Goatley | goathunter&goatley.com | ||
| Ignacy Gawedzki | Green Communications SAS | ignacy.gawedzki&green-communications.fr | 2022-05-24 |
| J.A. Smit | rsmit&daltcore.com | 2018-02-21 | |
| James Bottomley | James.Bottomley&steeleye.com | 2006-02 | |
| James E. King, III | James_E_K&dell.com | 2010-06-24 | |
| John Calcote | jcalcote&novell.com | 2006-10 | |
| John Murphy | john.m.murphy&mci.com | ||
| Joseph T Savarese | joesa&nmwco.com | 2007-06 | |
| Khiem Tran | Khiem.Tran&andrew.com | 2007-11-06 | |
| Micha Ben-Efraim | benmi07&ca.com | 2008-01-07 | |
| Micha Ben-Efraim | micha&metalix.net | 2011-01-31 | |
| Mipi Alliance | secretary&mipi.org | 2016-02-26 | |
| Peter Lefkin | peter.lefkin&mipi.org | 2016-02-26 | |
| PFU Systems Inc. | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Rituparna Agrawal | riagrawa&cisco.com | 2005-09 | |
| Scott Halberg | slh&gofrontrow.com | 2016-04-13 | |
| Sebastian Kiesel | kiesel&ikr.uni-stuttgart.de | 2006-01 | |
| SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 | |
| Steve Barton | SPG Controls Ltd | steveb&spgcontrols.com | 2017-03-27 |
| Thomas Sciorilli | Wi-Fi Alliance | tsciorilli&wi-fi.org | 2012-04-09 |
| Tim Serong | tserong&novell.com | 2010-03-31 | |
| Ty Ellis | tellis&novell.com | 2006-05 | |
| Venkata Krishna | VenkataKrishna.Bezawada&ca.com | 2010-02-24 | |
| Wi-Fi Alliance | certifications&wi-fi.org | 2012-04-09 |