Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 8075-8076 | Unassigned | ||||||||||
| 8077 | tcp | Reserved | 2024-01-05 | De-Assigned on 2024-01-05. | |||||||
| 8077 | udp | Reserved | |||||||||
| 8078-8079 | Unassigned | ||||||||||
| simplifymedia | 8087 | tcp | Simplify Media SPP Protocol | Emmanuel Saint-Loubert | Emmanuel Saint-Loubert | 2008-08-08 | |||||
| simplifymedia | 8087 | udp | Simplify Media SPP Protocol | Emmanuel Saint-Loubert | Emmanuel Saint-Loubert | 2008-08-08 | |||||
| sac | 8097 | tcp | SAC Port Id | Girish Bhat | Girish Bhat | 2006-04 | |||||
| sac | 8097 | udp | SAC Port Id | Girish Bhat | Girish Bhat | 2006-04 | |||||
| purityrpc | 8117 | tcp | Purity replication clustering and remote management | Pure Storage | Steve Hodgson | 2013-08-13 | |||||
| 8117 | udp | Reserved | |||||||||
| 8123-8127 | Unassigned | ||||||||||
| 8141-8147 | Unassigned | ||||||||||
| lm-sserver | 8207 | tcp | LM SServer | Chris Flynn | Chris Flynn | ||||||
| lm-sserver | 8207 | udp | LM SServer | Chris Flynn | Chris Flynn | ||||||
| hncp-udp-port | 8231 | udp | HNCP | IESG | IETF Chair | 2016-01-13 | RFC 7788 | ||||
| hncp-dtls-port | 8232 | udp | HNCP over DTLS | IESG | IETF Chair | 2016-01-13 | RFC 7788 | ||||
| 8267-8269 | Unassigned | ||||||||||
| robot-remote | 8270 | tcp | Robot Framework Remote Library Interface | Robot Framework Foundation | Chris Newman | 2017-01-26 | |||||
| 8270 | udp | Reserved | |||||||||
| 8271-8275 | Unassigned | ||||||||||
| ms-mcc | 8276 | tcp | Microsoft Connected Cache | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| ms-mcc | 8276 | udp | Microsoft Connected Cache | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| 8277-8279 | Unassigned | ||||||||||
| 8352-8375 | Unassigned | ||||||||||
| cruise-enum | 8376 | tcp | Cruise ENUM | Steve Husak | Steve Husak | ||||||
| cruise-enum | 8376 | udp | Cruise ENUM | Steve Husak | Steve Husak | ||||||
| cruise-swroute | 8377 | tcp | Cruise SWROUTE | Steve Husak | Steve Husak | ||||||
| cruise-swroute | 8377 | udp | Cruise SWROUTE | Steve Husak | Steve Husak | ||||||
| cruise-config | 8378 | tcp | Cruise CONFIG | Steve Husak | Steve Husak | ||||||
| cruise-config | 8378 | udp | Cruise CONFIG | Steve Husak | Steve Husak | ||||||
| cruise-diags | 8379 | tcp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| cruise-diags | 8379 | udp | Cruise DIAGS | Steve Husak | Steve Husak | ||||||
| espeech-rtp | 8417 | tcp | eSpeech RTP Protocol | Scott Tarone | Scott Tarone | 2003-04 | |||||
| espeech-rtp | 8417 | udp | eSpeech RTP Protocol | Scott Tarone | Scott Tarone | 2003-04 | |||||
| 8446-8447 | Unassigned | ||||||||||
| nexentamv | 8457 | tcp | Nexenta Management GUI | John S. Howard | Andrew Galloway | 2012-12-07 | |||||
| 8457 | udp | Reserved | |||||||||
| cisco-avp | 8470 | tcp | Cisco Address Validation Protocol | Cullen Jennings | Cullen Jennings | 2009-02-13 | |||||
| 8470 | udp | Reserved | |||||||||
| pim-port | 8471 | tcp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8471 | udp | Reserved | |||||||||
| otv | 8472 | tcp | Overlay Transport Virtualization (OTV) | Dino Farinacci | Dino Farinacci | 2008-01-07 | |||||
| otv | 8472 | udp | Overlay Transport Virtualization (OTV) | Dino Farinacci | Dino Farinacci | 2008-01-07 | |||||
| vp2p | 8473 | tcp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| vp2p | 8473 | udp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| noteshare | 8474 | tcp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| noteshare | 8474 | udp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| 8475-8499 | Unassigned | ||||||||||
| lsp-self-ping | 8503 | udp | MPLS LSP Self-Ping | IESG | IETF Chair | 2015-06-11 | 2016-02-01 | RFC 7746 | |||
| dof-tunnel | 8567 | tcp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| dof-tunnel | 8567 | udp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| 8616-8664 | Unassigned | Unauthorized Use Known on ports 8616 and 8617 | |||||||||
| 8667 | Unassigned | ||||||||||
| 8669-8674 | Unassigned | ||||||||||
| msi-cps-rm | 8675 | tcp | Motorola Solutions Customer Programming Software for Radio Management | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| msi-cps-rm-disc | 8675 | udp | Motorola Solutions Customer Programming Software for Radio Management Discovery | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| 8676-8685 | Unassigned | ||||||||||
| 8687 | Unassigned | ||||||||||
| 8700-8709 | Unassigned | ||||||||||
| semi-grpc | 8710 | tcp | gRPC for SEMI Standards implementations | SEMI | Albert Fuchigami | 2020-01-10 | |||||
| 8710 | udp | Reserved | |||||||||
| nvc | 8711 | tcp | Nuance Voice Control | Nuance Communications | Diego Negre | 2012-10-05 | |||||
| 8711 | udp | Reserved | |||||||||
| 8712-8731 | Unassigned | ||||||||||
| 8732 | tcp | Reserved | |||||||||
| dtp-net | 8732 | udp | DASGIP Net Services | Dr. Matthias Arnold | Dr. Matthias Arnold | 2009-03-23 | |||||
| ibus | 8733 | tcp | iBus | Silvano Maffeis | Silvano Maffeis | ||||||
| ibus | 8733 | udp | iBus | Silvano Maffeis | Silvano Maffeis | ||||||
| 8734-8749 | Unassigned | ||||||||||
| dey-keyneg | 8750 | tcp | DEY Storage Key Negotiation | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 8750 | udp | Reserved | |||||||||
| 8751-8762 | Unassigned | ||||||||||
| mc-appserver | 8763 | tcp | MC-APPSERVER | Romeo Kasanwidjojo | Romeo Kasanwidjojo | ||||||
| mc-appserver | 8763 | udp | MC-APPSERVER | Romeo Kasanwidjojo | Romeo Kasanwidjojo | ||||||
| openqueue | 8764 | tcp | OPENQUEUE | Matt Jensen | Matt Jensen | ||||||
| openqueue | 8764 | udp | OPENQUEUE | Matt Jensen | Matt Jensen | ||||||
| ultraseek-http | 8765 | tcp | Ultraseek HTTP | Walter Underwood | Walter Underwood | ||||||
| ultraseek-http | 8765 | udp | Ultraseek HTTP | Walter Underwood | Walter Underwood | ||||||
| amcs | 8766 | tcp | Agilent Connectivity Service | Keysight Technologies, Inc. | Tom Fay | 2013-01-16 | 2016-09-12 | ||||
| amcs | 8766 | udp | Agilent Connectivity Service | Keysight Technologies, Inc. | Tom Fay | 2013-01-16 | 2016-09-12 | ||||
| core-of-source | 8767 | tcp | Online mobile multiplayer game | Alt Solve Sdn Bhd | Almaz Hong | 2019-07-24 | |||||
| 8767 | udp | Reserved | |||||||||
| sandpolis | 8768 | tcp | Sandpolis Server | Tyler Cook | Tyler Cook | 2019-11-22 | |||||
| 8768 | udp | Reserved | |||||||||
| oktaauthenticat | 8769 | tcp | Okta MultiPlatform Access Mgmt for Cloud Svcs | Okta Inc | Tom Belote | 2019-12-19 | |||||
| 8769 | udp | Reserved | |||||||||
| dpap | 8770 | tcp | Digital Photo Access Protocol (iPhoto) | Amandeep Jawa | Amandeep Jawa | 2004-11 | Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password | ||||
| dpap | 8770 | udp | Digital Photo Access Protocol (iPhoto) | Amandeep Jawa | Amandeep Jawa | 2004-11 | Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password | ||||
| 8771-8777 | Unassigned | ||||||||||
| uec | 8778 | tcp | Stonebranch Universal Enterprise Controller | Stonebranch, Inc. | Nathan Hammond | 2013-06-25 | |||||
| 8778 | udp | Reserved | |||||||||
| 8779-8785 | Unassigned | ||||||||||
| msgclnt | 8786 | tcp | Message Client | Michael O'Brien | Michael O'Brien | 2003-03 | |||||
| msgclnt | 8786 | udp | Message Client | Michael O'Brien | Michael O'Brien | 2003-03 | |||||
| msgsrvr | 8787 | tcp | Message Server | Michael O'Brien | Michael O'Brien | 2003-03 | |||||
| msgsrvr | 8787 | udp | Message Server | Michael O'Brien | Michael O'Brien | 2003-03 | |||||
| 8788-8792 | Unassigned | ||||||||||
| acd-pm | 8793 | tcp | Accedian Performance Measurement | Marco Mascitto | Marco Mascitto | ||||||
| acd-pm | 8793 | udp | Accedian Performance Measurement | Marco Mascitto | Marco Mascitto | ||||||
| 8794-8799 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Fuchigami | albert.fuchigami&peergroup.com | 2020-01-10 | |
| Almaz Hong | almaz.hong&altsolve.com | 2019-07-24 | |
| Alt Solve Sdn Bhd | support&altsolve.com | 2019-07-24 | |
| Amandeep Jawa | dpap&apple.com | 2004-11 | |
| Andrew Galloway | Nexenta | andrew.galloway&nexenta.com | 2012-12-07 |
| Bryant Eastham | OenDOF | protocol&opendof.org | 2015-04-23 |
| Chris Flynn | cflynn&landmark.com | ||
| Chris Newman | chris.newman&oracle.com | 2017-01-26 | |
| Cullen Jennings | fluffy&cisco.com | 2010-02-03 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Diego Negre | Nuance Communications | Diego.Negre&nuance.com | 2012-10-05 |
| Dino Farinacci | dino&cisco.com | 2008-08-21 | |
| Dr. Matthias Arnold | m.arnold&dasgip.de | 2009-03-23 | |
| Emmanuel Saint-Loubert | emmanuel&simplifymedia.com | 2008-08-08 | |
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| Girish Bhat | gbhat&cranite.com | 2006-04 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jenish Amin | Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 |
| Jerome Grimbert | jerome.grimbert&atosorigin.com | ||
| Keysight Technologies, Inc. | iana.contact&keysight.com | 2016-09-12 | |
| Marco Mascitto | mmascitto&accedian.com | 2011-06-28 | |
| Matt Jensen | mattj&newsblip.com | ||
| Michael McNabb | michael&aquaminds.com | 2005-10 | |
| Michael O'Brien | mobrien03&gmail.com | 2020-05-11 | |
| Microsoft Corporation | naenglerµsoft.com | 2022-05-03 | |
| Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 | |
| Narkis Engler | Microsoft Corporation | naenglerµsoft.com | 2022-05-03 |
| Nathan Hammond | Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 |
| John S. Howard | Nexenta | jsh&nexenta.com | 2012-12-07 |
| Nuance Communications | NOD_SolutionsArchitecture&nuance.com | 2012-10-05 | |
| Okta Inc | tbelote&okta.com | 2019-12-19 | |
| OpenDOF | protocol&opendof.org | 2015-04-23 | |
| Pure Storage | iana&purestorage.com | 2016-04-04 | |
| Robot Framework Foundation | robotframework-foundation&googlegroups.com | 2017-01-26 | |
| Romeo Kasanwidjojo | romeoµcomgroup.com | ||
| Scott Tarone | starone&proactivethought.com | 2003-04 | |
| SEMI | jamano&semi.org | 2020-01-10 | |
| Silvano Maffeis | maffeis&softwired.ch | ||
| Steve Hodgson | Pure Storage | steve&purestorage.com | 2013-08-13 |
| Steve Husak | portmaster&cruisetech.com | ||
| Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 | |
| Tom Belote | tbelote&okta.com | 2019-12-19 | |
| Tom Fay | iana.contact&keysight.com | 2016-09-12 | |
| Tyler Cook | tcc&sandpolis.com | 2019-11-22 | |
| Walter Underwood | wunder&infoseek.com |