Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
distinct32 9998 tcp Distinct32 Anoop Tewari Anoop Tewari
distinct32 9998 udp Distinct32 Anoop Tewari Anoop Tewari
distinct 9999 tcp distinct Anoop Tewari Anoop Tewari
distinct 9999 udp distinct Anoop Tewari Anoop Tewari
swdtp-sv 10009 tcp Systemwalker Desktop Patrol Akira Ide Akira Ide 2006-03
swdtp-sv 10009 udp Systemwalker Desktop Patrol Akira Ide Akira Ide 2006-03
10011-10019 Unassigned
10024-10049 Unassigned
10056-10079 Unassigned
10082-10099 Unassigned
10108-10109 Unassigned
bmc-gms 10129 tcp BMC General Manager Server Dima Seliverstov Dima Seliverstov 2009-07-28
10129 udp Reserved
10130-10159 Unassigned
10163-10199 Unassigned
10254-10259 Unassigned
10289-10320 Unassigned
bngsync 10439 udp BalanceNG session table synchronization protocol Inlab Software GmbH Thomas G. Obermair 2014-05-02
10439 tcp Reserved
10444-10499 Unassigned
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
10501-10539 Unassigned
10549-10630 Unassigned
10632-10799 Unassigned
nbd 10809 tcp Network Block Device Wouter Verhelst Wouter Verhelst 2010-08-02 2024-04-30 https://github.com/NetworkBlockDevice/nbd/blob/master/doc/proto.md
10809 udp Reserved
10811-10859 Unassigned
10861-10879 Unassigned
10881-10932 Unassigned
octopustentacle 10933 tcp Listen port used by the Octopus Deploy Tentacle deployment agent Octopus Deploy Pty. Ltd. Paul Stovell 2015-01-28
10933 udp Reserved
10934-10989 Unassigned
rmiaux 10990 tcp Auxiliary RMI Port Eugen Bacic Eugen Bacic
rmiaux 10990 udp Auxiliary RMI Port Eugen Bacic Eugen Bacic
10991-10999 Unassigned
11002-11094 Unassigned
weave 11095 tcp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
weave 11095 udp Nest device-to-device and device-to-service application protocol Nest Labs, Inc. Grant Erickson 2014-01-16
11096-11102 Unassigned
sgi-dmfmgr 11109 tcp Data migration facility Manager (DMF) is a browser based interface to DMF SGI John Sygulla 2013-01-07
11109 udp Reserved
11209-11210 Unassigned
imip 11319 tcp IMIP Len Zuvela Len Zuvela
imip 11319 udp IMIP Len Zuvela Len Zuvela
11372-11429 Unassigned
asgcypresstcps 11489 tcp ASG Cypress Secure Only David Luxford David Luxford 2010-07-01
11489 udp Reserved
11490-11599 Unassigned
11624-11719 Unassigned Unauthorized Use Known on port 11711
11752-11795 Unassigned
lanschool 11796 tcp LanSchool Stoneware Inc. Dana Doggett 2012-05-18
lanschool-mpt 11796 udp Lanschool Multipoint Stoneware Inc. Dana Doggett 2012-05-18
11797-11875 Unassigned
11878-11966 Unassigned
sysinfo-sp 11967 tcp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
sysinfo-sp 11967 udp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
11968-11970 Unassigned
tibsd 11971 tcp TiBS Service Teradactyl LLC Kristen Webb 2019-05-17
11971 udp Reserved
11972-11996 Unassigned
wmereceiving 11997 sctp WorldMailExpress Greg Foutz Greg Foutz 2006-03
wmedistribution 11998 sctp WorldMailExpress Greg Foutz Greg Foutz 2006-03
wmereporting 11999 sctp WorldMailExpress Greg Foutz Greg Foutz 2006-03
12009 tcp Reserved
ghvpn 12009 udp Green Hills VPN Green Hills Software Tom R. Zavisca 2012-02-07
rets-ssl 12109 tcp RETS over SSL Jeremy Crawford Jeremy Crawford 2003-02
rets-ssl 12109 udp RETS over SSL Jeremy Crawford Jeremy Crawford 2003-02
12169-12171 Unassigned
12173-12299 Unassigned
12866-13159 Unassigned
13219-13222 Unassigned
13225-13399 Unassigned
13401-13719 Unassigned
dsmcc-session 13819 tcp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-session 13819 udp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
13833-13893 Unassigned
ucontrol 13894 tcp Ultimate Control communication protocol NEGU Soft borja lopez urkidi 2012-09-10
ucontrol 13894 udp Ultimate Control communication protocol NEGU Soft borja lopez urkidi 2012-09-10
13895-13928 Unassigned
dta-systems 13929 tcp D-TA SYSTEMS Alexis Bose Alexis Bose 2008-12-08
dta-systems 13929 udp D-TA SYSTEMS Alexis Bose Alexis Bose 2008-12-08
medevolve 13930 tcp MedEvolve Port Requester Jon Robertson Jon Robertson 2008-10-24
13930 udp Reserved
13931-13999 Unassigned
vrts-tdd 14149 tcp Veritas Traffic Director Sameer Deokule Sameer Deokule 2002-03
vrts-tdd 14149 udp Veritas Traffic Director Sameer Deokule Sameer Deokule 2002-03
14155-14249 Unassigned
14415-14499 Unassigned
14501-14935 Unassigned
hde-lcesrvr-1 14936 tcp hde-lcesrvr-1 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
hde-lcesrvr-1 14936 udp hde-lcesrvr-1 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
hde-lcesrvr-2 14937 tcp hde-lcesrvr-2 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
hde-lcesrvr-2 14937 udp hde-lcesrvr-2 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
14938-14999 Unassigned
15119-15344 Unassigned
15556-15659 Unassigned
15661-15739 Unassigned
15741-15997 Unassigned
15998 tcp Reserved
2ping 15998 udp 2ping Bi-Directional Ping Service Ryan Finnie Ryan Finnie 2010-10-06
programmar 15999 tcp ProGrammar Enterprise Norman Wilson Norman Wilson 2010-10-06

Contact Information

Name Organization Contact URI Last Updated
Akira Ide ide.akira&jp.fujitsu.com 2006-09
Alexis Bose abose&d-ta.com 2008-12-08
Anoop Tewari anoop&next.distinct.com
borja lopez urkidi NEGU Soft lopezurkidi&gmail.com 2012-09-10
Dana Doggett Stoneware Inc. dana.doggett&stone-ware.com 2012-05-18
David Luxford david.luxford&asg.com 2010-07-01
Dima Seliverstov Dima_Seliverstov&bmc.com 2009-07-28
Eugen Bacic eugen&texar.com
Grant Erickson Nest Labs, Inc. grant&nestlabs.com 2014-01-16
Green Hills Software iana-contact&ghs.com 2012-02-07
Greg Foutz gregf&adminovation.com 2006-03
Horizon Digital Enterprise Inc. info&hde.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Inlab Software GmbH info&inlab.de 2014-05-02
Jeremy Crawford jeremy&reso.org 2015-09-07
John Sygulla SGI jsygulla&sgi.com 2013-01-07
Jon Robertson jmrobertson&medevolve.com 2008-10-24
Kristen Webb kwebb&teradactyl.com 2019-05-17
Len Zuvela IM Unified Coalition imu-comments&egroups.com
Mike Cooper mcooper&magnicomp.com 2003-03
NEGU Soft info&negusoft.com 2012-09-10
Nest Labs, Inc. grant&nestlabs.com 2014-01-16
Norman Wilson nwilson&programmar.com 2010-10-06
Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Paul Stovell Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Ryan Finnie ryan&finnie.org 2010-10-06
SGI jsygulla&sgi.com 2013-01-07
Sameer Deokule sameer.deokule&veritas.com 2002-03
Stoneware Inc. coby.gurr&stone-ware.com 2012-05-18
Teradactyl LLC vendors&teradactyl.com 2019-05-17
Thomas G. Obermair Inlab Software GmbH thomas.obermair&inlab.de 2014-05-02
Tim Addington Tim.Addington&sciatl.com
Tom R. Zavisca Green Hills Software iana-contact&ghs.com 2012-02-07
Wouter Verhelst w&uter.be 2010-08-02