Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| neteh-ext | 3829 | tcp | Netadmin Systems Event Handler External | [Jonas_Krogell] | [Jonas_Krogell] | 2007-07-10 | |||||
| neteh-ext | 3829 | udp | Netadmin Systems Event Handler External | [Jonas_Krogell] | [Jonas_Krogell] | 2007-07-10 | |||||
| aipn-auth | 3833 | tcp | AIPN LS Authentication | [Qiang_Zhang] | [Qiang_Zhang] | 2006-10 | |||||
| aipn-auth | 3833 | udp | AIPN LS Authentication | [Qiang_Zhang] | [Qiang_Zhang] | 2006-10 | |||||
| markem-dcp | 3836 | tcp | MARKEM NEXTGEN DCP | ||||||||
| markem-dcp | 3836 | udp | MARKEM NEXTGEN DCP | ||||||||
| mkm-discovery | 3837 | tcp | MARKEM Auto-Discovery | [Vadym_Kargin] | [Vadym_Kargin] | 2005-08 | |||||
| mkm-discovery | 3837 | udp | MARKEM Auto-Discovery | [Vadym_Kargin] | [Vadym_Kargin] | 2005-08 | |||||
| amx-rms | 3839 | tcp | AMX Resource Management Suite | [Ron_Barber] | [Ron_Barber] | 2003-11 | |||||
| amx-rms | 3839 | udp | AMX Resource Management Suite | [Ron_Barber] | [Ron_Barber] | 2003-11 | |||||
| shiprush-db-svr | 3841 | tcp | ShipRush Database Server | [Z-Firm_LLC] | [Rafael_Zimberoff] | 2003-11 | 2014-08-22 | ||||
| quest-agent | 3843 | tcp | Quest Common Agent | [Peter_Maher] | [Peter_Maher] | 2003-11 | |||||
| quest-agent | 3843 | udp | Quest Common Agent | [Peter_Maher] | [Peter_Maher] | 2003-11 | |||||
| v-one-spp | 3845 | tcp | V-ONE Single Port Proxy | [Daniel_Becker_3] | [Daniel_Becker_3] | ||||||
| v-one-spp | 3845 | udp | V-ONE Single Port Proxy | [Daniel_Becker_3] | [Daniel_Becker_3] | ||||||
| an-pcp | 3846 | tcp | Astare Network PCP | [Tony_Gulino] | [Tony_Gulino] | 2003-08 | |||||
| an-pcp | 3846 | udp | Astare Network PCP | [Tony_Gulino] | [Tony_Gulino] | 2003-08 | |||||
| msfw-control | 3847 | tcp | MS Firewall Control | [Oren_Trutner] | [Oren_Trutner] | 2003-08 | |||||
| msfw-control | 3847 | udp | MS Firewall Control | [Oren_Trutner] | [Oren_Trutner] | 2003-08 | |||||
| spw-dnspreload | 3849 | tcp | SPACEWAY DNS Preload | [Daniel_Friedman] | [Daniel_Friedman] | 2003-08 | |||||
| spw-dnspreload | 3849 | udp | SPACEWAY DNS Preload | [Daniel_Friedman] | [Daniel_Friedman] | 2003-08 | |||||
| qtms-bootstrap | 3850 | tcp | QTMS Bootstrap Protocol | [Phil_Willis] | [Phil_Willis] | 2003-08 | |||||
| qtms-bootstrap | 3850 | udp | QTMS Bootstrap Protocol | [Phil_Willis] | [Phil_Willis] | 2003-08 | |||||
| sse-app-config | 3852 | tcp | SSE App Configuration | [Tim_Wilson] | [Tim_Wilson] | 2003-08 | |||||
| sse-app-config | 3852 | udp | SSE App Configuration | [Tim_Wilson] | [Tim_Wilson] | 2003-08 | |||||
| stryker-com | 3854 | tcp | Stryker Comm Port | [Andrew_Schultz] | [Andrew_Schultz] | 2003-08 | |||||
| stryker-com | 3854 | udp | Stryker Comm Port | [Andrew_Schultz] | [Andrew_Schultz] | 2003-08 | |||||
| trap-port | 3857 | tcp | Trap Port | [Norm_Freedman] | [Norm_Freedman] | 2003-08 | |||||
| trap-port | 3857 | udp | Trap Port | [Norm_Freedman] | [Norm_Freedman] | 2003-08 | |||||
| trap-port-mom | 3858 | tcp | Trap Port MOM | [Norm_Freedman] | [Norm_Freedman] | 2003-08 | |||||
| trap-port-mom | 3858 | udp | Trap Port MOM | [Norm_Freedman] | [Norm_Freedman] | 2003-08 | |||||
| nav-port | 3859 | tcp | Navini Port | [Chris_Sanders] | [Chris_Sanders] | 2003-08 | |||||
| nav-port | 3859 | udp | Navini Port | [Chris_Sanders] | [Chris_Sanders] | 2003-08 | |||||
| winshadow-hd | 3861 | tcp | winShadow Host Discovery | [Shu_Wei_Tan] | [Shu_Wei_Tan] | 2003-03 | |||||
| winshadow-hd | 3861 | udp | winShadow Host Discovery | [Shu_Wei_Tan] | [Shu_Wei_Tan] | 2003-03 | |||||
| giga-pocket | 3862 | tcp | GIGA-POCKET | [Yoshikazu_Watanabe] | [Yoshikazu_Watanabe] | ||||||
| giga-pocket | 3862 | udp | GIGA-POCKET | [Yoshikazu_Watanabe] | [Yoshikazu_Watanabe] | ||||||
| asap-tcp | 3863 | tcp | asap tcp port | ||||||||
| asap-udp | 3863 | udp | asap udp port | [RFC 5352] | |||||||
| asap-sctp | 3863 | sctp | asap sctp | [RFC 5352] | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | [RFC 5352] | |||||||
| 3864 | udp | Reserved | This entry has been removed on 2006-06-23. | ||||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | [RFC 5352] | |||||||
| ovsam-mgmt | 3869 | tcp | hp OVSAM MgmtServer Disco | [Mike_Pontillo] | [Mike_Pontillo] | 2003-08 | |||||
| ovsam-mgmt | 3869 | udp | hp OVSAM MgmtServer Disco | [Mike_Pontillo] | [Mike_Pontillo] | 2003-08 | |||||
| ovsam-d-agent | 3870 | tcp | hp OVSAM HostAgent Disco | [Mike_Pontillo] | [Mike_Pontillo] | 2003-08 | |||||
| ovsam-d-agent | 3870 | udp | hp OVSAM HostAgent Disco | [Mike_Pontillo] | [Mike_Pontillo] | 2003-08 | |||||
| avocent-adsap | 3871 | tcp | Avocent DS Authorization | [Eduardo_Fernandez] | [Eduardo_Fernandez] | 2003-08 | |||||
| avocent-adsap | 3871 | udp | Avocent DS Authorization | [Eduardo_Fernandez] | [Eduardo_Fernandez] | 2003-08 | |||||
| oem-agent | 3872 | tcp | OEM Agent | [Narain_Jagathesan] | [Narain_Jagathesan] | 2003-11 | |||||
| oem-agent | 3872 | udp | OEM Agent | [Narain_Jagathesan] | [Narain_Jagathesan] | 2003-11 | |||||
| dl-agent | 3876 | tcp | DirectoryLockdown Agent IANA assigned this well-formed service name as a replacement for "dl_agent". |
[Jason_Lockett][Melanie_Kacerek] | [Jason_Lockett][Melanie_Kacerek] | 2008-12-16 | |||||
| dl_agent | 3876 | tcp | DirectoryLockdown Agent | [Jason_Lockett][Melanie_Kacerek] | [Jason_Lockett][Melanie_Kacerek] | 2008-12-16 | This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| dl-agent | 3876 | udp | DirectoryLockdown Agent IANA assigned this well-formed service name as a replacement for "dl_agent". |
[Jason_Lockett][Melanie_Kacerek] | [Jason_Lockett][Melanie_Kacerek] | 2008-12-16 | |||||
| dl_agent | 3876 | udp | DirectoryLockdown Agent | [Jason_Lockett][Melanie_Kacerek] | [Jason_Lockett][Melanie_Kacerek] | 2008-12-16 | This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| xmpcr-interface | 3877 | tcp | XMPCR Interface Port | [Christopher_Carlson] | [Christopher_Carlson] | 2003-10 | |||||
| xmpcr-interface | 3877 | udp | XMPCR Interface Port | [Christopher_Carlson] | [Christopher_Carlson] | 2003-10 | |||||
| appss-lm | 3879 | tcp | appss license manager | [Peter_Krueger] | [Peter_Krueger] | 2003-10 | |||||
| appss-lm | 3879 | udp | appss license manager | [Peter_Krueger] | [Peter_Krueger] | 2003-10 | |||||
| softrack-meter | 3884 | tcp | SofTrack Metering | [John_T_McCann] | [John_T_McCann] | 2003-10 | |||||
| softrack-meter | 3884 | udp | SofTrack Metering | [John_T_McCann] | [John_T_McCann] | 2003-10 | |||||
| topflow-ssl | 3885 | tcp | TopFlow SSL | [Ken_Nelson] | [Ken_Nelson] | ||||||
| topflow-ssl | 3885 | udp | TopFlow SSL | [Ken_Nelson] | [Ken_Nelson] | ||||||
| nei-management | 3886 | tcp | NEI management port | [Kevin_Murphy_2] | [Kevin_Murphy_2] | 2003-10 | |||||
| nei-management | 3886 | udp | NEI management port | [Kevin_Murphy_2] | [Kevin_Murphy_2] | 2003-10 | |||||
| ciphire-data | 3887 | tcp | Ciphire Data Transport | [Lars_Eilebrecht] | [Lars_Eilebrecht] | 2003-10 | |||||
| ciphire-data | 3887 | udp | Ciphire Data Transport | [Lars_Eilebrecht] | [Lars_Eilebrecht] | 2003-10 | |||||
| ciphire-serv | 3888 | tcp | Ciphire Services | [Lars_Eilebrecht] | [Lars_Eilebrecht] | 2003-10 | |||||
| ciphire-serv | 3888 | udp | Ciphire Services | [Lars_Eilebrecht] | [Lars_Eilebrecht] | 2003-10 | |||||
| dandv-tester | 3889 | tcp | D and V Tester Control Port | [Voiko_Loukanov] | [Voiko_Loukanov] | 2003-10 | |||||
| dandv-tester | 3889 | udp | D and V Tester Control Port | [Voiko_Loukanov] | [Voiko_Loukanov] | 2003-10 | |||||
| rtc-pm-port | 3891 | tcp | Oracle RTC-PM port | [PV_Shivkumar] | [PV_Shivkumar] | 2003-10 | |||||
| rtc-pm-port | 3891 | udp | Oracle RTC-PM port | [PV_Shivkumar] | [PV_Shivkumar] | 2003-10 | |||||
| pcc-image-port | 3892 | tcp | PCC-image-port | [Shiro_Tamoto] | [Shiro_Tamoto] | 2003-10 | |||||
| pcc-image-port | 3892 | udp | PCC-image-port | [Shiro_Tamoto] | [Shiro_Tamoto] | 2003-10 | |||||
| cgi-starapi | 3893 | tcp | CGI StarAPI Server | [Garry_Moore] | [Garry_Moore] | 2003-10 | |||||
| cgi-starapi | 3893 | udp | CGI StarAPI Server | [Garry_Moore] | [Garry_Moore] | 2003-10 | |||||
| syam-agent | 3894 | tcp | SyAM Agent Port | [Michael_Daniele] | [Michael_Daniele] | 2003-10 | |||||
| syam-agent | 3894 | udp | SyAM Agent Port | [Michael_Daniele] | [Michael_Daniele] | 2003-10 | |||||
| syam-smc | 3895 | tcp | SyAm SMC Service Port | [Michael_Daniele] | [Michael_Daniele] | 2003-10 | |||||
| syam-smc | 3895 | udp | SyAm SMC Service Port | [Michael_Daniele] | [Michael_Daniele] | 2003-10 | |||||
| sdo-tls | 3896 | tcp | Simple Distributed Objects over TLS | [Alexander_Philippou] | [Alexander_Philippou] | 2003-10 | |||||
| sdo-tls | 3896 | udp | Simple Distributed Objects over TLS | [Alexander_Philippou] | [Alexander_Philippou] | 2003-10 | |||||
| sdo-ssh | 3897 | tcp | Simple Distributed Objects over SSH | [Alexander_Philippou] | [Alexander_Philippou] | 2003-10 | |||||
| sdo-ssh | 3897 | udp | Simple Distributed Objects over SSH | [Alexander_Philippou] | [Alexander_Philippou] | 2003-10 | |||||
| itv-control | 3899 | tcp | ITV Port | [Alex_Nicu] | [Alex_Nicu] | 2003-10 | |||||
| itv-control | 3899 | udp | ITV Port | [Alex_Nicu] | [Alex_Nicu] | 2003-10 | |||||
| udt-os | 3900 | tcp | Unidata UDT OS IANA assigned this well-formed service name as a replacement for "udt_os". |
[James_Powell] | [James_Powell] | ||||||
| udt_os | 3900 | tcp | Unidata UDT OS | [James_Powell] | [James_Powell] | This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| udt-os | 3900 | udp | Unidata UDT OS IANA assigned this well-formed service name as a replacement for "udt_os". |
[James_Powell] | [James_Powell] | ||||||
| udt_os | 3900 | udp | Unidata UDT OS | [James_Powell] | [James_Powell] | This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| omnilink-port | 3904 | tcp | Arnet Omnilink Port | [Ronen_Shaul] | [Ronen_Shaul] | 2003-10 | |||||
| omnilink-port | 3904 | udp | Arnet Omnilink Port | [Ronen_Shaul] | [Ronen_Shaul] | 2003-10 | |||||
| topovista-data | 3906 | tcp | TopoVista elevation data | [Gregg_Townsend] | [Gregg_Townsend] | 2003-11 | |||||
| topovista-data | 3906 | udp | TopoVista elevation data | [Gregg_Townsend] | [Gregg_Townsend] | 2003-11 | |||||
| imoguia-port | 3907 | tcp | Imoguia Port | [Emidio_Cunha] | [Emidio_Cunha] | 2003-11 | |||||
| imoguia-port | 3907 | udp | Imoguia Port | [Emidio_Cunha] | [Emidio_Cunha] | 2003-11 | |||||
| gbmt-stars | 3912 | tcp | Global Maintech Stars | [Harry_Goldschmitt] | [Harry_Goldschmitt] | 2003-11 | |||||
| gbmt-stars | 3912 | udp | Global Maintech Stars | [Harry_Goldschmitt] | [Harry_Goldschmitt] | 2003-11 | |||||
| listcrt-port | 3913 | tcp | ListCREATOR Port | [Tomokazu_Asai] | [Tomokazu_Asai] | 2003-11 | |||||
| listcrt-port | 3913 | udp | ListCREATOR Port | [Tomokazu_Asai] | [Tomokazu_Asai] | 2003-11 |