Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cim-rs 5993 tcp DMTF WBEM CIM REST WS, Inc Jim Davis 2015-04-24
5993 udp Reserved
rms-agent 5994 tcp RMS Agent Listening Service RiverMeadow Software Inc. Greg Dennis 2021-03-24
5994 udp Reserved
5995-5998 Unassigned
cvsup 5999 tcp CVSup Randall Atkinson Randall Atkinson
cvsup 5999 udp CVSup Randall Atkinson Randall Atkinson
winpharaoh 6065 tcp WinPharaoh Basil Lee Basil Lee
winpharaoh 6065 udp WinPharaoh Basil Lee Basil Lee
dpm-acm 6075 tcp Microsoft DPM Access Control Manager Prabu Ambravaneswaran Prabu Ambravaneswaran 2009-10-29
6075 udp Reserved
p25cai 6082 udp APCO Project 25 Common Air Interface - UDP encapsulation Steve Glass Steve Glass 2011-05-13
konspire2b 6085 tcp konspire2b p2p network Jason Rohrer Jason Rohrer 2002-10
konspire2b 6085 udp konspire2b p2p network Jason Rohrer Jason Rohrer 2002-10
primaserver 6105 tcp Prima Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
primaserver 6105 udp Prima Server Prima Designs Systems Ltd. Prima Designs Systems Ltd.
xic 6115 tcp Xic IPC Service Stephen R. Whiteley Stephen R. Whiteley 2010-10-07
6115 udp Reserved
6125-6129 Unassigned
statsci2-lm 6145 tcp StatSci License Manager - 2 Scott Blachowicz Scott Blachowicz
statsci2-lm 6145 udp StatSci License Manager - 2 Scott Blachowicz Scott Blachowicz
6150-6158 Unassigned
efb-aci 6159 tcp EFB Application Control Interface Jonathan Schaaf Jonathan Schaaf 2010-02-10
6159 udp Reserved
6245-6250 Unassigned
tl1-raw-ssl 6251 tcp TL1 Raw Over SSL/TLS Jim Humphreys Jim Humphreys 2008-01-29
tl1-raw-ssl 6251 udp TL1 Raw Over SSL/TLS Jim Humphreys Jim Humphreys 2008-01-29
tl1-ssh 6252 tcp TL1 over SSH Jim Humphreys Jim Humphreys 2008-01-25
tl1-ssh 6252 udp TL1 over SSH Jim Humphreys Jim Humphreys 2008-01-25
crip 6253 tcp CRIP Mike Rodbell Mike Rodbell
crip 6253 udp CRIP Mike Rodbell Mike Rodbell
6254-6266 Unassigned
6302-6305 Unassigned
scup 6315 tcp Sensor Control Unit Protocol Sven Kopacz Sven Kopacz 2010-09-01
scup-disc 6315 udp Sensor Control Unit Protocol Discovery Protocol Sven Kopacz Sven Kopacz 2010-09-01
dt-mgmtsvc 6325 tcp Double-Take Management Service Carbonite, Inc. James Wilkinson 2012-06-06 2019-08-23
6325 udp Reserved
6345-6345 Unassigned
adap 6350 tcp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
adap 6350 udp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
6351-6354 Unassigned
pmcs 6355 tcp PMCS applications Pavel Mendl Pavel Mendl 2007-03
pmcs 6355 udp PMCS applications Pavel Mendl Pavel Mendl 2007-03
6356-6359 Unassigned
boe-pagesvr 6405 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
sge-execd 6445 tcp Grid Engine Execution Service

IANA assigned this well-formed service name as a replacement for "sge_execd".
Andreas Haas Andreas Haas 2006-08
sge_execd 6445 tcp Grid Engine Execution Service Andreas Haas Andreas Haas 2006-08 This entry is an alias to "sge-execd". This entry is now historic, not usable for use with many common service discovery mechanisms.
sge-execd 6445 udp Grid Engine Execution Service

IANA assigned this well-formed service name as a replacement for "sge_execd".
Andreas Haas Andreas Haas 2006-08
sge_execd 6445 udp Grid Engine Execution Service Andreas Haas Andreas Haas 2006-08 This entry is an alias to "sge-execd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6447-6454 Unassigned
skip-cert-recv 6455 tcp SKIP Certificate Receive Tom Markson Tom Markson
skip-cert-recv 6455 udp SKIP Certificate Receive Tom Markson Tom Markson
skip-cert-send 6456 tcp SKIP Certificate Send Tom Markson Tom Markson
skip-cert-send 6456 udp SKIP Certificate Send Tom Markson Tom Markson
6457-6463 Unassigned
6465-6470 Unassigned
sun-sr-iiop 6485 tcp Service Registry Default IIOP Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop 6485 udp Service Registry Default IIOP Domain Paul Sterk Paul Sterk 2006-03
boks 6500 tcp BoKS Master Magnus Nystrom Magnus Nystrom
boks 6500 udp BoKS Master Magnus Nystrom Magnus Nystrom
boks-servc 6501 tcp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501
boks_servc 6501 tcp BoKS Servc Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501 This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servc 6501 udp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom
boks_servc 6501 udp BoKS Servc Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 tcp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 tcp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 udp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 udp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 tcp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 tcp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 udp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 udp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6504 Unassigned
badm-priv 6505 tcp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 tcp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-priv 6505 udp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 udp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 tcp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 tcp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 udp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 udp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 tcp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 tcp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 udp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 udp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 tcp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 tcp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 udp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 udp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
mgcs-mfp-port 6509 tcp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mgcs-mfp-port 6509 udp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mcer-port 6510 tcp MCER Port Portnoy Boxman Portnoy Boxman
mcer-port 6510 udp MCER Port Portnoy Boxman Portnoy Boxman
6511 tcp Reserved
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
6512-6512 Unassigned
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
6513 udp Reserved
syslog-tls 6514 tcp Syslog over TLS RFC 5425
syslog-tls 6514 udp syslog over DTLS RFC 6012
syslog-tls 6514 dccp syslog over DTLS RFC 6012

Contact Information

Name Organization Contact URI Last Updated
Steve Glass APCO Project 25 admin&sedition.org.au 2011-05-13
Andreas Haas andreas.haas&sun.com 2006-08
Basil Lee basil.lee&gnnettest.com
Carbonite, Inc. jwilkinson&carbonite.com 2019-08-23
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Greg Dennis RiverMeadow Software Inc. gdennis&rivermeadow.com 2021-03-24
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Wilkinson jwilkinson&carbonite.com 2019-08-23
Jason Rohrer rohrer&cse.ucsc.edu 2002-10
Jim Davis WS, Inc Jim.Davis&ws-inc.com 2015-04-24
Jim Humphreys jhumphre&ciena.com 2008-01-29
Jonathan Schaaf j.schaaf&astronautics.com 2010-02-10
Magnus Nystrom magnus&dynas.se
Mike Rodbell mrodbell&ciena.com
Minoru Ozaki Minoru.Ozaki&rdmg.mgcs.mei.co.jp
Paul Sterk paul.sterk&sun.com 2006-03
Pavel Mendl pavel_mendl&centrum.cz 2007-03
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Prabu Ambravaneswaran prambrav&microsoft.com 2009-10-29
Prima Designs Systems Ltd. info&prima.com.hk
Randall Atkinson rja&inet.org
RiverMeadow Software Inc. gdennis&rivermeadow.com 2021-03-24
SAP Giriraj Harapanahalli 2026-05-27
Scott Blachowicz scott&statsci.com
Stephen R. Whiteley stevew&wrcad.com 2010-10-07
Sven Kopacz s.kopacz&controllerware.com 2010-09-01
Thomas Kjoernes thomas&ipv.no 2010-06-22
Tom Markson markson&osmosys.incog.com
WS, Inc Jim.Davis&ws-inc.com 2015-04-24