Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 7634-7647 | Unassigned | ||||||||||
| cuseeme | 7648 | tcp | bonjour-cuseeme | Marc Manthey | Marc Manthey | 2006-07 | |||||
| cuseeme | 7648 | udp | bonjour-cuseeme | Marc Manthey | Marc Manthey | 2006-07 | |||||
| 7649-7662 | Unassigned | ||||||||||
| rome | 7663 | tcp | Proprietary immutable distributed data storage | TFOR | David von Vistauxx | 2018-02-07 | |||||
| rome | 7663 | udp | Proprietary immutable distributed data storage | TFOR | David von Vistauxx | 2018-02-07 | |||||
| 7664-7667 | Unassigned | ||||||||||
| authoritygate | 7668 | tcp | AuthorityGate Secure API communication for Orchestrated task sequencing | AuthorityGate Inc | Kevin Komlosy | 2025-03-28 | |||||
| 7668 | udp | Reserved | |||||||||
| 7669-7671 | Unassigned | ||||||||||
| imqstomp | 7672 | tcp | iMQ STOMP Server | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7672 | udp | Reserved | |||||||||
| imqstomps | 7673 | tcp | iMQ STOMP Server over SSL | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7673 | udp | Reserved | |||||||||
| imqtunnels | 7674 | tcp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnels | 7674 | udp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | tcp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | udp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqbrokerd | 7676 | tcp | iMQ Broker Rendezvous | Joseph Di Pol | Joseph Di Pol | 2002-04 | |||||
| imqbrokerd | 7676 | udp | iMQ Broker Rendezvous | Joseph Di Pol | Joseph Di Pol | 2002-04 | |||||
| sun-user-https | 7677 | tcp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-user-https | 7677 | udp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| 7678-7679 | Unassigned | ||||||||||
| ms-do | 7680 | tcp | Microsoft Delivery Optimization Peer-to-Peer | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| ms-do | 7680 | udp | Microsoft Delivery Optimization Peer-to-Peer | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| 7681-7682 | Unassigned | ||||||||||
| dmt | 7683 | tcp | Cleondris DMT | Cleondris GmbH | Christian Plattner | 2015-03-31 | |||||
| 7683 | udp | Reserved | |||||||||
| 7684-7686 | Unassigned | ||||||||||
| bolt | 7687 | tcp | Bolt database connection | Neo Technology, Inc | Julian Simpson | 2016-09-29 | |||||
| 7687 | udp | Reserved | |||||||||
| 7688 | Unassigned | ||||||||||
| collaber | 7689 | tcp | Collaber Network Service | Rajesh Akkineni | Rajesh Akkineni | 2007-01 | |||||
| collaber | 7689 | udp | Collaber Network Service | Rajesh Akkineni | Rajesh Akkineni | 2007-01 | |||||
| sovd | 7690 | tcp | Service-Oriented Vehicle Diagnostics | ASAM e.V. | Bernd Wenzel | 2022-07-01 | |||||
| 7690 | udp | Reserved | |||||||||
| 7691-7696 | Unassigned | ||||||||||
| klio | 7697 | tcp | KLIO communications | Helmut Giritzer | Helmut Giritzer | 2005-08 | |||||
| klio | 7697 | udp | KLIO communications | Helmut Giritzer | Helmut Giritzer | 2005-08 | |||||
| 7698-7699 | Unassigned | ||||||||||
| 7702-7706 | Unassigned | ||||||||||
| freezexservice | 7726 | tcp | FreezeX Console Service | David Crowe | David Crowe | 2005-06 | |||||
| freezexservice | 7726 | udp | FreezeX Console Service | David Crowe | David Crowe | 2005-06 | |||||
| 7745-7746 | Unassigned | ||||||||||
| 7748-7776 | Unassigned | ||||||||||
| 7776 | Unassigned | ||||||||||
| minivend | 7786 | tcp | MINIVEND | Mike Heins | Mike Heins | Known Unauthorized Use on port 7786 | |||||
| minivend | 7786 | udp | MINIVEND | Mike Heins | Mike Heins | Known Unauthorized Use on port 7786 | |||||
| 7795-7796 | Unassigned | ||||||||||
| apc-7846 | 7846 | tcp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| apc-7846 | 7846 | udp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| 7848-7868 | Unassigned | ||||||||||
| mobileanalyzer | 7869 | tcp | MobileAnalyzer& MobileMonitor | Jonas Gyllensvaan | Jonas Gyllensvaan | 2009-04-27 | |||||
| 7869 | udp | Reserved | |||||||||
| mipv6tls | 7872 | udp | TLS-based Mobile IPv6 Security | IESG | IETF Chair | 2012-04-12 | RFC 6618 | ||||
| 7881-7886 | Unassigned | ||||||||||
| 7934-7961 | Unassigned | ||||||||||
| generalsync | 7962 | tcp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| generalsync | 7962 | udp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| 7963-7966 | Unassigned | ||||||||||
| supercell | 7967 | tcp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| supercell | 7967 | udp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| 7968-7978 | Unassigned | ||||||||||
| wpl-analytics | 8006 | tcp | World Programming analytics | World Programming Limited | Thomas Quarendon | 2017-04-04 | |||||
| wpl-disc | 8006 | udp | World Programming analytics discovery | World Programming Limited | Thomas Quarendon | 2017-04-04 | |||||
| ads-s | 8016 | tcp | Beckhoff Automation Device Specification | Beckhoff Automation GmbH & Co. KG | Henning Mersch | 2019-02-28 | |||||
| 8016 | udp | Reserved | |||||||||
| ca-audit-ds | 8026 | tcp | CA Audit Distribution Server | Henning Smith | Henning Smith | 2006-07 | |||||
| ca-audit-ds | 8026 | udp | CA Audit Distribution Server | Henning Smith | Henning Smith | 2006-07 | |||||
| senomix05 | 8056 | tcp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix05 | 8056 | udp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix06 | 8057 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix06 | 8057 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| 8060 | tcp | Reserved | |||||||||
| aero | 8060 | udp | Asymmetric Extended Route Optimization (AERO) | IESG | IETF Chair | RFC 6706 | |||||
| nikatron-dev | 8061 | tcp | Nikatron Device Protocol | Nikatron | Marcel Uhlir | 2023-09-07 | |||||
| 8061 | udp | Reserved | |||||||||
| 8062-8065 | Unassigned | ||||||||||
| toad-bi-appsrvr | 8066 | tcp | Toad BI Application Server | Quest Software | Greg Cottman | 2013-04-19 | |||||
| 8066 | udp | Reserved | |||||||||
| infi-async | 8067 | tcp | Infinidat async replication | INFINIDAT | Eldar Kleiner | 2015-05-01 | |||||
| 8067 | udp | Reserved | |||||||||
| 8068-8069 | Unassigned | ||||||||||
| 8075-8076 | Unassigned | ||||||||||
| d-s-n | 8086 | tcp | Distributed SCADA Networking Rendezvous Port | Gary Hampton | Gary Hampton | 2008-02-27 | |||||
| d-s-n | 8086 | udp | Distributed SCADA Networking Rendezvous Port | Gary Hampton | Gary Hampton | 2008-02-27 | |||||
| 8092-8096 | Unassigned | ||||||||||
| cp-cluster | 8116 | tcp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| cp-cluster | 8116 | udp | Check Point Clustering | Roni Moshitzky | Roni Moshitzky | ||||||
| patrol | 8160 | tcp | Patrol | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol | 8160 | udp | Patrol | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-snmp | 8161 | tcp | Patrol SNMP | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-snmp | 8161 | udp | Patrol SNMP | Portnoy Boxman | Portnoy Boxman | ||||||
| lpar2rrd | 8162 | tcp | LPAR2RRD client server communication | LPAR2RRD project | Pavel Hampl | 2013-08-14 | |||||
| 8162 | udp | Reserved | |||||||||
| 8163-8180 | Unassigned | ||||||||||
| 8196-8198 | Unassigned | ||||||||||
| lm-dta | 8206 | tcp | LM Dta | Chris Flynn | Chris Flynn | ||||||
| lm-dta | 8206 | udp | LM Dta | Chris Flynn | Chris Flynn | ||||||
| 8244-8265 | Unassigned | ||||||||||
| 8266 | tcp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Amy Kang | amy.kang&sun.com | 2009-03-10 | |
| ASAM e.V. | marius.dupuis&asam.net | 2022-07-01 | |
| AuthorityGate Inc | support&authoritygate.com | 2025-03-28 | |
| Beckhoff Automation GmbH & Co. KG | legal&beckhoff.com | 2019-02-28 | |
| Bernd Wenzel | ASAM e.V. | bernd.wenzel&asam.net | 2022-07-01 |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| Chris Flynn | cflynn&landmark.com | ||
| Christian Plattner | Cleondris GmbH | christian.plattner&cleondris.ch | 2015-03-31 |
| Cleondris GmbH | noc&cleondris.ch | 2015-03-31 | |
| David Crowe | dcrowe&faronics.com | 2008-01-07 | |
| David von Vistauxx | vistauxx&tfor.infrastructuresecurity.com | 2018-02-07 | |
| Dirk Steinmetz | ds&generalsync.com | 2014-04-17 | |
| Eldar Kleiner | INFINIDAT | eldark&infinidat.com | 2015-05-01 |
| Gary Hampton | GH&2hti.com | 2008-02-27 | |
| Greg Cottman | Quest Software | Greg.Cottman&quest.com | 2013-04-19 |
| Helmut Giritzer | helmut.giritzer&o.roteskreuz.at | 2005-08 | |
| Henning Mersch | support&beckhoff.com | 2019-02-28 | |
| Henning Smith | henning.smith&ca.com | 2006-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| INFINIDAT | info&infinidat.com | 2015-05-01 | |
| Jonas Gyllensvaan | jonas&conceivium.com | 2009-04-27 | |
| Joseph Di Pol | joe.dipol&sun.com | 2002-04 | |
| Julian Simpson | Neo Technology, Inc | julian.simpson&neotechnology.com | 2016-09-29 |
| Kevin Komlosy | AuthorityGate Inc | support&authoritygate.com | 2025-03-28 |
| Kevin Nakagawa | nakagawa&sigsci.com | ||
| LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 | |
| Marc Manthey | codewarrior&cuseeme.de | 2006-07 | |
| Marcel Uhlir | Nikatron | marcel.uhlir&nikatron.cz | 2023-09-07 |
| Microsoft Corporation | naenglerµsoft.com | 2022-05-03 | |
| Mike Heins | mike&minivend.com | ||
| Narkis Engler | Microsoft Corporation | naenglerµsoft.com | 2022-05-03 |
| Neo Technology, Inc | admins&neotechnology.com | 2016-09-29 | |
| Nikatron | marcel.uhlir&nikatron.cz | 2023-09-07 | |
| Pavel Hampl | LPAR2RRD project | pavel.hampl&lpar2rrd.com | 2013-08-14 |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Quest Software | Greg.Cottman&quest.com | 2013-04-19 | |
| Rajesh Akkineni | rajesh&vimukti.com | 2007-01 | |
| Roni Moshitzky | rmosh&checkpoint.com | ||
| Shailesh S. Bavadekar | shailesh.bavadekar&sun.com | 2002-04 | |
| TFOR | vistauxx&tfor.infrastructuresecurity.com | 2018-02-07 | |
| Thomas Quarendon | World Programming Limited | tom.quarendon&worldprogramming.com | 2017-04-04 |
| World Programming Limited | support&worldprogramming.com | 2017-04-04 |