Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 8794-8799 | Unassigned | ||||||||||
| 8807 | tcp | Reserved | |||||||||
| hes-clip | 8807 | udp | HES-CLIP Interoperability protocol | Tim Schoechle | Ludo Bertsch | 2018-09-07 | |||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| 8810-8872 | Unassigned | ||||||||||
| dxspider | 8873 | tcp | dxspider linking protocol | Dirk Koopman | Dirk Koopman | 2005-08 | |||||
| dxspider | 8873 | udp | dxspider linking protocol | Dirk Koopman | Dirk Koopman | 2005-08 | |||||
| 8874-8879 | Unassigned | ||||||||||
| 8884-8887 | Unassigned | ||||||||||
| ddi-tcp-7 | 8894 | tcp | Desktop Data TCP 6: COAL application | Fred Yao | Fred Yao | ||||||
| ddi-udp-7 | 8894 | udp | Desktop Data UDP 6: COAL application | Fred Yao | Fred Yao | ||||||
| 8902-8907 | Unassigned | ||||||||||
| twds | 8937 | tcp | Transaction Warehouse Data Service | Lance M. Steenson | Lance M. Steenson | 2009-09-18 | |||||
| 8937 | udp | Reserved | |||||||||
| 8955-8979 | Unassigned | ||||||||||
| oracle-ms-ens | 8997 | tcp | Oracle Messaging Server Event Notification Service | Oracle Corp. | Hubert Vijay Arokiasamy | 2014-10-28 | |||||
| 8997 | udp | Reserved | |||||||||
| 9007 | tcp | Reserved | |||||||||
| ogs-client | 9007 | udp | Open Grid Services Client | Gareth Nelson | Gareth Nelson | 2008-08-22 | |||||
| 9027-9049 | Unassigned | ||||||||||
| 9061-9079 | Unassigned | ||||||||||
| classic | 9087 | tcp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| classic | 9087 | udp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| astergatefax | 9107 | tcp | AstergateFax Control Service | Gijs Middelkamp | Gijs Middelkamp | 2010-02-03 | |||||
| 9107 | udp | Reserved | |||||||||
| wap-vcal-s | 9207 | tcp | WAP vCal Secure | WAP Forum | WAP Forum | ||||||
| wap-vcal-s | 9207 | udp | WAP vCal Secure | WAP Forum | WAP Forum | ||||||
| fsc-port | 9217 | tcp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| fsc-port | 9217 | udp | FSC Communication Port | Teijo Mustonen | Teijo Mustonen | 2002-03 | |||||
| 9256-9276 | Unassigned | ||||||||||
| traingpsdata | 9277 | udp | GPS Data transmitted from train to ground network | Alstom Transport, Preston | Paul Steane | 2012-12-14 | |||||
| 9277 | tcp | Reserved | |||||||||
| pegasus | 9278 | tcp | Pegasus GPS Platform | Nestor A. Diaz | Nestor A. Diaz | 2009-05-12 | |||||
| pegasus | 9278 | udp | Pegasus GPS Platform | Nestor A. Diaz | Nestor A. Diaz | 2009-05-12 | |||||
| pegasus-ctl | 9279 | tcp | Pegaus GPS System Control Interface | Nestor A. Diaz | Nestor A. Diaz | 2009-05-12 | |||||
| pegasus-ctl | 9279 | udp | Pegaus GPS System Control Interface | Nestor A. Diaz | Nestor A. Diaz | 2009-05-12 | |||||
| cumulus | 9287 | tcp | Cumulus | Thomas Schleu | Thomas Schleu | ||||||
| cumulus | 9287 | udp | Cumulus | Thomas Schleu | Thomas Schleu | ||||||
| 9307-9309 | Unassigned | ||||||||||
| 9313-9317 | Unassigned | ||||||||||
| 9347-9373 | Unassigned | ||||||||||
| fjdmimgr | 9374 | tcp | fjdmimgr | Yutaka Ono | Yutaka Ono | ||||||
| fjdmimgr | 9374 | udp | fjdmimgr | Yutaka Ono | Yutaka Ono | ||||||
| 9375-9379 | Unassigned | ||||||||||
| d2dconfig | 9387 | tcp | D2D Configuration Service | Pete Camble | Pete Camble | 2008-12-24 | |||||
| 9387 | udp | Reserved | |||||||||
| mpidcagt | 9397 | tcp | MpIdcAgt | Yutaka Ono | Yutaka Ono | ||||||
| mpidcagt | 9397 | udp | MpIdcAgt | Yutaka Ono | Yutaka Ono | ||||||
| 9403-9417 | Unassigned | ||||||||||
| 9537-9554 | Unassigned | ||||||||||
| pd-admin | 9597 | tcp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| pd-admin | 9597 | udp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| erunbook-server | 9617 | tcp | eRunbook Server IANA assigned this well-formed service name as a replacement for "erunbook_server". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_server | 9617 | tcp | eRunbook Server | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9617 | udp | Reserved | |||||||||
| 9619-9627 | Unassigned | ||||||||||
| xmms2 | 9667 | tcp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | 2009-04-14 | |||||
| xmms2 | 9667 | udp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | ||||||
| board-roar | 9700 | tcp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-roar | 9700 | udp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9701-9746 | Unassigned | ||||||||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| 9748-9749 | Unassigned | ||||||||||
| board-voip | 9750 | tcp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-voip | 9750 | udp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9751-9752 | Unassigned | ||||||||||
| rasadv | 9753 | tcp | rasadv | Dave Thaler | Dave Thaler | ||||||
| rasadv | 9753 | udp | rasadv | Dave Thaler | Dave Thaler | ||||||
| 9754-9761 | Unassigned | ||||||||||
| tungsten-http | 9762 | tcp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| tungsten-http | 9762 | udp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| 9763-9799 | Unassigned | ||||||||||
| 9803-9874 | Unassigned | ||||||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| sd | 9876 | tcp | Session Director | Van Jacobson | Van Jacobson | ||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| 9877 | udp | Reserved | |||||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 9878 | tcp | Reserved | |||||||||
| 9879-9887 | Unassigned | ||||||||||
| 9890-9897 | Unassigned | ||||||||||
| 9957-9965 | Unassigned | ||||||||||
| 9967-9977 | Unassigned | ||||||||||
| xybrid-rt | 9978 | tcp | XYBRID RT Server | Rx Networks Inc. | Drew Davies | 2013-01-24 | |||||
| 9978 | udp | Reserved | |||||||||
| visweather | 9979 | tcp | Valley Information Systems Weather station data | Valley Information Systems, Inc. | Michael Walsh | 2017-05-12 | |||||
| 9979 | udp | Reserved | |||||||||
| dsm-scm-target | 9987 | tcp | DSM/SCM Target Interface | Mike Dyslin | Mike Dyslin | 2006-08 | |||||
| dsm-scm-target | 9987 | udp | DSM/SCM Target Interface | Mike Dyslin | Mike Dyslin | 2006-08 | |||||
| palace-6 | 9997 | tcp | Palace-6 | Douglas Crockford | Douglas Crockford | ||||||
| palace-6 | 9997 | udp | Palace-6 | Douglas Crockford | Douglas Crockford | ||||||
| mvs-capacity | 10007 | tcp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| mvs-capacity | 10007 | udp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| 10056-10079 | Unassigned | ||||||||||
| bctp-server | 10107 | tcp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| bctp-server | 10107 | udp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| iqrm | 10117 | tcp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| Afkham Azeez | azeez&wso2.com | 2006-06 | |
| Alstom Transport, Preston | paul.steane&transport.alstom.com | 2012-12-14 | |
| Dave Thaler | dthalerµsoft.com | ||
| Dirk Koopman | djk&tobit.co.uk | 2005-08 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Donna Dillenberger | engd&us.ibm.com | ||
| Douglas Crockford | douglas&crockford.com | ||
| Drew Davies | Rx Networks Inc. | ddavies&rxnetworks.com | 2013-01-24 |
| Duk Loi | dloi&peerdirect.com | 2005-11 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Francesco Rosi | frosi&orenburg.com | 2006-01 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Gareth Nelson | gareth&litesim.com | 2008-08-22 | |
| Gerhard Wagner | gw&nova-ratio.de | 2009-03-10 | |
| Gijs Middelkamp | astergate-fax&huisken-systems.nl | 2010-02-03 | |
| Hubert Vijay Arokiasamy | Oracle Corp. | hubert.vijay.arokiasamy&oracle.com | 2014-10-28 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Juho Vähä-Herttua | juhovh&iki.fi | 2009-04-14 | |
| Lance M. Steenson | lance&transactionwarehouse.net | 2009-09-18 | |
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Ludo Bertsch | Horizon Technologies Inc. | iana&horizontec.com | 2018-09-07 |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| Michael Walsh | michael.walsh&valleyinfosys.com | 2017-05-12 | |
| Mike Dyslin | mike.dyslin&hp.com | 2006-08 | |
| Nestor A. Diaz | nestor&tiendalinux.com | 2009-05-12 | |
| Oracle Corp. | hubert.vijay.arokiasamy&oracle.com | 2014-10-28 | |
| Paul Cadarette | pcadaret&us.ibm.com | 2007-01 | |
| Paul Steane | Alstom Transport, Preston | paul.steane&transport.alstom.com | 2012-12-14 |
| Pete Camble | pete.camble&hpe.com | 2023-04-05 | |
| Rx Networks Inc. | ddavies&rxnetworks.com | 2013-01-24 | |
| Saugata Guha | sguha&veritas.com | 2004-05 | |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 | |
| Teijo Mustonen | Teijo.Mustonen&f-secure.com | 2002-03 | |
| Thomas Schleu | tschleu&canto.de | ||
| Tim Schoechle | ISO/IEC JTC1 SC25/WG1 | timothy&schoechle.org | 2018-09-07 |
| Valley Information Systems, Inc. | info@valleyinfosys.com> | 2017-05-12 | |
| Van Jacobson | van&ee.lbl.gov | ||
| WAP Forum | wap-feedback&mail.wapforum.org
pg&uplanet.com |
||
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |