Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
programmar 15999 tcp ProGrammar Enterprise Norman Wilson Norman Wilson 2010-10-06
15999 udp Reserved
16004-16019 Unassigned
etb4j 16309 tcp etb4j Christopher R. Smith Christopher R. Smith 2004-11
etb4j 16309 udp etb4j Christopher R. Smith Christopher R. Smith 2004-11
16312-16359 Unassigned
16369-16383 Unassigned
xoms 16619 tcp X509 Objects Management Service Francis GASCHET Francis GASCHET 2008-09-08
16619 udp Reserved
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform Broadcom Thomas Sakowski 2015-06-02 2023-03-29
16789 udp Reserved
16790-16899 Unassigned
newbay-snc-mc 16900 tcp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
newbay-snc-mc 16900 udp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
16901-16949 Unassigned
sgcip 16950 tcp Simple Generic Client Interface Protocol John Aquilino John Aquilino
sgcip 16950 udp Simple Generic Client Interface Protocol John Aquilino John Aquilino
16951-16990 Unassigned
intel-rci-mp 16991 tcp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
intel-rci-mp 16991 udp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
amt-soap-http 16992 tcp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-http 16992 udp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-https 16993 tcp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-soap-https 16993 udp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-redir-tcp 16994 tcp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tcp 16994 udp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 tcp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 udp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
16996-17006 Unassigned
17008-17009 Unassigned
ncpu 17010 tcp Plan 9 cpu port Ronald G. Minnich Ronald G. Minnich 2022-05-13 Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root
chipper 17219 tcp Chipper Ronald Jimmink Ronald Jimmink
chipper 17219 udp Chipper Ronald Jimmink Ronald Jimmink
17236-17499 Unassigned
ea 17729 tcp Eclipse Aviation William Schmidt William Schmidt 2006-03
ea 17729 udp Eclipse Aviation William Schmidt William Schmidt 2006-03
17778-17999 Unassigned
18259 Unassigned Known Unauthorized Use on port 18259
18669-18768 Unassigned
ique 18769 tcp IQue Protocol Avi Drissman Avi Drissman 2002-07
ique 18769 udp IQue Protocol Avi Drissman Avi Drissman 2002-07
18889-18999 Unassigned
igrid 19000 tcp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
igrid 19000 udp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
19001-19006 Unassigned
scintilla 19007 tcp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
scintilla 19007 udp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
19008-19019 Unassigned
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
19021-19190 Unassigned
opsec-uaa 19191 tcp OPSEC UAA Reuven Harrison Reuven Harrison
opsec-uaa 19191 udp OPSEC UAA Reuven Harrison Reuven Harrison
19192-19193 Unassigned
ua-secureagent 19194 tcp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
ua-secureagent 19194 udp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
19195-19219 Unassigned
cora 19220 tcp Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
cora-disc 19220 udp Discovery for Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
19221-19282 Unassigned
keysrvr 19283 tcp Key Server for SASSAFRAS Mark Valence Mark Valence
keysrvr 19283 udp Key Server for SASSAFRAS Mark Valence Mark Valence
19284-19314 Unassigned
keyshadow 19315 tcp Key Shadow for SASSAFRAS Mark Valence Mark Valence
keyshadow 19315 udp Key Shadow for SASSAFRAS Mark Valence Mark Valence
19316-19397 Unassigned
mtrgtrans 19398 tcp mtrgtrans Katsuhito Muroi Katsuhito Muroi
mtrgtrans 19398 udp mtrgtrans Katsuhito Muroi Katsuhito Muroi
19399-19409 Unassigned
hp-sco 19410 tcp hp-sco Larry Schwartz Larry Schwartz
hp-sco 19410 udp hp-sco Larry Schwartz Larry Schwartz
hp-sca 19411 tcp hp-sca Larry Schwartz Larry Schwartz
hp-sca 19411 udp hp-sca Larry Schwartz Larry Schwartz
hp-sessmon 19412 tcp HP-SESSMON Gita Murthy Gita Murthy
hp-sessmon 19412 udp HP-SESSMON Gita Murthy Gita Murthy
19413-19538 Unassigned
fxuptp 19539 tcp FXUPTP Keiji Okuma Keiji Okuma 2005-08
fxuptp 19539 udp FXUPTP Keiji Okuma Keiji Okuma 2005-08
sxuptp 19540 tcp SXUPTP Keiji Okuma Keiji Okuma 2002-08
sxuptp 19540 udp SXUPTP Keiji Okuma Keiji Okuma 2002-08
jcp 19541 tcp JCP Client Yuji Sasaki Yuji Sasaki
jcp 19541 udp JCP Client Yuji Sasaki Yuji Sasaki
19542-19787 Unassigned
mle 19788 udp Mesh Link Establishment IESG IETF Chair 2012-12-18
19788 tcp Reserved
19789 Unassigned
faircom-db 19790 tcp FairCom Database FairCom Corporation Michael Bowers 2020-12-04
19790 udp Reserved
19791-19997 Unassigned
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
19998 udp Reserved
dnp-sec 19999 tcp Distributed Network Protocol - Secure Grant Gilchrist Grant Gilchrist 2008-08-04
dnp-sec 19999 udp Distributed Network Protocol - Secure Grant Gilchrist Grant Gilchrist 2008-08-04
dnp-sec 19999 sctp Distributed Network Protocol - secured DNP Users Group Andrew West 2022-12-20
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
20223-20479 Unassigned
20481-20669 Unassigned
20671-20809 Unassigned
20811-20998 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Andrew West andrew.west&ieee.org 2022-12-20
Avi Drissman ique-protocol&harrisbaseview.com 2002-07
Broadcom thomas.sakowski&broadcom.com 2023-03-29
Chirag Patel Veejansh Inc cpatel&veejansh.com 2014-03-04
Christopher R. Smith csmith4&us.ibm.com 2004-11
David T. Hines david.hines&intel.com 2005-02
DNP Users Group chair_tech&dnp.org 2022-12-20
FairCom Corporation alysha.brown&faircom.com 2020-12-04
Francis GASCHET NUMLOG fg&numlog.fr 2008-09-08
Gita Murthy gita&cup.hp.com
Grant Gilchrist grant&enernex.com 2010-10-18
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jane Dashevsky jane.dashevsky&intel.com
John Aquilino john.aquilino&maryville.com
Katsuhito Muroi muroi&pfu.co.jp
Keiji Okuma okuma&silex.jp 2005-08
Larry Schwartz lrs&cup.hp.com
Mark Valence kurash&sassafras.com
Massimo Cafaro massimo.cafaro&unile.it 2004-11
Michael Bowers FairCom Corporation mike.bowers&faircom.com 2020-12-04
Nimrod Diamant nimrod.diamant&intel.com 2005-02
Norman Wilson nwilson&programmar.com 2010-10-06
Reuven Harrison rnd_ana&checkpoint.com
Reuven Harrison rharrison&checkpoint.com 2003-01
Ronald G. Minnich rminnich&gmail.com 2022-05-13
Ronald Jimmink Ronald.Jimmink&chipper.nl
Ronny Krüger from-iana&softvise.de 2016-11-10
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Softvise GmbH from-iana&softvise.de 2016-11-10
Srinivasa Nayudu sn156n&att.com 2009-07-06
Thomas Sakowski Broadcom thomas.sakowski&broadcom.com 2023-03-29
Veejansh Inc admin&veejansh.com 2014-03-04
William Schmidt info&eclipseaviation.com 2006-03
Yuji Sasaki sasaki&silex.jp