Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| aairnet-1 | 3618 | tcp | AAIR-Network 1 | ||||||||
| aairnet-1 | 3618 | udp | AAIR-Network 1 | ||||||||
| aairnet-2 | 3619 | tcp | AAIR-Network 2 | James Mealey | James Mealey | 2002-10 | |||||
| aairnet-2 | 3619 | udp | AAIR-Network 2 | James Mealey | James Mealey | 2002-10 | |||||
| ep-nsp | 3621 | tcp | EPSON Network Screen Port | SEIKO EPSON | SEIKO EPSON | 2002-10 | |||||
| ep-nsp | 3621 | udp | EPSON Network Screen Port | SEIKO EPSON | SEIKO EPSON | 2002-10 | |||||
| cs-services | 3631 | tcp | C&S Web Services Port | Computer Software GmbH | Computer Software GmbH | 2002-10 | |||||
| cs-services | 3631 | udp | C&S Web Services Port | Computer Software GmbH | Computer Software GmbH | 2002-10 | |||||
| netplay-port1 | 3640 | tcp | Netplay Port 1 | ||||||||
| netplay-port1 | 3640 | udp | Netplay Port 1 | ||||||||
| netplay-port2 | 3641 | tcp | Netplay Port 2 | Predrag Filipovic | Predrag Filipovic | 2002-11 | |||||
| netplay-port2 | 3641 | udp | Netplay Port 2 | Predrag Filipovic | Predrag Filipovic | 2002-11 | |||||
| xrpc-registry | 3651 | tcp | XRPC Registry | Slava Monich | Slava Monich | 2003-01 | |||||
| xrpc-registry | 3651 | udp | XRPC Registry | Slava Monich | Slava Monich | 2003-01 | |||||
| can-ferret-ssl | 3661 | tcp | IBM Tivoli Directory Service using SSL | Nic Catrambone | Nic Catrambone | 2003-01 | |||||
| can-ferret-ssl | 3661 | udp | IBM Tivoli Directory Service using SSL | Nic Catrambone | Nic Catrambone | 2003-01 | |||||
| efcp | 3671 | tcp | e Field Control (EIBnet) | Marc Goossens | Marc Goossens | 2003-01 | |||||
| efcp | 3671 | udp | e Field Control (EIBnet) | Marc Goossens | Marc Goossens | 2003-01 | |||||
| bts-x73 | 3681 | tcp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| bts-x73 | 3681 | udp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| magaya-network | 3691 | tcp | Magaya Network Port | Jesus David Rodriguez | Jesus David Rodriguez | 2003-02 | |||||
| magaya-network | 3691 | udp | Magaya Network Port | Jesus David Rodriguez | Jesus David Rodriguez | 2003-02 | |||||
| netcelera | 3701 | tcp | NetCelera | Tarek Nabhan | Tarek Nabhan | 2003-02 | |||||
| netcelera | 3701 | udp | NetCelera | Tarek Nabhan | Tarek Nabhan | 2003-02 | |||||
| portgate-auth | 3710 | tcp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| portgate-auth | 3710 | udp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| edb-server2 | 3711 | tcp | EBD Server 2 | Carlos Portela | Carlos Portela | 2003-02 | |||||
| edb-server2 | 3711 | udp | EBD Server 2 | Carlos Portela | Carlos Portela | 2003-02 | |||||
| sentinel-ent | 3712 | tcp | Sentinel Enterprise | Ian Gordon | Ian Gordon | 2003-03 | |||||
| sentinel-ent | 3712 | udp | Sentinel Enterprise | Ian Gordon | Ian Gordon | 2003-03 | |||||
| tftps | 3713 | tcp | TFTP over TLS | Mark mayernick | Mark mayernick | 2003-03 | |||||
| tftps | 3713 | udp | TFTP over TLS | Mark mayernick | Mark mayernick | 2003-03 | |||||
| delos-dms | 3714 | tcp | DELOS Direct Messaging | Ekkehard Morgenstern | Ekkehard Morgenstern | 2003-03 | |||||
| delos-dms | 3714 | udp | DELOS Direct Messaging | Ekkehard Morgenstern | Ekkehard Morgenstern | 2003-03 | |||||
| anoto-rendezv | 3715 | tcp | Anoto Rendezvous Port | Ola Sandstrom | Ola Sandstrom | 2003-03 | |||||
| anoto-rendezv | 3715 | udp | Anoto Rendezvous Port | Ola Sandstrom | Ola Sandstrom | 2003-03 | |||||
| wv-csp-sms-cir | 3716 | tcp | WV CSP SMS CIR Channel | ||||||||
| wv-csp-sms-cir | 3716 | udp | WV CSP SMS CIR Channel | ||||||||
| wv-csp-udp-cir | 3717 | tcp | WV CSP UDP/IP CIR Channel | Jon Ingi Ingimundarson | Jon Ingi Ingimundarson | 2003-03 | |||||
| wv-csp-udp-cir | 3717 | udp | WV CSP UDP/IP CIR Channel | Jon Ingi Ingimundarson | Jon Ingi Ingimundarson | 2003-03 | |||||
| opus-services | 3718 | tcp | OPUS Server Port | Detlef Stoever | Detlef Stoever | 2003-03 | |||||
| opus-services | 3718 | udp | OPUS Server Port | Detlef Stoever | Detlef Stoever | 2003-03 | |||||
| itelserverport | 3719 | tcp | iTel Server Port | Mark Hendricks | Mark Hendricks | 2003-03 | |||||
| itelserverport | 3719 | udp | iTel Server Port | Mark Hendricks | Mark Hendricks | 2003-03 | |||||
| xsync | 3721 | tcp | Xsync | ||||||||
| xsync | 3721 | udp | Xsync | ||||||||
| smap | 3731 | tcp | Service Manager | ||||||||
| smap | 3731 | udp | Service Manager | ||||||||
| wysdma | 3741 | tcp | WysDM Agent | Jim McDonald | Jim McDonald | 2003-04 | |||||
| wysdma | 3741 | udp | WysDM Agent | Jim McDonald | Jim McDonald | 2003-04 | |||||
| gprs-cube | 3751 | tcp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| gprs-cube | 3751 | udp | CommLinx GPRS Cube | Peter Johnson | Peter Johnson | 2003-04 | |||||
| gsakmp | 3761 | tcp | gsakmp port | RFC 4535 | |||||||
| gsakmp | 3761 | udp | gsakmp port | RFC 4535 | |||||||
| sitewatch-s | 3766 | tcp | SSL e-watch sitewatch server | e-Watch Corporation | John M Baird | 2014-05-13 | this port was previously updated on 2009-06-19 | ||||
| 3766 | udp | Reserved | this port was previously updated on 2009-06-19 | ||||||||
| paging-port | 3771 | tcp | RTP Paging Port | Patrick Ferriter | Patrick Ferriter | 2003-06 | |||||
| paging-port | 3771 | udp | RTP Paging Port | Patrick Ferriter | Patrick Ferriter | 2003-06 | |||||
| abcvoice-port | 3781 | tcp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| abcvoice-port | 3781 | udp | ABCvoice server port | Carlos Gonzalez-Roman Ferrer | Carlos Gonzalez-Roman Ferrer | 2003-06 | |||||
| bfd-control | 3784 | tcp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-control | 3784 | udp | BFD Control Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | tcp | BFD Echo Protocol | RFC 5881 | |||||||
| bfd-echo | 3785 | udp | BFD Echo Protocol | RFC 5881 | |||||||
| tvnetworkvideo | 3791 | tcp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| tvnetworkvideo | 3791 | udp | TV NetworkVideo Data port | Kevin Brunner | Kevin Brunner | 2003-07 | |||||
| ibm-mgr | 3801 | tcp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| ibm-mgr | 3801 | udp | ibm manager service | Tim Hahn | Tim Hahn | 2006-03 | |||||
| wlanauth | 3810 | tcp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| wlanauth | 3810 | udp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| amp | 3811 | tcp | AMP | Northon Rodrigues | Northon Rodrigues | 2004-02 | |||||
| amp | 3811 | udp | AMP | Northon Rodrigues | Northon Rodrigues | 2004-02 | |||||
| neto-wol-server | 3812 | tcp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-wol-server | 3812 | udp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| rap-ip | 3813 | tcp | Rhapsody Interface Protocol | Paul Zander | Paul Zander | 2004-03 | |||||
| rap-ip | 3813 | udp | Rhapsody Interface Protocol | Paul Zander | Paul Zander | 2004-03 | |||||
| neto-dcs | 3814 | tcp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-dcs | 3814 | udp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| lansurveyorxml | 3815 | tcp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| lansurveyorxml | 3815 | udp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| sunlps-http | 3816 | tcp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| sunlps-http | 3816 | udp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| tapeware | 3817 | tcp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| tapeware | 3817 | udp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| crinis-hb | 3818 | tcp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| crinis-hb | 3818 | udp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| epl-slp | 3819 | tcp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| epl-slp | 3819 | udp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| pmcp | 3821 | tcp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| pmcp | 3821 | udp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| dvapps | 3831 | tcp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| dvapps | 3831 | udp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| shiprush-db-svr | 3841 | tcp | ShipRush Database Server | Z-Firm LLC | Rafael Zimberoff | 2003-11 | 2014-08-22 | ||||
| 3841 | udp | Reserved | 2003-11 | 2014-08-22 | |||||||
| spectraport | 3851 | tcp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| spectraport | 3851 | udp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| winshadow-hd | 3861 | tcp | winShadow Host Discovery | Shu-Wei Tan | Shu-Wei Tan | 2003-03 | |||||
| winshadow-hd | 3861 | udp | winShadow Host Discovery | Shu-Wei Tan | Shu-Wei Tan | 2003-03 | |||||
| avocent-adsap | 3871 | tcp | Avocent DS Authorization | Eduardo Fernandez | Eduardo Fernandez | 2003-08 | |||||
| avocent-adsap | 3871 | udp | Avocent DS Authorization | Eduardo Fernandez | Eduardo Fernandez | 2003-08 | |||||
| idac | 3881 | tcp | Data Acquisition and Control | Chatziandreoglou Christos | Chatziandreoglou Christos | 2003-10 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Barry Greenberg | barry.greenberg&sun.com | 2004-04 | |
| Bianling Zhang | blzhang&iwncomm.com | 2004-02 | |
| Carlos Gonzalez-Roman Ferrer | iana&abcdatos.com | 2003-06 | |
| Carlos Portela | cportela&simple-sw.com | 2003-02 | |
| Chatziandreoglou Christos | chatzi&xan.forthnet.gr | 2003-10 | |
| Computer Software GmbH | BrunoRistok&cs-ag.de | 2002-10 | |
| Detlef Stoever | mail&ivotec.com | 2003-03 | |
| e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 | |
| Eduardo Fernandez | eduardo.fernandez&avocent.com | 2003-08 | |
| Ekkehard Morgenstern | ekkehard&ekkehardmorgenstern.de | 2003-03 | |
| Eric McMurry | emcmurry&crinisnetworks.com | 2004-04 | |
| Graham Jones | gjones&nab.org | 2004-11 | |
| Hans Weibel | hans.weibel&zhwin.ch | 2004-10 | |
| Ian Gordon | ian&n-genltd.co.uk | 2003-03 | |
| James Mealey | jymealey&yahoo.com | 2002-10 | |
| Jesus David Rodriguez | jesusdavid&magaya.com | 2003-02 | |
| Jim McDonald | Jim.McDonald&sysdm.com | 2003-04 | |
| John M Baird | e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 |
| Jon Ingi Ingimundarson | jii&oz.com | 2003-03 | |
| Ketul Patel | ketulp76&yahoo.com | 2006-10 | |
| Kevin Brunner | brunner&tivo.com | 2003-07 | |
| Luke Dion | ldion&tapeware.com | 2004-04 | |
| Madhav Karhade | madhav.karhade&wibhu.com | 2003-08 | |
| Marc Goossens | mgoossens&eiba.com | 2003-01 | |
| Mark Hendricks | markah&copper.net | 2003-03 | |
| Mark mayernick | Mark.Mayernick&thomson.net | 2003-03 | |
| Martin Bestmann | martin&no.netopia.com | 2004-03 | |
| Michael Swan | swan&neon.com | 2004-04 | |
| Nic Catrambone | ncatramb&us.ibm.com | 2003-01 | |
| Northon Rodrigues | northon.rodrigues&thomson.net | 2004-02 | |
| Ola Sandstrom | ola.sandstrom&anoto.com | 2003-03 | |
| Patrick Ferriter | Patrick.Ferriter&zultys.com | 2003-06 | |
| Paul Zander | Philips CFT | p.j.zander&philips.com | 2004-03 |
| Peter Johnson | peter&commlinx.com.au | 2004-11 | |
| Predrag Filipovic | pfilipovic&digital5.com | 2002-11 | |
| Rafael Zimberoff | rafael&zfirmllc.com | 2003-11 | |
| SEIKO EPSON | Sato.Minoru3&exc.epson.co.jp | 2002-10 | |
| Scott Harris | Scott&xramp.com | 2003-02 | |
| Shu-Wei Tan | stan&omnicomtech.com | 2003-03 | |
| Slava Monich | Slava.Monich&nokia.com | 2003-01 | |
| Tarek Nabhan | standards&itworx.com | 2003-02 | |
| Tim Hahn | hahnt&us.ibm.com | 2006-03 | |
| Todd Cooper | todd&do11073.com | 2003-01 | |
| Z-Firm LLC | rafael&zfirmllc.com | 2014-08-22 |