Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
syslog-tls 6514 dccp syslog over DTLS RFC 6012
elipse-rec 6515 tcp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
elipse-rec 6515 udp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
6516-6542 Unassigned
lds-distrib 6543 tcp lds_distrib Jack Baker Jack Baker 2003-06
lds-distrib 6543 udp lds_distrib Jack Baker Jack Baker 2003-06
lds-dump 6544 tcp LDS Dump Service Jack Baker Jack Baker 2006-02
lds-dump 6544 udp LDS Dump Service Jack Baker Jack Baker 2006-02
6545-6546 Unassigned
apc-6547 6547 tcp APC 6547 American Power Conversion American Power Conversion
apc-6547 6547 udp APC 6547 American Power Conversion American Power Conversion
apc-6548 6548 tcp APC 6548 American Power Conversion American Power Conversion
apc-6548 6548 udp APC 6548 American Power Conversion American Power Conversion
apc-6549 6549 tcp APC 6549 American Power Conversion American Power Conversion
apc-6549 6549 udp APC 6549 American Power Conversion American Power Conversion
fg-sysupdate 6550 tcp fg-sysupdate Mark Beyer Mark Beyer
fg-sysupdate 6550 udp fg-sysupdate Mark Beyer Mark Beyer
sum 6551 tcp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
sum 6551 udp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
6552-6555 Unassigned
checkmk-agent 6556 tcp Checkmk Monitoring Agent Checkmk GmbH Alexander Wilms 2020-07-14 2024-08-06
6556 udp Reserved
6557 Unassigned
xdsxdm 6558 tcp Brian Tackett Brian Tackett possible contact
xdsxdm 6558 udp Brian Tackett Brian Tackett possible contact
6559-6565 Unassigned
sane-port 6566 tcp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
sane-port 6566 udp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
canit-store 6568 tcp CanIt Storage Manager

IANA assigned this well-formed service name as a replacement for "canit_store".
Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25
canit_store 6568 tcp CanIt Storage Manager Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25 This entry is an alias to "canit-store". This entry is now historic, not usable for use with many common service discovery mechanisms.
rp-reputation 6568 udp Roaring Penguin IP Address Reputation Collection Dianne Skoll Dianne Skoll 2010-02-05 2017-05-25
6569-6578 Unassigned
affiliate 6579 tcp Affiliate David Catmull David Catmull 2006-01
affiliate 6579 udp Affiliate David Catmull David Catmull 2006-01
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
parsec-peer 6581 tcp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-peer 6581 udp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-game 6582 tcp Parsec Gameserver Andreas Varga Andreas Varga
parsec-game 6582 udp Parsec Gameserver Andreas Varga Andreas Varga
joaJewelSuite 6583 tcp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
joaJewelSuite 6583 udp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
6584-6587 Unassigned
6588 Unassigned Unofficial use of port 6588 by AnalogX and Microsoft
6589-6599 Unassigned
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
kftp-data 6620 tcp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08
kftp-data 6620 udp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08
kftp 6621 tcp Kerberos V5 FTP Control Robert J. Scott Robert J. Scott 2005-08
kftp 6621 udp Kerberos V5 FTP Control Robert J. Scott Robert J. Scott 2005-08
ktelnet 6623 tcp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
ktelnet 6623 udp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
datascaler-ctl 6625 tcp DataScaler control Vasu Murthy Vasu Murthy 2010-02-08
6625 udp Reserved
6635 tcp Reserved
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6641-6652 Unassigned
openflow 6653 tcp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
openflow 6653 udp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
6654 Unassigned
pcs-sf-ui-man 6655 tcp PC SOFT - Software factory UI/manager Jerome AERTS Jerome AERTS 2010-11-30
6655 udp Reserved
emgmsg 6656 tcp Emergency Message Control Service Gerry Gorman Gerry Gorman 2010-12-06
6656 udp Reserved
6657 tcp Reserved
palcom-disc 6657 udp PalCom Discovery Boris Magnusson Boris Magnusson 2010-12-06
6658-6664 Unassigned Unauthorized Use Known on Port 6659
ircu 6665-6669 tcp IRCU Brian Tackett Brian Tackett
6665-6669 udp Reserved
6691-6695 Unassigned
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
6705 udp Reserved
6705 tcp Reserved
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
fibotrader-com 6715 tcp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
fibotrader-com 6715 udp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
dgpf-exchg 6785 tcp DGPF Individual Exchange Thomas Weise Thomas Weise 2006-04
dgpf-exchg 6785 udp DGPF Individual Exchange Thomas Weise Thomas Weise 2006-04
iccrushmore 6850 tcp ICCRUSHMORE Dave Hubbard Dave Hubbard
iccrushmore 6850 udp ICCRUSHMORE Dave Hubbard Dave Hubbard
6851-6867 Unassigned
6925-6934 Unassigned
ethoscan 6935 tcp EthoScan Service Marty Campbell Marty Campbell 2011-06-10
ethoscan 6935 udp EthoScan Service Marty Campbell Marty Campbell 2011-06-10
6937-6945 Unassigned
6947-6950 Unassigned
otlp 6951 tcp OTLP Brent Foster Brent Foster 2006-04
otlp 6951 udp OTLP Brent Foster Brent Foster 2006-04
6952-6960 Unassigned
swistrap 6965 tcp swistrap Yutaka Ono Yutaka Ono
swistrap 6965 udp swistrap Yutaka Ono Yutaka Ono
afs3-volser 7005 tcp volume managment server Known Unauthorized Use on port 7005
afs3-volser 7005 udp volume managment server Known Unauthorized Use on port 7005
talon-webserver 7015 tcp Talon Webserver Jim Thompson Jim Thompson
talon-webserver 7015 udp Talon Webserver Jim Thompson Jim Thompson
vmsvc-2 7025 tcp Vormetric Service II Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 udp Vormetric Service II Tom Boyle Tom Boyle 2005-06

Contact Information

Name Organization Contact URI Last Updated
Alexander Wilms Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
American Power Conversion ports&apcc.com 2002-02
Andreas Varga sid&parsec.org
Bob Rundle rundle&rundle.com 2005-11
Boris Magnusson boris&cs.lth.se 2010-12-06
Brent Foster brent.foster&onstreamsystems.com 2006-04
Brian Tackett cym&acrux.net
Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
Dave Hubbard dave&icc.net
David Catmull uncommon&uncommonplace.com 2006-01
Dianne Skoll dfs&roaringpenguin.com 2017-05-25
Fl√°vio Englert flavio&elipse.com.br 2007-09-17
Gerry Gorman gerry.gorman&emclock.com 2010-12-06
Henning Meier-Geinitz henning&meier-geinitz.de 2002-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ieuan Friend ieuan.friend&dip.co.uk 2006-03
Jack Baker Jack.Baker&l-3com.com 2006-02
Jan Dirven jan.dirven&agfa.com 2007-12-13
Jerome AERTS info&pcsoft.fr 2010-11-30
Jim Thompson jim.thompson&powerware.com
Mark Beyer mbeyer&freegate.com
Marty Campbell martyc&ethosinfo.com 2011-06-10
Open Networking Foundation iana&opennetworking.org 2013-07-18
Puneet Agarwal pagarwal&broadcom.com 2013-07-18
Robert J. Scott rob&hpcmo.hpc.mil 2005-08
Robert Wetzold robert.wetzold&fibotrader.com 2006-01
Thomas Weise weise&vs.uni-kassel.de 2006-04
Tom Boyle tboyle&vormetric.com 2005-06
Vasu Murthy vmurthy&datascaler.com 2010-02-08
Yutaka Ono ono&saint.nm.fujitsu.co.jp